Introduction

This document provides an introduction on how to use the Atollic TrueSTUDIO® software development toolchain (version 1.4.0 and later) with the STM32VLDiscovery board.

It provides novice users of the Atollic TrueSTUDIO® tool-chain some guidelines to build and run the sample program provided with this document which demonstrates how to create and build their own applications.

The DISCOVER project, referenced in this document, corresponds to the demo Flashed into the STM32VLDiscovery board during production. The project is available within the STM32VLDiscovery firmware package available at http://www.st.com/stm32vldiscovery.

Although this application note cannot show all the topics relevant to the Atollic TrueSTUDIO® tool, it demonstrates the first basic steps necessary to get started with the compiler/debugger.
Contents

1  About Atollic TrueSTUDIO® toolchain ........................................ 3
2  Starting an existing Atollic TrueSTUDIO project .......................... 4
3  Creating your first application .................................................. 14
4  Revision history ................................................................. 21
1 About Atollic TrueSTUDIO® toolchain

Atollic TrueSTUDIO® is an Eclipse based software development platform that includes a highly optimizing C/C++ compiler, a state-of-the-art editor, and a professional debugger. It integrates all the tools needed to develop embedded applications and helps expedite the development process of embedded applications by providing many features such as:

● Powerful source code editor with many features like spell checking of C/C++ comments, word and code completion, content assist, parameter hints and code templates.
● Project manager that automates the task of creating a working project for an electronic board or microcontroller device.
● Integrated Make Utility functionality for assembling, compiling, and linking your embedded applications.
● True integrated source-level and assembler-level debugger with high-speed CPU.
● Flash programming utility for downloading the application program into Flash ROM.
● Productivity features such as a graphical file difference viewer, a programmer's calculator, an integrated MS/DOS console window and a batch file execution window.
● Links to manuals, on-line help and user guides.
● Atollic TrueANALYZERTM/STM32 product is available for professional code quality analysis of STM32 applications.

Note: Atollic TrueSTUDIO®/STM32 Professional version is available with a lot more capabilities. Further information about Atollic TrueSTUDIO® toolchain can be found at: www.atollic.com.
Starting an existing Atollic TrueSTUDIO project

After installing Atollic TrueSTUDIO®/STM32 on your computer, start the program by performing the following steps:

1. Open the Microsoft Windows Start menu.
2. Click on Programs.
3. Open the Atollic folder.
4. Open the TrueSTUDIO® STM32 product folder.
5. Click on the Atollic TrueSTUDIO® STM32 product name.
6. The program starts and asks for the Workspace location. Browse to the folder that contains the Value Line Discovery Demonstration TrueSTUDIO workspace located at stm32vldiscovery_package\Project\Demo\TrueSTUDIO and click on OK.

Figure 1. Open workspace
7. A Welcome window is then displayed. To start using Atollic TrueSTUDIO®, click on **Start using TrueSTUDIO**.

**Figure 2. Start using TrueStudio**

[Image of the Welcome window with the option to start using TrueSTUDIO]
8. The main window of Atollic TrueSTUDIO is now open. *Figure 3* shows the names of the different views referred to in this document.

**Figure 3.** Atollic TrueSTUDIO windows
9. Now, the workspace is open, you are ready to load projects. The TrueSTUDIO Discovery workspace contains a demo project for the Discovery kit. To load this project, the following steps should be performed:
   a) Select Import... from File menu.
   b) In the Import window, select General - 'Existing Projects into Workspace' and click Next.

**Figure 4. Select to import an existing project**
c) Browse to the TrueSTUDIO workspace folder (which contains the DISCOVER project folder) located at `stm32vldiscovery_package\Project\Demo\TrueSTUDIO`.

**Figure 5. Select the project to import**

10. Select the **DISCOVER** project from the **Projects** list and click **Finish**.

11. Select **Preferences** from Window menu.

**Figure 6. Window preferences**
12. In the Preferences window, select General->Workspace->Linked Resources and click New button to add a path variable.

**Figure 7. Add linked resources**

13. Add a path variable named **CurPath** which points to the stm32vldiscovery_package folder containing "Libraries", "Project" and "Utilities" folders.

**Note:** All Files in the DISCOVER project are linked using a path variable called “CurPath” to allow users to copy and run this project under any path location, just by updating this variable.
14. To build the project, select the DISCOVER project in the project explorer.

15. Click on Build Project in the Project menu.
16. Your project is successfully compiled.

Figure 10. Successful compile

```
C:\Build [DISCOVER]
Discovery\FIRMWARE\Libraries\CMSIS\CM3\CoreSupport\core_cm3.o
arm-stellio-embi-gcc User\stm32f10x_it.o User\main.o
TrueSTUDIO\startup_stm32f10x_md_v1.o StdPeriph_Driver\stm32f10x_rcc.o
StdPeriph_Driver\stm32f10x_pwr.o StdPeriph_Driver\stm32f10x_gpio.o
StdPeriph_Driver\stm32f10x_exti.o StdPeriph_Driver\misc.o
STM32_Discrovver\STM32F10X_Discovery.o CMSIS\system_stm32f10x.o CMSIS\core_cm3
STM32100B-EVAL.elf -mthumb -mcpu=cortex-m3 -TC:\Value Line
Discovery\FIRMWARE\Project\Value Line Discovery
Demonstration\TrueSTUDIO\DISCOVER\STM32F10CRB_FLASH.ld -static
-Wl,-cref,-u,Faset_Handler -Wl,--Map=STM32100B-EVAL.map -Wl,--gc-sections
Build complete for project DISCOVER
Time consumed: 5512 ms.
```

17. Before running your application, you should establish the connection with the STM32VLDiscovery board as shown in Figure 11.

Figure 11. Hardware environment

18. Select the DISCOVER project in the project explorer and then press F11 to display the debug configurations window.

Figure 12. Edit configuration
19. In the **Debug configurations** window, click on **OK** to program the Flash and begin debugging.

20. Now you can start debugging your application. The debugger perspective supplied by Atollic TrueSTUDIO allows source code debugging at C and assembly levels, breakpoint setting, individual variables monitoring and watching during code execution.

21. To run your application, click on **Resume** in the **Run** menu or click on the resume button as shown in **Figure 13**. If everything is OK, LED3 blinks and every time the USER button is pressed, LED3 blinking frequency changes and LED4 is turned on.

**Figure 13. Resume execution**
Creating your first application

Creating a new project for the STM32VLDiscovery with Atollic TrueSTUDIO is very easy. With a few steps, all the required files (startup file, firmware library and so on) are added to the workspace and sample files are generated in the project folder to simplify development. The debug configuration is done automatically when the STM32VLDiscovery kit is selected as the evaluation board.

1. Start Atollic TrueSTUDIO STM32 as follows:
   a) Open the Microsoft Windows Start menu.
   b) Click on Programs.
   c) Open the Atollic folder.
   d) Open the TrueSTUDIO® STM32 product folder.
   e) Click on the Atollic TrueSTUDIO® STM32 product name.

2. The program is then started and requests the Workspace location. Click the OK button if you want to add your project to an existing workspace, otherwise enter a new workspace location.

Figure 14. Select workspace
3. A Welcome window is then displayed. To start using Atollic TrueSTUDIO®, click on the Start using TrueSTUDIO link.

Figure 15. Start using TrueSTUDIO

4. The main window of Atollic TrueSTUDIO is now open. Select New -> C Project from the File Menu.

Figure 16. New C project

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Source</th>
<th>Refactor</th>
<th>Navigate</th>
<th>Search</th>
<th>Run</th>
<th>Project</th>
<th>Manuals</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open File</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Close</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close All</td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+W</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+S</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save As...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save All</td>
<td></td>
<td></td>
<td></td>
<td>Ctrl+Shift+S</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revert</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Move...</td>
<td></td>
<td></td>
<td></td>
<td>F2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rename...</td>
<td></td>
<td></td>
<td></td>
<td>F2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Refresh</td>
<td></td>
<td></td>
<td></td>
<td>F5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Convert to C/C++ Project</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source Folder</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source File</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Header File</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File template</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Class</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Ctr+N</td>
</tr>
</tbody>
</table>
5. Name the project NewProject, select **STM32 C Project** in the Project type and click **Next**.

**Figure 17. Name the project**

![C Project Window](image)

- **Project name:** NewProject
- **Project type:** STM32 C Project
- **Toolchain:** Atmel ARM Tools
- **Location:** C:\NewWorkspace\NewProject
6. Select STM32_Discovery as **Evaluation board** and click **Next**.

**Figure 18.** Select STM32_Discovery as the evaluation board

![Target selection screenshot]

**Note:** Choosing STM32_Discovery as evaluation board configures the project as follows:
- **Microcontroller:** STM32F100RB
- **Debug probe:** ST-LINK
- **Connection:** Serial Wire Debug (SWD).
7. Verify that **ST-LINK** is used as **JTAG probe** and click **Finish**.

**Figure 19. Select ST-LINK as JTAG probe**

Your project is successfully created.

**Note:** Atollic TrueSTUDIO generates target-specific sample files (**main.c**, **stm32f10x_it.c** and so on) in the project folder to simplify development. You can tailor this project to your needs by modifying these sample files. The easiest way to add source files to the project is to copy them into this "src" folder (which contains **main.c**, **stm32f10x_it.c** and so on).

**Figure 20. Project sample files**
8. To build the project, select the **NewProject** project in the **project explorer**.
9. Click on **Build Project** in the **Project** menu.

**Figure 21. Build project**

![Project]

10. Your project is successfully compiled.

**Figure 22. Successfully compiled project**

```
firmware\STM32F10x_StdPeriph_Driver\src\misc.o
firmware\CMSIS\CM3\DeviceSupport\STM\STM32F10x\system_stm32f10x.o
firmware\CMSIS\CM3\DeviceSupport\STM\STM32F10x\startup\TrueSTUDIO\startup_stm32f10x_md_v1.o
firmware\CMSIS\CM3\CoreSupport\core_cm3.o
STM32_EVAL\Board\STM32_Discovery.o -o NewProject.elf -mthumb
-mcpu=cortex-m3 -TC:\NewWorkspace\NewProject\stm32_flash.ld -static
-Wl,-cref,-u,Reset_Handler -Wl,-Map=NewProject.map -Wl,--gc-sections
-arm-atollic-eabi-objcopy -O ihex NewProject.elf NewProject.hex
Flash Converter only available in TrueSTUDIO Professional
Build complete for project NewProject
Time consumed: 18515 ms.
```
11. Before running your application, you should establish connection with the STM32VLDiscovery as shown in Figure 11: Hardware environment.

12. Select the NewProject project in the project explorer and then press F11 to display the debug configurations window.

Figure 23. Edit configuration

13. In the Debug configurations window, click on OK to program the Flash and begin debugging.

14. Now you can start debugging your application.
## 4 Revision history

Table 1. Document revision history

<table>
<thead>
<tr>
<th>Date</th>
<th>Revision</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>10-Sep-2010</td>
<td>1</td>
<td>Initial release.</td>
</tr>
<tr>
<td>25-Oct-2010</td>
<td>2</td>
<td>Changed Firmware\Project\Value Line Discovery Demonstration\TrueSTUDIO path to stm32vdisccovery_package\Project\Demo\TrueSTUDIO. Changed Figure 1 and Figure 5.</td>
</tr>
</tbody>
</table>