Developing with Sensors
Made Simple

Hands-on Workshop

ST Developers Conference

ST Developers September 12th, 2019
Santa Clara Convention Center - Mission City Ballroom
Conference Santa Clara, GA .



Required HW

- Laptop with USB type A

+ 64 bit OS Win (7, 10), MacOS, Linux (Generic, Debian, RPM)
 Virtual Machine is also OK (example: Parallel, VM Fusion...)
« Administration rights are required for SW tools installation



Developing with Sensors Made Simple
Hands-On

« USB Flash drive with relevant material for the hands-on

* Please copy the content of the USB drive on your laptop

—l

Please return it at the
end of the workshop

We proudly reuse usB
drives between hands-on
to save the planet




Agenda

* Introduction « Lab 0 - Read all sensors in polling
mode
* Products & Ecosystem o Lab 1 - LIS2DW12 accelerometer

orientation change detection

« Hands-on Training Session
« Lab 2 - LPS22HH barometer read from

* Installation Process internal EIFO
« STM32CubeMX libraries installation . Lab 3 - LSMBDSO accelerometer
« STM32CubelDE installation embedded step counter
 Tera Term installation « Lab 4 - LIS2DW12 accelerometer
« Hardware Description acceleration detection
« Lab 5 - LSM6DSO accelerometer
. Lab Examples: single/double tap detection

« Lab 6 - LSM6DSO accelerometer 6.6
kHz data rate read at 100 Hz




ST Addresses Four End Markets

Communications
Automotive Industrial Personal Electronics Equipment,
Computers & Peripherals




Sensors Trends mm=

Global Semiconductor Market Automation Age

- Value «  Smart Industry
 Smart Driving

Cloud / loT Age
Mobile Age » Cloud services
Internet Age - Smartphones * |oT services

Digital Age « Internet search *  Mobile networks
« Data Storage »  Online video » Social media
« PCs « Gaming

Next MEMS Wave

First MEMS Wave
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Sensors Evolution
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Technologies Accuracy Multi Sensors Embedded Low Power
Manufacturing Stability Integration Smart Functions Always ON



Sensors Evolution mm
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17 Billion Units +83% -710% Embedded -91%
Shipped Temp. Stability size reduction FSM and Dec. Tree Current Consumption




Broad Sensors Portfolio mm

Motion Environment Interactivity Micro-Actuators Optical




ST: Products & Ecosystem

Connect Pre-integrated SW for vertical applications

Translate =/
Sensor Tile

Smart Things Smart Home Smart City Smart Industry

Move
Actuate

Development Ecosystem

ProfiMEMS : I I

Secure _
Code generators  Prototyping Development
software environments
Process ~
o @
STM32 Nucleo Development
& Expansion boards Debug Simulation On-line
solutions and analysis tools  design tools




Developing with Sensors
Complicated Simple

HW

Nucleo + X-Nucleo

SW

STM32CubelDE + STM32CUBEMX + X-CUBE-MEMS1




STM32CubeMX Libraries Installation



STM32CubeMX Libraries Installation

1. Run the STM32Cube Libraries.exe self-extracting archive located in
X-CUBE-MEMS1_HandsOn\Software

STM32Cube Libraries self extracting
container includes STM32Cubel4 and
X-CUBE-MEMSH1 library



STM32CubeMX Libraries Installation

1. Library extraction may take few minutes.
Please wait the library to be fully extracted before proceed any further.

Meantime we’ll proceed to
install and configure STM32CubelDE



STM32CubelDE Installation



STM32CubelDE Installation

1. Run the STM32CubelDE installer located in
X-CUBE-MEMS1_HandsOn\Software



STM32CubelDE Installation

1. Click Next >



STM32CubelDE Installation

1. Click I Agree

W STMicroelectronics STMM32CubelDE — >
License Agreement

Please review the license terms before installing
STMicroelectronics STM32CubeIDE.

Press Page Down to see the rest of the agreement.

STMicroelectronics Software License Agreement

SLAOD4E Rev4March 2018

BY INSTALLING COPYING, DOWNLOADING, ACCESSIMNG OR OTHERWISE USIMNG THIS
SOFTWARE PACKAGE OR ANY PART THEREOF (AMD THE RELATED DOCUMENTATION)
FROM STMICROELECTROMNICS INTERMATIOMAL M.V, SWISS BRANCH AND/OR ITS
AFFILIATED COMPANIES (STMICROELECTRONICS), THE RECIPIEMT, ON BEHALF OF
HIMSELF OR HERSELF, OR OM BEHALF OF ANY ENTITY BY WHICH SUCH RECIPIENT IS

EMPLOYED AMD/OR ENGAGED AGREES TO BE BOUND BY THIS SOFTWARE PACKAGE
LICEMSE AGREEMENT.

If you accept the terms of the agreement, dick I Agree to continue. You must accept the
agreement to install STMicroelectronics STM32CubeIDE.

<Back | IAgree Cancel




STM32CubelDE Installation

1. Click Next >

m STMicroelectronics STMM32CubelDE — >

Choose Install Location

Choose the folder in which to install STMicroelectronics
STM32CubeIDE.

Setup will install STMicroelectranics STM32CubeIDE in the following folder. To installin a
different folder, dick Browse and select another folder. Click Mext to continue,

Destination Folder

| C:\ST\STM32CubeIDE_1.0.0 | Browse...

Space reguired: 1.9 GB
Space available: 193.8 GB

<Back | Next> Cancel




STM32CubelDE Installation

1. Click Install

m STMicroelectronics STMM32CubelDE — >

Choose Components
Choose which features of STMicroelectronics STM32CubeIDE you
want to install.

Chedk the companents you want to install and unchedk the companents you don't want to
install. Clidk Install to start the installation.

: Description
Select components to install: SEGGER Iink drivers - P
Pasition your mouse

ST-LINK drivers ower a component ko
ST-LIMK server seg jts description.

Space reguired: 1.9 GB

<Back | Instal Cancel




STM32CubelDE Installation...

1. Wait until installation is completed

m STMicroelectronics STMM32CubelDE —

Installing
Please wait while STMicroelectronics STM32CubeIDE is being
installed.

Extract: SY5-5TM32F042_sys_v1_0_Mades. xml

= Back Mext = Cancel




STM32 Nucleo Expansion



#1: STM32 NUCLEO Board

Microcontroller

Flexible board power supply :
® through USB or external source

2 push buttons, 2 color Leds

S
. | s

Arduino extension connectors :
easy access to add-ons

STM32 MCU (NUCLEO-L476RG)

9 Morpho extension headers :

direct acces to all MCU 1/Os




HW #2. X-NUCLEO-IKS01A3 Board

Motion MEMS and environmental sensor

2

Accelerometer:

LIS2DW12

1
Accel. + Gyro:

LSM6DSO

Pressure:

LPS22HH

Temperature:

STTS751

1

Humidity:
HTS221

Magnetometer:

LIS2MDL



Development Software Architecture

Mobile app prototyping & cloud prototyping

Sample applications | Function Packs

STM32Cube
Hardware Abstraction Layer (HAL)

STM32 Nucleo STM32 Nucleo
Development boards Expansion boards

RN

'S o

2 & oy STM32Cube expansion SW
SES! STM32CUb High-value middleware

£ 25 MozLUbe -
S5 E LR STM32Cube

{28 g Expansion HAL

O £ 1

= I

__________




STM32 Supported IDEs



STM32CubelDE

-1 Development Tool 2

Configuration
and

Code Generation Complete multi platform family tools

Cover full development cycle

-
sTM3" NP
CGubeMonitor

Integrated solution

Programming



Software Development Tools

“STM32CubelDE”

development environment

“STM32CubeMX”

initialization code generator

“X-CUBE-MEMS1”

application code and drivers for sensors

> ® STMX-CUBE-MEMS t/Application Deiice
- © STMX.CUBE-MEMS 1/Appiication Deiice installed

SX.CUBE-MEMS1/Application  6.1.0 Deiice Application  [IKS01A3 DatalogTerminal v [IKS01A.

Instal”

> ® STMXCUBEMEMSIMEMS 60.1 Board Extension

v |5 ostuxcusenEMsIMEMS 601 Boad Component

© o STUXCUBEMEMSYMENS 610 BowdExension hstaled

e p— SXCUBEMEMSIMEMS 610 Bowd Extension Ksotm ) Ksora
SX-CUBE-MEMS1/MEMS 610 Board Extension IKS01A3/ IKSO1A.

oo oo e« || © SXCUBENENSUMENS 610 BoardComparent sl
e Comeoner 2 > © STMX.CUBEMEMSUSTMIZCube...6.0.1 Boars suppor. [T
CheckUncheck Al > © STMXCUBEMEMSY/STMRZCube 610 Board Support tald

0 Avifcia Iteligence
0 Board Component
[0 Board Extension
[0 Board Support
[ Data Exchange
[ Device
[ Wireless

G o]




STM32CubelDE

an All-in-1 Development Tool

Dedicated IDE for all STM32
microcontrollers

STM32CubeMX is natively integrated
as code generator

Based on Eclipse (Text editor),
GCC (compiler) and GDB (debugger)




STM32CubeMX

L 30
an All-in-1 Development Tool .

Very powerful configuration and
code generation

Support all STM32 MCU and MPU,
with integrated powerful Finder

Pinouts, clock tree, peripherals and
middleware configuration.

STM32Cubel0  STM32Cubel1  STM32Cubel4  STM32CubeF1  STM32CubeF3  STM32CubeF2  STM32CubeF4 EXpandable to Support wireless
connectivity, sensors and much
more!

STM32CubeGO0  STM32CubeF0 STM32CubeF7 STM32CubeH7



X-CUBE-MEMST
31

an All-in-1 Development Tool

ME Additi

Pack/Bundle Pack Action | Group/Subgroup Selection Condition &

> ® STMX-CUBE-MEMS1/Application  6.0.1 Device
~ ® STMX-CUBE-MEMS1/Application  6.1.0 Device Installed
# SX-CUBE-MEMS1/Application  6.1.0 Device IKS01A3_DatalLogTerminal | IKSD1A..
® STMXCUBE MEMS1MEMS 6.0.1 Board Extension
® STMX-CUBE-MEMS1/MEMS. 5.0.1 Board Companent
® STMX-CUBE-MEMS1/MEMS 510 Board Extension Installed
# SX-CUBE-MEMS1MEMS 6510 Board Extension IKS01A2/ IKSO1A -
# SX-CUBE-MEMS1MEMS 610 Board Extension IKS01A3/ IKSO1A -
@ STMX-CUBE-MEMS1/MEMS 6.1.0 Board Companent Installed
Software Component Class hd
® STMX-CUBE-MEMS1/STM32Cube... 6.0.1 Board Support
® STMX-CUBE-MEMS1/STM32Cube... 6.1.0 Board Support Installed

Check/Uncheck All

[ STMicroelectronics

Drivers for sensors

[ Artificial Intelligence

[ Board Component

[ Board Extension
[ Board Support
[ Data Exchange
[ Device

[ Wireless

Board Support Package firmware

architecture

Accelerometer  Inertial  Magnetometer Gyroscope  Pressure  Temperature Humidity
module Sensor Sensor sensor

Include Sample Applications




X-CUBE-MEMST

an All-in-1 Development Tool

Sample Applications

. 6D Orientation, Wake Up, Self Test

Accelerometer

« Data Logging on Terminal . Self Test
A” SenSOI’S Magnetometer

. FIFO Mode

Pressure
Sensor

. 6D, FIFO Modes, FreeFall, Pedometer,
nertial 1AP, Tilt, Wake Up, Self Test

module

. Temperature Limit

Temperature
Sensor



..STM32CubelDE Installation

1. Click Next >

m STMicroelectronics STMM32CubelDE —

Inst allation Complete
Setup was completed successfully.

Completed




STM32CubelDE Installation

1. Click Finish



STM32CubelDE Configuration

1. Open STM32CubelDE by double clicking the icon on your desktop

2. Wait until STM32CubelDE is loading

M L2

5TM32CubelDE
102




STM32CubelDE Configuration

1. Check Use this as the default and do not ask again

2. Click Launch

EE sTM32CubelDE Launcher : ne t S =]
| d I me
STM es th directory to store its preferences and development artifac. sele
CY;,
Workspace: C\Users\andrea vitali\STM32CubelDE\workspace_1.0.2 - Browse... n




STM32CubelDE Configuration

The main interface of STM32CubelDE will appear differently, depending if it is
the first time it has been run or not:



Tera Term Installation



Tera Term Setup 1/9

1. Lunch the teraterm-4.102.exe installer inside the
X-CUBE-MEMS1_HandsOn\Software directory



Tera Term Setup 2/9

1. Accept the agreement

2. Click on Next

ﬁ' Setup - Tera Term 4.102

License Agreement

Please read the following impartant information before continuing.

Flease read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

License of Tera Term

Copyright (C) 1994-1998 T. Teranishi
(C) 2004-2019 TeraTerm Project
All rights reserved.

Redistribution and use in source and binary forms, with or without modification,
are permitted provided that the following conditions are met:

1, Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer,

(®) I accept the agreement
()1 do not accept the agreement




Tera Term Setup 3/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Destination Location
Where should Tera Term be installed?

Setup will install Tera Term into the following folder.

To continue, dick Mext. If you would like to select a different folder, dick Browse.

C:\Program Files (x36)\teraterm | | Browse. ..

At least 10,4 MB of free disk space is required. n

<Back || Next> | | Cancel




Tera Term Setup 4/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Components
Which components should be installed?

Select the components you want to install; dear the components you do not want to
install, Clidk Mext when you are ready to continue.,

| Standard installation w
Tera Term & Macro 9.7ME

TTS5H 2.6 MB

CygTerm+ 0.2 MB

[ ] LogMeTT (Other installer is started) 4,1 MB

[ ] TTLEdit (Other installer is started) 2.1 MB

[]TeraTerm Menu 0.3 MB

TTProxy 0.3 MB

[ ] collector 1.6 MB

[m] Additional Plugins 0.3me v

Current selection requires at least 13,5 ME of disk space.

<Back || Next> | | Cancel




Tera Term Setup 5/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Language
Which language shoud be used?

Select the language of application's menu and dialog, then dick Mext.

(®) English

() Japanese

() German

(") French

O Russian

i) Korean

i) Chinese{simplified)
() Chinese{Traditional)

<Back || Next> | | Cancel




Tera Term Setup 6/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Start Menu Folder
Where should Setup place the program's shortouts?

'
Setup will create the program's shortouts in the following Start Menu folder.
[ =]

To continue, dick Mext. If you would like to select a different folder, dick Browse.

|TeraTerm | | Browse...

[ ]Don't create a Start Menu folder n

<Back || Next> | | Cancel




Tera Term Setup 7/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Additional Tasks
Which additional tasks should be performed?

Select the additional tasks you would like Setup to perform while installing Tera Term,
then dick Mext.

Create Tera Term shortout to Desktop
Create Tera Term shortout to Quick Launch
[ ] add "Cygterm Here™ to Context menu

] create cyglaunch shorteut to Quick Launch
[] Assodiate .t file to ttpmacro.exe

[ ] Associate telnet protocol to ttermpro.exe
[ ] Associate ssh protocol to ttermpro, exe

] Associate .ty file to thermpro.exe




Tera Term Setup 8/9

1. Click on Install

ﬁ' Setup - Tera Term 4.102

Ready to Install
Setup is now ready to beqin installing Tera Term on your computer.,

Click Install to continue with the installation, or dick Badk if yvou want to review or
change any settings.

Destination location:
C:\Program Files (x8a)\teraterm

Setup type:
Standard installation

Selected components:
Tera Term & Macro
TTS5H
CygTerm+
TTProxy
Additional Plugins

TT¥ResizeMenu (VT-Window size can be changed from pr

= Back || Install || Cancel




Select Launch Tera Term

Click on Finish

Completing the Tera Term Setup
Wizard

Setup has finished installing Tera Term on your computer, The
application may be launched by selecting the installed
shortouts,

Click Finish to exit Setup.

V| Launch Tera Term;a




Preparing the Hardware



In Your Hands

NUCLEO-L476RG X-NUCLEO-IKS01A3 MINI USB CABLE
Development board with Motion MEMS and environmental Enable USB communication
STM32L476RG MCU, supports sensor evaluation board system to the laptop

Arduino and ST morpho connectivity



Preparing the Hardware

1. Stack NUCLEO-L476RG and X-NUCLEO-IKS001A3 and connect it to
the PC



Tera Term Configuration



Plug the board to the PC using the micro USB cable provided

Select the STMicroelectronics Virtual COM Port

WT

CIiCk OK File Edit Setup Control Window Help

Tera Term: Mew connection
OTC PHIP

23

55HZ

G UNSPEC

® Serial Port: |COM38: STMicroelectronics ¥Yirtual C( -

| 0OK Cancel Help




Click Setup -> Serial port...

COMITY - Tera Term VT

File

Edit

Setup  Control

Terminal...
Window...
Font...
Keyboard...
Serial port...
Proxy...
S5H...

55H Authentication...
55H Forwarding...
55H KeyGenerator...
TCP/IP...

General...

Additional settings...

Save setup...
Restore setup...
Setup directory...

Load key map...

Window Help




Tera Term Configuration 3/5

1. Set the following:
Baud Rate: 115200
Data: 8 bit
Parity: none
Stop: 1 bit

Flow control: none 0 6

2. Click OK



Click Setup -> Save setup...

COMITY - Tera Term VT

File

Edit

Setup  Control  Window

Terminal...
Window...

Font...

Keyboard...

Serial port...
Proxy...

S5H...

55H Authentication...
55H Forwarding...
55H KeyGenerator...
TCP/IP...

General...

Additional settings...

Save setup...
Restore setup...
Setup directory...

Load key map...




Tera Term Configuration 5/5

1. Click Save



Hardware and Software Check

o [T ©

A—

» At this point you should all have:
1. Installed STM32Cube libraries
2. Installed STM32CubelDE
3. Stacked the Nucleo-L476 with X-Nucleo-IKS01A3 and plug it to the PC
4. Installed and configured Tera Term



NUCLEO-L476RG Header Pinout

In our labs we are going to use:
1. PB_8 and PB_9 for I2C interface
2. PB _0,PC_1and PB_5 for interrupts
3. PC_13 for user button
4. PA_5 forthe LED
g lorine ° -




X-NUCLEO-IKS01A3 Header Pinout

In our labs we are going to use:

1. PB_8 and PB_9 for I2C interface

2. PB _0,PC_1and PB_5 for interrupts
3. PC_13 for user button

4. PA_5 forthe LED




Goals:
« Configure a new project using X-CUBE-

LABO
« Configure all sensors and read data in polling

mode
* Visualizing sensor data on Tera Term



Leading Sensors for loT

ACCELEROMETER
& GYROSCOPE

6-Axis IMU

LSM6DSO

Wearables,
Smartphones, loT,
AR/VR

ULTRA LOw
POWER

ACCELEROMET

LIS2DW12

loT, wearable,
anti-tampering,
security

HIGH ACCURACY
PRESSURE
SENSOR

Compact, low
power, water
resistant

LPS22HH

MAGNETOMETER
COMPASS

LIS2ZMDL

Accuracy,
Temperature
Stability

LocAL
TEMPERATURE
SENSOR

STTS751

Low Voltage,
Low Power

HUMIDITY AND
TEMPERATURE

COoMBO
HTS221

Compact
Low Power

* Best in class for
Power/Noise

* Embedded Digital
Features including:
New Pedo, FSM

* High speed 13C
interface

* Real dual core

* Flexibility Power
Consumption vs.
Noise

* Ecosystem (SW,
libraries, ref design,
Nucleo boards ...)

* LPS22HH: high
accuracy,

* Low Power
Consumption

» Skip One Point Cal.
post Soldering

* Power Consumption

* Thermal Stability &
Precision

* The LIS2MDL has a
magnetic field
dynamic range of £50
gauss.

« Ultra low power with
one shot mode for
superior power
savings

* SMBus 2.0
compliant supporting
ALERT command

* Very small package

* Direct H and T data
readout

* Low current
consumption (3.5uA)

* Industrial
temperature
operating range




Lab0

1. Click on File > New > STM32 Project



Lab0

1. Check Remember my decision*®

2. Click on No

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



Lab0

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Lab0

1. Project Name Lab0

2. Click Finish




Lab( mm

1. Click Yes to init peripherals in default mode



Lab0

1. Check Remember my decision

2. Click Yes




Lab( mem

1. Check Remember my decision

2. Click No *

* We are using all the tools
in offline mode, so that internet
connection is not strictly needed



Lab0 — Configure the 12C Bus m=m

1. Left Click on PB9 pin

2. Select 12C1_SDA

> ®



Lab0 — Configure the 12C Bus

1. Left Click on PB8 pin

2. Select12C1_SCL

T > °



Lab0 — Configure the 12C Bus

1. At this point 12C1 pins PB9 and PB8 should appear in yellow (selected but
not configured)

>



Lab0 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

. Select 12C in 12C1 Mode

and Configuration

. PB8 and PB9 should 0
now become green




Lab0 — Select the MEMS Library

1. Click on
Additional Software



Additional Software Intro

X-CUBE-MEMS1/... will be
the Pack/Bundle we are
going to use in this hands-on

If multiple X-Cube packs, If needed, enlarge the column
use latest version: here Selection to see the options
version 6.2.0 available

[ additional 53
Filters

* @

are Components selection

&

Search hd
Q |
Pack Vendor hd

[ STMicraelectronics

Software Component Class hd

[ Artificial Intelligence
[ Board Component
[ Board Extension

(1 Board Support

[ Data Exchange

[ Device

[ Wireless

(=]
Pack / Bundle / Component VEE =
> STMicro
> STMicroelect
> STMicroelectroMgs X-CUBE-GNSS1
w

STMicroelectronics X-CUBE-MEMS

>
>
>
>

Device_Application

Board_Component_MEMS
Board_Extension_ MEMS

Board_Support_STM32Cube_Custom_BSP_Drivers
> STMicroelectronics X-CUBE-NFC4

Show/hide filters 4 Show/hide details < Show/hide dependencies

140M®

Ok




Additional Software Intro

There are two ways to use the X-CUBE-MEMS1 Pack/Bundle:

 If you are using the X-NUCLEO from STMicroelectronics
1. Select the high level Device application. Example: IKSO01A3 DatalLogTerminal
2. Select the Board Extension that you are using. Example: IKS01A3

- If you are using a custom expansion board
1. Select the high level Device application. Example: DataLogTerminal
2. Select the middle level Board Support Pack (BSP). Example: Custom/MOTION SENSOR
3. Select the low level Board Components. Example: AccGyr/LSM6DSO on 12C




Additional Software Intro

There are two ways to use the X-CUBE-MEMS1 Pack/Bundle:

Lab0 - Lab 5
ot are using the X-NUCLEO from STMicroelectronics

1. Select the high level Device application. Example: IKSO01A3 DatalLogTerminal

elect the Board Extension that you are using. Example: IKS01A3

e using a custom expansion board

1. Select the high level Device application. Example: DataLogTerminal
2. Select the middle level Board Support Pack (BSP). Example: Custom/MOTION SENSOR
the low level Board Components. Example: AccGyr/LSM6DSO on |12C




Click to

expand tree

Lab0 — Select the MEMS Library

.
[ additional Software Components selection
Filters Packs

*

ke @ O

Pack / Bundle / Component
STMicroelectronics X-CUBE-AI

STMicroelectronics X-CUBE-BLE1
STMicroelectronics ¥-CUBE-GMNSS1

440

300M
STMicroelectronics X-CUBE-MEMSA 620

=]

Collapse all
‘

Selection

: Device_Application
Application |IKSU1A3_DataLDgTerminaI ~
Board_Component MEMS
Software Compaonent Class
Board_Extension _MEMS
O Artificial Intelligence IKS01A2 O
1 Board Component IKS01A3

Roard Sunnort STM3?Cube Custom BSP Drivers

In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_DatalLogTerminal

In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

Click OK

. ]




Lab0 — Configure the MEMS Library

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:
Board Extension MEMS
Device Application

3. Configure Platform Settings 6
as in picture (details in
next page)




Lab0 — Configure the MEMS Library

Configuration

Reset Configuration

@ FParameter Settings | Blatiarm Settings

- Platform proposal
-BSP

Name IPs or Components Found Solutions 12C Addr BS

BSP BUTTON GPIO:EXTI PC13 [B1 [Blue PushButton]] ~ | BSF

BSP USART USART:-Asynchronous LISARTZ ~ [ BSP

BSP LED GPIO-Output PAS [LD2 [green Led]] BSP

KS01A3 BUS 1O drver |12C:12C




Lab0 — Save the Project mm
1. Click the save button




Lab0 — Code Generation

1. Check Remember my decision

2. Click Yes



Lab0 — Code Editing

1. Expand Src

2 Double CIiCk On main c File Edit Sorce Refactor Mavigate Search Project Run  Window Help
L L}

B-HE - R -Bik-idies-[HH-FH-oer-0-0 [Quick Access] | g | i
[¥5 Project Explorer 3 = O mLabO.ioc [ main.c 32 = O
= <3=={'> - 1 IK* USER CODE BEGIN Header */ -
2._.‘;’**
vm Labd 3
> [l Includes 4 * [@file : main.c
» 2 Drivers 5 * fibrief : Main program body
w [ Src 6
5 [2 app_x-cub: ; : @attention
> [€] main.c a * <h2r<centerr&copy; Copyright (c) 2819 STMicroelectronics.
> [g] stm32idoch 10 * All rights reserved.</center></h2>
> ] stm32Mocit.c 1 *
3 @ stm32l4w_nucleo_bus.c 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [8 syscalls.c 13 * the “License"; You may not use this file except in compliance with the
14 * License. You may obtain a copy of the License at:
> €] sysmem.c 15 * opensource.org/licenses/B5D-3-Clause
5 [ system_strn32l4wc 15 =
> [ Startup 17
> = Inc 18 */
m LabO.ioc 19 /* USER CODE END Header */
= 28
|Td STM32L476RGTX_FLASH.Id 21 /% TNCLUAES — === m = m - o m . oy
[T STM32L476RGTX_RAM.Id 22 #include "main.h”
23 #include "app_x-cube-memsl.h"
24
252 /* Private dincludes ---------------mmmmm */
26 /* USER CODE BEGIN Includes */
27
28 /* USER CODE END Includes */
29
382 /* Private typedef ---------------\0-"0"bbbb i bbb i i e o ———————— */
31 /* USER CODE BEGIN PTD */
32
33 /* USER CODE END PTD */
34
358 /* Private define -------------ommmmmm */
36 /* USER CODE BEGIN PD */
37
38 /* USER CODE END PD */
39
489 /* Private Macre —------- - oo oo e */
41 /* USER CODE BEGIN PM */
el PRy v
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Lab0 - Compiling

1. Click on the hammer %- to begin compilation, or press CTRL+B

BE workspace_1.0.0, 1 1ain.c - 5TM32Cubel DE

2. Compilation should terminate | = s S s row o e v
Tl | ®-R-Bit-iddI-[HH-F-oec-2-0 |Quick Access] ;| g% | B[
L] L] :
with O errors and O warning  |cromsess =5 Muste G =5
= <!=|,=> - 1 IK* USER CODE BEGIN Header */ -
26 j*=
VB 3
> 3 Binaries 4 * [@file : main.c
> [t Includes 5 * fibrief : Main program body
> 2 Drivers 6
v (& Sre ; : @attention
> @ app.l_x-cube-mems'l.c a * <h2r<centerr&copy; Copyright (c) 2819 STMicroelectronics.
> || main.c 10 * All rights reserved.</center></h2>
> €] stm32Moc_hal_msp.c 11 *
3 @ st 321de_it.c 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [8 stm324i_nuclea_bus.c 13 ’ the "License"™; You may not use this ‘Fil? except in compliance with the
B lec 14 * License. You may obtain a copy of the License at:
’ syscalls. 15 * opensource.org/licenses/BSD-3-Clause
5 [ sysmem.c 15| =
5[] system_strn32l4wcc 17
> (2 Startup 18 ) */ .
5 (= Debug 19 /* USER CODE END Header */
& 28
> ne . b R e o T L e */
[ Labd.ioc 22 #include "main.h”
|Td STM32L476RGTX_FLASH.Id 23 #include "app_x-cube-memsl.h"
|3d STM32L476RGTX_RAM.Id 24 _ v
B Console 33 @@%|':E5E::_|ZE'F3':E|
COT Build Console [Lab0]
RIS G DuEEwaig SST G T CEoT T
A
arm-none-eabi-size  Lab@.elf
arm-none-eabi-objdump -h -5 Lab@.elf > "Lab@.list"
text data bss dec hex filename
597ea 528 2616 62844 f57c Lab@.elf
Finished building: default.size.stdout
Finished building: Lab®.list
16:82:38 Build Finished. @ errors, @ warnings. (tock 12s.583ms)
v
£ >
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Click on the bug jﬁﬂ to begin debugging

E workspace_1.0.0 - Lab0/Src/

Select
STM32 MCU C/C++ App

= 8
B5Y ¥

[¥5 Project Explorer 3

vm Labd
> &'} Binaries
> [l Includes
> 2 Drivers
v @ Src

» [€] app_x-cube-memsl.c

Click OK

o €] main.c

> @ stm32ldioc_hal_msp.c

> €] stm32Meit.c

> @ stm32l4e_nucleo_bus.c
5 [g] syscalls.c

> €] sysmem.c

€] system_strm32ldo0e
[ Startup

= Debug

= Inc

m Labl.ioc

|Td STM32L476RGTX_FLASH.Id
|3d STM32L476RGTX_RAM.Id

vow W

B HG B R Bk Ao @

Lab0 - Debugging mem

32CubelDE — O s
Search Project Run  Window Help
| | @@
[ Lab0.ioc [€] main.c 52 = 0
* *
;_.i**USER CODE BEGIN Header i€ Debug As -
3 EEXXEXEXXEXERX K
4 * {@file : main.d Select away to debug 'Lab0":
5 * fibrief : Main g —
& [€]Local C/C++ Application o
7| = @attention [[F5TM32 MCU C/C++ Application 2
8 *
a * <h2r<centerr&copy; Copyr|
10 * All rights reserved.</cq
11 *
12 * This software component license,
13 * the “License"; You may rf E with the
14 * License. You may obtain
15 * q
16 *
17 Descri tion frExrrrrrkrkrrrk
18l = i o
19 /* USER CODE END Header */ STM32 MCU C/C++ Application
28
21 /* Includes ---------------4 e */
22 #include "main.h"
23 #include "app_x-cube-memsl.H
& Console 32 ® | oK Cancel @@%|EE§ZE|SE'F3'=‘E
CDT Build Console [Lab0]
RIS G DuEEwaig SST G T CeoT T
A
arm-none-eabi-size  Lab@.elf
arm-none-eabi-objdump -h -5 Lab@.elf > "Lab@.list"
text data bss dec hex filename
597ea 528 2616 62844 f57c Lab@.elf
Finished building: default.size.stdout
Finished building: Lab®.list
16:82:38 Build Finished. @ errors, @ warnings. (tock 12s.583ms)
v
£ >
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Lab0 - Debugging

1. Click OK



Lab0 - Debugging ==

» The first time you debug the board by pressing vl;f; , a Problem Occurred
because ST-LINK needs to be upgraded

Ne
W NU
aly,. “CLEg,
Vs he o boa,.
u ed¢, , 'ds
Dg,a degy 0 pe



Lab0 — Updating ST-LINK ===

1. Click OK to run upgrade to latest firmware



Lab0 — Upgrading ST-LINK ===

1. Click Yes when is asked to upgrade the ST-LINK

B workspace_1.0.0 - Lab0/Src/main.c - STM32CubelDE - O >
File Edit Source Refactor Mavigate Search Project Run  Window Help
N-HGI - R-Bidi - I-HH-F G- O |Quick Access| | 9 | B8 [ 4
[¥5 Project Explorer 3 = B [ Labioc [€] main.c 52 = 0
s - 1 /* USER CODE BEGIN Header */ ~
='|> 2._.;**
viZLaeo 3
> 3%, Binaries a4 * [@file : main.c
> )l Includes 5 * ibrief : Main program body
> (2 Drivers 6
7 * [@attention
w @ Src : . @
> @ app__x-cube-memﬂ.c 9 * <h2»<center>&copy; Copyright (c) 2019 STMicroelectronics.
> [l main.c 18 * All rights reserved.</center></h2>
> [ stm32Mc_hal_msp.c 11 *
3 @ st 321de_it.c 12 * This software component is licensed by ST under BSD 3-Clause license,
> stm32lde_nucleo_bus.c = * the "LE ST-LINK
&l _nuclea_ DO |iGE <7k
s [g] syscalls.c 15 .
> €] sysmem.c 16 * ST-LINK firmware upgrade required.
» €] system_stm32ldo0e 17 Rl Please first reconnect ST-LINK, and then select YES to upgrade using the ST-LINK
> [ Startup 18 */ upgrade tool.
5 (= Debug 19 /* USER COD|
= Inc 28
’ 21 /* Includes Yes | | No
=/ LabD.elf launch 22 #include "m
m Labl.ioc 23 #include "app——cuoe T
|id STM32L476RGTX_FLASH.Id 24 v
|3g STM32L476RGTX_RAM.Id
& Console &3 Ux%|§k£ﬁ§¢@@|ﬂa'rﬁ':ﬁ
<terminated> Lab0.elf [STM32 MCU Debugging] ST-LINK (ST-LINK GDB server)
A
Starting server with the following options:
Persistent Mode : Disabled
Logging Level : 1
Listen Port Number T 61234
Status Refresh Delay 1 15s
Verbose Mode : Disabled
SWD Debug : Enabled
Error in initializing ST-LINK device.
Reason: ST-LINK firmware upgrade required. Please upgrade the ST-LINK firmware using the upgrade tool.
v
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Lab0 — Upgrading ST-LINK ==

1. Click Open in update mode to force ST-LINK

2. Click on Upgrade




Lab0 — Upgrading ST-LINK ==

Wait until update is finished and then close the window.

1. Click on X when
finished



Lab0 - Debugging m=m

Click again on the bug "ﬁ“ to begin debugging

Select
STM32 MCU C/C++ App

Click OK

E workspace_1.0.0 - Lab0/Src/
File Edit Source Refactor

DGR - R - @ik S~

[ Project Explorer 52 = B
g -
v E Labd
> &'} Binaries
> [l Includes
> 2 Drivers
v @ Src
s [€] app_x-cube-memsl.c
o €] main.c
> @ stm32ldioc_hal_msp.c
> €] stm32Meit.c
> @ stm32l4e_nucleo_bus.c
5 [g] syscalls.c
> €] sysmem.c
€] system_strm32ldo0e
[ Startup
= Debug
= Inc
m Labl.ioc

| STM32L4TERGTX_FLASH.Id
|3d STM32L476RGTX_RAM.Id

vow W

32CubelDE
Search Project Run  Window Help

G ~-Fl-oero-| 0

- [} X

[Goreees] | | I

[ Lab0.ioc [€] main.c 52 = 0
* *
;_.i**USER CODE BEGIN Header i€ Debug As -
3 EEXXEXEXXEXERX K
4 * {@file : main.d Select away to debug 'Lab0":
5 * fibrief : Main g —
5 [E]Local C/C++ Application i e
7| = @attention [[F5TM32 MCU C/C++ Application 2
8 *
a * <h2r<centerr&copy; Copyr|
10 * All rights reserved.</cq
11 *
12 * This software component license,
13 * the “License"; You may rf E with the
14 * License. You may obtain
15 * q
16 *
17 Descri tion frExrrrrrkrkrrrk
18l = i o
19 /* USER CODE END Header */ STM32 MCU C/C++ Application
28
21 /* Includes --------------—-—4 e */
22 #include "main.h"
23 #include "app_x-cube-memsl.H
= Console 2 @ [ oK Cancel 4 ¢ S| BEE =B tB~-9-= 8
CDT Build Console [Lab0]
RIS G DuEEwaig SST G T CeoT T
A
arm-none-eabi-size  Lab@.elf
arm-none-eabi-objdump -h -5 Lab@.elf > "Lab@.list"
text data bss dec hex filename
597ea 528 2616 62844 f57c Lab@.elf
Finished building: default.size.stdout
Finished building: Lab®.list
16:82:38 Build Finished. @ errors, @ warnings. (tock 12s.583ms)
v
£ >
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Lab0 - Debugging

1. Click OK



Lab0 - Debugging

1. Code start at the first line of the main function

2. Click play b button 6
to run the code



Lab0 - Debugging

1. Open Tera Term to view the output



Lab0 - Debugging

1. Click stop button to interrupt the debugging



Lab0 — Closing the Project mm

1. Right-Click on Lab0 project

2. Click on Close Project




Goals:
» Configure a new project using X-CUBE-MEMS1

LAB 1 » Configure LIS2DW12 accelerometer in order to
generate an interrupt at every orientation change
* Enable interrupts in STM32CubelDE
* Visualizing the new orientation on Tera Term



LIS2DW12 m=m

Power saving and flexible Accelerometer

Down to 0.38 nA power consumption (1.6Hz ODR) Enabling battery saving
High Perf. mode: up to 1600Hz with noise density Accuracy
90 pug/\Hz

5 Power Modes + 2 Noise Modes High Flexibility

32-level FIFO buffer

System Power Saving & Smart Functions

Digital Features
Free fall
Wake-up
6D /4D
Stationary/Motion detection

Double Tap

LGA-12L
(2.0x2.0x0.7 mm)




Lab1 mem

1. Click on File > New > STM32 Project



Lab1

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Lab1

1. Project Name Lab1

2. Click Finish



Lab1

1. Click Yes to init peripherals in default mode



Lab1 — Configure the 12C Bus

1. Left Click on PB9 and
select 12C1_SDA

2. Left Click on PB8 and
select 12C1_SCL

>



Lab1 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

. Select 12C in 12C1 Mode

and Configuration

. PB8 and PB9 should
now become green °



Lab1 — Configure LIS2DW12 Interrupt

1. Left Click on PB0 and
select GPIO_EXTIO



Lab1 — Configure LIS2DW12 Interrupt

. Check NVIC in tab

System Core

. Select NVIC in NVIC

. Enable

Mode and Configuration

EXTI line0 interrupt



Lab1 — Select the MEMS Library

1. Click on
Additional Software



Lab1 — Select the MEMS Library

m Additional Software Components selection [==]
Filters Packs
T ® x| ) Collapse all
ersion Selection 5

Click to
expand tree

IKS01A3_LIS2DW12_6DOrientation ~ | I

Software Component Class

oard_Extension_|
KS01A2
KS01A3

[ Artificial Intelligence

[ Board Component

FFFFFF

["1 Board Extension

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3 LIS2DW12_6DOrientation

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”: @)
Check IKS01A3/

3. Click OK



Lab1 — Configure the MEMS Library

. Expand Additional Software and select the X-CUBE-MEMS1

. Check both:

Board Extension MEMS
Device Application

. Configure Platform Settings 6
as in picture



Lab1 — Configure the MEMS Library

@ Parameter Settings | & BI&torm Settings "

-Platform proposal
- Application

Name IPs or Components Found Solutions

MEMS_INT_PIN_A |GPIO-EXTI PBO

-BSP “

Name IPs or Components Found Solutions  [2C Addr

BSP BUTTON GPIO:-EXTI PC13 [B1 [Blue PushButton]] ~ %

BSP USART USART:Asynchronous USARTZ

BSP LED GPID:Dutput

IKS01A3 BUS 1O driver |12C:12C




Lab1 — Save the Project

1. Click the save button ['ﬁ']

This action will generate 0
the source code of this lab



Lab1 — Code Editing

1. Expand Src in folder Lab1

. - main.c - ST )
2 - Dou ble CIICk On maln.c File Edit 5curce Refactor Mavigate Search Project Run Window Help
BB ®-R-RBidiw-SdI-[HH-H-oe-0|0 [uick Access] | 5 | R0
I Project Explorer 33 = O m Labl.ioc [ main.c 32 = O
= (_E|> = 1 y* USER CODE BEGIN Header */ ~
g LabO 2._.‘;’**
3
VE Lab1 4 * [@file : main.c
> [ Includes 5 * fibrief : Main program body
> 22 Drivers 6
v 2 Sre ; : [@attention
> €] app_mems_int_pin_a_inter 9 * ¢h2»<center>&copy; Copyright (c) 2019 STMicroelectronics.
> €] app_x-cube-memsl.c 18 * All rights reserved.</center></h2>
> L] main.c 11 *
3 @ stm32ldio_hal_msp.c 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [8) stm32icit.c 13 * the “License"; You may not use this file except in compliance with the
- 14 * License. You may obtain a copy of the License at:
> €] stm32lec nucleo_bus.c 15 * opensource.org/licenses/BSD-3-Clause
> g syscalls.c 16 *
> @ Sysmem.c 17
> €] system_stm32idec.c B *
5 (3 Startup 19 /* USER CODE END Header */
28
> & Inc . 21 /% Includes —----mmmm oo */
[0 Lablioc 22 #include "main.h"
|Td STM32L476RGTX_FLASH.IA 23 #include "app_x-cube-memsl.h"
|Tg STM32L4T6RGTX_RAM.Id 24
252 /* Private includes ---------------mmmmmm */
26 /* USER CODE BEGIN Includes */
27
28 /* USER CODE END Includes */
29
382 /* Private typedef -------->------:"0b bbb i e il e */
31 /* USER CODE BEGIN PTD */
32
33 /* USER CODE END PTD */
34
352 /* Private defipe ---------""0-"o v bbbl */
36 /* USER CODE BEGIN PD */
37
38 /* USER CODE END PD */
34
489 /* Private macro —--------mm oo s m oo oo */
41 /* USER CODE BEGIN PM */
42 v
£ >
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Lab1 - Compiling

1. Click on the hammer %- to begin compilation, or press CTRL+B

IDE workspace_1.01 1 main.c - 5STM32CubelDE

2. Compilation should terminate [ e . S S e tn tnion e

. . T RF R R S-S SR PRl R R CRCREONY [uick Access] | g | B&
with O errors and 0 warning ST - o [ -

=] <§> - 1 /* USER CODE BEGIN Header */ -~
3 Labo i
v [ Lab 4 * [@file : main.c
> g;-? Binaries 5 * (@brief : Main program body
3 I@J Includes 6
5 [ Drivers 7 * [@attention
8
v (5 Src . . . 9 * ¢h2»<center>&copy; Copyright (c) 2019 STMicroelectronics.
> €] app_mems_int_pin_a_inter 1@ * All rights reserved.</center></h2>
> [ app_x-cube-memsi.c 11 *
3 @ main.c 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [8 stm32i_hal_msp.c 13 ’ tI'Iua "License"; You may not use this ‘Fil? except in compliance with the
. 14 * License. You may cbtain a copy of the License at:
> (8 stm32Mo ftc 15 * opensource.org/licenses/BSD-3-Clause
> @ stm32ldie_nucleo_bus.c 16 =
5 [ syscalls.c 17
> € sysmem.c 18 *y
s [ system_stm32loce ;g /* USER CODE END Header */
> 2 Startup 21 /% Includes —---- - oo oo oo e */
> [= Debug 22 #include "main.h"
> [= Inc 23 #include "app_x-cube-memsl.h"
[ Lablioc 24 &
|g STM32LA76RGTX_FLASH.IA
|3g STM32L476RGTX_RAM.Id B Console 44 <|§>| B RE = B | #B-My= 8

CDT Build Console [Lab1]
FIN1sNed DULLO1Ng Target: Labl.eir

A
arm-none-eabi-size  Labl.elf
arm-none-eabi-objdump -h -5 Labl.elf > "Labl.list"
text data bss dec hex filename
44196 ELt:] 2272 46828 b6ec Labl.elf
Finished building: default.size.stdout
Finished building: Labl.list
15:@3:06 Build Finished. @ errors, @ warnings. (took 14s5.949ms)
v
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Click on the bug jﬁﬂ to begin debugging

Select
STM32 MCU C/C++ App

Click OK

Lab1 - Debugging

m workspace_1.0.0 - Lab1/Src/main

File Edit Source Refactor MNawi

[ Project Explorer 53 = 8

& -

3 Lab0
+ I Lab1

> &'} Binaries

> @]] Includes

> 22 Drivers

v 2 Src

> @ app_mems_int_pin_a_inter

app_x-cube-memsl.c
main.c
stm32lde_hal_msp.c
stm32ldio_it.c
stm32lde_nucleo_bus.c
syscalls.c
SYSMem.c

FREEEEERE

VW OW W W W W Y

systermn_stm32ldwoc.c

2 Startup

= Debug

= Inc

[ Lablioc

|g STM32LA76RGTX_FLASH.IA
|3g STM32L476RGTX_RAM.Id

VoW W

helDE

Project Run  Window Help

O EHR - R - BidH - @@y~ fH-F -2 0O

m Labl.ioc [€] main.c 32

1 /* USER CODE BEGIN Header *
28 J**

IDE Debug As

3 LRt ]
4 * @file . main.qd Selectaway to debug'labl"
5 * [@brief : Mai
5 @brie s [ElLocal C/C++ Application [,
7 * @attention [T STM32 MCU C/C++ Application (Y2
a *
9 * <h2»<center>&copy; Copyil
1@ * All rights reserved.</cq
11 *
12 * This software component license,
13 * the "License"; You may e with the
14 * License. You may cbtain
15 *
16 *
1? Description LRt ]
18 * o =
19 /* USER CODE END Header */ STM32 MCU C/C++ Application
28
21 /* Includes -------------—--4 0 femmmmeeeee e */
22 #include "main.h"
23 #include "app_x-cube-mems1.H
24
& Conscle 33 @ I oK | | Cancel
CDT Build Console [Lab1]

- O X

[oieee | | [
= 8

-~

¢ 4%

BE=BMB-m-=0

FIN1sned DUILO1Ng Target: Labl.eLr

arm-none-eabi-size  Labl.elf

arm-none-eabi-objdump -h -5 Labl.elf > "Labl.list"
text data bss dec hex filename
44196 ELt:] 2272 46828 b6ec Labl.elf

Finished building: default.size.stdout

Finished building: Labl.list

15:@3:06 Build Finished. @ errors, @ warnings. (took 14s5.949ms)
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Lab1 - Debugging

1. Click OK



Lab1 - Debugging

1. Code start at the first line of the main function

2. Click play g button a
to run the code



Lab1 - Testing

1. Open Tera Term to view the output

Rotate the board to see
the output changing

2. After testing close Tera Term
by clicking X



Lab1 - Debugging

1. Click stop button to interrupt the debugging



Lab1 — Closing the Project

1. Right-Click on Lab1 project

2. Click on Close Project



Goals:
« Configure a new project using X-CUBE-MEMS1

LABZ « Configure LPS22HH pressure and temperature
sensor to acquire data using internal FIFO

* Enable interrupts in STM32CubelDE



LPS22HH

High-performance, high-ODR Barometer / Altimeter

Absolute Accuracy: 0.5hPa

Relative Accuracy: £0.025hPa

RMS Noise: +0.65Pa (0.0065hPa)
ODR up to 200Hz

Embedded Temperature compensation

Unique Full Molded Package

High Resolution - ~5cm

High Performance: excellent noise figure

Fast Response

System

Robustness

Skip One Point Cal.

post Soldering
- Cost Saving

Power Saving

HLGA-10L |:|
(2x2x0.73 mm)



Lab2

1. Click on File > New > STM32 Project



Lab2

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Lab2

1. Project Name Lab2

2. Click Finish



Lab2

1. Click Yes to init peripherals in default mode



Lab2 — Configure the 12C Bus

1. Left Click on PB9 and
select 12C1_SDA

2. Left Click on PB8 and
select 12C1_SCL

>



Lab2 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

. Select 12C in 12C1 Mode

. PB8 and PB9 should

and Configuration

now become green




Lab2 — Configure LPS22HH Interrupt

1. Left Click on PB10 and
select GPIO_EXTI10



Lab2 — Configure LPS22HH Interrupt

. Check NVIC in tab

System Core

. Select NVIC in NVIC

. Enable

Mode and Configuration

EXTI line[15:10] interrupt




Lab2 — Select the MEMS Library

1. Click on
Additional Software



Lab2 — Select the MEMS Library

mﬁ\ddi‘tl’onal Software Components selection [==]
Filters Packs

* @ & 1nx | J Collapse all
- :
Cl | Ck tO Search v STMicroelectronics X-CUBE-Al
icroelectronic

>
Q | > STMicroelectronics X-CUBE-BLE1 440
expand tree \ > STMicroelectronics X-CUBE-GNSS1 3.00M 0
mack Vendor v icroelectronics X-CUBE-MEMS1
. Lievice_A ICatian

Software Component Class

KS01A2
KS01A3

[ Avtificial Intelligence
[ Board Component
[] Board Extension

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3 LPS22HH_FIFOMode

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”: @)
Check IKS01A3/

3. Click OK



Lab2 — Configure the MEMS Library

. Expand Additional Software and select the X-CUBE-MEMS1

. Check both:

Board Extension MEMS
Device Application

. Configure Platform Settings 6
as in picture



Lab2 — Configure the MEMS Library

- Platform proposal

-Application

Name IPs or Components Found Solutions 12C Addr

MEMS_INT_PIN_A |GPIO:EXTI PE10

-BSP
Name IPs or Components Found Solutions 12C Addr BSP!{

BSP BUTTOM GPIC:EXTI ~ | |[PC13 [B1 [Blue PushButton]] ~ | BSP_Ci

BSP USART USART:Asynchronous ~ | |LUSARTZ ~ | BSP_Ci

BSP LED GPIO:Output ~ | |PAS [LD2Z [green Led]] BSP Ci

IKS01A3 BUS 1O driver 12C:12C BSP_Bl




Lab2 — Save the Project

1. Click the save button ['ﬁ']

This action will generate 0
the source code of this lab



Lab2 — Code Editing

1. Expand Src in folder Lab2

. - rain.c - 5Th )
2. Double click on main.c Fle it Sowce Ao Hovte Sech ot Aindon bl
O-HR ®-R-Bidiw-ids-{HE-H-0c-2-0 |Quick Access| :| 5 | B@ [T A%
I Project Explorer 33 = B8 [@Labioc [€] main.c £2 = 0
= <§> - 1 y* USER CODE BEGIN Header */ ~
2._.‘;’**
3 Labd 3 * ek
0 Labt 4 * [@file : main.c
VE Lab2 5 * fibrief : Main program body
> [ Includes 6 * B
5 (2 Drivers ; : [@attention
v [ Src . - .
. . . 9 * ¢h2»<center>&copy; Copyright (c) 2019 STMicroelectronics.
> €] app_mems_int_pin_a_interf 18 * All rights reserved.</center></h2>
» [ app_x-cube-memsl.c 11 *
3 @ main.c 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [8 stm32i4hal_msp.c 13 * the “License"™; You may not use this file except in compliance with the
[6) stm32l4 _'t - 14 * License. You may obtain a copy of the License at:
’ mack e 15 * opensource.org/licenses/BSD-3-Clause
> @ stm32lde_nucleo_bus.c 16 *
» @ syscalls.c 17 * U
5 [ sysmem.c 18 */
3 @ system_stm32diac.c 19 /* USER CODE END Header */
» 2 Startu ) 28
P 21 /% Includes —-----mmm oo */
> = Inc 22 #include "main.h”
m Lab2.ioc 23 #include "app_x-cube-memsl.h"
[T STM32L4T6RGTX_FLASH.IA 24
[5 STM32L476RGTX_RAM.Id 252 /* Private includes ----------------mmmmmm e */
- 26 /* USER CODE BEGIN Includes */
27
28 /* USER CODE END Includes */
29
3@= /* Private typedef ----------""-"0"bb bbb i e i e —— —, */
31 /* USER CODE BEGIN PTD */
32
33 /* USER CODE END PTD */
34
352 /* Private defipe ---------""v--'bv"00oiv el */
36 /* USER CODE BEGIN PD */
37
38 /* USER CODE END PD */
34
489 /* Private macro —-------m o m s oo e */
41 /* USER CODE BEGIN PM */
42 w
£ >
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2. Compilation should terminate
with O errors and 0 warning

BE workspace_1.0] 1

File

i

I Project Explorer 33

Edit

-

17 Labd
I Lab1

~ I Lab2

> g;-? Bin
> @].l Inc

Source

Mavigate
il
= 8

i3 -

IS

=]

aries

ludes

> [ Drivers

v [ Src
> g

app_mems_int_pin_a_interf

» [ app_x-cube-memsl.c
> L] main.c
> [ stm32iohal_msp.c
> [ stm32kboc_it.c
> @ stm32lde_nucleo_bus.c
> [ syscalls.c
> [ sysmem.c
> [ system_stm32l4ic.c
> [ Startup
» 2= Debug
3 = Inc

| STM32L4TERGTX_FLASH.IA
|3d STM32L476RGTX_RAM.Id

Lab2 - Compiling

1. Click on the hammer %- to begin compilation, or press CTRL+B

main.c - 5STM32CubelDE

Search Project Run  Window Help
TR AT TR IR IR RN
m LabZioc [€] main.c £2
1 /* USER CODE BEGIN Header */
2@ =
4 * [@file : main.c
5 * (@brief : Main program body
7 * [@attention
8
9 * ¢h2»<center>&copy; Copyright (c) 2019 STMicroelectronics.
1@ * All rights reserved.</center></h2>
11
12 * This software component is licensed by ST under BSD 3-Clause license,
13 * the "License™; You may not use this file except in compliance with the
14 * License. You may obtain a copy of the License at:
15 * opensource.org/licenses/BSD-3-Clause
16 *
18 */
19 /* USER CODE END Header *;"’I
28
21 /F Includes —---mmm s e e e e */
22 #include "main.h”
23 #include "app_x-cube-memsl.h"
24
B Console 33

CDOT Build Console [Lab2]

oreed i | G

= 0

-~

FINlsfed DULLOLNg Target: LabZ.elr

arm-none-eabi-size  Lab2.elf

arm-none-eabi-objdump -h -5 Lab2.elf > "Lab2.list"
text data bss dec hex filename
42292 32@ 2536 45148 b@85c Lab2.elf

Finished building: default.size.stdout

Finished building: Lab2.list

17:@@:29 Build Finished. @ errors, @ warnings. (toock 1@s5.872ms)
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Click on the bug jﬁﬂ to begin debugging

Lab2 - Debugging

E workspace_1.0.0 - Lab

Select ot
STM32 MCU C/C++ App em— 018

Edit  Source

=g
BES ~

[¥5 Project Explorer 53

LJ Lab0
L Lab1

v I Lab2
> &'} Binaries
> [l Includes
> [ Drivers
v [ Src

> @ app_mems_int_pin_a_interf

Click OK

[€] app_x-cube-mems1.c
[ main.c

[ stm32M40_hal_msp.c
[€] stm32loc it.c

@ stm32ldio_nucleo_bus.c
[£] syscalls.c

[£] sysmem.c

[€] system_stm32Mbocc

2 Startup

== Debug

= Inc

[ Labioc

|g STM32L476RGTX_FLASH.Id
|3d STM32L4TERGTX_RAM.IA

>
>
>
i
>
>
>
>

VoW W

elDE

Project Run  Window Help

- O X

RS0 A I RURE TR AR RSN |Quick Access| ;| g% | B[] 4%
[ Lab2.ioc [€] main.c 53 = 0

1 /* USER CODE BEGIN Header *JFH Debug As ~

2._..',?**

3 FEkEkEEREXRERRRERR

4 * @file . main.| Selectawayto debug 'Lab2":

5 * [@brief ¢ Mai _

5 @orie - []Local C/C++ Application P

7 * @attention [ STM32 MCU C/C++ Application

a *

9 * <h2r<center>&copy; Copy|

1@ * All rights reserved.</g

11 *

12 * This software component license,

13 * the "License™; You may e with the

14 * License. You may obtain

15 *

16 *

17 Description EEEEEEEEEEE L Ll

1 o STM32 MCU C/C++ Applicati

19 /* USER CODE END Header */ Ele gl Prikaton

28

21 /* Includes -------------ocf gy oo */

22 #include "main.h"

23 #include "app_x-cube-memsl.

24 v
B Console 52 @ [ ok || conce 4 48 ERE=&I 2B =0
CDT Build Console [Lab2]

FLA1sMed DUILOLNg Target: LapZ.eLim ~
arm-none-eabi-size  Lab2.elf
arm-none-eabi-objdump -h -5 Lab2.elf > “"Lab2.list"™

text data bss dec hex filename

42292 328 2536 45148 b@5c Lab2.elf
Finished building: default.size.stdout
Finished building: Lab2.list
17:82:29 Build Finished. @ errors, @ warnings. (tock 18s.872ms)

v
£ >
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Lab2 - Debugging

1. Click OK



Lab2 - Debugging

1. Code start at the first line of the main function

2. Click play g button a
to run the code



LabZ2 - Testing

1. Open Tera Term to view the output

Press User button (blue) on
Nucleo board

2. After testing close Tera Term
by clicking X



Lab2 - Debugging

1. Click stop button to interrupt the debugging



Lab2 — Closing the Project

1. Right-Click on Lab2 project

2. Click on Close Project



Goals:
» Configure a new project using X-CUBE-

LAB 3 . gﬂfnl\;:SJre LSM6DSO accelerometer

embedded step counter
* Enable interrupts in STM32CubelDE



LSM6DSO
Accelerometer + Gyroscope Inertial Measurement Unit

0.45mA power consumption (normal mode)
Accelerometer: 0.05mA, Gyroscope: 0.40mA

Lowest power consumption IMU - battery saving

Auxiliary SPI typically used for OIS / EIS or

Design Flexibility and cost optimization
closed loop control; I3C Interface

9kB equivalent FIFO Memory for local data System power saving
storage

Finite State Machines (up to 16) Smart Functions with High Flexibility

Digital Features
Free fall

Pedometer 2.0
6D /4D
Tilt detection

Tap/ Double Tap

LGA-14L
(2.5 x 3 x 0.83 mm)




Lab3

1. Click on File > New > STM32 Project



Lab3

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Lab3

1. Project Name Lab3

2. Click Finish



Lab3

1. Click Yes to init peripherals in default mode



Lab3 — Configure the 12C Bus

1. Left Click on PB9 and
select 12C1_SDA

2. Left Click on PB8 and
select 12C1_SCL

>



Lab3 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

. Select 12C in 12C1 Mode

. PB8 and PB9 should

and Configuration

now become green



Lab3 — Configure LSM6DSO Interrupt

1. Left Click on PB5 and
select GPIO_EXTIS



Lab3 — Configure LSM6DSO Interrupt

. Check NVIC in tab

System Core

. Select NVIC in NVIC

Mode and Configuration

. Enable a

EXTI line[9:5] interrupt G




Lab3 — Select the MEMS Library

1. Click on
Additional Software



Lab3 — Select the MEMS Library

Filters

* @ ®» @

Click to

m Additional Software Components selection

expand tree

STMicroe

STMic
STMic
STMic

Pack / Bundle / Component
lectronics. X-CUBE-AI
oelectronics X-CUBE-BLEA1

oelectronics X-CUBE-GNSS1
oelectronics X-CUBE-MEMSA

(2]

Collapse all

Selection

=

4 4.0
300 0
6.2.0

~ Device Application
Application IKS01A3_LSMBDSO_Pedometer |
s Board_Component_MEMS
Software Component Class
~ Board Extension _MEMS
[ Artificial Intelligence IKS01A2 O
[ Board Component IKS01A3
> Board Support STM32Cube Custom BSP Drivers

1. In X- CUBE MEMS1/AppI|cat|on Class “Device”:
Select IKS01A3 _LSM6DSO_ Pedometer

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK



Lab3 — Configure the MEMS Library

. Expand Additional Software and select the X-CUBE-MEMS1

. Check both:

Board Extension MEMS
Device Application

. Configure Platform Settings °
as in picture




Lab3 — Configure the MEMS Library

- Platform proposal
-Application

Name IPs or Components Found Solutions 12C Addr

MEMS_INT_PIN_A |GPIO:-EXTI FB5

-BSP

Name IPs or Components Found Solutions 12C Addr BSP.

BSP BUTTON GPIC:EXTI PC13 [B1 [Blue PushButton]] ~ | BSP_C

BSP USART LSART-Asynchronous LSARTZ ~ | BSP_C

BSP LED GPIO:Output PAS [LDZ [green Led]]

IKS01A3 BUS 1O driver (12C:12C




Lab3 — Save the Project

1. Click the save button ['ﬁ']

This action will generate 0
the source code of this lab



Lab3 — Code Editing

1. Expand Src in folder Lab3

" " g in.c-5 ell)
2. Double CIICk On maln.c File Edit Source Refactor Mavigate Search Project Run  Window Help

D-HRI®-R-BidH-®I-[H-F-0C-2-|0 (Quick Access| | g | 8 [
¥ Project Explorer &3 = O m Lab3.ioc [€] main.c 52 = O
s - 1 /* USER CODE BEGIN Header */ -
E =|'> 2._.!’**
3 Lab0 3 ek EE
0 Lab1t 4 * f{file ¢ main.c
I Lab2 5 * (@brief : Main program body
v [0 Lab3 6 s
> @l Includes 7 * [@attention
. 8 *
> €3 Drivers 9 * ¢h2r<center>&copy; Copyright (c) 2819 STMicroelectronics.
v (B Src 1@ * ALl rights reserved.</center></h2>
> @ app_mems_int_pin_a_interf 11 *
3 @ app_x-cube-memsl.c 12 * This software component is licensed by ST under BSD 3-Clause license,
> €] main.c 13 * tl'je "License™; You may not use this ‘Filn? except in compliance with the
[¢] stm32ldioc_hal msp.c 14 * License. You may obtain a copy of the License at:
’ - = P 15 * opensource.org/licenses/BSD-3-Clause
> [ stm32kboc_it.c 15 *
> @ stm32lde_nucleo_bus.c 17 FEEEE
g syscalls.c 18 */
5 [@ sysmem.c ;g /* USER CODE END Header */
> [g] system_stm32l4iocc 21 /% INCLUAES == === o mmm e #/
> 2 Startup 22 #include "main.h™
> [= Inc 23 #include "app_x-cube-memsl.h"
[ Lab3ioc 24
[3 STM32L4TERGTX_FLASH.Id ig_:: EE;EESDE”;;?:SIN*I """"""""""""""""""""""""" !
[5 STM32L476RGTX_RAM.Id - nesues
28 /* USER CODE END Includes */
29
388 /* Private typedef -------------o */
31 /* USER CODE BEGIN PTD */
32
33 /* USER CODE END PTD */
34
352 /* Private define ---------¢":"- b i e el */
36 /* USER CODE BEGIN PD */
37
38 /* USER CODE END PD */
39
489 /* Private Macro —--------mm s oo */
41 /* USER CODE BEGIN PM */
42 w
£ >
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Lab3 - Compiling

1. Click on the hammer %- to begin compilation, or press CTRL+B

2. Compilation should terminate
with O errors and 0 warning

BE workspace_1.0) 1

File Edit
Il

¥ Project Explorer &3

Source

= 8
S
I Lab0
T Lab1
0 Lab2
v I Lab3
> ﬁ-? Binaries
> )l Includes
> (2 Drivers
w @ Src
> @ app_mems_int_pin_a_interf
» [€ app_x-cube-memsl.c
> [ main.c
> @ stm32lde_hal_msp.c
s [8 stm32idboc_it.c
> @ stm32ldie_nucleo_bus.c
> [ syscalls.c
> [ sysmem.c
€] systemn_str32ldo0c
(2 Startup
= Debug
= Inc
[ Lab3ioc
|3 STM32L476RGTX_FLASH.Id
|3g STM32L476RGTX_RAM.Id

WO W

Mavigate
&8~/ -&id

main.c - STM32CubelDE

Search Project Run  Window Help
A - R AT FRE TRA R AR (Quick Access| | g | 8 [
mLabS.ioc [€] main.c 52 = O
1 /* USER CODE BEGIN Header */ -
28 =
4 * [@file : main.c
5 * (@brief : Main program body
7 * [@attention
8 -
9 * ¢h2r<center>&copy; Copyright (c) 2819 STMicroelectronics.
1@ * All rights reserved.</center></h2>
11 *
12 * This software component is licensed by ST under BSD 3-Clause license,
13 * the "License"; You may not use this file except in compliance with the
14 * License. You may obtain a copy of the License at:
15 * opensource.org/licenses/BSD-3-Clause
16 *
17 e
18 */
19 /* USER CODE END Header */
28
21 /* Includes -----------ommo */
22 #include "main.h"|
23 #include "app_x-cube-memsl.h"
24
252 /* Private dincludes --------------mmmmm */
26 /* USER CODE BEGIN Includes */
27
28 /* USER CODE END Includes */ W
& Console &3 @4}<LF:>|'TE5E:1‘|ZE'F3'='E|
COT Build Console [Lab3]
41592 368 2288 44232 accd Lab3.elf "
Finished building: default.size.stdout
Finished building: Lab3.list
14:26:57 Build Finished. @ errors, @ warnings. (toock 12s.264ms)
v
£ >
Writable Smart Insert 22:18




Lab3 - Debugging

. Click on the bug jﬁﬂ to begin debugging

. Select G

STM32 MCU C/C++ App

. Click OK a



Lab3 - Debugging

1. Click OK



Lab3 - Debugging

1. Code start at the first line of the main function

2. Click play g button a
to run the code



1. Open Tera Term to view the output

Simulate a walk by giving
up/down movement to the
board. Steps will be updated
after about 10 steps

2. After testing close Tera Term
by clicking X

Lab3 - Testing



Lab3 - Debugging

1. Click stop button to interrupt the debugging



Lab3 — Closing the Project

1. Right-Click on Lab3 project

2. Click on Close Project



LAB4

Goals:

Configure a new project using X-CUBE-MEMS1
Configure LIS2DW12 accelerometer in order to
generate an interrupt when an acceleration is
detected

Enable interrupts in STM32CubelDE

Turn the led ON at wake-up



LIS2DW12

Power saving and flexible Accelerometer

Down to 0.38 nA power consumption (1.6Hz ODR) Enabling battery saving
High Perf. mode: up to 1600Hz with noise density Accuracy
90 pug/\Hz

5 Power Modes + 2 Noise Modes High Flexibility

32-level FIFO buffer

System Power Saving & Smart Functions

Digital Features
Free fall

Wake-up
6D /4D
Stationary/Motion detection

Double Tap

LGA-12L
(2.0x2.0x0.7 mm)




Lab4

1. Click on File > New > STM32 Project



Lab4

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Lab4

1. Project Name Lab4

2. Click Finish



Lab4

1. Click Yes to init peripherals in default mode



Lab4 — Configure the 12C Bus

1. Left Click on PB9 and
select 12C1_SDA

2. Left Click on PB8 and
select 12C1_SCL

>



Lab4 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

. Select 12C in 12C1 Mode

. PB8 and PB9 should

and Configuration

now become green




Lab4 — Configure LIS2DW12 Interrupt

1. Left Click on PB0 and
select GPIO_EXTIO



Lab4 — Configure LIS2DW12 Interrupt

. Check NVIC in tab

System Core

. Select NVIC in NVIC

. Enable

Mode and Configuration

EXTI line0 interrupt G




Lab4 — Select the MEMS Library

1. Click on
Additional Software



Lab4 — Select the MEMS Library

m Additional Software Components selection =]
Filters Packs
* ® ® x| 3 Collapse all

0 Pack / Bundle / Component _ Selection =
C | I Ck to Search - STMicroelectronics. X-CUBE-Al m

STMicroslectronics X-CUBE-BLE 440
expand tree STMicroslectronics X-CUBE-GNSSH 3000 0
STMicroelectronics X-CUBE-MEMS1 2o ]

W N W

~ Device Application

iiiii

Application IKS01A3_LIS2DWA12_WakeUp v |
s Board_Component_MEMS
Software Component Class
~ Board_Extension MEMS
[ Artificial Intelligence IKS01A2 O
[ Board Component IKS01A3
> Board Support STM32Cube Custom BSP Drivers

1. In X- CUBE MEMS1/AppI|cat|on Class “Device”:
Select IKS01A3 LIS2DW12_ WakeUp

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”: @)
Check IKS01A3/

3. Click OK



Lab4 — Configure the MEMS Library

. Expand Additional Software and select the X-CUBE-MEMS1

. Check both:

Board Extension MEMS
Device Application

. Configure Platform Settings a
as in picture



Lab4 — Configure the MEMS Library

Name IPs or Components Found Solutions 12C Addr

MEMS_INT_FIN_A |GPIO:EXTI FBO

-BSP

Name IPs or Components Found Solutions  12C Addr

BSF BUTTON GPIO:EXTI ~ | |[PC13 [B1 [Blue PushButton]] ~

BSF USART USART-Asynchronous -~ | [USARTZ W

BSF LED GPI0:Output ~ | |[PAS [LDZ [green Led]]

IKS01A3 BUS 10 driver |I2C:12C




Lab4 — Save the Project

1. Click the save button ['ﬁ']

This action will generate 0
the source code of this lab



1. Expand Src in folder Lab4

2. Double click on main.c

File Edit Source Refactor Mavigate Search Project Run  Window Help
D-HRI®-R-BidiH-®I-[EH-F-0C-2-|0 (Quick Access| | g | 8 [
5 Project Explorer 22 = B [ *Labdicc [€] main.c 22 = 8
=] <_E|> - 1 I/* USER CODE BEGIN Header */ -
= f**
I Lab0 28/
3
0 Lab1t 4 * [@file ¢ main.c
I Lab2 5 * [@brief : Main program body
I Lab3 6
7 * [@attention
v [ Lab4 .
> @] Insludes 9 * <h2r<center>&copy; Copyright (c) 2019 STMicroelectronics.
> (£ Drivers 1@ * All rights reserved.</center></h2>
W (23 Sre 11 *
3 @ main.c 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [8 stm32l_hal_msp.c 13 * tl'lna “License"; You may not use this ‘Fil? except in compliance with the
6] stm32doc_it.c 14 * License. You may cbtain a copy of the License at:
’ = 15 * opensource.org/licenses/B5SD-3-Clause
g syscalls.c 16 *
> [ sysmem.c 17
€] systemn_str32ldo0c 18 */
S (2 Startup ;g /* USER CODE END Header */
> & Inc . 21 /% Includes —---mmm s o */
m Labd.ioc 22 #include "main.h"
[T STM32L4T6RGTX_FLASH.I 23
|53 STM32L4T6RGTX_RAM.Id 242 /* Private includes -------------mmmmmmm */
25 /* USER CODE BEGIN Includes */
26
27 /* USER CODE END Includes */
28
292 /* Private typedef -----------":"--bb bbb el e */
3@ /* USER CODE BEGIN PTD */
31
32 /* USER CODE END PTD */
33
342 /* Private defing -----mmmmmm oo e */
35 /* USER CODE BEGIN PD */
36
37 /* USER CODE END PD */
38
392 /% Private macro ----------mmmm oo */
4@ /* USER CODE BEGIN PM */
41
42 /* USER CODE END PM */ W
£ >
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Lab4 - Compiling

1. Click on the hammer ﬁ- to begin compilation, or press CTRL+B

. . . B workspace_1.0
2. Compilation should terminate - « ...

. . FuRENEI R S L PR W IR AR R [Quick Acess] | g9 | B[] 4
with O errors and 0 warning o = 0 (G 3 o158 o

nain.c - STM32CubelDE — O *

Mavigate Search Project Run  Window Help

s - 1 /* USER CODE BEGIN Header */ -
5
2._.‘;’**
J Lab0
3
0 Lab1t 4 * [@file ¢ main.c
I Lab2 5 * [@brief : Main program body
I Lab3 6
VE Labd 7 : [@attention
> &" Binaries 8 . . .
<h2»<center>&copy; Copyri c Microelectronics.
! 9 * <h2 ter>&copy; Copyright (c) 2013 S5TM lect
> [l Includes 1@ * All rights reserved.</center></h2>
> [ Drivers 11 *
v (2 Src 12 * This software component is licensed by ST under BSD 3-Clause license,
> [8 app_mems._int_pin_a_i 13 * tl'lna “License"; You may not use this ‘Fil? except in compliance with the
[¢] app_x-cube-mems.c 14 * License. You may cbtain a copy of the License at:
’ PF—:_ ' 15 * opensource.org/licenses/B5SD-3-Clause
> €] main.c 16 *
5 [€ stm32idboc_hal_msp.c 17
> [g] stm32ldioc it.c 8 */
5 [8 stm3214ia_nuclea_bus. gg /* USER CODE END Header */
> & syscallsc 2] | L F-mmmmm e *
> [g] sysmem.c 22 #include "main.h"
> [ system_str32l4wcc 23 #include "app_x-cube-memsl.h"
» [ Startup 24
5 (= Debug 252 /* Private includes --------------mmmmm e */
26 /* USER CODE BEGIN Includes */
> (= Inc 57
[0 Labdioc 28 /* USER CODE END Includes */ v

[ STM32L4T6RGTH_FLASH.I
[ STM32L476RGTX_RAM.Id

B Console 32 G@<§>|ﬂgﬁza|ﬂavrﬁvzﬁ
COT Build Console [Lab4]
37836 264 2668 39308 9984 Lab4.elf )

Finished building: default.size.stdout

Finished building: Lab4.list

15:27:37 Build Finished. @ errors, @ warnings. (toock 165.647ms)
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Lab4 - Debugging

. Click on the bug jﬁﬂ to begin debugging

. Select 0

STM32 MCU C/C++ App

. Click OK 6



Lab4 - Debugging

1. Click OK



Lab4 - Debugging

1. Code start at the first line of the main function

2. Click play b button a
to run the code



Lab4 - Testing

1. Shake the board and the GREEN led will turn ON



Lab4 - Debugging

1. Click stop button to interrupt the debugging



Lab4 — Closing the Project

1. Right-Click on Lab4 project

2. Click on Close Project



Goals:
« Configure a new project using X-CUBE-MEMS1

| AB5S . Configure LSMBDSO single and double tap
detection

« Enable interrupts in STM32CubelDE
« Change tap threshold to increase sensitivity



LSM6DSO
Accelerometer + Gyroscope Inertial Measurement Unit

0.45mA power consumption (normal mode)
Accelerometer: 0.05mA, Gyroscope: 0.40mA

Lowest power consumption IMU - battery saving

Auxiliary SPI typically used for OIS / EIS or

Design Flexibility and cost optimization
closed loop control; I3C Interface

9kB equivalent FIFO Memory for local data System power saving
storage

Finite State Machines (up to 16) Smart Functions with High Flexibility

Digital Features
Free fall
Pedometer 2.0

6D /4D
Tilt detection
Tap/ Double Tap (2.5x3x (;_g?;;ﬂ;



Lab5

1. Click on File > New > STM32 Project



Lab5

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Lab5

1. Project Name Lab5

2. Click Finish



Lab5

1. Click Yes to init peripherals in default mode



Lab5 — Configure the 12C Bus

1. Left Click on PB9 and
select 12C1_SDA

2. Left Click on PB8 and
select 12C1_SCL

>



Lab5 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

. Select 12C in 12C1 Mode

. PB8 and PB9 should

and Configuration

now become green



Lab5 — Configure LSM6DSO Interrupt

1. Left Click on PB5 and
select GPIO_EXTIS



Lab5 — Configure LSM6DSO Interrupt

. Check NVIC in tab

System Core

. Select NVIC in NVIC

. Enable

Mode and Configuration

EXTI line[9:5] interrupt




Lab5 — Select the MEMS Library

1. Click on
Additional Software



Labb — Select the MEMS Library

mﬁ\ddi‘tional Software Components selection [==]
Filters Packs
* ® x| I Collapse all

0 Pack / Bundle / Component Selection =
C“Ck tO Search - STMicroelectronics X-CUBE-AI

STMicroelectronics X-CUBE-BLE1 440
expand tree STMicroelectronics X-CUBE-GNSS1 300m 0
STMicroelectronics X-CUBE-MEMS1 620

£ W

~ Device_Application

Application IKS01A3_LSMBDSO_SingleDoubl |
> Board_Component_ MEMS
Software Component Class
~ © Board_Extension MEMS
[ Artificial Intelligence IKS01A2 O
] Board Component IKS01A3

> Bnard Sunnomt STM3I?Cube Custom RSP Nrivers

1. In X-CUBE-MEMS1/Application, Class “Device”
Select IKS01A3 LSM6DSO_SingleDoubleTap

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”: @)
Check IKS01A3/

3. Click OK



Lab5 — Configure the MEMS Library

. Expand Additional Software and select the X-CUBE-MEMS1

. Check both:

Board Extension MEMS
Device Application

. Configure Platform Settings °
as in picture



Lab5 — Configure the MEMS Library

- Platform proposal

- Application

Name IPs or Components Found Solutions 12C Addr

MEMS_INT_PIN_A |GPIO:EXTI PBS v

-BSP
Name IPs or Components Found Solutions  12C Addr BSP AF

BSP BUTTOMN GPIOEXTI | [PC13 [B1 [Blue PushButton]] ~ | BSP_COI

BSP USART USART:Asynchronous | [USARTZ ~ | BSP_COl

BSP LED GPIO:Output v | |PAS [LD2 [green Led]] BSP_COl

IKS01A3 BUS 1O driver ||2C:12C BSP_BU:




Lab5 — Save the Project

1. Click the save button ['ﬁ']

This action will generate 0
the source code of this lab



LabS — Code Editing

1. Expand Src in folder Lab5

[ - 3 5| . in. elD
2. Double CIICk On maln.c File Edit Source Refactor Mavigate Search Project Run  Window Help

H-HR SR -Bidi- @[ -Ce-2-0 |Quick Access| || 5 | B@ [E] 4%
EypPr. m = B  [ILab5icc [€] main.c 52 = 0
& 1 /* USER CODE BEGIN Header */ -
H S
D fE*
3 Labo sud .
0 Labl 4 * @file : main.c
1 Lab2 5 * (brief : Main program body
J Lab3 6 *
17 Lab4 ; : fattention
VE Lab3 9 * <h2»<center>&copy; Copyright (c) 2819 STMicroelectronics.
> [l Includes 18 * All rights reserved.</center></h2>
> 2 Drivers 11 *
2 Src 12 * This software component is licensed by ST under BSD 3-Clause license,
5 [€ main.c 13 * the "License"; You may not use this file except in compliance with the
[&] stm32koct 14 * License. You may cbtain a copy of the License at:
’ m “—. 15 * opensource.org/licenses/B5D-3-Clause
g stm32doi 15«
5 [ syscalls.c 17 *
5 € sysmem.c B %
> @ system_strr ;2 /* USER CODE END Header */
> €8 Startup 21 /* InCludes — - - e e e */
> g Inc 22 #include "main.h"
Lab5.ioc 23
|33 STM32L4T6RG 245 /* Private includes ---------ommmmmmm oo */
[74 STM32L4T6RG 25 /* USER CODE BEGIN Includes */
26
27 /* USER CODE END Includes */
28
292 /* Private typedef ----------:"0"0b bbb e e i e oo */
3@ /* USER CODE BEGIN PTD */
31
32 /* USER CODE END PTD */
33
342 /* Private define --------mmmmmm - *f
35 /* USER CODE BEGIN PD */
36
37 /* USER CODE END PD */
38
399 /% Private mMacro --------mm oo e */
4@ /* USER CODE BEGIN PM */
41
42 /* USER CODE END PM */ W
£ >
Writable Smart Insert 187




2. Compilation should terminate
with O errors and 0 warning

IE workspace_1.0.

File Edit Source
Hwil | ® ~
e, 2 = 8
SIE-

I Labd

I Lab1

I Lab2

I Lab3

I Lab4
~ [T Labs

> f;" Binaries

> I@J Includes

> 2 Drivers

v 3 Src

» € app_mems,
> [ app_x-cube
[ main.c

[ stm321d0t
[€] stm32ldoc
[ stm321d00
[€] syscalls.c

[£] sysmem.c
> @ system_strmr
2 Startup

= Debug

= Inc

[ LabS.ioc

| STM32L476RG
|33 STM32L476RG

>
>
b
>
>
>

oW W

Lab5 - Compiling ezm

1. Click on the hammer %- to begin compilation, or press CTRL+B

1  Jnainc- sTM3acubelDE

Mavigate Search Project Run  Window Help
RGBS H- OIS Fl- -0 |Quick Access| || 5 | B@ [E] 4%
[ Labs.ioc [€] main.c 52 = 0
1 /* USER CODE BEGIN Header */ -
26 j**
3 *
4 * [@file : main.c
5 * (brief : Main program body
6
7 * ([@attention
3
9 * <h2»<center>&copy; Copyright (c) 2819 STMicroelectronics.
1@ * All rights reserved.</center></h2»
11
12 * This software component is licensed by ST under BSD 3-Clause license,
13 * the "License"; You may not use this file except in compliance with the
14 * License. You may cbtain a copy of the License at:
15 * opensource.org/licenses/B5D-3-Clause
16 *
17 *
18 */
19 /* USER CODE END Header */
28
21 /% Includes —-----mmmmm e */
22 #include "main.h"|
23 #include "app_x-cube-memsl.h"
24
252 /* Private includes "/
26 /* USER CODE BEGIN Includes */
27
28 /* USER CODE END Includes */ W
& Console &3 @4}<LF:>|'TE5E:1‘|ZE'F3'='E|
COT Build Console [Lab5]
37928 264 2e@s 48192 9dee@ Lab5.elf ~
Finished building: default.size.stdout
Finished building: Lab5.list
11:19:33 Build Finished. @ errors, @ warnings. (toock 115.921ms)
v
£ >
Writable Smart Insert 22:18




Labb - Debugging

. Click on the bug jﬁﬂ to begin debugging

. Select G

STM32 MCU C/C++ App

. Click OK a



Labb - Debugging

1. Click OK



Labb - Debugging

1. Code start at the first line of the main function

2. Click play g button a
to run the code



Labb - Testing

1. TAP or DOUBLE TAP the board and the GREEN led will turn ON




Labb - Debugging

1. Click stop button to interrupt the debugging



Lab5 — Code Editing

1. Expand folder Drivers > BSP > Components > Ism6dso

2. Open file Ism6dso.c

3. Gotoline #1574

File

i

<

[€] /Lab5/Drivers/BSP/Components/lsmbdso/lsmbdso.c

Edit

-

I Lak0

I Lab1

1 Lab2

I Lab3

17 Lab4
~ [T Labs
> f;" Binaries
> I@J Includes

w 22 Drivers
v = BSP
w [= Components

>

> (= Commen
> = hts221

> = lis2dw12
> = lis2mdl

> = lps22Zhh
v = Ismbdso

>

>
>
>

[ Ismbdso_reg.c
[H] IsmBdso_reg.h
[ Ismbdso.c
[h] Ismédso.h

@ Release_Motes.hi

> [ stts751
> (= IKSD1A3
> = 5TM32Ld0c_Nucleo
> = CMSIS
> (= STM32Ldec HAL Driver
v [ Src

@ app_mems_int_pin_a_inte

[ app_t-cube-memsl.c
[£] main.c

[ stm321d0_hal_msp.c
[€] stm32ldieit.c

@ stm32ldo_nucleo_bus.c W

Source Refactor Mavigate Search Project Run Window Help

Ridig-& @ idei® g dRE T - ¥a oo v|ﬂ
8 b5.ioc €] main.c [£] Ismédso.c 52
- if (lsmédso_tap_detection_on_x_set{&(pObj->Ctx), PROPERTY_ENABLE) != LSMGDSO_OK)
1
return LSMGEDS0_ERROR;
b
/* Enable Y direction in tap recognition. */
if (lsmédso_tap_detection_on_y_ set(&(pObj->Ctx), PROPERTY_ENABLE) != LSMBDS0O_OK)
1
return LSMGDS0_ERROR;
b

/* Enable I direction in tap recognition. */
if (lsmédso_tap_detection_on_z_ set(&(pObj-»>Ctx), PROPERTY_ENABLE) != LSMBDS0_OK)
{

return LSMEDS0_ERROR ;

}

/* Set tap threshold. */
if (lsmédsc_tap_threshold_x_set(&(pObj-»>Ctx), @x@8) != LSMEDSO_0OK)
{

return LSM6D50_ERROR;

}

/* Set tap shock time window. */
if (lsmédsc_tap_shock_set(&(pObj-»>Ctx), @x@2) != LSMEDSO_OK)
{

return LSM6D50_ERROR;

}

/* Set tap quiet time window. */
if (lamfAdzn tan nndist zat(Rinnhd-wrfv) AvATY 1= 1 SMANSN NkKY

B Console 33 Properties
<terminated> Lab5.elf [STM32 MCU Debugging] ST-LINK (ST-LINK GDB server)

>

[ucreess] | | D 4

E= 0. 2 @B = B

<

BN o %k 7
LSMBDSO_GYRO_Gel A

LSMBDSO_GYRO_Set
L5MBDS0_GYRO_Ge
LSMBDSO_GYRO_Set
LSMBDSO_GYRO_Gel
LSMBDSO_GYRO_Gel
L5MEDSO_Read_Reg
L5MBDSO_Write_Reg
LSMBDS0_Set_Interr
L5MBDS0_ACC_Enat
LSMBDSO_ACC_Disa
LSMBDSO_ACC Set |
LSMBDSO_ACC Set |
LSMBDSO_ACC_Enat
LSMBDSO_ACC_Disa
LSMBDSO_ACC_Get_
L5MBDSO_ACC_Step
LSMBDSO_ACC_Enat
LSMBDSO_ACC_Disa
LSMBDSO_ACC_Enat
LSMBDSO_ACC_Disa
L5MEDS0_ACC Set
LSMBDSO_ACC_Set!

L5MBD50_ACC Enat

>

X% EEMERESE M-8 -=0O

Download verified successfully

Debugger connection lost.
Cloddsdme Aman

>

h




Lab5 — Code Editing

1. Inline #1574, edit the threshold from value 0x08 to value 0x02*

/Components/lsmbdso/lsmbdso, 4

e . I_I
2. Save modification . L ——

H-HR SRRV E-S- -Gy dRE TN e O [Quick Access] || e | [ERI M 4+

refer to Application Note AN5192 Section 5.5.1 & cusis

(2= STM32Ldec_Mucleo ape

>

5 Project Explorer 32 = B  [@Labsioc [ main.c [£] "lsmédso.c &1 | [§] startup_stm3214T6rgbes =0 gEo. 2 @8 = 8 =&
3 R -I =] <ﬁ> - if (lsmédso_tap_detection_on_x_set{&(pObj->Ctx), PROPERTY_ENABLE) != LSMGDSO_OK) ~ Bl o ¥ © @
- eCOI I Ipl e W Labd . return LSMEDS0_ERROR; e LSMEDS0_GYRO Geln =
I Lab1 3 @ LSMBDSO_GYRO_Set
0 Lab2 @ LSMEDSO_GYRO_Gel
17 Lab3 /* Enable Y direction in tap recognition. */ ® LSMEDSO_GYRO_Set
if (lsmédso_tap_detection_on_y_set(&(pObj->Ctx), PROPERTY_ENABLE) != LSMBDSO_OK
0 Lab4 e LSMEDSO_GYRO_Gel
4 . LaunCh debug vERLaes return LSMGDSO_ERROR; ©  LSMEDSO_GYRO_Gef
3%, Binaries 3 @ LSMEDSO_Read Reg
@]J Includes @ L5MEDSO_Write_Reg
w 22 Drivers /* Enable Z direction in tap recognition. */ ® LSMBEDSO_Set_Intern
v = BSP if (lsmédso_tap_detection_on_z_ set(&(pObj-»>Ctx), PROPERTY_ENABLE) != LSMBDS0_OK) ® LSMBDSO ACC Enat
{ T
w [= Components return LSMGDSO ERROR; @ LSMEDSO_ACC Disa
= Commen 3 - @ LSMBDSO_ACC Set |
(= hts221 @ LSMBDSO_ACC Set |
(= lis2dw12 /* Set tap threshold. */ ® LSMEDSO_ACC_Enat
= lis2ml if (1lsmédso_tap_threshold_x_set(&(pObj->Ctx), ENGE) != LSMEDSO_OK) o LSMBDSO ACC Dica
& lps2Zhh return LSM6D50_ERROR; @ LSMEDSO_ACC Get.
v = Ismbdso 3 o L5MEDS0_ACC Step
@ lsmédso_reg.c @ LSMBDSO_ACC_Enak
. [H] lsmédso_reg.h /* Set tap shock time window. */ e LSMBDSO_ACC Disa
1 1Fi 1 1 if (lsmédso_tap shock set(&(pObj->Ctx), @x@2) != LSMEDSO _OK
This modification will reduce the threshold 0 lmédso.c £ (ansdio_tap_shock_set(8(pobj->Cex), 0x02) -0 o LSMBDSO_ACCEnct
. . . e @ lzmbdso.h return LSMDSO_ERROR; @ LSMBDSO_ACC_Disa
[ elease_Motes, L] _ el
of the tap detection, increasing sensitivity @ Release Noteshi } LSMEDSO_ACC.Set.
. . (= stts751 @ LSMBDSO_ACC Set
of the recognized tap. For further details please & Ks01A3 /* Set tap quiet time window. */ o LSMBDSO_ACC Enat ,
if flamfdza tan aniet sat(R(n0hi-3rEv)  AvB1Y 1= | SMENSH OKY C e e

< >

< >

Smart Insert

1574: 49

(= STM32Ld_HAL_Driver * Problems J£| Tasks B Console &3 Properties = X &| B BE B |& @| = B~-f-=0
<terminated> Lab3.el ebuggin a a SEMVET,
v [ Src inated> Lab3.elf [STM32 MCU Debugging] ST-LINK (ST-LINK GDB )
[£] app_mems_int_pin_a_inte Download verified successfully "~
[ app_t-cube-memsl.c
[8) mainc Deb tion lost
ebugger connection lost.
[& stm32Moc hal msp.c shutting down...
[€] stm32ldieit.c
@ stm32ldo_nucleo_bus.c W Y]




Labb - Debugging

1. Code start at the first line of the main function

2. Click play g button a
to run the code



Lab5b - Testing

TAP or DOUBLE TAP the board and the GREEN led will turn ON

You may notice that

the sensitivity of the TAP
recognition has been
increased




Lab5 — Closing the Project

1. Right-Click on Lab5 project

2. Click on Close Project



LABG

Goals:

Configure a new project using X-CUBE-MEMS1
Configure LSM6DSO only for USB data logging
Change Output Data Rate to log accelerometer
and gyroscope at higher acquisition speed



Labb

1. Click on File > New > STM32 Project



Labb

. Click on Board Selector

. Type NUCLEO-L476RG °

. Click on the board

. Click Next > (2 ]



Labb

1. Project Name Lab6

2. Click Finish



Labb

1. Click Yes to init peripherals in default mode



Lab6 — Configure the 12C Bus

1. Left Click on PB9 and
select 12C1_SDA

2. Left Click on PB8 and
select 12C1_SCL

>



Lab6 — Configure the 12C Bus

. Expand Connectivity tab and check 12C1

Select 12C in 12C1 Mode
and Configuration

PB8 and PB9 should
now become green

Setup Fast Mode in
Parameter Settings G G



Lab6 — Select the MEMS Library

1. Click on
Additional Software




goes \ Lab6 — Select the MEMS Library

‘o be [ additional Software Components selection

(=]
Filters Packs
o @ ® x| ! Collapse all
H Pack / Bundle / Component Selection (&5
Click to -

STMicroelectronics X-CUBE-AI

STMicroelectronics X-CUBE-BLE1 440
STMicroelectronics X-CUBE-GNSS1 300k

STMicroelectronics X-CUBE-MEMS1 6.2.0

~ Device Application

expand tree

Application DatalogTerminal

Board_Component_NEN

Acc/liS2DLPC

Software ComPeygent Class

Not selected
[] Data Exchange

_ AccGyr/LSMEDSO
[ Device AccGyr/LSMBDSOX
L veLs
_ > Board Extension MEMS
O Wireless = =

<

Board_Support_STM32Cube_Custom_BSP_Drivers
Custom/ENV_SENSOR
Custom/MOTION_SENSOR

1. In X-CUBE-MEMS1/Application, Class “Device”: .
Select DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Component”:
In AccGyr/LSM6DSO Selection 12C

3. In X-CUBE-MEMS1/MEMS, Class “Board Support”:
Check Custom/MOTION_SENSOR

4. Click OK




Labo — Select the MEMS Library

MX Additional Software Components selection

Filters 4 —
) ’ Pack/Bundle Selection
~ @ STMX-CUBE-MEMS1/Application 6.1.0 Device Install...
Search SX-CUBE-MEMS1/Application 6.1.0 Device Application
. » @ STMX-CUBE-MEMS1T/MEMS 6.1.0 Board Extension Install... 1
Cl I Ck to 4»\/ ® STM X-CUBE-MEMS1/MEMS 6.1.0 Board Component  Install. ..
Pack Vendor ™ SX-CUBE-MEMS1/MEMS 6.1.0 Board Component Acc/LISZDW12 ~Select—-
expa N d tree SX-CUBE-MEMS1/MEMS 6.1.0 Board Component AccGyr/LSMEDSL ~Select-
] ] EX-CUBE-MEMS1/MEMS 6.1.0 Board Component AccGyr/LSMEDSO
[ SThicroelectronics SX-CUBE-MEMS1/MEMS 6.1.0 Board Component AccMag/LSM303AGR —-Select—
SX-CUBE-MEMS1/MEMS 6.1.0 Board Component HumTemp/HTS221 ~-Select—-
g Component Class ™ SX-CUBE-MEMS1/MEMS 610 Board Component Mag/LIS2VDL _Select—
SX-CUBE-MEMS1/MEMS 6.1.0 Board Component Mag/LIS3MDL ~-Select—-
[ Artificial Intellig EX-CUBE-MEMS1/MEMS 6.1.0 Board Component PressTemp/LP522HB —-Select—-
[ Board Component SX-CUBE-MEMS1/MEMS 6.1.0 Board Component PressTemp/LPS322HH —-Select—
[] Board Extension SX-CUBE-MEMS1/MEMS 6.1.0 Board Component Temp/STTSTE1 ~-Select—-
~ @ STMX-CUBE-MEMS1/STM32Cube_Custom__.. 6.1.0 Board Support Install...
[ Board Support SX-CUBE-MEMS1/STM32Cube_Custom_.. 6.1.0 Board Support Custom/ENV_SENSOR O
[ Data Exchange EX-CUBE-MEMS1/STM32Cube_Custom_._. 6.1.0 Board Support Custom/MOTION_SENSOR °
[ Device

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Component”:
In AccGyr/LSM6DSO Selection 12C

3. In X-CUBE-MEMS1/MEMS, Class “Board Support”:
Check Custom/MOTION_SENSOR

4. Click OK

Ok

Cancel




Labo — Configure the MEMS Library

. Expand Additional Software and select the X-CUBE-MEMS1

. Check both:

Board Component MEMS
Board Support STM32...
Device Application

. Configure Platform Settings Q
as in picture



Labo — Configure the MEMS Library

Platform proposal
-BSP

Name IPs or Components Found Solutions  12C Addr Bf

LSMEDS0 BUS 10 driver (12C:12C |2C1 ~ 0 BSF

BSP BUTTOM GPIC:EXTI PCA13 [B1 [Blue PushButton]] ~ | BSF

BSP USART USART:Asynchronous USARTZ ~ | BSF

BSP LED GPIO:Output PAS [LDZ [green Led]]




Labo — Configure the MEMS Library

1. Configure Parameter Settings as in picture

2. ODR_Accelerometer: 6667Hz
FS_Accelerometer: 169
ODR_Gyroscope: 6667Hz
FS_Gyroscope: 2000dps



Labo — Configure the MEMS Library

& Parameter Settings | @ User Constants | @ Platform Settings
|C|:|nﬁgure the below parameters : |

Qlsearch (CitHF) | ©® @ w
~ Basic Parameters

LSMEDS0 ODR Accelerometer  BBBTHz

LSMeDSO FS Accelerometer 16g

LSMBDS0O ODR Gyroscope bbb THzZ

LSMEDS0O FS Gyroscope 2000dps

LSMEDS0O SAD pin




Lab6 — Save the Project

1. Click the save button ['ﬁ']

This action will generate 0
the source code of this lab



Lab6 — Code Editing 1/2

1. Expand Src in folder Lab6

|l“ workspace_1.0.0 - Lab6/5rc/app_x-cube-memsl.c - 5STM32CubelDE

2. Double CIiCk On File Edit Source Refactor Mavigate Search Project Run  Window Help
IR T R RSP SRR R X TR R RS [ovice Access] | 5 | B[ 4
app_x-cu be-mems1 -c Iy Project Explorer &3 = B [ Labbioc [£] app_x-cube-memslc i1 = 8
2E - 64 */ -~

55= void MX_DatalLogTerminal_ Process(void)

0 Lab0 o
0 Lab1 int i;
3. Gotoline #202 .
- O O Ine 0 Lab3 if (PushButtonDetected != @U)
I Lab4 i o
/* Debouncing */
W Lab5 HAL Delay(5@);
~ [ Lab6
" > @]J Includes /* Wait until the button is released */
4 Change It frol I l > [ Drivers while ((BSP_PB_GetState( BUTTON_KEY ) == PushButtonState));
’ v 2 Src n ) B
= 0 5.
HAL_Delay( 1000 ); S,
e ay y > @ custom_motion_sensors_ex.c

5 [€ custorn_motion_sensors.c /* Reset Interrupt flag */

PushButtonDetected = 8;

to > [€ main.c
> @ stm32ldec_hal_msp.c

> [ stm32kboc it.c

HAL_DeIay( 50 ); > [ stm32Micnucleo_bus.c

> [ syscalls.c

/* Do nothing */

}

for(i = @; i < CUSTOM_MOTION_INSTANCES_NBR; i++)

> [ sysmem.c

5 [8) system_strm32iio.c if(MotionCapabilities[i].Acc)
» E5 Startup Accelero_Sensor_Handler(i);
¥ = Inc

if(MotionCapabilities[i].Gyro)
1

Gyro_Sensor_Handler(i);

Note: Sensor ODR is 6667 Hz, meanwhile géiﬁié’fmm_w.m
output on serial terminal is updated every : o
50 ms (20 Hz)

if(MotionCapabilities[i].Magneto)

{

Magneto_Sensor_Handler(i);
b
b

HAL Delay( 1@8@e );

Writable Smart Insert 202: 21




Lab6 — Code Editing 2/2

1. Goto line #50 of file app_x-cube-mems1.c

DE workspace

2. Change it from File Edit Source Refactor Mavigate Search Project Run  Window Help

H-EBRI ®-&-Bidit-ds-[HH-F-0c-2-0 [Quick Access] || g | B2 I 4

EyPr. 2 = 8 [ILabbiocc [€] "app_x-cubs-memsl.c &1 = 0

& - £ T 11m1Tatlons under Tne L1Cense.

static uint8_t verbose
to sus | T
static uint8_t verbose

1|
-

~

07 Lab? 24 #ifdef _ cplusplus
25  extern "C"

W Lt 26 #endif £

1J Lab4 27

1 Labs 28 fF InClUdes — - - oo o m o */
vm Lab6 29 #include "app_x-cube-memsl.h"

3 I@J Includes 32 #include "main.h"

, (2 Drivers 31 #include <stdic.h>

> 2 Sre 33 #include "custom_motion_sensors.h”
» [ Startup 34 #include "lsmédso_settings.h”
3 = Inc 35 #include "stm32l4wx_nucleoc.h”

m Labé.ioc 36 #include "math.h"

[ig STM32L476RC J* Private typedef - --- oo oo 7

[ STM32L4TERC 39= typedef struct displayFloatToInt s {
48 int8_t sign; /* @ means positive, 1 means negative*/
41 uint32_t out_int;
42 uint32_t cut_dec;

displayFloatToeInt_t;

This modification will reduce the serial terminal 45 |/* Private defime - —---ooooooooooooosssoooooooooooossooooooooooo

46 #define MAX_BUF_SIZE 256

output info to only RAW accelerometer and a8 /* private variables - amm
49 static volatile uintd_t PushButto, = a;
gyroscope data 58 static uint8_t verbose = @; /* put to UART terminal ON/OFF. */|
51 static CUSTOM_MOTION_SENSOR_Capab MotionCapabilities[CUSTOM_MOTION INSTANCES NBR];
52 static char dataOut[MAX_BUF_SIZE];
53 static int32_t PushButtonState = GPIO PIN RESET;

[
e

s
]
=

55 /* Private function prototypes -------------------om "/
56 static void floatToInt(float in, displayFloatToInt t *out value, int32 t dec_prec);
57 static void Accelero_Sensor Handler(uint32_t Instance);

58 static void Gyro_Sensor_Handler(uint32_t Instance);

59 static void Magneto_Sensor_Handler(uint32_t Instance);

66 static void MX_DatalogTerminal_ Init(void);

61 static void MX_DataLogTerminal Process(void);

< > < >
Writable Smart Insert 50:75




Lab6 - Compiling

1. Click on the hammer %- to begin compilation, or press CTRL+B

. . . |l“ workspace_1.0.4 1 pp_x-cube-memsl.c - STM32CubelDE
2. Compilation should terminate |5 a s SP LS e o o e
-tho dO . Hmild I B-{R-BG - B IS H-F -0
WI errors an warning By, 5t = 0 [QQiesRe | B sppr-cobememsic 52
= <§> - HAL_Delay(5@); ~
W Lato /* Wait until the button is released */
g Lab1 while ((BSP_PB_GetState( BUTTON KEY ) == PushButtonState));
Lab2
7 Lab2 /* Dehaunci *4
1 Lab4 HAL_Delay(5@);
W Labs /* Reset Interrupt flag */
VE Lab6 PushButtonDetected = @;
g;-? Binaries
@]’J Includes /* Do nothing */
2 Drivers 1
or(i = @; 1 < CUSTOM_MOTION_INSTANCES_NBR; i++
w 2 Src P . . 1 5 3
[ app_x-cube-l:r {
[€] custom_motic if(MotionCapabilities[i].Acc)
[ custom_motic
[ main.c Accelero_Sensor_Handler(i);
1
% ‘t"”:i:j""—_ha'- if(MotionCapabilities[i].Gyro) "
stm boo_it.c r
[ stm32ldo_nuc < i
%syscalls.c 3 Console 52 @@ﬁ”'—ﬁaﬁ :.:Ex|.'".E'ﬁ'=' B
SYEMEME  COT Build Console [Lab6)
[ systern_strm32 = : : = = ==
2 Start - arm-none-eabi-gcc "../Drivers/BSP/Components/lsmédso/lsmedso_reg.c” -mcpuscortex-m4 -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32L476xx -DDEBUG -c -I A
artup arm-none-eabi-gcc -o "Lab6.elf” @"objects.list”™  -mcpu=cortex-m4 -T"C:\Users\michael galizzil\STM32CubeIDE\workspace_1.@8.8%\Lab&\STM32L476RGTI_
(= Debug Finished building target: Lab6.elf
= Inc
m Lab6.ioc arm-none-eabi-size  LabG.elf
[3 STM32LATERGTX arm;nize—eagiéobjdumg -h -5 dLabE,el: )f?iabﬁ,list"
= e ata ss ec ex filename
[ STM32L47ERGTX 39188 252 2156 41588 a274 Lab6.elf

Finished building: default.size.stdout

Finished building: Labg.list

11:19:43 Build Finished. @ errors, @ warnings. (tock 75.932ms)

Writable Smart Insert 202:15




Lab6 - Debugging

Click on the bug jﬁﬂ to begin debugging

E workspace_1.0.0 - Lab6/5

Select

re/app_

Source Refactor Mavi

h  Project Run

l.c - 5TM32CubelDE

Window Help
LRI TR CRER RN i

- O X

[uick Access] | g9 | [ 4

STM32 MCU C/C++ App N HE S -R-BIG i

[y Proje.. 22 = B
S
J Lak0
7 Lab1
I Lab2
J Lab3
1 Lab4
J Lab5
v I Labé
> b’ Binaries
> @] Includes
> [ Drivers

Click OK

>

> [ custom_motic
> € mainc

5 € stm32idochal,
s g stm32ibocit.c
> € stm32ibecnuc
> g syscalls.c

> € sysmem.c

> [g] system_stm32
(A2 Startup

(= Debug

= Inc

[ Labé.ioc

[T STM32L4TERGTX
|3d STM32L47ERGTX,

VoW W

[ Labb.ioc [€ app_x-cube-memsl.c 52 = 0

HAL Delay(58); € Debug As "

/* Wait until the button is releg

while ((BSP_PB_GetState( BUTTON_K| Selectaway to debug 'Labf’

/5D nei wy [€]Local C/C++ Application

HAL_Delay(5@); [T STM32 MCU C/C++ Application 2

/* Reset Interrupt flag */

PushButtonDetected = 8;

/* Do nothing */

}
for(i = @; i < CUSTOM_MOTION_INSTAN
if(MotionCapabilities[i].Acc) Description
Accelero_Sensor_Handler(i); SIMGANIRC IS phlication
if(MotionCapabilities[i].Gyro) v
< | >
& Console 52 @’@?{}|'—E5ﬁ:|§k|ﬂa'rﬁvzﬁ
COT Build Console [Labg]
arm-none-eabi-gcc "../Drivers/BSP/Component ® | oK | | Cancel | -md -std=gnull -g3 -DUSE_HAL DRIVER -DSTM32L476xx -DDEBUG -c -I
arm-none-eabi-gce -o "Lab6.elf" @"objects.]| chael galizzil\STM32CubeIDE\workspace_1.8.@8\Lab6\STM32L476RGTX_
Finished building target: Labg.elf
arm-none-eabi-size  Lab6.elf
arm-none-eabi-objdump -h -5 Lab6.elf > “"Lab6.list"
text data bss dec hex filename
3918e 252 2156 41588 a274 Labg.elf
Finished building: default.size.stdout
Finished building: Lab6.list
11:19:43 Build Finished. @ errors, @ warnings. (tock 75.932ms)
v
£ >
Writable Smart Insert 202:15




Lab6 - Debugging

1. Click OK



Lab6 - Debugging

1. Code start at the first line of the main function

2. Click play g button °
to run the code
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Open Tera Term to view the output

File Edit Source Refactor Mavigate Search Project Run Window Help

i @i = | m m o | i+ R R A R A CRER AN i | | @M

#HD.. 2 = 8 Labé.ioc || app_x-cube-memsl.c [8] startup_stm321476rgtxs [g] main.c 22 = 8 =V 3 = 0
is = 65 " _é’e-_'.a'_ int ~ % it v

v Lab6.elf [STM32 MCU Deb - ini.::.:main(void) Name Type Value

w (2 Lab6.elf [cores: 0]
& Thread #1 [main] 1 /* USER CODE BEGIN 1 */
po C/ST/STM32CubelDE_

W ST-LINK (ST-LINK GDE ° USER CODE END 1 */

B COM1T - Tera Term VT
File Edit Setup Control Window Help
: 280, GYR_Y[0]: 0, GYR_Z[O0]:

-3, ACC_Y[0]: -16, Acc_z[0]:

: 280, GYR_Y[0]: 0, GYR_Z[0]:
-4, ACC_Y[0]: -14, Acc_z[0]: 1014

: 280, GYR_Y[0]: -70, GYR_Z[0]: -350
-5, ACC_Y[0]: -13, Acc_z[0]: 1008

: 280, GYR_Y[0]: -210, GYR_Z[0]: -350
-4, AcC_Y[0]: -13, Acc_z[0]: 1011
350, GYR_Y[0]: -70, GYR_Z[0]: -280
-5, ACC_Y[0]: -15, Acc_z[0]: 1009

: 280, GYR_Y[0]: -70, GyrR_Z[0]: -350

-7, ACC_Y[0]: -13, Aacc_z[0]: 1012

Download verified successfully

Writable Smart Insert 77:1



Lab6 - Debugging

1. Click stop button to interrupt the debugging



Lab6 — Closing the Project

1. Right-Click on Lab6 project

2. Click on Close Project
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Thank Youl!

© STMicroelectronics - All rights reserved

The STMicroelectronics corporate logo is a registered trademark
of the STMicroelectronics group of companies

All other names are the property of their respective owners



Troubleshooting



Common Issue ;

 Description: when debugging is launched by pressing £~ , @ Problem
Occurred because ST-LINK need to be updated

.‘.

-
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Common lIssue 7

1. Click OK to run upgrade to latest firmware

.‘

t1: Solution



ommon Issue #1:

1. Click Yes when is asked to upgrade the ST-LINK

olution

E workspace_1.0.0 - Lab0/Src/

main.c - 5TM32CubelDE

File Edit Source Refactor Mavigate Search Project Run  Window Help
N-HR SRRk HH-F oD@
[¥5 Project Explorer 3 = B [ Labioc [€] main.c 52

: Main program body

<h2:<center>&copy; Copyright (c) 2819 STMicroelectronics.

This software component is licensed by ST under BSD 3-Clause license,

ST-LINK firmware upgrade required.
Please first reconnect ST-LINK, and then select YES to upgrade using the ST-LINK

Yes

<)=={-> - 1 /* USER CODE BEGIN Header */
2._.‘;’**
viZLaeo 3
> 35, Binaries 4 * @file : main.c
> )l Includes 5 * @brief
> (2 Drivers 6
7 * [@attention
w @ Src : . @
» [€] app_x-cube-memsl.c g .
> [l main.c 18 * All rights reserved.</center></h2>
> [ stm32Mc_hal_msp.c 11 *
> [g] stm32idncit.c 12 *
13 * the "Li
5 [ stm32idbo_nucleo_bus.c T B [ <7-Link
s [g] syscalls.c 15 .
> [ sysmem.c 16
> [ system_stm32l4icc 17 hahhiddd
> [ Startup 18 */ upgrade tool.
3 Debu 19 /* USER COD|
EZ' E 28
’ ne 21 /* Includes
=/ LabD.elf launch 22 #include "m
m Labl.ioc 23 #include "app——cuoe T
|id STM32L476RGTX_FLASH.Id 24
|3g STM32L476RGTX_RAM.Id
B Console 32

<terminated> Lab0.elf [STM32 MCU Debugging] ST-LINK (ST-LINK GDB server)

— O *

[k reces] | 2 | & 4
= 08

-~

W

X% BEREE 2B-8-=0

Starting server with the following options:

Persistent Mode
Logging Level

Listen Port Number
Status Refresh Delay

Verbose Mode
SWD Debug

: Disabled
1

: 61234

: 155

: Disabled
: Enabled

Error in initializing ST-LINK device.

Reason: ST-LINK firmware upgrade required. Please upgrade the ST-LINK firmware using the upgrade tool.

Writable Smart Insert
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Common lIssue 7

1. Click Open in update mode to force ST-LINK

2. Click on Upgrade

41: Solution



Common lIssue 7

Wait until update is finished and then close the window.

1.

Click on X when
finished

.‘

E1: Solution



Common Issue ;

 Description: when debugging is launched by pressing £52 , @ Problem
Occurred because ST-LINK is not detected even if it is plugged correctly to

the PC

Bl |E Problemn Occurred

£
Error in initializing ST-LIMNK device,
*5 Reason: (2) ST-LIME DLL error.
'm g
o
iInd

i1t

igu

P "\._I ‘Launching Lab&.elf' has encountered a problem.

k- _/'- . .
= Errorin final launch sequence:

Error in final launch sequence:

Errcrin initializing ST-LINK device.
Reazon: (2) ST-LIMNE DLL error,
Error in initializing ST-LINK device,
Reason: (2) ST-LIMK DLL error.

.‘

2.
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Common lIssue 7

1. Click OK and proceed to install ST-LINK driver

.‘

t2: Solution



Common Issue #2: Solution

1. Extract the archive en.stsw-link009.zip located in
C:\X-CUBE-MEMS1_HandsOn\Drivers

2. Run installer for your PC architecture (32bit or 64bit)

amded
x36
0 § dpinst_amdfd.exe
k7 dpinst_xB86.exe 0
D readme.tet
£ stlink_bridge_winush.inf
] stlink_dbg_winusb.inf
5 stlink_VCP.inf
stlink_winusb_install.bat
= stlinkbridgewinusb_x64.cat
=4 stlinkbridgewinush_x86.cat
=4 stlinkdbgwinusb_x64.cat
= stlinkdbgwinusb_x86.cat
=4 stlinkvep_xBd.cat
=4 stlinkvcp_x86.cat
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Click Next >

Click Finish

Completing the Device Driver

Welcome to the Device Driver
Installation Wizard

Installation Wizard!

This wizard helps you ingtall the software drivers that some

computers devices need in orderto wark.
o The drivers were successfully installed on this computer.

You can now connect your device to this computer. f your device
came with instructions, please read them first.

Driver Name Status

s STMicroelectronics (Win... Ready to use
s STMicroelectronics (Win... Ready to use

To continue, click MNext. s STMicroelectronics (usb... Readyto g

Bac Mext = Cancel Bac Finizh Cancel



Common Issue ;

3 =

 Description: regenerating the code by saving the project |Ef] after modify
the .ioc file may lead to some missed source file inclusion and compilation

will fails.

belDE
File Edit Source Refactor Mavigate Search Project Run  Window Help
‘e - [ ®-R-midiH-i® g Y -FH ooy
[y Project Explorer §2 = 0 m Labé.ioc main.c i
B % = 1 /* USER CODE BEGIN Header */ ~
28 *
3 Lab0 "
3
0 Lab1 4 : main.c
3 Lab2 5 : Main program body
3 Lab3 6
3 Lab4 ; f@attention
O Labs 4 * <h2><centersBcopy; Copyright (c) 2619 STMicroelectronics.
~ [ Labe 1@ * All rights reserved.</center»</h2>
it Includes 11
w [Z8 Drivers 12 * This software component is licensed by ST under BSD 3-Clause license,
v = BSP 13 * tI:ve "License"; You may not use this filg except in compliance with the
c t 14 * License. You may obtain a copy of the License at:
ve D;"ﬂpDﬁ;Eﬂ o 15 : opensource.org/licenses/BsSD-3-Clause
V¥ [= lsmBdso 16
|5 Ismédso_reg.h 17
|K] Ismédso.h 18 */ _
P Release_Notes.htn ;g /% USER COD /
(= STM32L4e Nucleo 20 % IREIUAES - m e e .y
& CMsis 22 #include "main.h
= STM32L4x_HAL_Driver 23 #include “app_x-cube-memsl.h"
w g Sre 24 _
@ app_x-cube-memsl.c 258 /* Private includes - --------------- oo */
26 /* USER CODE BEGIN Includes
@ custom_motion_sensors_ex 27
#e] custom_motion_sensors.c 28 /* USER CODE END Includes */ v
[£] main.c 2o
@ stm321dx_hal_msp.c
[ stm32M0 it.c 3 Console 52 &4 4 <3===>| CREE = | B~~~ = 08
L] stm32l4ocnucleo_bus.c CDT Build Console [Lab6]
scalls.c STM-NUNE-EdDL-HLL ../ UrLVEr S/ 513 ZLaRA_NAL_UrIVEr; 5FC/ 5 LIS ZIaX%_Ta1_Udiri_EA.C  -MCpPU=COr LEA-4 -5 LUSENULL -g5 -UUSE_NAL_URLVER -UZ
[g] syscall & AL SUCESCC P g E A
[ sysmem.c arm-none-eabi-gcc .. /Drivers/BSP/STM32L4xx_Nucleo/stm3214w_nucleo.c” -mcpu=cortex-m4 -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32L476x
[8] system_stm32lcce arm-none-eabi-gec -o "Lab6.elf" @"objects.list™  -mcpu=cortex-m4 -T"C:\Users\michael galizzil\STM32CubeIDE\workspace_l.@.8%Lab6\ST
o = : src/custom_motion_sensers.o: In function °LSMBDSO_B_Probe’:
& Startup C:/Users/michael galizzil/STM32CubeIDE/workspace 1.8.8/Lab6/Debug/../Src/custom motion sensors.c:583: undefined reference to ~LSMeL
(= Debug Users/michael galizzil/STM32CubeIDE/workspace_1.8.8/Lab6/Debug/../Src/custom_motion_sensors. : undefined reference to *LSMAL
(= Inc Users/michael galizzil/STM32CubeIDE/workspace_1.@.8/Lab6/Debug/../Src/custom_motion_sensors. : undefined reference to *LSM6LC
[ Labbiicc Users/michael galizzil/STM32CubelIDE/workspace_1.8.8/Lab6/Debug/../Src/custom_motion_sensors. : undefined reference to “LSMeL
= C:/Users/michael galizzil/STM32CubeIDE/workspace 1.8.8/Lab6/Debug/../Src/custom motion sensors.c: : undefined reference to ~LSMBL
B STMB2LATERGTFLASHIY ol | S aeli i e s e R s e e e b s B B Sy S
< > b
Writable Smart Insert 34:1 L]




Common Issue #3: Solution

1. Right click on the project

main.c -

: ! C I iCk On C I Ose P ro - ect File Edit Source Refactor Mavigate Search Project Run  Window Help
: J Su R AENETR RA ON- Y TE Sy A IRURE TRACRCR LRI |Quick Access| || 5 | B@ [E] A%
¥ Project Explorer 33 = 0 [€] main.c 23 = 0
= Q=|,=> - 1 /* USER CODE BEGIN Header */ ~
13 Lab0 ~ 28/
3
0 Lab1 4 * @file : main.c
1 Lab2 5 * (ibrief t Main program body
J Lab3 6
17 Lab4 ; : f@attention
h5
U Le N <center>&copy; Copyright (c) 2819 STMicroelectronics.
VE Li ew rights reserved.</centers</h2>
> Bl Go Into
v £ E software component is licensed by ST under BSD 3-Clause license,
v Open in New Window “License"; You may not use this file except in compliance with the
Ense. You may obtain a copy of the License at:
Copy Ctrl+C opensource.org/licenses/B5D-3-Clause
Paste Ctrl+V
W Delete Delete
FermEs CODE END Header */
Move... B S == - o mmm o m e */
’ Rename... F2  E "main.h"
> e "app_x-cube-memsl.h"
v GE v Import...
N Bte includes -----------mmmmm e */
;i Beort. CODE BEGIN Includes */
> B s CODE END Includes */ v
> Clean Project
> #| Refresh =
| CloseProject S| B -B&lMB-O-=0
Close Unrelated Project 2 [Lab6)
> 2ol i s FBLC L UTLVETS/SIMIZLEXK_AAL_UTLVET/ S1C/S UNSZI4XK_IaL_UdTL_EX.C  -WLpUSCUTLEX I ~SLUSBIIULL B3 -UUSE_MAL_URLVER -US
3 . ) . ~gcc ../ /Drivers/BSP/5TM32L4xx_Nucleo/stm3214xx_nucleoc.c” -mcpu=cortex-md -std=gnull -g3 -DUSE_HAL DRIVER -DSTM32L476x
N Build Configurations -gcc -o “lLab6.elf" @"objects.list"  -mcpuscortex-m4 -T"C:\Users\michael galizzil\5TM32CubeIDE‘\workspace_1.8.8\Labg\5T
Build Targets tion_sensors.o: In function °LSMEDSO_8 Probe':
= ael galizzil/STM32CubeIDE/workspace_1.8.@/Lab6/Debug/../Src/custom motion_sensors.c:583: undefined reference to ~LSM6L
> 1= Index ael galizzil/STM32CubelIDE/workspace_1.8.8/Lab6/Debug/../Src/custom motion_sensors.c:587: undefined reference to ~LSMEL
y = Run A el galizzil/STM32CubeIDE/workspace_1.8.@/Lab6/Debug/../Src/custom motion_sensors.c:597: undefined reference to ~LSM6L
m O Runas ael galizzil/STM32CubelIDE/workspace_1.8.8/Lab6/Debug/../Src/custom motion_sensors.c:648: undefined reference to ~LSMEL
= 15 Debughs ael g3112211fSTM32CubeIDEJ’workspace 1.8.8/Lab6/Debug/. ./Src/custom motlon sensors.c:64@8: undefined reference to ~LSMGL
l! T A~ T == J T A TRE fiumm e mm i m R = R S N . v omdAaFlnad cnFmcmmes s Tl omEr
< Profile As >
m Lab6 Team "=§

Compare With




Common lIssue 7

1. Double click the project to open it back

.‘

£3: Solution



Common lIssue 7

.‘

E3: Solution

1. Open the .ioc file and modify something in the project in order that is possible

to save it again



Common Issue #3: Solution

1. Save the project by clicking on L'j']

At this point included G
files will be restored

correctly



2. Compile by

clicking on

ommon Issue #3: Solution

1. Expand Src folder and open main.c

orkspace_1.0. 3 main.c - STV

File Edit Source Mavigate Search Project Run  Window Help
N HR SR RIS B SIS -F G0
¥ Project Explorer 33 = 0 Labé.ioe [€] main.c 23
& 1 /* USER CODE BEGIN Header */
E ="> 2._.,,!’**
0 Lab0
3
0 Lab1 4 * @file : main.c
0 Lab2 5 * @brief t Main program body
0 Lab3 6
17 Lab4 7 * ([@attention
a *
I Lab5 . . - .
9 <h2»<center>&copy; Copyright (c) 2819 STMicroelectronics.
E Labg 1@ * All rights reserved.</centers</h2>
> @]] Includes 11 *
5 [ Drivers 12 * This software component is licensed by ST under BSD 3-Clause license,
v B Src 13 * tPI1e "License™; You may not use this ‘Fil? except in compliance with the
B cube-memel.c 14 * License. You may cbtain a copy of the License at:
’ appeed . ' 15 * opensource.org/licenses/B5D-3-Clause
> @ custom_motion_sensors_ex.c 16 *
> @ custem_moetion_sensors.c 17
o g main.c 18 */
3 @ stm32lds_hal_msp.c ;2 /* USER CODE END Header */
> [g stm32idcit.c 21 /% TRELUAES oo m o oo m oo f o f o oL *f
> [ stm32idio_nucleo_bus.c 22 #include "main.h"
> [ syscalls.c 23 #include "app_x-cube-memsl.h™
> [ sysmem.c 24
5 [2 system_stm32Mx.c 252 /* Private includes -------------mmmmmim */
26 /* USER CODE BEGIN Includes */
» [ Startup .
» (& Debug 28 /* USER CODE END Includes */
> [= Inc 29
[ Lab6.ioc 382 /* Private typedef -------------mm *
[i STM32L476RGTX_FLASH.Id i /* USER CODE BEGIN PTD */
[ig STM32L476RGTX _RAM.Id 33 /* USER CODE END PTD */
34
352 /* Private define -----------:"b'v- bbb i el */
36 /* USER CODE BEGIN PD */
37
38 /* USER CODE END PD */
39
489 /% Private Macr0 —-—-- - oo oo */
41 /* USER CODE BEGIN PM */
42

[€] /Lab6/Sre/main.c

< >

ucrces] | s | BT 4
= 8

-

s




ommon Issue #3: Solution

1. Compilation should now terminate without warnings/errors

File Edit Source Refactor Mavigate Search Project Run  Window Help
RN RE - H U AT R AW RURE R A K R R (Quick Access] || 5 | [ 45
¥ Project Explorer 33 = B [@Labsioc [€) main.c 2 = 0
s - 1 /* USER CODE BEGIN Header */ ~
E = 2._.‘;’**
0 Lab0
3
0 Lab1 4 * [{file + main.c
I Lab2 5 * [@brief : Main program body
J Lab3 6
10 Lab4 7 * [@attention
o 2.
Lab5 9 * <h2r<center>&copy; Copyright (c) 2019 STMicroelectronics.
v I Lab6 18 * All rights reserved.</center></h2>
> ﬁ' Binaries 11 *
3 @] Includes 12 * This software component is licensed by ST under BSD 3-Clause license,
5 (2 Drivers 13 * the "License™; You may not use this file except in compliance with the
@ s 14 * License. You may obtain a copy of the License at:
M rc 15 * opensource.org/licenses/B5D-3-Clause
» [ app_e-cube-memsl.c 16 *
> @ custem_moetion_sensors_ex.c 17
» € custom_motion_sensors.c 18 */
3 @ main.c ;g /* USER CODE END Header */
> g stm32|4)o(_ha|_msp.c 21 /* Includes ---
> g stm32idoc it.c 22 #include "main.h"
5 € stm32denuclec_bus.c 23 #include "app x-cube-mems1.h"|
5 [ sysealls.c 24
5 [€ sysmem.c 258 /* Private includes --------oommmmmmm oo */
26 /* USER CODE BEGIN Includes */
> [ system_stm32iocc 37
> (&2 Startup 28 /* USER CODE END Includes */ "
> [= Debug 2o
» = Inc
m'—abﬁ-i‘x B Console 53 @G%M'—E@'—E :.:§k|:'javrﬁ"=ﬁ
@ STM32L476RGTX_FLASH.Id CDT Build Console [Lab]
[y STM32L476RGTX RAM.Id 39188 256 2168 41664 a284 Labg.elf -
Finished building: default.size.stdout
Finished building: Lab6.list
17:1@:82 Build Finished. @ errors, @ warnings. (tock 8s.58@ms)
v
£ > £ >
Writable Smart Insert 23:30 L]
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Backup: How to Download and Install sw
Tools from the Web
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Required HW & SW



Required HW & SW

Laptop with USB type A

64 bit OS Win (7, 10), MacQOS, Linux (Generic, Debian, RPM)
* Virtual Machine is also OK (example: Parallel, VM Fusion...)
« Administration rights are required for SW tools installation

Terminal emulator
« TeraTerm under Windows is OK, download from https://ttssh2.o0sdn.jp/index.html.en
« Serial COM port settings: 115200 bps, 8N1, no flow control

SW tools from STMicroelectronics installed

« STM32CubelDE 1.0.2 integrated development environment, download from www.st.com
You will need to create a my.st.com account.

« X-Cube-MEMS1 6.2.0 software package extension for MEMS sensors, download from
STM32CubelDE after installation (see next slides)



https://ttssh2.osdn.jp/index.html.en
http://www.st.com/

STM32CubelDE Installation



STM32CubelDE Installation

1. Go to www.st.com and download the zip package STM32CubelDE

2. Unzip and run the installer

required


http://www.st.com/

STM32CubelDE Installation

1. Click Next >



STM32CubelDE Installation e=

1. Click I Agree

W STMicroelectronics STMM32CubelDE — >
License Agreement

Please review the license terms before installing
STMicroelectronics STM32CubeIDE.

Press Page Down to see the rest of the agreement.

STMicroelectronics Software License Agreement

SLAOD4E Rev4March 2018

BY INSTALLING COPYING, DOWNLOADING, ACCESSIMNG OR OTHERWISE USIMNG THIS
SOFTWARE PACKAGE OR ANY PART THEREOF (AMD THE RELATED DOCUMENTATION)
FROM STMICROELECTROMNICS INTERMATIOMAL M.V, SWISS BRANCH AND/OR ITS
AFFILIATED COMPANIES (STMICROELECTRONICS), THE RECIPIEMT, ON BEHALF OF
HIMSELF OR HERSELF, OR OM BEHALF OF ANY ENTITY BY WHICH SUCH RECIPIENT IS

EMPLOYED AMD/OR ENGAGED AGREES TO BE BOUND BY THIS SOFTWARE PACKAGE
LICEMSE AGREEMENT.

If you accept the terms of the agreement, dick I Agree to continue. You must accept the
agreement to install STMicroelectronics STM32CubeIDE.

<Back | IAgree Cancel




STM32CubelDE Installation

1. Click Next >

m STMicroelectronics STMM32CubelDE — >

Choose Install Location

Choose the folder in which to install STMicroelectronics
STM32CubeIDE.

Setup will install STMicroelectranics STM32CubeIDE in the following folder. To installin a
different folder, dick Browse and select another folder. Click Mext to continue,

Destination Folder

| C:\ST\STM32CubeIDE_1.0.0 | Browse...

Space reguired: 1.9 GB
Space available: 193.8 GB

<Back | Next> Cancel




STM32CubelDE Installation

1. Click Install

m STMicroelectronics STMM32CubelDE — >

Choose Components
Choose which features of STMicroelectronics STM32CubeIDE you
want to install.

Chedk the companents you want to install and unchedk the companents you don't want to
install. Clidk Install to start the installation.

: Description
Select components to install: SEGGER Iink drivers - P
Pasition your mouse

ST-LINK drivers ower a component ko
ST-LIMK server seg jts description.

Space reguired: 1.9 GB

<Back | Instal Cancel




STM32CubelDE Installation... ==

1. Wait until installation is completed

m STMicroelectronics STMM32CubelDE —

Installing
Please wait while STMicroelectronics STM32CubeIDE is being
installed.

Extract: SY5-5TM32F042_sys_v1_0_Mades. xml

= Back Mext = Cancel




..STM32CubelDE Installation

1. Click Next >

m STMicroelectronics STMM32CubelDE —

Inst allation Complete
Setup was completed successfully.

Completed




STM32CubelDE Installation

1. Click Finish



STM32CubelDE Configuration

1. Open STM32CubelDE by double clicking the icon on your desktop

2. Wait until STM32CubelDE is loading

M L2

5TM32CubelDE
102




STM32CubelDE Configuration

1. Check Use this as the default and do not ask again

2. Click Launch

EE sTM32CubelDE Launcher : ne t S =]
| d I me
STM es th directory to store its preferences and development artifac. sele
CY;,
Workspace: C\Users\andrea vitali\STM32CubelDE\workspace_1.0.2 - Browse... n




STM32CubelDE Configuration

The main interface of STM32CubelDE will appear differently, depending if it is
the first time it has been run or not:



X-Cube-MEMS1 Installation



X-Cube-MEMS1 Installation

X-Cube-MEMS1 can be downloaded from STM32CubelDE

» X-Cube downloads can be managed only while a project is opened

« We will create a temporary project which will be deleted at the end of the installation, this is
also an opportunity to test the STM32CubelDE installation

« Cube downloads may be triggered if updates are available and deemed necessary
« Currently STM32CubelDE 1.0.2 needs to download STM32Cube_FW 14 v1140.zip package

« NOTE: If you are in a VPN and/or behind a proxy that requires authentication, you may
need to change the network connection setting. You will find details the relevant
information in the section “Network Setting Configuration”

 |tis always possible to configure network connection settings in Window > Preferences then in
General > Network Connections



X-Cube-MEMS1 Installation

1. Click on File > New > STM32 Project



X-Cube-MEMS1 Installation

1. Check Remember my decision*

2. Click No’

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



X-Cube-MEMS1 Installation

If you answer Yes and network settings are wrong, required downloads will not
be completed. Just click Ok and ignore it. We can fix this later.

roblem during Download and/or Unzip of selected Files @1
e Error downloading the following  Problem during Download andy/or Unzip of sele... @]
uuuuuuuuuu AndDescription js e Error dowi Idghflp T S T L e @]
mc

- 9 Error downloading the fo Problem during Download and/or Unzip of s... [ £2 |
boardsDocs json (HTTP Error downloading the following files:

boards json (HTTP or Proxy host unknown)




X-Cube-MEMS1 Installation

. Click on Board Selector

. Type NUCLEO-L476RG 0

. Click on the board

. Click Next > @



X-Cube-MEMS1 Installation

1. Project Name Lab0 (any name is OK)

2. Click Finish




X-Cube-MEMS1 Installation

1. Click Yes to init peripherals in default mode



X-Cube-MEMS1 Installation

1. Check Remember my decision

2. Click Yes to open the
project perspective




X-Cube-MEMS1 Installation

1. Check Remember my decision

2. Click No’

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



STM32CubelDE Configuration

1. Click No™ (we will download it later)

Warning | 28 |

&) The Firmware Package (STM32Cube FW_L4 V1.14.0) or one of its

== dependencies required by the Project is not available in your
5TM32CubeMX Repository.

You can download the missing Firmware Package, but connection
to ST Server is not setted.

Or you can continue and generate only source code, without
Project settings.

Set this connection (and download) now 7

Yes ‘ ‘ Mo




STM32CubelDE Configuration

1. Click Ok

FE Code Generation @

Code generation could not be done because the necessary firmware package is missing.
Not able to complete 5STM32Cube project creation.

See Firmware Updater for settings related to firmware package installation

Tips:
Please use the Device Configuration Tool, and then use 'Project » Generate Code’ to complete the project generation.

OK




STM32CubelDE Configuration

1. Click on Help > Manage embedded software packages



STM32CubelDE Configuration

1. Scroll down to STM32L4, click to expand tree, select latest package 1.14.0

m Embedded Software Packages Manager =]
H STM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

STM32Cube MCU Fackages

-_________ P Installed Version | Available Version

STMicroelectronics

»> STM321L1

STM32L4

STM32Cube MCU Package for STM32L4 Series (Size : 712 MB)

O STM32Cube MCU Package for STM32L4 Series (Size - 777 MB) 1.13.0
O STM32Cube MCLU Package for STM32L4 Series (Size - 772 MB) 1.12.0
Details

STM32L4_ReleaseMotes_V1140_html




STM32CubelDE Configuration

1. Scroll down to X-CUBE-MEMS1, click to expand, select latest package 6.2.0
(older packages are marked as not compatible with this IDE version)

m Embedded Software Packages Manager =]
H STM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

;ube MCU Packages |SSTNICIOElEctranics

X-CUBE-GNS51
¥  X.CUBE-MEM31

Drivers and sample applications for MEMS components (Size - 79.92 MB)

O & Drivers and sample applications for MEMS components (Size - 58.91 MB) 6.1.0
O & Drivers and sample applications for MEMS components (Size - 59.4 MB) 6.0.1
Details
6.2.0:

Create sample applications with STM32CubeMX W5.2.0 and upwards

This release is not fully compatible with STM32CubeMX V4.27.0, STM32CubeMX V5.0.0, STM32CubeMX V5.0.1 and
STM32CubeMX V5.1.0

Add support to ASM330LHH, IS2DLPC, IIS2ZMDC, ISM303DAC, ISM330DLC, LIS2DH12, LPS33HW, LSMEDS0X




STM32CubelDE Configuration

1. Click Install Now. If you get an error you must configure the network
settings (see next slides).

m Embedded Software Packages Manager =]
ﬂ STM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

STM32Cube MCU Packages

- __Descrip Installed Version | Available Version
»> STM3211
[-m Downloading selected software packages @-}

¥ STM32L4 - -

Problem during Download and/or Unzip of selected Files =]
STM32Cy Error downloading the following files: 1.14.0

stm32cube fw 14 w1140 zip (HTTP or Proxy host unknown)

O STM32Cy STMicroelectronics X-CUBE-MEMS1.6.2.0 pack (HTTF or Proxy host unknown) 1.13.0
O STM32Cy Ok 1.12.0
Details

STM32L4_ReleaseMotes V114 b=

From Local ... Fram Url ... Refresh Remaove Mow Close

Install Mow




Network Setting Configuration
NOTE: this section applies only if you are in a VPN and/or behind a proxy that

requires authentication. Otherwise you can go directly to the following section.




Network Setting Configuration

1. Click on Window > Preferences



Network Setting Configuration

1. Click on General > Network Connection



Network Setting Configuration

]

1. Change Active Provider to Manual



Network Setting Configuration

. Select the protocol (repeat for each protocol, HTTP, HTTPS and SOCKS)

. Press Edit

. Insert proxy IP address and
port number

. Check “Requires Authentication”
if needed, and insert user name
and password

. Click OK
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STM32CubelDE Configuration



STM32CubelDE Configuration

1. Click on Help > Manage embedded software packages



STM32CubelDE Configuration

1. Scroll down to STM32L4, click to expand tree, select latest package 1.14.0

m Embedded Software Packages Manager =]
H STM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

STM32Cube MCU Fackages

-_________ P Installed Version | Available Version

STMicroelectronics

»> STM321L1

STM32L4

STM32Cube MCU Package for STM32L4 Series (Size : 712 MB)

O STM32Cube MCU Package for STM32L4 Series (Size - 777 MB) 1.13.0
O STM32Cube MCLU Package for STM32L4 Series (Size - 772 MB) 1.12.0
Details

STM32L4_ReleaseMotes_V1140_html




STM32CubelDE Configuration

1. Scroll down to X-CUBE-MEMS1, click to expand, select latest package 6.2.0
(older packages are marked as not compatible with this IDE version)

m Embedded Software Packages Manager =]

2 C I ICk ﬂ STM32Cube MCU Packages and embedded software packs releases
L] + —

Releases Information was last refreshed 18123 days ago.

Install Now

STMicroelectronics

X-CUBE-GNS51

X-CUBE-MEMS1

Drivers and sample applications for MEMS components (Size - 79.92 MB)

O & Drivers and sample applications for MEMS components (Size - 58.91 MB) 6.1.0
O & Drivers and sample applications for MEMS components (Size - 59.4 MB) 6.0.1
Details
6.2.0:

Create sample applications with STM32CubeMX W5.2.0 and upwards

This release is not fully compatible with STM32CubeMX V4.27.0, STM32CubeMX V5.0.0, STM32CubeMX V5.0.1 and
STM32CubeMX V5.1.0

Add support to ASM330LHH, IS2DLPC, I1IS2MDC, ISM303DAC, ISM330DLC, LIS2DH12, LPS33HW, LSMEDS0K

From Local .. From Url ..




STM32CubelDE Configuration

1. Wait for the download and unzip to be completed. Accept terms and
conditions.

m Embedded Software Packages Manager =]
ﬂ S5TM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

STMicroelectronics

- - e x| Licensing Agreement =]
¥ X-CUBE-MEM51 STMicroelectronics X-CUBE-MEMS1 6.2.0 License Agreement
) Please read and accept the following agreement carefully to finish the installation:
Drivers and sample 4 [l Downloading selected software packages =] 620
O ® Drivers and sample 3 Download File st32cuhe_ﬁ~_l4_v11-‘l[].2|p 610
Ll 12 0 MBytes |
O @ Orivers and sample § Download and Unzip selected Files m Downloading selected software packages @ Click here to open the license agreement
O ® Drivers and sample 3 Unzip File - stm32cube_fw 14 v1140.zip |
: QK ;

Details W{m Downloading selected software packages =]
6.2.0: - : : (® | accept the terms of this license agreement

Create sample applicatiuns with STM32CubeMX V5.2.0 and upwards Download File SIrEtDIS_EMMS‘LE‘.Z.U.FECI( O | do not accept the terms of this license agreemeant

This release is not fully compatible with STM32CubeMX V4.27.0, ST 9 MBytes /79,9 MBytes I
STM32CubeMX V5.1.0 Download and Unzip selected Files inish Cancel

Add support to ASM330LHH, 1S2DLPC, 1S2MDC, ISM303DAC, IS s |

From Local ... From Url ... Refresh Install Mow Remove Now Close ’




STM32CubelDE Configuration

1. When STM32CUBE-L4 package is updated and X-CUBE-MEMS1 package
IS installed the corresponding checkboxs become green. Close window.

[ Embedded Software Packages Manager =]
ﬂ STM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

e MCU Packages

Installed Version | Available Version

» STM32L1

¥ STM32L4 l
] STM32Cube MCU Package for STM32L4 Series 1.14.0 1.14.0

m| STM32Cube MCU Package for STM32L4 Series (Size : 777 MB) 113.0

[m] STM32Cube MCU Package for STM32L4 Series (Size : 772 MB) 112.0

Details

STM32L4_ReleaseMotes_V1140.html

m Embedded Software Packages Manager =]
ﬂ STM32Cube MCU Packages and embedded software packs releases

Releases Information was last refreshed 18123 days ago.

STMicroelectronics

| p

»  XCUBE-GNSS51

¥  X.CUBE-MEMS51

(] Drivers and sample applications for MEMS components 6.2.0
O @& Drivers and sample applications for MEMS components (Size - 58.91 MB) 6.1.0
O & Drivers and sample applications for MEMS components (Size - 59.4 MB) 6.0.1
Details
6.2.0:

Create sample applications with STM32CubeMX V5.2.0 and upwards

This release is not fully compatible with STM32CubeMX V4.27.0, STM32CubeMX V5.0.0, STM32CubeMX V5.0.1 and
STM32CubelMX V5.1.0

Add support to ASM330LHH, IS2DLPC, 1I52MDC, 1SM303DAC, 1ISM3300LC, LIS2DH12, LPS33HW, LSMEDS0OX




STM32CubelDE Configuration

1. Let's check the code generator: Project > Generate Code



STM32CubelDE Configuration

1. Let's have a look at the generated code: expand the Src folder.



STM32CubelDE Configuration

1. Let's have a look at the generated code: double click on main.c to openit.

5 workspace_1.0.2 - Lab0/Sre/main.c - STM32CubelDE [==] =]
File Edit Source Refactor MNavigate Search Project Run  Window Help
DR ®- & -Bix-idosy-FH-F-0c-2-0 Quick Access | g | B ()
B Proj.. 22 T B [ Labl.ioc [€ main.c & = 8
s - 1 /* USER CODE BEGIN Header */ -
='|> 2._.‘;’**
4[E Lab0 3
b @ Includes 4 * [@file : main.c
R 5 * [@brief : Main program body
& 2 Drivers 6
7 * [@attention
a *
9 * <h2r<center>&copy; Copyright (c) 2819 STMicroelectronics.
18 * All rights reserved.</center></h2>
S ol o1 =
b g stm3214x_ 12 * This software component is licensed by ST under BSD 3-Clause license,
13 * the "License"; You may not use this file except in compliance with the
> ld syscalls.c 14 * License. You may cbtain a copy of the License at:
b [g sysmem.c 15 * opensource.org/licenses/BSD-3-Clause
16 *
b [ system_stm 2
& (2 Startup B3 %/
19 /* USER CODE END Header */
b= Inc 28
[@ Lablioc 21 /* Includes ----
22 #include "main.h"
1 STM32L476R( 53
STM32L4T76R 249 /* Private includes ----------mmmmmmm e *
25 /* USER CODE BEGIN Includes */
26
27 /* USER CODE END Includes */
28
292 /* Private typedef ----------b"-bvb’blb ;b i i b i i e i e e *
3@ /* USER CODE BEGIN PTD */
31
32 /* USER CODE END PTD */
33
342 /* Private define ----------mommmm e *
35 /* USER CODE BEGIN PD */
36
37 /* USER CODE END PD */
38
392 /* Private macro ------ - - s e *
48 /* USER CODE BEGIN PM */ S

Writable Smart Insert 1:1




STM32CubelDE Configuration mmm

Right click on the project name and select Close Project

IDE| workspace_1.0.2 - Lab0/Src/main.c - STM32CubeIDE

File Edit Source Refactor Mavigate Search Project Run Window Help

- |- |R-Bitt-idi®@ i B R L RN |
MNew 3
5 Prg
Go Into .
der */
4@ Open in New Window
> (B Copy Cirl+¢  frain.c
Main program body
> Paste Ctri+Vv
a(] ® Delete Delete
Source Y Copyright (c) 2019 STMicroelectronics.
Maove... d.</center></h2»
Rename... F2 lonent is licensed by ST under BSD 3-Clause license,
. may not use this file except in compliance with the
g Import.. btain a copy of the License at:
iy  Export. opensource.org/licenses/BSD-3-Clause
Build Project
G Clean Project ey
&F F5
C Close Project @ T
g Project
& ; " .
Build Configurations 4
i 2
Build Targets s )
Index 4
© Runas »
45 Debug As [ P
Profile As v |
Team 4 f """"""""""""""""""""""""""""
Compare With v
Restore from Local History...
Generate Code b
< | S%  Convertto C++ */
#7  Run C/C++ Code Analysis
[ Lak )
Configure 4

Alt+Enter

Quick Access

===

® | B

= 0

Properties



STM32CubelDE Configuration

1. Right click on the project name and select Delete



STM32CubelDE Configuration

1. Check to delete files on disk and then click Ok



STM32CubelDE Configuration

1. Close the window and confirm Exit



Tera Term Installation



Tera Term Setup 1/9

1. Lunch the teraterm-4.102.exe installer



1. Accept the agreement

2. Click on Next

Tera Term Setup 2/9 =

ﬁ' Setup - Tera Term 4.102

License Agreement

Please read the following impartant information before continuing.

Flease read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

License of Tera Term

Copyright (C) 1994-1998 T. Teranishi
(C) 2004-2019 TeraTerm Project
All rights reserved.

Redistribution and use in source and binary forms, with or without modification,
are permitted provided that the following conditions are met:

1, Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer,

(®) I accept the agreement
()1 do not accept the agreement




Tera Term Setup 3/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Destination Location
Where should Tera Term be installed?

Setup will install Tera Term into the following folder.

To continue, dick Mext. If you would like to select a different folder, dick Browse.

C:\Program Files (x36)\teraterm | | Browse. ..

At least 10,4 MB of free disk space is required. n

<Back || Next> | | Cancel




Tera Term Setup 4/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Components
Which components should be installed?

Select the components you want to install; dear the components you do not want to
install, Clidk Mext when you are ready to continue.,

| Standard installation w
Tera Term & Macro 9.7ME

TTS5H 2.6 MB

CygTerm+ 0.2 MB

[ ] LogMeTT (Other installer is started) 4,1 MB

[ ] TTLEdit (Other installer is started) 2.1 MB

[]TeraTerm Menu 0.3 MB

TTProxy 0.3 MB

[ ] collector 1.6 MB

[m] Additional Plugins 0.3me v

Current selection requires at least 13,5 ME of disk space.

<Back || Next> | | Cancel




Tera Term Setup 5/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Language
Which language shoud be used?

Select the language of application's menu and dialog, then dick Mext.

(®) English

() Japanese

() German

(") French

O Russian

i) Korean

i) Chinese{simplified)
() Chinese{Traditional)

<Back || Next> | | Cancel




Tera Term Setup 6/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Start Menu Folder
Where should Setup place the program's shortouts?

'
Setup will create the program's shortouts in the following Start Menu folder.
[ =]

To continue, dick Mext. If you would like to select a different folder, dick Browse.

|TeraTerm | | Browse...

[ ]Don't create a Start Menu folder n

<Back || Next> | | Cancel




Tera Term Setup 7/9

1. Click on Next

ﬁ' Setup - Tera Term 4.102 —

Select Additional Tasks
Which additional tasks should be performed?

Select the additional tasks you would like Setup to perform while installing Tera Term,
then dick Mext.

Create Tera Term shortout to Desktop
Create Tera Term shortout to Quick Launch
[ ] add "Cygterm Here™ to Context menu

] create cyglaunch shorteut to Quick Launch
[] Assodiate .t file to ttpmacro.exe

[ ] Associate telnet protocol to ttermpro.exe
[ ] Associate ssh protocol to ttermpro, exe

] Associate .ty file to thermpro.exe




Tera Term Setup 8/9

1. Click on Install

ﬁ' Setup - Tera Term 4.102

Ready to Install
Setup is now ready to beqin installing Tera Term on your computer.,

Click Install to continue with the installation, or dick Badk if yvou want to review or
change any settings.

Destination location:
C:\Program Files (x8a)\teraterm

Setup type:
Standard installation

Selected components:
Tera Term & Macro
TTS5H
CygTerm+
TTProxy
Additional Plugins

TT¥ResizeMenu (VT-Window size can be changed from pr

= Back || Install || Cancel
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Select Launch Tera Term

Click on Finish

Completing the Tera Term Setup
Wizard

Setup has finished installing Tera Term on your computer, The
application may be launched by selecting the installed
shortouts,

Click Finish to exit Setup.

V| Launch Tera Term;a




Tera Term Configuration
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Plug the board to the PC using the micro USB cable provided

Select the STMicroelectronics Virtual COM Port

Click OK

WT

File Edit

Setup

Control

Window Help

Tera Term: Mew connection
OTC PHIP

23

55HZ

G UNSPEC

® Serial Port: |COM38: STMicroelectronics ¥Yirtual C( -

| 0OK Cancel Help
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Click Setup -> Serial port...

COMITY - Tera Term VT

File Edit Setup Control Window Help
Terminal...
Window...
Font...

Keyboard...

Serial port... °
Proxy...

S5H...

55H Authentication...

55H Forwarding...

55H KeyGenerator...

TCP/IP...

General...

Additional settings...

Save setup...
Restore setup...
Setup directory...

Load key map...
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1. Set the following:
Baud Rate: 115200
Data: 8 bit
Parity: none
Stop: 1 bit

Flow control: none n 6

2. Click OK
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Click Setup -> Save setup...

COMITY - Tera Term VT

File Edit Setup Control Window
Terminal...
Window...

Font...

Keyboard...

Serial port...

Proxy...

S5H...

55H Authentication...
55H Forwarding...
55H KeyGenerator...
TCP/IP...

General...

Additional settings...

Save setup... G

Restore setup...
Setup directory...

Load key map...
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1. Click Save



