
Simplify the Integration of Sensors and 
Bluetooth Low Energy (BLE) Connectivity Using 
the BlueNRG-Tile Eval Kit

Hands-on Workshop

IoT Systems Development - Connectivity
WiFi Network:  STMicro
Password:       STMTT2019



Agenda 2

BlueNRG-Tile 
(STEVAL-BCN002V1)

• Training Material Check/Installation Help

• ARM® Keil MDK Installation

• Introduction to Bluetooth® Low Energy

• BlueNRG-Tile Development Kit

• ARM® Keil MDK License Installation

• Lab 1: Getting Started with BlueNRG-Tile “Serial Terminal Test”

• Lab 2: Connecting to the ST BLE Sensor app

• Lab 3: LED characteristic

• Lab 4: Accelerometer embedded events detection

• Lab 5: 9-axis Acc+Gyro+Mag Sensor Data Fusion 

• Lab 6: Cloud data logging on IBM Watson

• Lab 7: Bonus – Voice over BLE



Training Material Check / Installation Help



BlueNRG-Tile Hands-on - LABs Preparation

ON YOUR LAPTOP

ON YOUR PHONE

• USB Flash drive with relevant hands-on material 

• Unzip the content to C:\
• Mandatory: installation folder has to be 

C:\BlueNRG_Tile_HandsOn

• Install “ST BLE Sensor” app

Please return it at the 
end of the workshop



ST BLE Sensor
Version: 4.2.2

if you already have the ST BLE Sensor 
app installed…

• You need to upgrade the “ST BLE Sensor” app to the latest 

version available on Google Play and Apple iOS app stores

For Android Devices -> v4.2.2
For iOS Devices -> v4.2.2

ST BLE Sensor
Version: 4.2.2



Today’s workout! 6

- Connect BlueNRG-Tile (STEVAL-BCN002V1) to PC using USB 

- Run Tera Term virtual serial terminal

LAB1
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Client

Start a BLE Connection
- Run ST BLE Sensor and discover YOUR OWN BlueNRG-Tile
- Connect your phone to the BlueNRG-Tile

- Get Sensor data on the ST BLE Sensor client

Server

Today’s workout! 
LAB2
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Client

Add LED characteristic and remotely toggle the LED

Server

LAB3
Today’s workout! 
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Client

Add Accelerometer embedded events detection feature

Server

LAB4
Today’s workout! 
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Client

Add 9-axis Sensor Data Fusion feature

Server

LAB5
Today’s workout! 
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Server

Client

IBM Watson

Enable Cloud sensor logging on IBM Watson 

LAB6
Today’s workout! 
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Client

Bonus lab: add Voice over BLE feature

Server

LAB7
Today’s workout! 



It’s a class: remember that… 13

• OUR GOAL is for ALL OF YOU to successfully
complete all the Labs

• Each lab has a step-by-step procedure. We need to go through each step!

• It’s not a race. If you’re ahead, please help your neighbor… 



And there is a prize… 14

At the end of the workshop each of you will receive a 

free BlueNRG-Tile eval kit (STEVAL-BCN002V1B) 



Hands On Directory Content

1. BlueNRG Graphical User Interface

2. UART Flasher Application

3. Code Snippets text file

4. Documents: DS, User Manuals and App 
Notes

5. Hands on Labs presentation and binary

6. Keil setup files

7. Software Utilities

8. BlueNRG-Tile DK V 3.0.0 

15

2

1

3

5

4

6

Open “BlueNRG_Tile_HandsOn.pdf” presentation

7

8



ARM Keil MDK Installation



What is Arm Keil MDK?

•MDK: Microcontroller Development Kit
• Complete software development environment from Arm for a wide range of 

Arm Cortex-M based microcontroller devices. 

• MDK includes the µVision IDE, debugger, and Arm C/C++ compiler

• A FREE license is available for ST BlueNRG-2 device

17



Keil MDK Installation 1/6 18

1

2

3

1. Go to the folder C:\BlueNRG_Tile_HandsOn\KeilMDK

2. Double click on MDK525.EXE

3. Click on Next in the Setup window



19Keil MDK Installation 2/6
1. Click on Agree and then Next

2. Click on Next

3. Fill in your info and click on 

Next

1

123

The installation starts.

TO BE CONTINUED IN 
A FEW MINUTES…



Introduction to 
Bluetooth Low Energy



Bluetooth® Evolution 21

5.0

Bluetooth Low EnergyBluetooth Classic

• 20 Years in the market

• 2009: Classic -> BLE



Bluetooth low energy (LE): Designed for 
Success

• Lower power than Bluetooth “Classic” (or Bluetooth 3.0)

• Lower duty cycle

• Faster connection

• Lower peak power (relaxed RF parameters)

• Compatible with all major platforms (iOS, Android, Windows, Linux)

• Multiple network topologies:

• Point to point: single master connects to single slave (and each slave can connect to 2 master)

• Star: Multiple slaves connected to a single master

• Mesh: introduced in the 2017

• State of the Art encryption, security including privacy/authentication

22



Protocol Stack 23

PHY layer

Link layer

Host Controller Interface

L2CAP

SMATT

GATT

GAP

Application

BLE Application Profiles

• Generic Acces Profile
• How a device can discover and connect with one another

• Generic Attribute Profile 
• How services, characteristics can be discovered and then used

• Attribute Protocol
• Protocol for discovering, reading, and writing attributes on a peer

• Security Manager 
• Handles the secure communication

• L2CAP
• Protocol multiplexer. Segmentation and reassembly of packets

• HCI
• Interface between Host and Controller

• Link Layer
• Handles packets, channels, advertising, scanning & connections

• Physical Layer
• Transmits/receives bits

H
o
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t
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Developer User 

Space.
We will be 

working here 
today!
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24

Source : Bluetooth® SIG

Protocol Stack: PHY
• A BLE Radio is a 2.4 GHz ISM Band Transceiver

• 40 RF Channels, 2 MHz Channel Spacing. Two types of channels: 

• Advertising channels (3 - orange) for Advertising Packets. Used for Discoverability and 
for Broadcasting/Observing

• Data Channels (37 - blue) for Data Packets. Used to send application data in Connection

• GFSK Modulation

• BT = 0.5

• Modulation Index = 0.5

• “pulse shaping” Gaussian 
filter “smooths” transitions 
from zero to one reduces 
spectral width



Protocol Stack - GAP 25

• Who controls the radio network?

• GAP (Generic Access Profile)

• Defines 4 roles

• Broadcaster

• Observer

• Peripheral

• Central

PHY layer

Link layer

Host Controller Interface

L2CAP

SMATT

GATT

GAP

Application

BLE Application Profiles
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GAP 26

Peripheral Central

Peripheral is in Advertising mode.
Sends Advertising packets.

My name is John
My capabilities are X, Y, Z, 
etc…

Central is Scanning.
Look for known peripherals by listening
to advertising packets.

Advertising packets consists of multiple 
information units known as AD types.
E.g.: Local Name, TX Output Power, 
Manufacturer Specific info, etc… 

I’m looking 
for John

As the John peripheral is found, 
it initiates a BLE connection. 

Connection



Protocol Stack - GATT 27

• Who controls the data flow?

• GATT (Generic Attribute Profile)

• Defines 2 roles

• Server

• Client

PHY layer

Link layer

Host Controller Interface

L2CAP

SMATT

GATT

GAP

Application

BLE Application Profiles
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GATT 28

Protocol PDU Type Sent by Description

Request Client Client requests something from server (it always causes a response)

Response Server Server sends response to a request from a client

Command Client Client commands something to server  (no response)

Notification Server Server notifies client of new value (no confirmation)

Indication Server Server indicates to client new value (it always causes a confirmation)

Confirmation Client Confirmation to an indication

Data

Data
Requests

Responses

Client talks to 
the server. 
Sends requests, 
wait for response. 
Can confirm 
indications

Server contains 
the data.
Receives requests, 
executes, responds.
Can indicate value

Client

Server

Data

Data

Data



Attributes
• Data are organized and exposed as attributes

• Each attribute has:

• A handle: it identifies the attribute on the server

• A type (defined by Universal Unique ID - UUID): what the 

value means

• 16-bit UUID: pre-defined by Bluetooth SIG

• 128-bit UUID: Vendor Specific identifiers

• A value (0 to 512 octets)

• Example

29

Source : Bluetooth® SIG

Server

Data

Data

Data

Each Data element 
in the Server is 
called Attribute



GATT Profile 30

a typical example:

1 service: “ARG” (Angular Rate and Gravity)

2 characteristics: “Gyro”, “Acc”

Values: [0,-1,+2], [-10,+15,+950]

Profile

Service

Service

Characteristic

Characteristic

Characteristic

Characteristic

• A GATT Profile defines how attributes are 
organized and how the application can 
access them.

• Attributes are organized in Services and 
Characteristics 



ST BLE devices



ST BLE Roadmap
32

PERFORMANCE

F
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U
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BlueNRG-MS
BLE4.1 Network processor

QFN32, WLCSP34

BlueNRG-2
BLE5.0 Application processor

Cortex-M0 32MHz, 256KB 

QFN32, QFN48, WLCSP34

STM32WBxx
BLE 5.0 Application processor

Dual core Cortex-M4 / M0+

Flash: 256K up to 1MB

RAM: 128K up to 256K

UQFN48, VQFN64, WLCSP100

BlueNRG-LP
BLE5.0 Application processor

Cortex-M0+ 64MHz, 256KB 

Flash, up to 36 GPIOs

QFN, WLCSP

(in development)

Single Core BLE

Dual Core BLE

BlueNRG-1
BLE4.2 Application processor

Cortex-M0 32MHz, 160KB 

QFN32, WLCSP34

TODAY’S 
Hands on



BlueNRG-2 SoC at a glance
The lowest power 

consumption

>3 years lifetime on 
CR2032(*)

59 µA/MHz
0.9 µA sleep

33

(*) Based on the average current consumption in connection mode (7.059 μA, connection interval 1000 ms)

Low-power
architecture, Cortex-

M0 @ 32 MHz

Flexible memory
architecture

256 KB eFLASH
24 KB ULL SRAM

(with full SRAM data 
retention)

Processing power on 
demand

Maximum security

ECC-256
AES-128

Factory UID
Secure KEY

Robust and 

Reliable BLE Link

Seamless connection 

with SENSORS
Small form factor

Privacy 1.2 and secure 

connection 4.2

Faster and more 

reliable data transfer

Bluetooth 5.0 

certified

5 data

Optimized BLE 
Radio stack

70 kB FLASH
8 kB RAM

0.9uA with full RAM 
retention

Sensors



34

ARM
Cortex M0

32 MHz

Flash
256 KB

SRAM
24 KB

BLE 5.0

Advanced High-Performance Bus (AHB)

GPIO
x 26

SPI

I2C
Decimation 

filter
PDM

Interface

UART
ADC 10 bit
4 channels

RF
PHY
+8 

dBm

RTC
(timers)

DC/DC
LDO

DMA

PROGRAMMABLE
PERIPHERALS

Bluetooth LE
5.0

ULP radio

PROGRAMMABLE
Digital I/O

PROGRAMMABLE
MCU

with eFLASH
to host application code

Bluetooth LE programmable processor

BLE Protocol stack

Application and Profiles



BlueNRG-Tile Development Kit



STEVAL-BCN002V1

User button

Pressure Sensor
LPS22HH

Magnetometer
LIS2MDL

Time of Flight
VL53L1X

Humidity + Temperature
HTS221

Balun
BALF-NRG

BLE SoC
BlueNRG-232

Accelerometer + Gyro
LSM6DSO

I2C for expansion

32KHz XTAL to enable ultra-
low-power BLE sleep mode

L2 bead to enable low-
power BLE active mode

RGB LED

36

Bottom view

Microphone
MP34DT05-A

SWD Connector Antenna



STEVAL-BCN002V1 Block Diagram 37

BlueNRG-2
Bluetooth 5.0 Network and

Application processor

BALF-NRG-02D3
Integrated balun

32 MHz

Integrated 
antenna

32 KHz

LSM6DSO
accelerometer + gyroscope

LIS2MDL
magnetometer

LPS22HH
barometer

MP34DT05-A
microphone

HTS221
Relative Humidity & Temp.

VL53L1
time-of-flight proximity

I2C PDM

I2C

I2C

I2C

I2C

I2C

400 
kHz

1.6 MHz

User 
Button

RGB LED

U
A

R
T

S
W

D
IRQ

IRQ

Matching
Network*

connector

TEST ADC SDA SCL VDD GND
I2C

Test points

UART_RX line

TES
T

ADC

RFTEST

RFTEST

inductor

The 32kHz crystal enables lowest power BLE sleep mode.

The inductor enables lowest power BLE active mode.



STEVAL-BCN002V1D 38

STEVAL-BCN002V1 Socket
20-pin JTAG connector

Micro-USB connector (bottom)

STM32L151 (bottom)

STLinkV3 socket

Reset



BlueNRG-Tile DK

• Open the BlueNRG_Tile_HandsOn folder in C:\

• Open the STEVAL-BCN002V1 DK 3.0.0 folder

39



40BlueNRG-Tile DK overview

2

1

3

5

4

1. PC Applications

2. Documentation

3. Pre-built FW images

4. Low level drivers and BLE stack library

5. Virtual COM port drivers

6. Reference examples in source code

7. Utility section: IAR BlueNRG-2 Flasher

6

7



Documents 41

• Double click on index.html

• Device Datasheet

• BLE stack documentation

• Release notes

• APIs and events

• Programming manual

• Device (and kits) 
documentation

• PCB design guidelines 

• Bring up guide

• Getting started

• Open the Docs folder from the STEVAL-BCN002V1 DK 3.0.0 
folder



On st.com

http://www.st.com/bluetile

42



Arm Keil MDK Configuration and 
License installation



44

• Open Keil uVision5 IDE

• This is the main GUI

Check on successful tool installation



Keil MDK Installation 3/6

• Open the Pack Installer 

• Go to Project->Manage->Pack Installer

45



1. In the Pack Installer…

2. Go to File->Import

46Keil MDK Installation 4/6

2

1



Keil MDK Installation 5/6 47

1.Select the .zip file “Keil.STBlueNRG-2_DFP.1.0.0.zip” from the folder 
“C:\BlueNRG_Tile_HandsOn\KeilMDK”

2.Click on Open



48Keil MDK Installation 6/6

1. Once the Device Support pack 
has been installed, on the 

Devices list in the left column 

select the vendor 

STMicroelectronics

2. Go to STBlueNRG-2 Series 
and select STBlueNRG-2

3. Now it will show in green            

“Up to date”

4. Close the Pack Installer

3

4

2

1



Arm Keil MDK License

• A FREE license is available for ST BlueNRG-2 device

• This procedure requires on-line registration. 

• To avoid potential problems with the Wi-Fi network, we’re skipping this for the hands-on 
and we will install one temporary license (expiring end of the month)

• But, AT THE END OF THE PRESENTATION you can find the step-by-
step procedure for installing the FREE and unlimited license! 

49



Arm Keil MDK License Installation 1/6

• Go to the folder “C:\BlueNRG_Tile_HandsOn\KeilMDK”

• Double click on the file MDK-ARM_Pro_Eval_AddOn_03-2019

50



Arm Keil MDK License Installation 2/6

• This pop up window will appear

• Click on Next

51



Arm Keil MDK License Installation 3/6 52

• Select on Agree License terms 

• Click on Next



Arm Keil MDK License Installation 4/6

• Click on Next

53



Arm Keil MDK License Installation 5/6

• Fill in your data and click on Next

54



Arm Keil MDK License Installation 6/6

• Click on Finish

55



Arm Keil MDK License Installation –
FINAL CHECK

56

• Go back to Keil uVision5 IDE



57

• In Keil uVision tool open the dialog

File -> License Management...

Arm Keil MDK License Installation –
FINAL CHECK



• Select the tab FlexLM License 
and you should see the product 

“MDK-ARM Professional”

58

• Close the License Management 
popup window

Arm Keil MDK License Installation –
FINAL CHECK



Hands on overview



Labs overview
• Lab 1: Getting started with STEVAL-BCN002V1 “Serial Terminal Test”

• Lab 2: Connecting to the ST BLE Sensor app

• Lab 3: LED characteristic

• Lab 4: Accelerometer embedded events detection

• Lab 5: 9-axis Acc+Gyro+Mag Sensor Data Fusion 

• Lab 6: Cloud data logging on IBM Watson

• Lab 7: Bonus Lab – Voice over BLE

60



Code Snippets 61

L2 STEP1 : Customize your BlueNRG

1. Go to the path

2. Open with a text editor the file

1:1 correspondence 
with slides titles

Do NOT close this file! 



Lab 1
Getting Started with STEVAL-BCN002V1

“Serial Terminal Test”



“Serial Terminal Test” 63

• Plug the BlueNRG-Tile to the PC using the USB cable

• Install and open Tera Term and configure serial terminal



Code modifications

NO MODIFICATIONS NEEDED! 

64



Connect your STEVAL-BCN002V1 
to the PC using USB

65

The BlueNRG-Tile comes already 
connected to the daughterboard 

Connect the USB cable

On the PC file system a 
BCN002V1 drive will appear



Windows7: Allow the driver installation 66

2

1

1. Click on Install driver software 
anyway

2. Installation starts



Virtual COM port driver 67

If you have issue with the STMicroelectronics Virtual COM 

Port device driver installation, raise your hand.

Here the instructions for installing the Virtual COM port driver:

Win7 Win10



1. Go to the folder C:\BlueNRG_Tile_HandsOn\Software

2. Double Click on teraterm-4.97.exe

Tera Term installation 1/10 68



Tera Term installation 2/10 69

1

1. Select Accept the agreement

2. Click on Next

2



Tera Term installation 3/10 70

1

1. Click on Next



Tera Term installation 4/10 71

1

1. Click on Next



Tera Term installation 5/10 72

1

1. Click on Next



Tera Term installation 6/10 73

1

1. Click on Next



Tera Term installation 7/10 74

1

1. Click on Next



Tera Term installation 8/10 75

1

1. Click on Next



Tera Term installation 9/10 76

Installation 
starts...



Tera Term installation 10/10 77

1

1. Select Launch Tera Term

2. Click on Finish

2



Tera Term Configuration 1/6

1. Select the STMicroelectronics Virtual COM Port

• NOTE: on Win10 PC the serial port is labeled just as “COMxx”

2. Click OK

78

1

2



Tera Term Configuration 2/6

1. Click Setup -> Serial port…

79



Tera Term Configuration 3/6

1. Set the following:

Baud rate : 115200
Data : 8 bit

Parity : none

Stop : 1 bit

Flow control : none

2. Click OK

80

1
2



Tera Term Configuration 4/6

1. Click Setup -> Terminal…

81



Tera Term Configuration 5/6

1. In the New-line set:

Receive : AUTO

2. Click OK

82

2
1



Tera Term Configuration 6/6
1. Click Setup->Save setup… 

2. Click Save

83

1

2



…done! 

• If you see the output above, Tera Term is now properly configured

84

Push SW1 button on the daughterboard



Lab 2
Connect to the ST BLE Sensor app



Customize YOUR STEVAL-BCN002V1 86

+  STEVAL-BCN002V1 DK
Sensor Demo ref FW

Client

ST BLE Sensor



Code modifications

1. Modify local name in advertising packet

87



88

1. In Windows explorer browse to the path: 

2. Double click on the shortcut “BLE_SensorDemo.uvprojx”

Go down till the root of 
installation folder and 

then in HandsOn folder

BLE_SensorDemo application



89BLE_SensorDemo application



Application structure 90

Application source code
- Main
- ATTRIBUTE Database
- Application 

HW peripherals drivers and platform layer files

BLE Stack library – provided in binary format

Hardware Abstraction Layer and sleep management

Where we work today

Sensor Data Fusion library

Voice over BLE library



Open the BLE_SensorDemo main 91

1. Open the file SensorDemo_main.c

2. Scroll down to line 35



Show Line Numbers in KEIL IDE 92

1. Go to “Edit->Configuration…”. 

2. In the Editor tab click on “Show Line Numbers”



A look at the main application 93

int main(void) {

SystemInit();

SdkEvalIdentification();

PlatformInit();

BlueNRG_Stack_Initialization(&BlueNRG_Stack_Init_params);

Sensor_DeviceInit();

Set_DeviceConnectable();

while(1){

BTLE_StackTick();

User_AppTick();

} // end while(1)
}

Remap the vector table and configure all the interrupts priority

Identifies STEVAL or custom PCB

HW peripherals initialization

Sensors initialization

Start of while loop

BLE stack initialization

Advances the stack FSM

Advances the application FSM. THIS IS DEVELOPERS USER SPACE!

line 35

Set device in advertising 



BLE flow on the LAB 94

Advertise

Advertise Step 1: Advertising
Slave is in Peripheral mode and 

sends ADV_IND PDU

Central Peripheral

Connection created

Step 3: Connection request 
Connection request

Step 5: Data flow
Slave (Server) starts sending 

periodically (100 ms) to the master, 
notifications packets of sensors 
values (acc&gyro and pressure)

Advertise

Step 2: Scan
Master is in discovery mode

looking for a specific slave to connect to

Notification

Step 4: Services & Chars 

discovery
Master (Client) starts the BLE Service 
and Characteristics discovery procedure 

to understand the Server ATT DB

Service & Characteristics 
discovery

Notification

100msecs



Advertising and scanning
95

Advertise

Advertise Step 1: Advertising
Slave is in Peripheral mode and 

sends ADV_IND PDU

Central Peripheral

Connection created
Step 3: Connection request 

Connection request

Advertise

Step 2: Scan
Master is in discovery mode looking 

for a specific slave to connect to

LightBlue® Explorer

Master:
needs an app for 

discovering the slave 
device in advertising

Off-the-shelf app: e.g. Custom app: e.g.

https://itunes.apple.com/us/app/lightblue-explorer/id557428110?mt=8



Reminder: install ST BLE Sensor app 96

ON YOUR PHONE

• Look for “ST BLE Sensor” on the App Store or Google Play



Scan results

How devices will pop up in 
the ST BLE Sensor scan list?

97

LightBlue scan results ST BLE Sensor scan results

Why some devices are not present 
in the ST BLE Sensor app?



ST BlueMS Protocol
• In order to be connected to the ST BLE Sensor app, a BLE peripheral 

SHALL comply with a specific advertising packet format

• ST BlueMS protocol specifies a 26-byte packet format composed of 
Advertisement Types – ADTypes - compliant with BT SIG definitions

98

Pre Acc Addr CRCBlueMS Adv Packet

1 4 6 3

LL 
Header

2

AdvA AD Flags

3 26

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC

1 1 11 4 6

Len Type

1 1

Local Name

7

Pwr

1

Len Type

1 1

Manufacturer Specific
ADType
Len = 13
Type = 0xFF

Complete Local Name 
ADType
Len = 8
Type = 0x09

TX Out Power 
ADType
Len = 2
Type = 0x0A



BlueST SDK for Android and iOS 99

https://github.com/stmicroelectronics-centrallabs/bluestsdk_ios

https://github.com/stmicroelectronics-centrallabs/bluestsdk_android

Source code for iOS and 
Android

available online and maintained on GitHub repos

Android

iOS



ST BLE Sensor Scan results

Users can distinguish their node from 

the Local Name 

100

Each ST Platform is recognized by means of a 

Device ID (for STEVAL-BCN002V1 it is equal to 

0x05)

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name



L2 STEP1: Customize your BlueNRG-Tile
101



L2 STEP1: Customize your BlueNRG-Tile
102

Modify the local name in the advertisement payload

1. In the file sensor.c go to line 51

2. Modify X, Y values in the string 

• NOTE: COPY THE X,Y VALUES FROM YOUR STEVAL BLISTER

• E.g. if on the box is written X=3 and Y=4, then ‘B’,’C’,’N’,’-’,‘0’,‘3’,‘4’ 



Build the new code 103

1. Click on the Build button (top left corner) 

or hit F7 on your keyboard

2. In the Build Output window (bottom) wait for 
the build to be completed. 

• BLE_SensorDemo.bin created 

• “0 Error(s), 0 Warning(s)” message appear



Disconnect the serial terminal 104

1. Go back to Tera Term

2. Click on the File->Disconnect

Do  NOT close the 
terminal!



Programming embedded Flash
105

1. UART Bootloader

• ROM bootloader. HW activation through dedicate pin (DIO7) configured for Boot

• PC interface named “BlueNRG-1_2 Flasher Utility” available in the SW package 

2. SWD interface + ST-LINK

• Interface with the STEVAL-BCN002V1 through the 20-pin JTAG connector

• Same PC interface BlueNRG-1_2 Flasher 

Remove CN2 Jumpers 
and plug daughterboard 

on top

STM32 
Nucleo

ST-Link



Open the Flasher Utility 106

1. Go to 

BlueNRG_Tile_HandsOn\BlueNRG-1_2 Flasher Utility 2.0.0\Application

2. Double click on BlueNRG-1_Flasher_GUI.exe



For HD screens…If you’ve problem with the resolution 

• Right Click on the .exe file and select Properties

• In the Compatibility tab select either Disable display scaling… 
or Override high DPI scaling… –> Application

107



BlueNRG Flasher Utility 108

UART

SWD



MAC Addresses

• BLE addresses (6 bytes) can be either public or random.

• Public MAC addresses (6 bytes- 48-bit address) uniquely identifies a BLE device, and are 
defined by IEEE. 

• The first 3 bytes identify the company trough Organizationally Unique Identifier (OUI). 

• Up to 2^24 addresses from the remaining 3 bytes of the public address

• Public address has to be stored on a specific device Flash location and to set within the BLE stack 
through the aci_hal_write_config_data(). 

• Random can be either static or private

• Static random addresses: randomly generated and need to follow some rules defined in the BT 
specifications (refer to the BT Core specs v4.2, Vol 6, Part B, Section 1.3.2 for the details). 

• NOTE: BLE radio stack generates it autonomously and stores in flash: developer doesn’t need to care 
about programming the address.

• Private random addresses are used when privacy is enabled and according to the BT Core 
specs.

109



Flash the BlueNRG-2 1/6
110

1. Select the COM port labeled (ST DK)



Flash the BlueNRG-2 2/6 111

1. Device Memory will populate with data



Flash the BlueNRG-2 3/6
112

1. Select Mass Erase



Flash the BlueNRG-2 4/6
113

1. Click on the Select Image file button

2. And browse the following path



Flash the BlueNRG-2 5/6
114

1. Select BLE_SensorDemo.bin and click Open

2. Click on the Flash button



Flash the BlueNRG-2 6/6 115

1. Flashing starts: green bar proceeding

2. Wait for the pop-up window and click on OK

Do NOT close the Utility!



Clean Buffer in the serial terminal

1. In Tera Term in order to have the terminal clean, go to 

Edit -> Clear buffer

116



Reconnect the serial terminal

1. Click Setup -> Serial port…
2. Serial port should be already configured. 

Just need to click on OK

117

1

2



Sanity Check on serial port
Push SW1 button on the daughterboard -> LED blinking Blue

118



Open the ST BLE Sensor App 119

Launch the ST BLE Sensor 
app previously installed 

Note: in the following slides all the pictures are
referred to the iOS version of the ST BLE Sensor app.
The Android version is slightly different

ST BLE Sensor
Version: 4.2.2



Connect using the ST BLE Sensor App 120

Tap
“Connect to a device”

Select your 
STEVAL-BCN002V1

You are 
connected

1 2 3

Look for YOUR

X,Y couple 
before 

connecting!
Otherwise you’ll 
be connecting to 

someone else 
device!!! 

Blow air on 
the 

Temperature 
sensor to 

change the 
temperature 
and humidity 

values
ST BLE Sensor

Version: 4.2.2



Tera Term output
121

• “Device connected” will appear as connection is created

• Each time user moves on different tabs/screens in the app:

• BLE notifications on different BLE characteristics are enabled. 

• Environmental and Gas Gauge/Battery characteristics are involved



ST BlueMS Protocol
122

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

3 bytes TX output power

13 bytes Manufacturer Specific 

9 bytes Local Name

In file sensor.c at line 413



Feature Mask
123

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

4 Bytes

0x00

0x1E

0x00

0x00



STEVAL-BCN002V1 Block Diagram 124

BlueNRG-2
Bluetooth 5.0 Network and

Application processor

BALF-NRG-02D3
Integrated balun

Integrated 
antenna

LSM6DSO
accelerometer + gyroscope

LIS2MDL
magnetometer

LPS22HH
barometer

MP34DT05-A
microphone

HTS221
Relative Humidity & Temp.

VL53L1
time-of-flight proximity

I2C PDM

I2C

I2C

I2C

I2C

I2C

400 
kHz

1.6 MHz

user button

RGB LED

U
A

R
T

S
W

D

IRQ

IRQ

Matching
Network*

connector

UART_RX line

TES
T

ADC



BlueMS Protocol – complete Feature Mask
125

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

4 Bytes

0x6A

0xFE

0x05

0x40



Advertising Data
• In file sensor.c at line 413, this is how the Feature Mask looks like

126



How Feature Mask is mapped onto ATT DB?

• 3 services: HWServW2ST, Config, 
and Console

• Each bit of the 4-byte Feature 
Mask in the Advertising packet 
corresponds to a HW/SW feature

• In the Server ATT DB a BLE 
Characteristic has to be added 
for each bit of the Advertising 
Feature Mask

127

ATT DB

HWServW2ST

Prox

LED

Console

Term Char

Config

Config Char

STDERR Char

Environmental

Acc Gyro Mag

Quaternions

Ecompass

Acc Event

Battery

ADPCM SynchADPCM



BLE_SensorDemo ATT DB 128

The ATT DB is defined and 

created in the file gatt_db.c



BLE_SensorDemo ATT DB
129ATT DB

HWServW2ST

Environmental

Len PROPERTIES UUID TYPE UUID VALUE

12 N,R 128-bit 001D0000000111e1ac360002a5d5c51b

20 N 128-bit 00E00000000111e1ac360002a5d5c51b

5 N,R 128-bit 00000400000111e1ac360002a5d5c51b

9 N,R 128-bit 00020000000111e1ac360002a5d5c51b

4 N,R 128-bit 02000000000111e1ac360002a5d5c51b

3 N,R 128-bit 20000000000111e1ac360002a5d5c51b

8 N 128-bit 00000100000111e1ac360002a5d5c51b

4 N 128-bit 00000040000111e1ac360002a5d5c51b

20 N 128-bit 08000000000111e1ac360002a5d5c51b

6 N 128-bit 40000000000111e1ac360002a5d5c51b

Acc EventAcc Gyro Mag

Acc Events

Acc EventBattery

Acc Event

Acc Event

Prox

LED

Quaternions

Ecompass

Acc Event

ADPCM

ADPCM synch

NOTE: two additional bytes for a timestamp for each char



23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

ATT DB

HWServW2ST

Battery

Example: Battery Characteristic
130

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

0x00

0x02

0x00

0x00

UUID VALUE

00020000000111e1ac360002a5d5c51b

The UUID values are linked to 
the Feature Mask in advertising



BLE_SensorDemo ATT DB
131

ATT DB

Console

Term

STDERR

Each characteristic is defined by the following key parameters

Len PROPERTIES UUID TYPE UUID VALUE

20 N,R 128-bit 00000001000E11e1ac360002a5d5c51b

20 N,R 128-bit 00000002000E11e1ac360002a5d5c51b

Config

Config

Len PROPERTIES UUID TYPE UUID VALUE

20 N, Ww/oR, 
R,W

128-bit 00000002000F11e1ac360002a5d5c51b

This byte differentiates the Service



132

tBleStatus Add_HWServW2ST_Service(void)

aci_gatt_add_char(ServHandle,UUID_TYPE,UUID,Length,PROPERTIES,PERMISSIONS,…,&CharHandle)

HWServW2STHandle = 0x000C

EnvironmentalCharHandle = 0x000D

AccGyroMagCharHandle = 0x0010

aci_gatt_add_service(UUID_TYPE,UUID, …,MAX_NB_ATTRIBUTES,&ServHandle)

BLE_SensorDemo ATT DB

ATT DB

HWServW2ST

Environmental

Acc Gyro Mag

Config

Config Char

ConfigW2STHandle = 0x002B

ConfigCharHandle = 0x002C



133BLE_SensorDemo ATT DB

Environmental 

Char Declaration

Value

CCCD

EnvironmentalCharHandle = 0x000D

Char Value Handle = 0x000E

Char CCCD Handle = 0x000F

• Declaration Handle: used by the application to access the Characteristic

• Characteristic Value Handle: used by the Client for Read/Write operations

• Client Characteristic Configurator Descriptor (CCCD): a GATT 

descriptor is added by default by the stack, if char has Notify/Indicate 
property. Used by Client to enable notifications/indications on char value.



Central: Services and Characteristics 
discovery procedure 

134

This is how  
ATT DB 

looks like 
from the 
Central

Values
UUIDs Handles



BLE Sensor – Characteristic update
135

Central Peripheral

Connection created

Notification

100 ms

aci_gatt_update_char_value(ServiceHandle,

CharHandle, 

Offset, 

Length, 

Value)

0x000C, //HWserv handle

0x000D, //EnvChar handle

0x00, 

0x08, 

Data) //EnvChar Value



Cortex-M0 Sleep management 136

Central Peripheral

Connection created

Notification

100 ms

timeConnection Intervals

Deep sleep mode

Radio Active 
phase

• Sleep mode managed through specific a library and API

• BlueNRG_Sleep(sleepMode, gpioWakeBitMask, gpioWakeLevelMask)

• 4 wake-up sources: timers, DIO11, DIO12 and DIO13

• Timers: 4 virtual timers mapped on 2 physical timers managed by the radio IP

• DIO11: Interrupt line from UART RX or SW1 button

• DIO12: Interrupt line from Magnetometer

• DIO13: Interrupt line from 6-axis Accelerometer & Gyroscope



Typical scenarios
137

Low throughput

High throughput

Short Connection 
Intervals (min 7.5msecs)

time

time
Long Connection Intervals (in the orders of secs)

Deep sleep mode

Active mode 
Tx/Rx

time

mA

Start-up

CPU 
Active

XTAL 
startup & 

PLL lock

RX

RX-2-TX

TX

CPU 
Active

CPU OFF

Active phase 
typical plot



Low Power Modes
• Deep sleep mode can represent most of the application time. 

• Efficient management of sleep mode significantly lowers the avg power 
consumption.

138

Sleeping Mode Consumption Notes

RUNNING 1.9mA Core running

CPU HALT 1.5mA WFI instruction

WAKETIMER 900nA GPIOs and Timer Wakeup

NOTIMER 500nA GPIOs only Wakeup

Highest pwr

Lowest pwr

Low Power library combines 
requests coming from the 
application with the radio 

operating mode

BlueNRG-2 flexible low power architecture



Context Save/Restore
• BlueNRG-2 Low Power Library handles autonomously entering 

and exiting to/from the sleep mode. 

• The library saves peripherals configurations and application 
context before entering deep sleep, and restores the context on 
exiting from low power state:

• CPU returns to execute the next instruction after the low power function call

• No need to re-initialize peripheral and radio stack

• RAM retention is guaranteed

139

NO need for the application to worry about 
sleep management and RAM retention!



BlueNRG Current Consumption 
Estimation Tool

• Check on the installation folder in the path 
“BlueNRG_Tile_HandsOn/Software”

140

http://www.st.com/content/st_com/en/products/embedded-software/wireless-connectivity-software/stsw-bnrg001.html

• Or on st.com at this link:



BlueNRG Current Consumption Estimation Tool
141

1. Select the device

2. Select the type of 
event

3. Configure the HW  
operating conditions

6. Read the average current and the 
estimated battery lifetime

4. Configure the 
application use case 
scenario

5. Specify the Battery capacity

• Accurate estimate of average current consumption and battery lifetime



Advertising example 1/3
142

1. Select the device

2. Configure the HW  
operating conditions



Advertising example 2/3 143

1. Select the event type

2. Configure the event  
operating conditions



Advertising example 3/3 144

1. Get average current 
consumption

2. Get expected battery 
lifetime for a CR2032

3. Plot of the active 
phase



Lab 3
LED characteristic 



Enable LED toggling 146

Notification
Packet

‘1’ LED ON
‘0’ LED OFF

1. Tap the image on the 
screen

2. Send BLE notification 
packet

3. Image changes color 
and the RED LED
toggles

Write
Packet

‘1’ LED ON
‘0’ LED OFF



Code flow

1. Modify advertising packet

2. Client enables LED characteristic notifications 

3. Client Writes in Config Char

4. Parse write command from the client and send BLE notification 
on LED status from the server

147



148Sensor Demo reference application

Now we go back again 

to Keil uVision



L3 STEP1: Modify advertising packet
149



ST BlueMS Protocol
150

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

4 Bytes

0x20

0x1E

0x00

0x00



STEVAL-BCN002V1 Block Diagram 151

BlueNRG-2
Bluetooth 5.0 Network and

Application processor

BALF-NRG-02D3
Integrated balun

Integrated 
antenna

LSM6DSO
accelerometer + gyroscope

LIS2MDL
magnetometer

LPS22HH
barometer

MP34DT05-A
microphone

HTS221
Relative Humidity & Temp.

VL53L1
time-of-flight proximity

I2C PDM

I2C

I2C

I2C

I2C

I2C

400 
kHz

1.6 MHz

user button

RGB LED

U
A

R
T

S
W

D
IRQ

IRQ

Matching
Network*

connector

UART_RX line

TES
T

ADC



L3 STEP1: Modify advertising packet
152

Modify the Feature Mask in the advertisement payload

1. In the file sensor.c

2. Go to line 423

3. Modify Feature Mask byte#1 from 0x00 to 0x20



L3 STEP2: Client enables LED 
characteristic notifications 

153



L3 STEP2: Client enables LED 
characteristic notifications 

154

1. In the file gatt_db.c go to the line 686

2. Client writes in the LED Characteristics Client Configurator Descriptor 
(CCCD) and Server enables notifications through the 

xFeatureNotification structure in line 689 by 

xFeatureNotification.LedNotification = true;



L3 STEP3: Client Writes in Config Char
155



L3 STEP3: Client Writes in Config Char 156

1. In the file gatt_db.c go to the line 816
2. Client writes in the Config Char and Server parses the command through the 

function ConfigCommandParsing(att_data, data_length)



L3 STEP4: Parse write command and  
send BLE notification on LED status 

157



158

L3 STEP4: Parse write command and  
send BLE notification on LED status 

1. Line 941:  ConfigCommandParsing

2. Check on the FeatureMask (line 947)

3. If it’s the LED feature mask (line 1125)

4. Check on the command value. If 0x01 (case1)

5. Turn ON LED3

6. Send Notification on the Config char on the 
command received and parsed

7. Send Notification on the LED char with the 
LED status



Build the new code 159

1. Click on the Build button (top left corner) 

or hit F7 on your keyboard

2. In the Build Output window (bottom) wait

for the build to be completed. 

• BLE_SensorDemo.bin created 

• “0 Error(s), 0 Warning(s)” message appear



Disconnect the serial terminal 160

1. Go back to Tera Term

2. Click on the File->Disconnect

Do  NOT close the 
terminal!



1. Go back to the BlueNRG-2 Flasher Utility

161Re-flash the BlueNRG-2



Flash the BlueNRG-2 1/4 162

1. Select the COM port labeled (ST DK)



Flash the BlueNRG-2 2/4 163

1. Click on the Select Image file button

2. And browse the following path



Flash the BlueNRG-2 3/4
164

1. Select BLE_SensorDemo.bin and click Open

2. Click on the Flash button



Flash the BlueNRG-2 4/4 165

1. Flashing starts: green bar proceeding

2. Wait for the pop-up window and click on OK

Do NOT close the Utility!



Clean Buffer in the serial terminal

1. In Tera Term in order to have the terminal clean, go to 

Edit -> Clear buffer

166



Reconnect the serial terminal

1. Select Setup -> Serial port…

2. Serial port should be already configured. 

Just need to click on OK

167

1

2



Sanity Check on serial port

Push SW1 button on the daughterboard -> LED blinking Blue

168



ST BLE Sensor

Version: 4.2.2

Connect using the ST BLE Sensor App 169

Tap

“Connect to a device”

Select your 

STEVAL-BCN002V1
1 2 3

“Kill” 
the BLE Sensor app

Home button and 
then swipe to top



170Enabling LED toggling

Click on “Switch” A new page will appear



Enable LED toggling
171

Notification
Packet

‘1’ LED ON
‘0’ LED OFF

1. Tap the image on the screen

2. Send BLE notification packet

3. Image changes color and RED LED
toggles

Write
Packet

‘1’ LED ON
‘0’ LED OFF



LED fast blinking due to Sleep Mode 172

• Red LED fast toggling shows the entering/exiting to/from Sleep mode

time

Connection Intervals

Deep sleep mode

In Sleep Phase 
LED is OFF

In Active Phase 
LED is ON



Tera Term output 173

• String “LED Notification ON” will appear as the app tab is enabled

• Each time user click on the LED icon in the BLE Sensor app, the 
Write command is sent to the board and the LED toggles 
accordingly (“Enabled: RGB led” = ON, “Disabled: RGB led” = OFF)



Lab 4
Accelerometer embedded events detection



Example - Single Tap 175

Notification
Packet

‘SINGLE TAP’

1. On the board perform a 
Single Tap

2. Send BLE notification 
packet

NOTE: this is just an example 
for SingleTap. Other events will 
be displayed later in the lab!



Code modifications

1. Modify advertising packet

2. Enable Accelerometer events detection feature 

3. Read Event Status and send BLE notification through an update 
on the Accelerometer Event characteristic value

176



177
Sensor Demo reference application

Now we go back
again to Keil uVision



L4 STEP1: Modify advertising packet
178



ST BlueMS Protocol
179

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

4 Bytes

0x20

0x9E

0x04

0x00



STEVAL-BCN002V1 Block Diagram 180

BlueNRG-2
Bluetooth 5.0 Network and

Application processor

BALF-NRG-02D3
Integrated balun

Integrated 
antenna

LSM6DSO
accelerometer + gyroscope

LIS2MDL
magnetometer

LPS22HH
barometer

MP34DT05-A
microphone

HTS221
Relative Humidity & Temp.

VL53L1
time-of-flight proximity

I2C PDM

I2C

I2C

I2C

I2C

I2C

400 
kHz

1.6 MHz

user button

RGB LED

U
A

R
T

S
W

D
IRQ

IRQ

Matching
Network*

connector

UART_RX line

TES
T

ADC



L4 STEP1: Modify advertising packet
181

Modify the Feature Mask in the advertisement payload

1. In the file sensor.c

2. Go to line 424 and 425

3. Modify the Feature Mask byte#2 from 0x1E to 0x9E

4. Modify the Feature Mask byte#3 from 0x00 to 0x04



L4 STEP2: Enable Accel events feature
182



L4 STEP2: Enable Accel events feature 183

Enable multiple accelerometer embedded events detection

1. In the same file sensor.c

2. Go to line 54 to line 58

3. Set the defines from line 54 to line 58 from 0 to 1



LSM6DSO at a glance
184

1. PERFORMANCE AND FEATURE 2. FLEXIBILITY: algorithm @ silicon level

3. NEW STANDARD 4. INNOVATION

• Accuracy: Tango and Daydream compliance

• 0.55mA current consumption is HP combo 

-15% vs. LSM6DSL/M @ same performance

• New ultra low power mode: 
14uA (@100Hz ODR) Axl only

• I3C

• FIFO tag

• MEMS: Axl T-structure for mechanical 
shock robustness

• Compressed FIFO (3x)
• 10 patents protecting LSM6DSO 

innovation

• Pedometer 2.x
WeChat Precision

• FSM build custom 

sensors for XL and 
Gyro

LSM6DSO

2.5x3x0.86 mm



L4 STEP3: Client enables Acc Event 
characteristic notifications 

185



L4 STEP3: Client enables Acc Event 
characteristic notifications 

186

1. In the file gatt_db.c go to the line 717

2. Client writes in the Acc Event Characteristic Client Configurator Descriptor 

(CCCD) and Server enables notifications through the xFeatureNotification
structure in line 728 by xFeatureNotification.AccEventNotification = true



L4 STEP4: Read Event Status and 
send BLE notification 

187



L4 STEP4: Read Event Status and 
send BLE notification 

188

In the file sensor.c

1. line 1179 void MEMSCallback(void)

Callback triggered by IO13

2. line 1181 lsm6dso_all_sources_get

Read accelerometer status registers

3. line 1185 if (all_source.reg.all_int_src.single_tap)

Check vs. single tap event

4. line 1190 AccEvent_Notify

Send BLE notification



Build the new code
189

1. Click on the Build button (top left corner) or hit

F7 on your keyboard

2. In the Build Output window (bottom) wait for 

the build to be completed. 

• BLE_SensorDemo.bin created 

• “0 Error(s), 0 Warning(s)” message appear



Disconnect the serial terminal
190

1. Go back to Tera Term 

2. Click on the File->Disconnect

Do  NOT close the 
terminal!



1. Go back to the BlueNRG-2 Flasher Utility

191Re-flash the BlueNRG-2



Flash the BlueNRG-2 1/4 192

1. Select the COM port labeled (ST DK)



Flash the BlueNRG-2 2/4 193

1. Click on the Select Image file button

2. And browse the following path



Flash the BlueNRG-2 3/4 194

1. Select BLE_SensorDemo.bin and Click OK

2. Click on the Flash button



Flash the BlueNRG-2 4/4 195

1. Flashing starts: green bar proceeding

2. Wait for the pop-up window and click on OK

Do NOT close the Utility!



Clean Buffer in the serial terminal

1. In Tera Term in order to have the terminal clean, go to 

Edit -> Clear buffer

196



Reconnect the serial terminal
1. Click Setup -> Serial port…

2. Serial port should be already configured. 
Just need to click on OK

197

1

2



Sanity Check on serial port

Push SW1 button on the daughterboard -> LED blinking Blue

198



ST BLE Sensor

Version: 4.2.2

Connect using the ST BLE Sensor App 199

Tap

“Connect to a device”

Select your 
STEVAL-BCN002V1

1 2 3
“Kill” 

the BLE Sensor app

Home button and 
then swipe to top



Visualize Single Tap Event in ST BLE Sensor 200

Tap
“Event Enabled”

Select

“Single Tap” 

and hit “Select”
Enabled

“Single Tap”
Select

“Acc Event”



Event Detection 201

Single Tap

Tap gently on the board

1. On the board perform a 
Single Tap

2. Send BLE notification 
packet

Notification
Packet

‘SINGLE TAP’



Tera Term output 202

• “AccEvent Notification ON”: 
enable notifications on the 
Accelerometer Event characteristic

• “Enabled Single Tap Detection”: 
user enables Single Tap event 
detection

• “Event: Single Tap”: the actual 
BLE notification packet is sent 
upon detection of the Single Tap 
event. 

NOTE: if the phone display enters sleep mode, the notifications are not sent



LSM6DSO Embedded Events 203

Other possible 
embedded events

No event Free fall Single tap

Wake up Tilt Pedometer

WakeUp 
example



Visualize Hardware Wakeup Event in BLE Sensor
204

Select
“Acc Event”



Event Detection 205

Wake Up

1. Leave the board still for a few seconds 

2. Shake the board

3. Send BLE notification packet

Notification
Packet

‘WAKE UP’



Tera Term output 206

• “AccEvent Notification ON”: enable 
notifications on the Accelerometer Event 
characteristic

• “Enabled Hardware Wakeup”: user 
enable hardware wakeup event detection

• “Event: Hardware Wakeup”: the actual 
BLE notification packet sent upon 
detection of the Hardware Wakeup event. 

NOTE: if the phone display enters sleep mode, notifications are not sent



LSM6DSO Embedded Events 207

Other possible 
embedded events

No event Free fall Single tap

Wake up Tilt Pedometer

You can go ahead later and test other events…



Lab 5
9-axis Acc+Gyro+Mag Sensor Data Fusion 



Goal 209

• In this example we are going to demonstrate how to:

• Enable the embedded sensor data fusion library 

• Input: raw Acc+Gyro+Mag sensor data

• Output: quaternions

• Scale the quaternions value by a scaling factor proportional to proximity 
detection

• Send scaled data fusion information through BLE notifications packets
to the ST BLE Sensor app client



Sensor Data Fusion 210

Notification
Packet

QUATERNIONS

1. Enable Sensor Fusion 
library

2. Send quaternions 
information through BLE 
notification packet

Sensors used by data fusion: 
Acc+Gyro+Mag and Proximity



Code modifications

1. Modify advertising packet

2. Enable Sensor Data fusion library

3. Enable proximity sensor

4. Send quaternions data – scaled by proximity sensor data -
through BLE notifications packets

211



212
Sensor Demo reference application

Now we go back again 

to Keil uVision



L5 STEP1: Modify advertising packet
213



ST BlueMS Protocol
214

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

4 Bytes

0x22

0xFE

0x05

0x40



STEVAL-BCN002V1 Block Diagram 215

BlueNRG-2
Bluetooth 5.0 Network and

Application processor

BALF-NRG-02D3
Integrated balun

Integrated 
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LIS2MDL
magnetometer

LPS22HH
barometer

MP34DT05-A
microphone

HTS221
Relative Humidity & Temp.

VL53L1
time-of-flight proximity

I2C PDM

I2C

I2C

I2C

I2C

I2C

400 
kHz

1.6 MHz

user button

RGB LED

U
A

R
T

S
W

D
IRQ

IRQ

Matching
Network*

connector

UART_RX line

TES
T

ADC



L5 STEP1: Modify advertising packet
216

Modify the Feature Mask in the advertisement payload

1. In the file sensor.c and go to line 423, 424, 425 and 426

2. Modify line 423 Feature Mask byte#1 from 0x20 to 0x22

3. Modify line 424 Feature Mask byte#2 from 0x9E to 0xFE

4. Modify line 425 Feature Mask byte#3 from 0x04 to 0x05

5. Modify line 426 Feature Mask byte#4 from 0x00 to 0x40



Build the new code 217

1. Click on the Build button (top left corner) 

or hit F7 on your keyboard

2. In the Build Output window (bottom) wait

for the build to be completed. 

• BLE_SensorDemo.bin created 

• “0 Error(s), 0 Warning(s)” message appear



Disconnect the serial terminal 218

1. Go back to Tera Term 

2. Click on the File->Disconnect

Do  NOT close the 
terminal!



1. Go back to the BlueNRG-2 Flasher Utility
219Re-flash the BlueNRG-2



Flash the BlueNRG-2 1/4 220

1. Select the COM port labeled (ST DK)



Flash the BlueNRG-2 2/4 221

1. Click on the Select Image file button

2. And browse the following path



Flash the BlueNRG-2 3/4 222

1. Select BLE_SensorDemo.bin and click on Open

2. Click on the Flash button



Flash the BlueNRG-2 4/4 223

1. Flashing starts: green bar proceeding

2. Wait for the pop-up window and click on OK

Do NOT close the Utility!



Clean Buffer in the serial terminal

1. In Tera Term in order to have the terminal clean, go to 

Edit -> Clear buffer

224



Reconnect the serial terminal

1. Click Setup -> Serial port…

2. Serial port should be already configured. 

Just need to click on OK

225

1

2



Sanity Check on serial port

Push SW1 button on the daughterboard -> LED blinking Blue

226



ST BLE Sensor

Version: 4.2.2

“Kill” the            

BLE Sensor app

Connect using the ST BLE Sensor App 227

Tap
“Connect to a device”

Select YOUR
STEVAL-BCN002V1

1 2 3

Home button and 
then swipe to top



Sensor Data Fusion 228

Swipe left to view the
Mems Sensor Fusion

Click on 
OK 

Sensor Fusion 
enabled

“Mems Sensor 
Fusion” tab

1 2 3



Proximity Sensor 229

Enable Proximity 
Sensor

Far from 
BlueNRG-Tile

1 2

ON

OFF

Move your 
hand far and 

close to the 
BlueNRG-Tile

Near to 
BlueNRG-Tile

Note: ONLY for rendering purposes, the cube is scaled 
proportional to a clipped 30 cm distance



Proximity Sensor - VL53L1X
3rd gen ToF sensor with lens for long distance ranging & ROI selection

Enhanced performances:

• Full FoV ranging : 400cm+ (white target, no IR)

• Programmable FOV: SPAD zone selection – full-screen to  4x4

Cutting-edge module and silicon :

• Fastest miniature ToF product in the market up to 50Hz

• Integrated lens for longer range and better ambient light immunity

• Programmable settings to best fit customer’s application:

• Low power with interrupts for user / object detection

• Long distance ranging

• High accuracy for small movement detection

230

OLGA: 4.9 x 2.5 x 1.56 mm
FoV : 27°

Compatible footprint with VL53L0X 

Product highlights Applications
Presence user detection
• Autonomous mode with interrupts

• Low-power
• Long distance 400cm+

• PC, tablets, IoT, portable handsets, security     

Obstacle detection:
• Robots: Obstacle avoidance

• Vacuum cleaners: Wall following, cliff detection
• Drones: Take-off and landing, Ceiling detection

Accurate objects distance scanning
• Vending machines: control of objects in racks

• Coins dispensers: coins counting
• Smart shelves: Consumer scanning



Full-range Proximity Real-time Data Plot 231

Swipe left to view the
real-time data plot

Select
Proximity

Select the 
time frame

View the 
real-time 
data plot

“Plot Feature”
tab

1 2 3 4



Logging Real-time Data Plot 232

Click on 
top right corner

After some time 
re-click on the 
right-top corner

Select
“Stop logging”

App opens your 
email client

Select
“Start logging”

1
2

3 4

.csv files attached 
to the email



Sensor Data Fusion 233

Sensor Fusion 
enabled

Try static position: no drift, the cube is perfectly still
• In steady static position the acc and mag enable an accurate orientation 

estimate 

• acc vibrations and mag bias and interferences are rejected or 
compensated by the motionFX library

Try highly dynamic motion: perfect tracking
• In high dynamic motion the acc cannot be used, therefore the gyro is used to 

update the orientation

• gyro bias is estimated and compensated at runtime by the 
motionFX library



Sensor Data Fusion
MotionFX library

234

Accelerometer

Magnetometer

Gyroscope

MotionFX

Sensor 
Fusion

Roll, Pitch Yaw

Quaternion

Heading

Gravity Vector

Linear Acceleration



Sensor Data Fusion
MotionFX library

235

Accelerometer

Magnetometer

Gyroscope

MotionFX

Sensor 
Fusion

Roll, Pitch Yaw

Quaternion

Heading

Gravity Vector

Linear Acceleration

• Accelerometer gives roll and pitch angles and the gravity 
vector…but only in static conditions! (or low dynamics)



Sensor Data Fusion
MotionFX library

236

Accelerometer

Magnetometer

Gyroscope

MotionFX

Sensor 
Fusion

Roll, Pitch Yaw

Quaternion

Heading

Gravity Vector

Linear Acceleration

• Magnetometer gives yaw angle and heading
…but only if tilt is compensated: the accelerometer is needed!
…and mag bias (hard-iron) must be compensated!



Sensor Data Fusion
MotionFX library

237

Accelerometer

Magnetometer

Gyroscope

MotionFX

Sensor 
Fusion

Roll, Pitch Yaw

Quaternion

Heading

Gravity Vector

Linear Acceleration

• Gyroscope gives the new orientation based on previous orientation
…but gyro bias offset needs to be compensated for accuracy!



Sensor Data Fusion
MotionFX library

238

Accelerometer

Magnetometer

Gyroscope

MotionFX

Sensor 
Fusion

Roll, Pitch Yaw

Quaternion

Heading

Gravity Vector

Linear Acceleration

Motion FX library provides orientation estimation plus:
• Magnetometer hard-iron offset compensation.
• Accelerometer vibrations rejection.
• Gyroscope bias offset compensation.



Gyroscope 239

LSM6DSO is an inertial module with Acc and Gyro

• Exceptional noise performance for maximum 
accuracy in orientation estimation
• 90 ug/sqrtHz acc noise density
• 3.8 mdps/sqrtHz gyro noise density

• Extremely low-power
• 650 uA peak power at ODR 6.66kS/sec with 

Acc+Gyro in high performance mode!

The gyroscope is the most important sensor in the system
…works in highly dynamic conditions when the Acc cannot be used
…works with magnetic anomalies when the Mag cannot be used



Magnetometer 240

LIS2MDL is digital Mag

• Exceptional noise performance and 
dynamic range for maximum accuracy in 
orientation estimation

• 50 Gauss dynamic range
• 3 mgauss RMS noise

• Embedded offset compensation
• Intrinsic offset is estimated and compensated 

automatically
• Extrinsic offset (hard-iron) must be estimated by 

host and can be compensated internally



Magnetometer
Calibration

241

Move the BlueNRG-Tile with the 

“8 pattern” shown in the figure 

to calibrate the magnetometerTap
Calibration is Completed

when the icon becomes green.



Magnetometer
Calibration

242

Before calibration, 
data not centered

After calibration, 
data centered:
hard-iron offset 
subtracted

Each magnetometer has intrinsic offset: 
this is compensated internally

Higher precision in 
the compensation! 

What if magnetometer is 
NOT calibrated?

Not accurate eCompass 



Magnetometer eCompass
243

Tap
Select

“Compass”

Red arrow is related to 
the current orientation 
of the BlueNRG-Tile

(you can check against the 
phone eCompass)

Rotate the BlueNRG-Tile



Real-time Data Plot 244

Swipe left to view the

real-time data plot

Select the 

time frame
View the real-
time data plot

“Plot Data” 
Feature tab

1 2 3 4

Select the 

sensor data to 
plot



Logging Real-time Data Plot 245

Click on 
top right corner

After some time 
re-click on the 
right-top corner

Select
“stop logging”

App opens your 
email client

Select
“Start logging”

1
2

3 4

.csv files attached 
to the email



246

Do NOT disconnect!
Just stay connected for the next lab…



Lab 6
Cloud data logging on IBM Watson



Cloud Logging 248

Notification
Packets

1. Enable IBM Watson IoT – Cloud Logging

2. Send BLE notification packets on Sensor status

3. Visualize the data

IBM Watson



Code modifications

NO MODIFICATIONS NEEDED! 

249



IBM Watson IoT Quickstart 250

2. Select “IBM Watson 
IoT - Quickstart”

1. Select one or 
multiple features Wait a few secondsClick “Connect”

2. Click “View Data 
on Cloud”

1. select “Cloud 
Logging”



IBM Watson IoT Quickstart 251

Scroll down 
to see your 

selected 
sensor plot.

Quickstart will 

appear

You will see the Plot
of selected feature

Table of available 
features

Scroll down again to 
change sensor data or axes



Lab 7
Bonus Lab – Voice over BLE

Next 
Section



Goal 253

• In this example we are going to demonstrate how to:

• Enable the BlueVoice library for Voice Over BLE streaming 

• Input: raw data from the MEMS microphone 

• Output: ADPCM data streaming @8kHz

• Send ADPCM data through BLE notifications packets to the 
ST BLE Sensor app



BlueVoice library
254

Notification
Packet

ADPCM 
compressed audio

1. Enable BlueVoice library

2. Send voice to the ST BLE Sensor app client 

through BLE notification packet

MEMS 
Microphone



Code modifications

1. Modify advertising packet

2. Enable BlueVoice (voice over BLE) embedded library

through preprocessor symbol

255



256
Sensor Demo reference application

Now we go back again 

to Keil uVision



L7 STEP1: Modify advertising packet
257



ST BlueMS Protocol
258

Len Type
Protocol 
version

Device 
ID

Feature 
Mask

Device MAC Len Type Local Name PwrLen Type

23 22 21 20 19 18 17 16

Acc Gyro Mag Pressure Humidity Temperat Battery 2nd Temp

7 6 5 4 3 2 1 0

SensFus Compass MotionInt Activity Carry Pos MemsGes ProxGes Pedo

15 14 13 12 11 10 9 8

RFU RFU RFU RFU Beamform AccEvent FreeFall SensFusC

31 30 29 28 27 26 25 24

RFU ADPCM Switch DoA ADPC MicLevel Proximity Lux

4 Bytes

0x6A

0xFE

0x05

0x40



STEVAL-BCN002V1 Block Diagram 259

BlueNRG-2
Bluetooth 5.0 Network and

Application processor

BALF-NRG-02D3
Integrated balun

Integrated 
antenna

LSM6DSO
accelerometer + gyroscope

LIS2MDL
magnetometer

LPS22HH
barometer

MP34DT05-A
microphone

HTS221
Relative Humidity & Temp.

VL53L1
time-of-flight proximity

I2C PDM

I2C

I2C

I2C

I2C

I2C

400 
kHz

1.6 MHz

user button

RGB LED

U
A

R
T

S
W

D

IRQ

IRQ

Matching
Network*

connector

UART_RX line

TES
T

ADC



L7 STEP1: Modify advertising packet
260

Modify the Feature Mask in the advertisement payload

1. In the file sensor.c and go to line 423

2. Modify line 423 Feature Mask byte#1 from 0x22 to 0x6A



L7 STEP2: Enable BlueVoice library
261

Add the preprocessor symbol ENABLE_AUDIO to the project

1. Right-click on Release

2. Select “Options for Target ‘Release’…”



L7 STEP2: Enable BlueVoice library
262

In the project options:

1. Go to the tab C/C++ and then in the Preprocessor Symbols 

2. Set the symbol ENABLE_AUDIO=1 and then click on OK



Build the new code 263

As we have modified the 
preprocessor options it’s 
recommended to clean all the 
previously compiled object files

1. Click on Project

2. Select Clean Targets



Build the new code 264

1. Click on the Build button (top left corner) 

or hit F7 on your keyboard

2. In the Build Output window (bottom) wait

for the build to be completed. 

• BLE_SensorDemo.bin created 

• “0 Error(s), 0 Warning(s)” message appear



Disconnect the serial terminal 265

1. Go back to Tera Term 

2. Click on the File->Disconnect

Do  NOT close the 
terminal!



1. Go back to the BlueNRG-2 Flasher Utility

266Re-flash the BlueNRG-2



Flash the BlueNRG-2 1/4 267

1. Select the COM port labeled (ST DK)



Flash the BlueNRG-2 2/4 268

1. Click on the Select Image file button

2. And browse the following path



Flash the BlueNRG-2 3/4 269

1. Select BLE_SensorDemo.bin

2. Click on the Flash button



Flash the BlueNRG-2 4/4 270

1. Flashing starts: green bar proceeding

2. Wait for the pop-up window and click on OK

Do NOT close the Utility!



Clean Buffer in the serial terminal

1. In Tera Term in order to have the terminal clean, go to 

Edit -> Clear buffer

271



Reconnect the serial terminal

1. Click Setup -> Serial port…

2. Serial port should be already configured. 

Just need to click on OK

272

1

2



Sanity Check on serial port

Push SW1 button on the daughterboard -> LED blinking Blue

273



ST BLE Sensor

Version: 4.2.2

Connect using the ST BLE Sensor App 274

Tap

“Connect to a device”

Select your 
STEVAL-BCN002V1

1 2 3
“Kill” 

the BLE Sensor app

Home button and 
then swipe to top



BlueVoice: voice over Bluetooth LE 275

Tap

Select
“BlueVoice”

MEMS 
Microphone

Speak close to 

the BlueNRG-Tile

Do not silence your phone, 
must NOT be vibration only!

(if the mic captures the audio from 
the phone speaker, a very high 

pitch sound can happen!)

Voice will be streamed over BLE
You will hear it from the phone 



Voice over Bluetooth LE 276

Central
(Master)

Peripheral
(Slave)

Service

Characteristic

Characteristic

Descriptor

Client Server

Audio processing 

GAP configuration

GATT configuration
Audio: exported by the Server 

through 2 dedicated 
BLE characteristics

Voice streaming over BLE:

Audio @8kHz
Codec: ADPCM
Bitrate: 32kbps

It’s a Vendor Specific 
Service!



BlueVoice ADPCM - Audio 8kHz 277

Advertise

Connect Request

Notification

Notification

Advertise Advertisement ModeDiscovery Mode

Central Peripheral

Connection created

Peripheral-to-
Central

communication...

No acknowledge required for Notifications:

• OK for Audio streaming
• Minimal Latency
• Optimal Bandwidth

Audio can be 
half-duplex

2 packets/event
20 bytes/packets
100 events/sec

=
32kbps

Connection
Event

10ms t

Audio Data Packet, 20 bytes 

160ms
Connection interval

Connection
Event

…

ADPCM Synch interval

Sync Data Packet, 6 bytes

… ………
Radio 
Idle

Connection
Event

Connection
Event

Connection
Event

Voice Streaming

• Audio Format: PCM 16 bit @ 8 kHz

• ADPCM Compression @ 32 Kbps: 
Low latency and low complexity

• Side Information at low data rate 
enhances error resilience



BlueVoice architecture

PDM to PCM 
conversion

PCM 

8kHz

PDM ADPCM 
Compression

Raw Data
Audio

Acquisition

Audio 
Decompression 

Serial Audio 
Out

USB, I2S, …

Server - TX

Client - RX

ST digital MEMS 
microphone

BlueNRG-2 

HW 

implementation

Smartphone app (ST BLE Sensor app)

Raw Data PCM

278

Bitrate 32 kbps

“Packetization”

“De-Packetization”



Customizing your design



STEVAL-BCN002V1 Block Diagram 280

BlueNRG-2
Bluetooth 5.0 Network and
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I2C

I2C
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IRQ

IRQ

Matching
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connector

UART_RX line
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Enable/Disable Sensors & Libraries
• Dedicated structure “FeaturePresence” for enabling/disabling 

sensors & libraries individually. File sensor.h at line 64

281

• SensorScan() function set each field of the structure to false or 

true. File sensor.c at line 319

Disable the unneeded 
sensor for optimizing the 
power consumption!



BLE timings
• Advertising intervals:

• Dedicated API aci_gap_set_discoverable(Advertising_Type, 

Advertising_Interval_Min,  Advertising_Interval_Max, … )

• In file sensor.c at line 451

• Connection intervals: 

• Dictated by the Central device. Peripheral has no full control on this.

• Notifications frequency

• Dedicated Virtual Timers (mapped on HW physical timers) for different 
functionalities

• Timeouts defined in sensor.h at line 172-174

282



HW modifications
• In this case redesign is of course necessary

• Schematics and Gerbers files: 

• online at www.st.com/bluetile

• BlueNRG-2 pin mapping 

• Check BlueNRG-2 DS at Table 129

283



Quick recap



285

Middleware

BlueVoiceADPCM MotionFX

BlueNRG-2_Peripheral_Driver Board Support Package

Drivers

Application
SensorDemo

Development Board

STEVAL-BCN002V1

HW Components

BlueNRG-2
MP34DT05-A

LPS22HH

VL53L1X LSM6DSO

LIS2MDL HTS221

Library

CMSISBLE stack

DK 3.0.0 SW architecture



STEVAL-BCN002V1 Block Diagram 286

BlueNRG-2
Bluetooth 5.0 Network and

Application processor
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Integrated balun

Integrated 
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magnetometer

LPS22HH
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MP34DT05-A
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I2C
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A

R
T

S
W

D
IRQ

IRQ

Matching
Network*

connector

UART_RX line

TES
T

ADC



Power consumption 287

advertise
170uA

c
o
n
n
e
c
tio

n

advertise
170uA

stand-by
25uA

connected
d
is

-c
o
n
n
e
c
tio

n

mFX+ToF
8mA

battery
0.25mA

BlueVoice
3.6mA

motionFX
1.4mA

Acc event
0.3mA

LED ctrl
0.3mA

State Avg power cons

stand-by 25uA

advertise 250ms 170uA

Battery notification 0.25mA

Environmental / AccEvents / LED control 0.3mA

Motion FX (Inertial) 1.4mA

BlueVoice 3.6mA

Motion FX plus Time Of Flight 8mA

environm.
0.3mA



Battery lifetime: CR2032 288

State Avg Power Cons Battery lifetime

stand-by 25uA 8800 hrs / 367 days

advertise 250ms 170uA 1294 hrs / 54 days

Battery notification 0.25mA 880 hrs / 37 days

Environmental / AccEvents / LED control 0.3mA 733 hrs / 30 days

Motion FX (Inertial) 1.4mA 157 hrs / 6.5 days

BlueVoice 3.6mA 61.1 hrs / 2.5 days

Motion FX plus Time Of Flight 8mA 27.5 hrs



The end: Q&A



Virtual COM driver installation Win7



Open the Windows Control Panel 291

1. From Start Menu select Control Panel

2. Select Device Manager 

2

1



Open the Device Manager 292

1

1. Look for Other devices and right click and then select 

Update Driver Software…



293

1

Look for the VCOM Driver

1. Select Browse my computer for driver software



294

2

1

Look for the VCOM Driver
1. Click on Browse button and go to the folder “C:\BlueNRG_Tile_HandsOn\STEVAL-BCN002V1 

DK 3.0.0\PCDriver\Virtual COM Port Driver”

2. Click on Include subfolder and then on Next



Allow the driver installation 295

2

1

1. Click on Install driver software 
anyway

2. Installation starts



done 296

2

1

1. Installation completed 

2. Device is in the COM Ports list

Done! Now please go back from here!



Virtual COM driver installation Win10



Open the Windows Settings 298

1. From Start Menu select Settings

2. Select Devices

2

1



Open the Device Manager
299

1. Select Device manager

2. Select Other Devices and Unknown device

2

1



Update Driver Software
300

1. Right click and then select Update Driver Software…

2. Select Browse my computer for driver software

2

1



Look for the VCOM Driver 301

2

1

1. Click on Browse button and go to the folder 

“C:\BlueNRG_Tile_HandsOn\STEVAL-BCN002V1 DK 3.0.0\PCDriver\Virtual COM Port Driver”

2. Click on Include subfolder and then on Next



done 302

1. Installation completed. Device 

is in the COM Ports list

1

Done! Now please go back from here!



Keil MDK Free license installation steps



MDK for BlueNRG-2 and STM32F0 
Installation & Activation

• You can refer to the following webpage: 

• http://www2.keil.com/stmicroelectronics-stm32/mdk

• Note: it is mentioned STM32L0 and STM32F0, but the same 
procedure applies to BlueNRG-2 device 

304



Arm Keil MDK License Installation 1/6
305

• Login with an account that has administration rights.

• Right-click the µVision icon and select Run as 
Administrator... from the context menu.



306

1.Open the dialog File — License Management...

Arm Keil MDK License Installation 2/6
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Arm Keil MDK License Installation 3/6

Select the Single-User 
License tab and click the 

button Get LIC via Internet..., 



308

Click the button OK to register 

the product. 

This action opens the License 

Management page on the Keil web 
site.

Arm Keil MDK License Installation 4/6



309

For the latest Product Serial Number 
please check on the Keil website at this URL: 

http://www2.keil.com/stmicroelectronics-stm32/mdk

Then enter the PSN in this webpage along 
with your contact information and click the 

button Submit. 

An e-mail is sent back with the License ID 
Code (LIC) within a few minutes.

Arm Keil MDK License Installation 5/6



310

To activate the Software Product, 

enter the LIC you received by email 

in the field New License ID Code 
(LIC) and click Add LIC.

Then click on Close

Arm Keil MDK License Installation 6/6


