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Agenda 2

• Introduction

• Training Material and installation needs

• Connect to Amazon Workspaces

• Create your Device (“Thing”) on AWS

• Compile “Hello World” demo project

• Connect to AWS IoT & Send Data

• Compile Sensors demo project

• Send sensors data to the AWS IoT

• Store and transform data in AWS

….



ST Has all the Building Blocks for the IoT 3

“Thing” you know how to build.

Plus what “Smart”?

Pieces from different sources and

and no building instructions…

...or 



Supporting the IoT Movement 4

Development Ecosystem

Pre-integrated SW for vertical applicationsConnect

Translate

Sense

Power

Process

Secure

Move

Actuate



STM32L475 Discovery Kit IoT Node
B-L475E-IOT01A

5

SW Libraries for STM32L4 MCU & Sensors 

Low-power long-range communication (SubGHz)

Environmental awareness: humidity, pressure, temp 

Direct Wi-Fi connection to cloud servers

Detection hub: motion, proximity, audio 



Workshop Deliverables

• For the workshop ST will provide

6

Discovery Kit IoT node
https://www.st.com/content/st_com/en/products/evaluation-tools/product-evaluation-tools/mcu-mpu-eval-
tools/stm32-mcu-mpu-eval-tools/stm32-discovery-kits/b-l475e-iot01a.html

USB 2.0 A-Male to Micro B Cable

https://www.st.com/content/st_com/en/products/evaluation-tools/product-evaluation-tools/mcu-mpu-eval-tools/stm32-mcu-mpu-eval-tools/stm32-discovery-kits/b-l475e-iot01a.html


7STM32L4 Discovery Kit IoT Node
• STM32L4 MCU enables your IoT projects with the combination of ultra-

low power and high performance

• STM32L4 Discovery Kit IoT is a compact, yet powerful board to explore 
various connectivity options

• Next Steps

• You can add BLE, NFC and sensors features to the Amazon FreeRTOS project to create 
an application that can connect to the cloud and also has short range connectivity with 
your smartphone

• Post your projects or ideas on the ST Community website to gather feedback and get 
support: https://community.st.com/community/share-your-activities/pages/overview

• Refer to Amazon FreeRTOS user guide for more examples.

https://community.st.com/community/share-your-activities/pages/overview


Lab Deliverables 8

Training Material on AWS S3 Bucket (USB Key Backup)

Navigate to: https://sttt.signin.aws.amazon.com/console with credentials distributed to you

In Find Services search box type “S3”

Under sttechnologytour\1_tools you’ll find
.\MacOS\WorkSpaces.pkg
.\Windows\teraterm-4.102.exe
.\Windows\Amazon+WorkSpaces.msi
.\Windows\7\en.stsw-link009.zip
.\en.stm32cubeprog.zip
.\This presentation

Install WorkSpaces.pkg

Install Amazon+Workspaces.msi
Unzip en.stsw-link009.zip and run dpinst_amd64.exe (W7 Only)

No Client available for Linux (Web Browser)

https://sttt.signin.aws.amazon.com/console


Amazon Web Services
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IoT on AWS 
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If you knew the state of everything and 

could reason on top of that data…

what problems would you solve? 
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Predictive 
maintenance

Wellness &
health solutions

Connected buildings 
& city systems

Maintain 
device fleets

Monitor energy 
efficiency

Safeguard manufacturing 
facilities

What customers are doing with AWS IoT

IoT payment & 
connected commerce  

Remote patient 
monitor
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Nobody just buys IoT technology…

they seek business outcomes



© 2019, Amazon Web Services, Inc. or its Affiliates. All rights reserved.

Revenue growth

IoT data drives business growth

Operational efficiency

IoT data decreases OpEx

Business outcomes with IoT 

New services &
business models

Products that get 
better with time

Better relationship
with customers

Increased 
efficiency

Intelligent 
decision making

Data driven
discipline



© 2019, Amazon Web Services, Inc. or its Affiliates. All rights reserved.

Connect, 
communicate, 

secure

IoT solutions are complex & multidimensional 

Onboard, 

provision, 
manage

Devices & 
sensors

Connectivity & 
infrastructure

Analyze, 

visualize, 
act

Analytics 
& insights

Engage, 
empower,

delight

Applications 
& services

Transform, 
shift culture

Change 
management
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Our concept of IoT 

Things

Sense & Act

Cloud

Storage & Compute

Intelligence

Insights & Logic → Action
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AWS IoT Architecture

Things

Sense & Act

Cloud

Storage & Compute

Intelligence

Insights & Logic → Action

Secure device 
connectivity

and messaging 
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AWS IoT Architecture

Endpoints

Fleet onboarding, 
management and 

SW updates

Fleet 
audit and 
protection

IoT data 
analytics and 
intelligence

Gateway

Things

Sense & Act

Cloud

Storage & Compute

Secure local
triggers, actions, 

and data sync 

Intelligence

Insights & Logic → Action

Secure device 
connectivity

and messaging 
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Secure Device Connectivity and Messaging 

AWS IoT Core

Device

Gateway

Rules

Engine

Message

Broker

Device

Shadow

RegistryIdentity

Service
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How can I 

extend AWS 

cloud capabilities 

to the edge?
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AWS Greengrass extends AWS IoT onto your devices, so that they can act 

locally on the data they generate, while still taking advantage of the cloud.

Extend AWS IoT to the Edge

AWS Greengrass

Edge Cloud

Law of Economics

Law of Physics

Law of the Land
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Extend AWS IoT to the Edge

AWS Greengrass

Data and 
State Sync

Security Over the 
Air Updates

Protocol 
Adapters

Local 
Device Shadows

Local
Actions

Lambda 
Functions

Local
Messages 

and Triggers

Local 
Message Broker

AWS-grade 
security

Easily Update 
Greengrass Core

Machine 
Learning 
Inference

Local Execution 
of ML Models

Local 
Resource 

Access

Lambdas Interact 
With Peripherals

Easy Integrations 
With Local 
Protocols

ʥ
A
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How can I

securely connect 

constrained, 

microcontroller-

based devices?

?
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Will it work on my chip? Does it have the 

functionality I need?
How do I start?Where do I get it?

10101011010

10111010110

10101010101

00101010101

00101001010

10111010101

10011001011

00100101101

?

IoT Operating System for Microcontrollers 

Amazon FreeRTOS

Amazon FreeRTOS, based on the popular FreeRTOS, is a microcontroller 

operating system that makes small, low powered edge devices easy to 

program, deploy, secure, connect, and maintain. 
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EMBEDDED APPS

FreeRTOS
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Amazon FreeRTOS

Will it work on my chip? Does it have the 

functionality I need?
How do I start?Where do I get it?

IoT Operating System for Microcontrollers 

Amazon FreeRTOS, based on the popular FreeRTOS, is a microcontroller 

operating system that makes small, low powered edge devices easy to 

program, deploy, secure, connect, and maintain. 
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Local Connectivity 
Libraries

Cloud Connectivity 
Libraries

Security 
Connectivity

Libraries

OTA Beta &
Code Signing 

Based on FreeRTOS kernel 

AWS Greengrass AWS IoT Core 

IoT Microcontroller OS

Amazon FreeRTOS
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Based on #1 Real-Time 
Operating System for 
Microcontrollers

• 15 years, trusted, and widely 
distributed

• 40+ supported architectures

• Broad ecosystem support

• Free and open source

• Introducing version 10

• MIT Open Source License

• Improved Inter-Process 
Communication (IPC) capabilities 
with stream and message buffers
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Local Connectivity 
Libraries
Connect with AWS Greengrass

• Local communication with edge 
gateways and a Wi-Fi stack, including 
AWS Greengrass discovery support

• Wi-Fi management library 
implements an abstraction layer 
for Wi-Fi features such as setup, 
configuration, provisioning, security, and 
power management

• Continue communicating, collecting 
data, and taking actions without a cloud 
connection

• Support for many network 
topologies and use cases

AWS Greengrass
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Cloud Connectivity 
Libraries

• Connectivity to AWS IoT Core

• MQTT Pub/Sub messaging

• Device Shadow support

• Take advantage of IoT Core 
benefits like IoT Device 
Management, scalable architecture, 
and pay as you go pricing 

• Fastest way to get started on 
IoT microcontrollers

AWS IoT Core
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Security Connectivity  
Libraries 

• Secure sockets using TLS

• Certificate-based authentication

• PKCS#11 interface for key 
management

• Secure by default

• No open network ports

• Only run trusted code

• Clear, modular implementation
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Over-the-Air 
Firmware Updates

• Use AWS IoT Device Management 
to assign updates to groups

• Code sign new firmware images 

• Stream updates to your device 
over MQTT

• Validate signature on device

• APIs to control installation and 
reboot logic

• Simple to manage groups

• Control authorship and ensure 
devices only run trusted code

• Memory efficient updated client



Let’s get started!



52AWS Console Login

• Navigate to: https://sttt.signin.aws.amazon.com/console

• Login with credentials distributed to you

https://sttt.signin.aws.amazon.com/console


53Get the credentials file from S3 bucket

• On your laptop open the browser and login to AWS Console

• Navigate to S3 service (Services -> type S3 -> Select S3)



54Get the credentials file from S3 bucket
• Open sttechnologytour/studentXX folder

• Download studentXX_credentials.txt file



55Set up Amazon Workspaces client

Windows

Desktop 

Client

(W7, W8, W10)

MacOS

Desktop

Client 

(Mac OS X 10.8.1 and above)

Web Client

(Chrome or Firefox v48 or later)

https://clients.amazonworkspaces.com/ https://clients.amazonworkspaces.com/webclient

Use webclient ONLY(!) if you cannot 

use Windows/Mac/Chromebook client

https://clients.amazonworkspaces.com/
https://clients.amazonworkspaces.com/webclient


56Log in to your Workspace
• Run client, click Options -> Manage Registrations, register with WSpdx+P2D4ZD

• Login with credentials you have in your file



57Clone the repository

• Run GitHub Desktop

• Press Skip this step, then Continue, then Finish

• Click Clone a repository from Internet … and provide URL found in 

studentXX_credentials.txt file 

Click Show in Explorer



58Import the project to System Workbench

• Run System Workbench for STM32 

• Accept default location of your Eclipse workspace

• Click File -> Open Projects from File System …



59Provision Thing, and device credentials

• In System Workbench click File -> Open file… and navigate to 

D:\Users\studentXX/Documents\GitHub\sttt-workshop/tools/aws_config_quick_start/configure.json

• Edit it content to match example in studentXX_credentials.txt and save the changes



60Provision Thing, and device credentials

• Run Windows Command Prompt and configure AWS CLI by issuing 

aws configure command (make sure the region is us-west-2 and 

format is json)

• AWS Access and Secret keys are in the studentXX_credentials.txt file



61Provision Thing, and device credentials

• Change directory to 
D:\Users\studentXX\Documents\GitHub\sttt-workshop\tools\aws_config_quick_start

• Run Provisioning script: python SetupAWS.py setup



62Provision Thing, and device credentials

• Start Firefox browser

• In the AWS Console click Services and type iot core

• Select IoT Core service

• Make sure your region is set to Oregon. 



63Provision Thing, and device credentials

• Examine Thing, Certificate and Policy created in the AWS IoT Core

• Click Manage ->Things and type studentXX to search for your thing



64Provision Thing, and device credentials

• Drill down



65Provision Thing, and device credentials

• Run python SetupAWS.py cleanup in Windows Command Prompt

• In AWS Console verify that your Thing, Certificate and Policy are gone

• Run python SetupAWS.py setup in Windows Command Prompt to 

provision your device again



66Edit the MQTT topic you will be publishing

• Return to System Workbench

• In the aws_demos project, navigate to application_code/common_demos/source/aws_hello_world.c

file

• On line 90 change "freertos/demos/echo" to "freertos/demos/echo/studentXX”

• Save the file



67Examine all the changes

• Open GitHub Desktop and see all the changes that were made to the project

There are 2 files you edited

And 5 files generated/modified by 

provisioning script

Inspect them and ask the mentors if 

you do not understand the purpose of 

each change



68Build the project

• Return to System Workbench. Highlight aws_demos project. Press Ctrl+B

• Switch to SW Console tab and check output files



69Transfer firmware binary to your laptop

• In the AWS Workspace open the browser and login to AWS Console

• Navigate to S3 service (Services -> type S3 -> Select S3)



70Transfer firmware binary to your laptop

• Navigate to sttechnologytour bucket -> studentXX prefix

• Click on Upload button. Upload aws_demos.bin file by dragging it from SW to 

S3 upload interface 



71Transfer firmware binary to your laptop

• Login to the AWS Console from your laptop

• Navigate to S3 service -> sttechnologytour bucket -> studentXX prefix

• Click on aws_demos.bin file and download it



72How to Flash the IoT DK

IoT DK

Drag’n’Drop
aws_demos.bin

into

DIS_L4IOT (F: in the example)

This action will flash the board with the 

new FW

Press the Reset Button

to restart program

Reset Button

User Button

USB 2.0 A-Male

to Micro B Cable

Connect to 

STLINK USB Port 

1

2

3



73How to Flash the IoT DK (Opt 2)

IoT DK

Click CONNECT

BROWSE to 
aws_demos.bin

START PROGRAMMING

Press the Reset Button

to restart program

Reset Button

User Button

USB 2.0 A-Male

to Micro B Cable

Connect to 

STLINK USB Port 

1

2

3

4

5

2

3

4



74Local Machine

Serial Terminal

USB 2.0 A-Male

to Micro B Cable

STLINK

USB Port 

MQTT

TLS

IoT DK



75Verify that your firmware functions properly

• Open Console and verify your device can connect to WiFi, AWS MQTT 

broker, and publish/receive messages on freertos/demos/echo/studentXX

topic

• In AWS Console open IoT Core->Test and subscribe to 

freertos/demos/echo/studentXX topic. Observe MQTT messages



76Change Git branch

• Open GitHub desktop and change branch to “sensors-demo”

• In the System Workbench click on aws_demos project and verify that 

branch is changed from master to sensors-demo



77Compile and run

• Build the project in System Workbench
(In some cases you might need to clean your previous build first)

• Transfer file using your S3 bucket/folder to the laptop

• Flash firmware to the board



78Sensor values in the local console

• Open Console and observe sensor values transmitted



79Sensor values received by MQTT broker

• Check MQTT messages in AWS Console -> AWS IoT Core

The topic is freertos/demos/sensors/studentXX



80AWS IoT Topic Rules

• In the AWS Console go to Services -> IoT Core

• Click on Act tab and inspect 2 rules currently provisioned



81Store every MQTT message as a file

• Publish to S3 bucket rule
(check the SQL syntax operation on JSON)



82Store every MQTT Message as a file

• Publish to S3 bucket rule action
(notice the usage of functions to create dynamic S3 key)

https://docs.aws.amazon.com/iot/latest/developerguide/iot-sql-functions.html

https://docs.aws.amazon.com/iot/latest/developerguide/iot-sql-functions.html


83Check the files published to S3

• In the AWS Workspace open the browser and login to AWS Console

• Navigate to S3 service (Services -> type S3 -> Select S3)



84Check the files published to S3

• Navigate to sttechnologytour bucket -> studentXX/sensorsData prefix

• Inspect the files created and open one of the files



85Aggregate messages
• Check Publish2KinesisFirehose rule

• It aggregates messages from all boards, buffer them for 60 seconds in 

Kinesis stream and then publish to S3



86Aggregate messages
• Check Publish2KinesisFirehose rule

• It aggregates messages from all boards, buffer them for 60 seconds in 

Kinesis stream and then publish to S3



Appendix: Software and Other Pre-requisites



System Workbench for STM32
(requires registration to openstm32.org)

http://www.openstm32.org/Downloading+the+System+Workbench+for+STM32+installer

• install_sw4stm32_win_64bits-v2.5.exe

• install_sw4stm32_macos_64bits-v2.5.run

• Warning: To run System Workbench for STM32 on MAC OSX systems, XCode may be required. To download it, please refer to the Apple developer 

website (registration as Apple Developer is required)

• The downloaded installer is an executable binary file. Your web browser might have removed the execution right of the file. Please set the execution 

right to the installer file (chmod 755 install_sw4stm32.run then ./install_sw4stm32.run) OR Launch it with /bin/bash (/bin/bash install_sw4stm32.run)

• If an error message saying the installer “is damaged and can’t be opened. You should move it to the Trash.”, please modify the installation access 

right in the Gatekeeper. On latest version of MAC OSX, go in the terminal:

• On older version of MAC OSX: 

• Go in the “System Preferences” > “Security & Privacy”, then select “Allow downloaded app from :” “Anywhere”. When the installation is done, restore 

the setting value back at “Mac App Store and identified developers”

• install_sw4stm32_linux_64bits-latest.run
• The installer in GUI-mode requires gksudo. On Ubuntu, gksudo is in package gksu, that you can install by sudo apt-get install gksu. If gksudo is not 

installed, the installer can still be launched in command-line.

• The downloaded installer is an executable binary file. Your web browser might have removed the execution right of the file. Please set the execution 

right to the installer file (chmod 755 install_sw4stm32.run then ./install_sw4stm32.run) OR launch it with /bin/bash (/bin/bash install_sw4stm32.run)

88

http://www.openstm32.org/Downloading+the+System+Workbench+for+STM32+installer


Software and Others Pre-requisites 
Windows (Win7, Win8, Win10)

• STM32 ST-Link Utility: STSW-LINK004 (requires registration to 

my.st.com)
• NOTE: Required for Window 7 

• ST-LINK, ST-LINK/V2, ST-LINK/V2-1 USB driver signed for Windows7, 

8, 10: STSW-LINK009 (requires registration to my.st.com) 
• NOTE: Required for Window 7

• Serial line monitor: Tera Term (https://ttssh2.osdn.jp/ ) 

• Install from USB .\Windows\teraterm-4.99.exe

89

https://ttssh2.osdn.jp/


Tera Term Setup 90



Tera Term Setup 91



Software and Others Pre-requisites 
Mac OS: PicoCom

Serial line monitor: PicoCom or Screen

• Launch Spotlight by pressing Cmd + Space. Type terminal and select 

the Terminal app.

• In the Terminal window, enter the commands

• $ brew install picocom

• $ ls –l /dev/tty*usbmodem*

• Example: /dev/tty.usbmodem413

• $ picocom --imap lfcrlf -b 115200 -p 1 -d 8 –c <usb device file>

• Example: $ picocom --imap lfcrlf -b 115200 -p 1 -d 8 –c 
/dev/tty.usbmodem413

92



Software and Others Pre-requisites 
Mac OS: Screen (native app)

Serial line monitor: PicoCom or Screen

• Launch Spotlight by pressing Cmd + Space. Type terminal and select the Terminal app.

• In the Terminal window, enter the command: ls /dev/cu.usb*

• In the list of devices, look for a device that contains cu.usbserial or cu.usbmodem; in 

the example below IoT DK is mapped to /dev/cu.usbmodem1413

• Launch the from the terminal the screen utility by entering the command: 

screen –L /dev/cu.usbmodem1413 115200 –L

93

usb device name

Serial terminal baudrate

• The screen command will open a serial terminal connected to the device. 

Reset the board to see log messages from the device 



Software and Others Pre-requisites
Linux (Ubuntu)

Serial line monitor: Putty or Picocom

• Putty
• $ sudo apt-get update (This command updates the Ubuntu package list 
with latest one)

• $ sudo apt-get install -y putty

• Picocom

• $ sudo apt-get install picocom

• $ ls –l /dev/tty*usbmodem*

• Example: /dev/tty.usbmodem413

• $ picocom --imap lfcrlf -b 115200 -p 1 -d 8 -c <usb device file>

• Example: $ picocom --imap lfcrlf -b 115200 -p 1 -d 8 –c /dev/tty.usbmodem413

94



Ubuntu 
Open and Configure Serial Terminal (Putty) 

• Open a Linux terminal and enter 

command: dmesg

95

• Open Putty

Note down device 

name for Discovery Kit



Releasing Your Creativity 96

www.st.com/stm32 

/STM32

@ST_World

st.com/e2e


