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Developing with Sensors Made Simple
Hands-On

• USB Flash drive with relevant material for the hands-on

• Please copy the content of the USB drive on your laptop

2

Please return it at the 

end of the workshop
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• Introduction

• Products & Ecosystem

• Hands-on Training Session

• Installation Process

• STM32CubeMX libraries installation

• STM32CubeIDE installation

• Tera Term installation

• Hardware Description

• Lab Examples:

• Lab 0 - Read all sensors in polling

mode

• Lab 1 - LIS2DW12 accelerometer 

orientation change detection

• Lab 2 - LPS22HH barometer read from 
internal FIFO

• Lab 3 - LSM6DSO accelerometer 
embedded step counter

• Lab 4 - LIS2DW12 accelerometer 

acceleration detection

• Lab 5 - LSM6DSO accelerometer 

single/double tap detection

• Lab 6 - LSM6DSO accelerometer 6.6 
kHz data rate read at 100 Hz

Agenda
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Personal ElectronicsIndustrialAutomotive
Communications 

Equipment, 
Computers & Peripherals

ST Addresses Four End Markets



ST: Products & Ecosystem 5

Development Ecosystem

Pre-integrated SW for vertical applicationsConnect

Translate

Sense

Power

Process

Secure

Move

Actuate

ProfiMEMS



>150 Partners… and Counting 6



Sensors Trends 
Growth enablers of the Semiconductor Market

7

Digital Age

• Data Storage

• PCs

Internet Age

• Internet search

• Online video

• Gaming

Mobile Age

• Smartphones

• Mobile networks

• Social media

Cloud / IoT Age

• Cloud services

• IoT services

Automation Age

• Smart Industry

• Smart Driving

First MEMS Wave

Next MEMS Wave

Value

1990 2000 2010 2020

Global Semiconductor Market



Sensors Evolution 8

Technologies

Manufacturing

Embedded

Smart Functions

Low Power

Always ON

Multi Sensors

Integration

Accuracy

Stability



A Broad Sensor Portfolio 9

%

Motion OpticalInteractivityEnvironment Micro-Actuators



Designing with Sensors

Complicated

10

Simple

NUCLEO + X-NUCLEO

STM32CubeIDE + STM32CUBEMX + X-CUBE-MEMS1

HW

SW



STM32CubeMX libraries installation



STM32CubeMX libraries installation 12

1. Run the STM32Cube Libraries.exe self-extracting archive located in
X-CUBE-MEMS1_HandsOn\Software

1

STM32Cube Libraries self extracting 

container includes STM32CubeL4 and 

X-CUBE-MEMS1 library



STM32CubeMX libraries installation 13

1. Library extraction may take few minutes.
Please wait the library to be fully extracted before proceed any further.

Meantime we’ll proceed to
install and configure STM32CubeIDE



STM32CubeIDE installation



STM32CubeIDE installation 15

1. Run the STM32CubeIDE installer located in
X-CUBE-MEMS1_HandsOn\Software

1

required



STM32CubeIDE installation 16

1. Click Next >

1



STM32CubeIDE installation 17

1. Click I Agree

1



STM32CubeIDE installation 18

1. Click Next >

1



STM32CubeIDE installation 19

1. Click Install

1



STM32CubeIDE installation… 20

1. Wait until installation is completed



STM32 Nucleo Expansion



STM32 complete product range 
from ultra-low power to high performance

STM32 Nucleo Development Boards 22

27 development boards and growing… in two flavors (Processing & Security)



DIL 24-pin

X-NUCLEO-IKS01A3
Motion MEMS and environmental sensor expansion board

• The X-NUCLEO-IKS01A3 is a motion MEMS and 
Environmental sensor evaluation board system.

• It is compatible with the Arduino UNO R3 connector 
layout, and is designed around ST’s latest sensors.

23

Arduino UNO R3 connector

ST morpho connector**

** Connector for the STM32 Nucleo Board

STTS751

LPS22HH

LSM6DSO

LIS2DW12

LIS2MDL HTS221

Magnetometer Gyroscope

Temperature

Sensor

Humidity 

sensor
Pressure

Sensor

Accelerometer Inertial 

module



Development Software Architecture 24
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STM32 Nucleo 

Development boards

STM32 Nucleo 

Expansion boards

STM32Cube 

Expansion HAL

Sample applications  | Function Packs     

Mobile app prototyping & cloud prototyping 

STM32Cube 

Hardware Abstraction Layer (HAL)

STM32Cube 

middleware

STM32Cube expansion SW 

High-value middleware



STM32 Supported IDEs 25



STM32CubeIDE
an All-in-1 development tool

26

Configuration

and

Code Generation

Edition

and

Debug

Programming

Monitoring

Complete multi platform family tools

Cover full development cycle

Integrated solution



“STM32CubeIDE”
development environment

“STM32CubeMX”
initialization code generator

“X-CUBE-MEMS1”
application code and drivers for sensors

27Software Development Tools



28STM32CubeIDE
an All-in-1 development tool

Dedicated IDE for all STM32 

microcontrollers

STM32CubeMX is natively integrated 

as code generator

Based on Eclipse (Text editor),

GCC (compiler) and GDB (debugger)



29STM32CubeMX
an All-in-1 development tool

Very powerful configuration and 

code generation

Support all STM32 MCU and MPU, 

with integrated powerful Finder 

Pinouts, clock tree, peripherals and 

middleware configuration.

STM32CubeL1 STM32CubeF1 STM32CubeF2 STM32CubeF4STM32CubeL0 STM32CubeL4

STM32CubeF0

STM32CubeF3

STM32CubeF7 STM32CubeH7STM32CubeG0

Expandable to support wireless 

connectivity, sensors and much 

more!



30X-CUBE-MEMS1
an All-in-1 development tool

Drivers for sensors

Board Support Package firmware 

architecture

Include Sample Applications

Magnetometer Gyroscope Temperature

Sensor

Humidity 

sensor
Pressure

Sensor

Accelerometer Inertial 

module



…STM32CubeIDE installation 31

1. Click Next >

1



STM32CubeIDE installation 32

1. Click Finish

1



STM32CubeIDE configuration 33

1. Open STM32CubeIDE by double clicking the icon on your desktop

2. Wait until STM32CubeIDE is loading

1 2



STM32CubeIDE configuration 34

1. Check Use this as the default and do not ask again

2. Click Launch

1

2



STM32CubeIDE configuration 35

The main interface of STM32CubeIDE will appear differently, depending if it is 
the first time it has been run or not:



Preparing the hardware



Preparing the Hardware 1/3

1. Stack NUCLEO-L476RG and X-NUCLEO-IKS001A3 and connect it to 
the PC

37



Preparing the Hardware 2/3

1. Once the hardware is connected to the PC a new drive named 
“NODE_L476RG” should appear on your File Explorer

38



Preparing the Hardware 3/3

1. Drag and Drop the X-CUBE-MEMS1_HandsOn\Binary\HelloWorld.bin
in the “NODE_L476RG” drive

39



Tera Term installation



Tera Term setup 1/9

1. Lunch the teraterm-4.102.exe installer inside the 
X-CUBE-MEMS1_HandsOn\Software directory

41

1



Tera Term setup 2/9 42

1. Accept the agreement

2. Click on Next

1

2



Tera Term setup 3/9 43

1. Click on Next

1



Tera Term setup 4/9 44

1. Click on Next

1



Tera Term setup 5/9 45

1. Click on Next

1



Tera Term setup 6/9 46

1. Click on Next

1



Tera Term setup 7/9 47

1. Click on Next

1



Tera Term setup 8/9 48

1. Click on Install

1



Tera Term setup 9/9 49

1. Select Launch Tera Term

2. Click on Finish

2

1



Tera Term configuration



Tera Term configuration 1/6 51

Plug the board to the PC using the mini USB cable provided

1. Select the STMicroelectronics STLink Virtual COM Port

2. Click OK

1

2

If ST-LINK Virtual COM port is not
detected please go to
troubleshooting solution #2



Tera Term configuration 2/6 52

1. Click Setup -> Serial port…

1



Tera Term configuration 3/6 53

1. Set the following:
Baud Rate: 115200

Data: 8 bit
Parity: none

Stop: 1 bit

Flow control: none

2. Click OK

1 2



Tera Term configuration 4/6 54

1. Check if on the Tera Term is printed “Hello world” every second

1



Tera Term configuration 5/6 55

1. Click Setup -> Save setup…

1



Tera Term configuration 6/6 56

1. Click Save

1



Hardware



In your hands 58

X-NUCLEO-IKS01A3NUCLEO-L476RG MINI USB CABLE

Motion MEMS and environmental 
sensor evaluation board system

Development board with 
STM32L476RG MCU, supports 

Arduino and ST morpho connectivity

Enable USB communication
to the laptop



NUCLEO-L476RG header pinout 59

In our labs we are going to use:

1. PB_8 and PB_9 for I2C interface

2. PB_0, PC_1 and PB_5 for interrupts

3. PC_13 for user button

4. PA_5 for the LED

2

2

1

3

4



X-NUCLEO-IKS01A3 header pinout 60

1

2

2

In our labs we are going to use:

1. PB_8 and PB_9 for I2C interface

2. PB_0, PC_1 and PB_5 for interrupts

3. PC_13 for user button

4. PA_5 for the LED



Hardware and Software check 61

• At this point you should all have:

1. Installed STM32Cube libraries

2. Installed STM32CubeIDE

3. Stacked the Nucleo-L476 with X-Nucleo-IKS01A3 and plug it to the PC

4. Installed and configured Tera Term

1

2

4
3



LAB0

Goals:
• Configure a new project using X-CUBE-

MEMS1
• Configure all sensors and read data in polling 

mode
• Visualizing sensor data on Tera Term



Leading Sensors for IoT 63

ULTRA LOW

POWER

ACCELEROMET

ER

IoT,  wearable, 
anti-tampering, 

security

MAGNETOMETER

COMPASS

Accuracy, 
Temperature 

Stability

HIGH ACCURACY

PRESSURE

SENSOR

Compact, low 
power, water 

resistant

LPS22HH LIS2MDLLIS2DW12 

• Flexibility Power 

Consumption vs. 

Noise

• Ecosystem (SW, 

libraries, ref design, 

Nucleo boards …)

• LPS22HH: high 

accuracy,

• Low Power 

Consumption 

• Skip One Point Cal. 

post Soldering 

• Power Consumption

• Thermal Stability & 

Precision
• The LIS2MDL has a 

magnetic field 
dynamic range of ±50 
gauss.

ACCELEROMETER

& GYROSCOPE

6-AXIS IMU

Wearables, 
Smartphones, IoT, 

AR/VR

LSM6DSO

• Best in class for 

Power/Noise 

• Embedded Digital 

Features including: 

New Pedo, FSM

• High speed I3C 

interface

• Real dual core

LOCAL

TEMPERATURE

SENSOR

Low Voltage,
Low Power

STTS751

• Ultra low power with 

one shot mode for 

superior power 

savings 

• SMBus 2.0 

compliant supporting 

ALERT command

• Very small package

HUMIDITY AND

TEMPERATURE

COMBO

Compact
Low Power

HTS221

• Direct H and T data 

readout

• Low current 

consumption (3.5uA)

• Industrial 

temperature 

operating range



Lab0 64

1. Click on File > New > STM32 Project

1



Lab0 65

1. Check Remember my decision*

2. Click on No

1
2

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



Lab0 66

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab0 67

1. Project Name Lab0

2. Click Finish
1

2



Lab0 68

1. Click Yes to init peripherals in default mode

1



Lab0 69

1. Check Remember my decision

2. Click Yes

1 2



Lab0 70

1. Check Remember my decision

2. Click No *

1 2

* We are using all the tools
in offline mode, so that internet 

connection is not strictly needed



Lab0 – Configure the I2C bus 71

1. Left Click on PB9 pin

2. Select I2C1_SDA

1

2



Lab0 – Configure the I2C bus 72

1. Left Click on PB8 pin

2. Select I2C1_SCL

1

2



Lab0 – Configure the I2C bus 73

1. At this point I2C1 pins PB9 and PB8 should appear in yellow (selected but 
not configured)

1



Lab0 – Configure the I2C bus 74

1

2

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green

3



Lab0 – Select the MEMS library 75

1

1. Click on 
Additional Software



Additional Software Intro 76

X-CUBE-MEMS1/… will be
the Pack/Bundle we are
going to use in this hands-on

Pack Version to be
selected is 6.1.0
(mandatory)

Enlarge the column 
Selection to see the 
option available



Additional Software Intro 77

There are two way to use the X-CUBE-MEMS1 Pack/Bundle:

X-NUCLEO board Custom board

Pack/Bundle 

class required

Device Device (Application)

Board Extension
Board Support (STM32Cube BSP Drivers)

Board Component (MEMS)



Additional Software Intro 78

Lab0 to Lab5 will be based on X-NUCLEO board, Lab6 on a Custom board

X-NUCLEO board Custom board

Pack/Bundle 
class required

Device Device (Application)

Board Extension
Board Support (STM32Cube BSP Drivers)

Board Component (MEMS)

Lab0 - Lab 5 Lab6



Lab0 – Select the MEMS library 79

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

3

Click to 
expand tree

2



Lab0 – Configure the MEMS library 80

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture (details in

next page)

1

2

3



Lab0 – Configure the MEMS library 81



Lab0 – Save the project 82

1. Click the save button

1



Lab0 – Code Generation 83

1. Check Remember my decision

2. Click Yes

1 2



Lab0 – Code Editing 84

1. Expand Src

2. Double click on main.c

1
2



Lab0 - Compiling 85

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab0 - Debugging 86

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab0 - Debugging 87

1. Click OK

1



• The first time you debug the board by pressing , a Problem Occurred
because ST-LINK needs to be upgraded

88Lab0 - Debugging



89

1

1. Click OK to run upgrade to latest firmware

Lab0 – Updating ST-LINK



90

1. Click Yes when is asked to upgrade the ST-LINK

1

Lab0 – Upgrading ST-LINK



91

1. Click Open in update mode to force ST-LINK 

2. Click on Upgrade

1

2

Lab0 – Upgrading ST-LINK



92

Wait until update is finished and then close the window.

1. Click on X when
finished

1

Lab0 – Upgrading ST-LINK



Lab0 - Debugging 93

1. Click again on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab0 - Debugging 94

1. Click OK

1



Lab0 - Debugging 95

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab0 - Debugging 96

1. Open Tera Term to view the output

1



Lab0 - Debugging 97

1. Click stop         button to interrupt the debugging

1



Lab0 – Closing the project 98

1. Right-Click on Lab0 project

2. Click on Close Project

1

2



LAB1

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LIS2DW12 accelerometer in order to 

generate an interrupt at every orientation change
• Enable interrupts in STM32CubeIDE
• Visualizing the new orientation on Tera Term



LIS2DW12 100

• Down to 0.38 µA power consumption (1.6Hz ODR)

• High Perf. mode: up to 1600Hz with noise density 
90 µg/√Hz

• 5 Power Modes + 2 Noise Modes

• 32-level FIFO buffer

• Digital Features

• Free fall

• Wake-up

• 6D / 4D

• Stationary/Motion detection

• Double Tap

Power saving and flexible Accelerometer

LGA-12L

(2.0 x 2.0 x 0.7 mm)

Accuracy

Enabling battery saving 

High Flexibility

System Power Saving & Smart Functions



Lab1 101

1. Click on File > New > STM32 Project

1



Lab1 102

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab1 103

1. Project Name Lab1

2. Click Finish
1

2



Lab1 104

1. Click Yes to init peripherals in default mode

1



Lab1 – Configure the I2C bus 105

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab1 – Configure the I2C bus 106

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab1 – Configure LIS2DW12 interrupt 107

1. Left Click on PB0 and 
select GPIO_EXTI0

1



Lab1 – Configure LIS2DW12 interrupt 108

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 
EXTI line0 interrupt

3



Lab1 – Select the MEMS library 109

1

1. Click on 
Additional Software



Lab1 – Select the MEMS library 110

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LIS2DW12_6DOrientation

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

2

3

Click to 
expand tree



Lab1 – Configure the MEMS library 111

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab1 – Configure the MEMS library 112



Lab1 – Save the project 113

1. Click the save button

This action will generate 

the source code of this lab

1



Lab1 – Code Editing 114

1. Expand Src in folder Lab1

2. Double click on main.c

1

2



Lab1 - Compiling 115

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab1 - Debugging 116

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab1 - Debugging 117

1. Click OK

1



Lab1 - Debugging 118

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab1 - Testing 119

1. Open Tera Term to view the output

Rotate the board to see 

the output changing

2. After testing close Tera Term

by clicking X

1

2



Lab1 - Debugging 120

1. Click stop         button to interrupt the debugging

1



Lab1 – Closing the project 121

1. Right-Click on Lab1 project

2. Click on Close Project

1

2



LAB2

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LPS22HH pressure and temperature 

sensor to acquire data using internal FIFO
• Enable interrupts in STM32CubeIDE



LPS22HH 123

High-performance, high-ODR Barometer / Altimeter

• Absolute Accuracy: 0.5hPa

• Relative Accuracy: ±0.025hPa

• RMS Noise: ±0.65Pa (0.0065hPa)

• ODR up to 200Hz

• Embedded Temperature compensation

• Unique Full Molded Package

High Performance: excellent noise figure

High Resolution - ~5cm

Robustness

Skip One Point Cal. 
post Soldering
 Cost Saving

HLGA-10L

(2 x 2 x 0.73 mm)

Fast Response

System Power Saving



Lab2 124

1. Click on File > New > STM32 Project

1



Lab2 125

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab2 126

1. Project Name Lab2

2. Click Finish
1

2



Lab2 127

1. Click Yes to init peripherals in default mode

1



Lab2 – Configure the I2C bus 128

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab2 – Configure the I2C bus 129

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab2 – Configure LPS22HH interrupt 130

1. Left Click on PB10 and 
select GPIO_EXTI10

1



Lab2 – Configure LPS22HH interrupt 131

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 

EXTI line[15:10] interrupt

3



Lab2 – Select the MEMS library 132

1

1. Click on 
Additional Software



Lab2 – Select the MEMS library 133

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LPS22HH_FIFOMode

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

2

3

Click to 
expand tree



Lab2 – Configure the MEMS library 134

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab2 – Configure the MEMS library 135



Lab2 – Save the project 136

1. Click the save button

This action will generate 

the source code of this lab

1



Lab2 – Code Editing 137

1. Expand Src in folder Lab2

2. Double click on main.c

1

2



Lab2 - Compiling 138

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab2 - Debugging 139

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab2 - Debugging 140

1. Click OK

1



Lab2 - Debugging 141

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab2 - Testing 142

1. Open Tera Term to view the output

Press User button (blue) on

Nucleo board

2. After testing close Tera Term

by clicking X

1

2



Lab2 - Debugging 143

1. Click stop         button to interrupt the debugging

1



Lab2 – Closing the project 144

1. Right-Click on Lab2 project

2. Click on Close Project

1

2



LAB3

Goals:
• Configure a new project using X-CUBE-

MEMS1
• Configure LSM6DSO accelerometer 

embedded step counter
• Enable interrupts in STM32CubeIDE



LSM6DSO 146

Accelerometer + Gyroscope Inertial Measurement Unit

• 0.45mA power consumption (normal mode)

• Accelerometer: 0.05mA, Gyroscope: 0.40mA

• Auxiliary SPI typically used for OIS / EIS or 
closed loop control; I3C Interface

• 9kB equivalent FIFO Memory for local data 
storage

• Finite State Machines (up to 16)

• Digital Features

• Free fall

• Pedometer 2.0

• 6D / 4D

• Tilt detection

• Tap/ Double Tap LGA-14L

(2.5 x 3 x 0.83 mm)

Design Flexibility and cost optimization

Lowest power consumption IMU  battery saving 

System power saving

Smart Functions with High Flexibility



Lab3 147

1. Click on File > New > STM32 Project

1



Lab3 148

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab3 149

1. Project Name Lab3

2. Click Finish
1

2



Lab3 150

1. Click Yes to init peripherals in default mode

1



Lab3 – Configure the I2C bus 151

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab3 – Configure the I2C bus 152

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab3 – Configure LSM6DSO interrupt 153

1. Left Click on PB5 and 
select GPIO_EXTI5

1



Lab3 – Configure LSM6DSO interrupt 154

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 

EXTI line[9:5] interrupt

3



Lab3 – Select the MEMS library 155

1

1. Click on 
Additional Software



Lab3 – Select the MEMS library 156

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LSM6DSO_Pedometer

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

2

3

Click to 
expand tree



Lab3 – Configure the MEMS library 157

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab3 – Configure the MEMS library 158



Lab3 – Save the project 159

1. Click the save button

This action will generate 

the source code of this lab

1



Lab3 – Code Editing 160

1. Expand Src in folder Lab3

2. Double click on main.c

1

2



Lab3 - Compiling 161

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab3 - Debugging 162

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab3 - Debugging 163

1. Click OK

1



Lab3 - Debugging 164

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab3 - Testing 165

1. Open Tera Term to view the output

Simulate a walk by giving

up/down movement to the

board. Steps will be updated

after about 10 steps

2. After testing close Tera Term

by clicking X

1

2



Lab3 - Debugging 166

1. Click stop         button to interrupt the debugging

1



Lab3 – Closing the project 167

1. Right-Click on Lab3 project

2. Click on Close Project

1

2



LAB4

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LIS2DW12 accelerometer in order to 

generate an interrupt when an acceleration is 
detected

• Enable interrupts in STM32CubeIDE
• Turn the led ON at wake-up



LIS2DW12 169

• Down to 0.38 µA power consumption (1.6Hz ODR)

• High Perf. mode: up to 1600Hz with noise density 
90 µg/√Hz

• 5 Power Modes + 2 Noise Modes

• 32-level FIFO buffer

• Digital Features

• Free fall

• Wake-up

• 6D / 4D

• Stationary/Motion detection

• Double Tap

Power saving and flexible Accelerometer

LGA-12L

(2.0 x 2.0 x 0.7 mm)

Accuracy

Enabling battery saving 

High Flexibility

System Power Saving & Smart Functions



Lab4 170

1. Click on File > New > STM32 Project

1



Lab4 171

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab4 172

1. Project Name Lab4

2. Click Finish
1

2



Lab4 173

1. Click Yes to init peripherals in default mode

1



Lab4 – Configure the I2C bus 174

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab4 – Configure the I2C bus 175

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab4 – Configure LIS2DW12 interrupt 176

1. Left Click on PB0 and 
select GPIO_EXTI0

1



Lab4 – Configure LIS2DW12 interrupt 177

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 
EXTI line0 interrupt

3



Lab4 – Select the MEMS library 178

1

1. Click on 
Additional Software



Lab4 – Select the MEMS library 179

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LIS2DW12_WakeUp

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

2

3

Click to 
expand tree



Lab4 – Configure the MEMS library 180

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab4 – Configure the MEMS library 181



Lab4 – Save the project 182

1. Click the save button

This action will generate 

the source code of this lab

1



Lab4 – Code Editing 183

1. Expand Src in folder Lab4

2. Double click on main.c

1

2



Lab4 - Compiling 184

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab4 - Debugging 185

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab4 - Debugging 186

1. Click OK

1



Lab4 - Debugging 187

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab4 - Testing 188

1. Shake the board and the GREEN led will turn ON

1



Lab4 - Debugging 189

1. Click stop         button to interrupt the debugging

1



Lab4 – Closing the project 190

1. Right-Click on Lab4 project

2. Click on Close Project

1

2



LAB5

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LSM6DSO single and double tap 

detection
• Enable interrupts in STM32CubeIDE
• Change tap threshold to increase sensitivity



LSM6DSO 192

Accelerometer + Gyroscope Inertial Measurement Unit

• 0.45mA power consumption (normal mode)

• Accelerometer: 0.05mA, Gyroscope: 0.40mA

• Auxiliary SPI typically used for OIS / EIS or 
closed loop control; I3C Interface

• 9kB equivalent FIFO Memory for local data 
storage

• Finite State Machines (up to 16)

• Digital Features

• Free fall

• Pedometer 2.0

• 6D / 4D

• Tilt detection

• Tap/ Double Tap LGA-14L

(2.5 x 3 x 0.83 mm)

Design Flexibility and cost optimization

Lowest power consumption IMU  battery saving 

System power saving

Smart Functions with High Flexibility



Lab5 193

1. Click on File > New > STM32 Project

1



Lab5 194

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab5 195

1. Project Name Lab5

2. Click Finish
1

2



Lab5 196

1. Click Yes to init peripherals in default mode

1



Lab5 – Configure the I2C bus 197

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab5 – Configure the I2C bus 198

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab5 – Configure LSM6DSO interrupt 199

1. Left Click on PB5 and 
select GPIO_EXTI5

1



Lab5 – Configure LSM6DSO interrupt 200

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 

EXTI line[9:5] interrupt

3



Lab5 – Select the MEMS library 201

1

1. Click on 
Additional Software



Lab5 – Select the MEMS library 202

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LSM6DSO_SingleDoubleTap

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

2

3

Click to 
expand tree



Lab5 – Configure the MEMS library 203

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab5 – Configure the MEMS library 204



Lab5 – Save the project 205

1. Click the save button

This action will generate 

the source code of this lab

1



Lab5 – Code Editing 206

1. Expand Src in folder Lab5

2. Double click on main.c

1

2



Lab5 - Compiling 207

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab5 - Debugging 208

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab5 - Debugging 209

1. Click OK

1



Lab5 - Debugging 210

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab5 - Testing 211

1

1. TAP or DOUBLE TAP the board and the GREEN led will turn ON



Lab5 - Debugging 212

1. Click stop         button to interrupt the debugging

1



Lab5 – Code editing 213

1. Expand folder Drivers > BSP > Components > lsm6dso

2. Open file lsm6dso.c

3. Go to line #1574

1

2

3



Lab5 – Code editing 214

1. In line #1574, edit the threshold from value 0x08 to value 0x02*

2. Save modification

3. Recompile

4. Launch debug

1

2 3 4

* This modification will reduce the threshold
of the tap detection, increasing sensitivity

of the recognized tap. For further details please
refer to Application Note AN5192 Section 5.5.1



Lab5 - Debugging 215

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab5 - Testing 216

1

1. TAP or DOUBLE TAP the board and the GREEN led will turn ON

You may notice that

the sensitivity of the TAP

recognition has been

increased



Lab5 – Closing the project 217

1. Right-Click on Lab5 project

2. Click on Close Project

1

2



LAB6

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LSM6DSO only for USB data logging
• Change Output Data Rate to log accelerometer 

and gyroscope at higher acquisition speed



Lab6 219

1. Click on File > New > STM32 Project

1



Lab6 220

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab6 221

1. Project Name Lab6

2. Click Finish
1

2



Lab6 222

1. Click Yes to init peripherals in default mode

1



Lab6 – Configure the I2C bus 223

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green

4. Setup Fast Mode in
Parameter Settings

Lab6 – Configure the I2C bus 224

1

2

3

4



Lab6 – Select the MEMS library 225

1

1. Click on 
Additional Software



Lab6 – Select the MEMS library 226

Click to 
expand tree

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Component”:
In AccGyr/LSM6DSO Selection I2C

3. In X-CUBE-MEMS1/MEMS, Class “Board Support”:
Check Custom/MOTION_SENSOR

4. Click OK

1

2

3

4



Lab6 – Configure the MEMS library 227

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Component MEMS

Board Support STM32…

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab6 – Configure the MEMS library 228



Lab6 – Configure the MEMS library 229

1. Configure Parameter Settings as in picture

2. ODR_Accelerometer: 6667Hz

FS_Accelerometer: 16g

ODR_Gyroscope: 6667Hz

FS_Gyroscope: 2000dps

1

2



Lab6 – Configure the MEMS library 230



Lab6 – Save the project 231

1. Click the save button

This action will generate 

the source code of this lab

1



Lab6 – Code Editing 1/2 232

1. Expand Src in folder Lab6

2. Double click on

app_x-cube-mems1.c

3. Go to line #202

4. Change it from

HAL_Delay( 1000 );

to

HAL_Delay( 50 );

1

2

3
4

Note: Sensor ODR is 6667 Hz, meanwhile
output on serial terminal is updated every 

50 ms (20 Hz)



Lab6 – Code Editing 2/2 233

1. Go to line #50 of file app_x-cube-mems1.c

2. Change it from

static uint8_t verbose = 1;

to

static uint8_t verbose = 0;

1

This modification will reduce the serial terminal
output info to only RAW accelerometer and

gyroscope data 2



Lab6 - Compiling 234

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab6 - Debugging 235

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab6 - Debugging 236

1. Click OK

1



Lab6 - Debugging 237

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab6 - Debugging 238

1. Open Tera Term to view the output

1



Lab6 - Debugging 239

1. Click stop         button to interrupt the debugging

1



Lab6 – Closing the project 240

1. Right-Click on Lab6 project

2. Click on Close Project

1

2
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Thank You!



Troubleshooting



Common Issue #1

• Description: when debugging is launched by pressing        , a Problem 
Occurred because ST-LINK need to be updated

243



Common Issue #1: solution 244

1

1. Click OK to run upgrade to latest firmware



Common Issue #1: solution 245

1. Click Yes when is asked to upgrade the ST-LINK

1



Common Issue #1: solution 246

1. Click Open in update mode to force ST-LINK 

2. Click on Upgrade

1

2



Common Issue #1: solution 247

Wait until update is finished and then close the window.

1. Click on X when
finished

1



Common Issue #2

• Description: when debugging is launched by pressing        , a Problem 
Occurred because ST-LINK is not detected even if it is plugged correctly to 
the PC

248



Common Issue #2: solution 249

1

1. Click OK and proceed to install ST-LINK driver



Common Issue #2: solution 250

1. Extract the archive en.stsw-link009.zip located in
C:\X-CUBE-MEMS1_HandsOn\Drivers

2. Run installer for your PC architecture (32bit or 64bit)

1 2



Common Issue #2: solution 251

1. Click Next >

2. Click Finish

21



Common Issue #3

• Description: regenerating the code by saving the project            after modify 
the .ioc file may lead to some missed source file inclusion and compilation 
will fails.

252



Common Issue #3: solution 253

1

1. Right click on the project

2. Click on Close Project

2



Common Issue #3: solution 254

1

1. Double click the project to open it back



Common Issue #3: solution 255

1. Open the .ioc file and modify something in the project in order that is possible 
to save it again

1



Common Issue #3: solution 256

1. Save the project by clicking on
At this point included
files will be restored
correctly 

1



Common Issue #3: solution 257

1. Expand Src folder and open main.c

2. Compile by 
clicking on

1

2

3



Common Issue #3: solution 258

1. Compilation should now terminate without warnings/errors

1


