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Required HW

• Laptop with USB type A

• 64 bit OS Win (7, 10), MacOS, Linux (Generic, Debian, RPM)

• Virtual Machine is also OK (example: Parallel, VM Fusion…)

• Administration rights are required for SW tools installation
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Developing with Sensors Made Simple 
Hands-On

• USB Flash drive with relevant material for the hands-on

• Please copy the content of the USB drive on your laptop
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Please return it at the 

end of the workshop
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• Introduction

• Products & Ecosystem

• Hands-on Training Session

• Installation Process

• STM32CubeMX libraries installation

• STM32CubeIDE installation

• Tera Term installation

• Hardware Description

• Lab Examples:

• Lab 0 - Read all sensors in polling

mode

• Lab 1 - LIS2DW12 accelerometer 

orientation change detection

• Lab 2 - LPS22HH barometer read from 
internal FIFO

• Lab 3 - LSM6DSO accelerometer 
embedded step counter

• Lab 4 - LIS2DW12 accelerometer 

acceleration detection

• Lab 5 - LSM6DSO accelerometer 

single/double tap detection

• Lab 6 - LSM6DSO accelerometer 6.6 
kHz data rate read at 100 Hz

Agenda
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Personal ElectronicsIndustrialAutomotive
Communications 

Equipment, 
Computers & Peripherals

ST Addresses Four End Markets



Sensors Trends 6

Digital Age

• Data Storage

• PCs

Internet Age

• Internet search

• Online video

• Gaming

Mobile Age

• Smartphones

• Mobile networks

• Social media

Cloud / IoT Age

• Cloud services

• IoT services

Automation Age

• Smart Industry

• Smart Driving

First MEMS Wave

Next MEMS Wave

Value

1990 2000 2010 2020

Global Semiconductor Market



Sensors Evolution 7

Technologies

Manufacturing

Embedded

Smart Functions

Low Power

Always ON

Multi Sensors

Integration

Accuracy

Stability



Sensors Evolution 8

17 Billion Units

Shipped

Embedded

FSM and Dec. Tree

-91%

Current Consumption

-70% 

size reduction

+83% 

Temp. Stability



Broad Sensors Portfolio 9

%

Motion OpticalInteractivityEnvironment Micro-Actuators



ST: Products & Ecosystem 10

Development Ecosystem

Pre-integrated SW for vertical applicationsConnect

Translate

Sense

Power

Process

Secure

Move

Actuate

ProfiMEMS

STM32 Nucleo Development

& Expansion boards

Sensor Tile



Developing with Sensors

Complicated

11

Simple

Nucleo + X-Nucleo

STM32CubeIDE + STM32CUBEMX + X-CUBE-MEMS1

HW

SW



STM32CubeMX Libraries Installation



STM32CubeMX Libraries Installation 13

1. Run the STM32Cube Libraries.exe self-extracting archive located in
X-CUBE-MEMS1_HandsOn\Software

1

STM32Cube Libraries self extracting 

container includes STM32CubeL4 and 

X-CUBE-MEMS1 library



STM32CubeMX Libraries Installation 14

1. Library extraction may take few minutes.
Please wait the library to be fully extracted before proceed any further.

Meantime we’ll proceed to
install and configure STM32CubeIDE



STM32CubeIDE Installation



STM32CubeIDE Installation 16

1. Run the STM32CubeIDE installer located in
X-CUBE-MEMS1_HandsOn\Software

1



STM32CubeIDE Installation 17

1. Click Next >

1



STM32CubeIDE Installation 18

1. Click I Agree

1



STM32CubeIDE Installation 19

1. Click Next >

1



STM32CubeIDE Installation 20

1. Click Install

1



STM32CubeIDE Installation… 21

1. Wait until installation is completed



STM32 Nucleo Expansion



STM32 MCU (NUCLEO-L476RG)

Arduino extension connectors : 
easy access to add-ons

Integrated ST-Link/V2-1:
mass storage device flash programming

HW #1: STM32 NUCLEO Board

Integrated ST-Link/V2-1:

mass storage device flash programming

Microcontroller

23

Arduino extension connectors : 

easy access to add-ons

Morpho extension headers : 

direct acces to all MCU I/Os

2 push buttons, 2 color Leds

Flexible board power supply :

through USB or external source
1

2

Integrated ST-Link/V2-1:

mass storage device flash programming



HW #2: X-NUCLEO-IKS01A3 Board
Motion MEMS and environmental sensor

24

Accelerometer:

LIS2DW12

Accel. + Gyro:

LSM6DSO

Pressure:

LPS22HH

Temperature:

STTS751

Humidity:

HTS221

Magnetometer:

LIS2MDL

1

2



Development Software Architecture 25
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STM32 Nucleo 

Development boards

STM32 Nucleo 

Expansion boards

STM32Cube 

Expansion HAL

Sample applications  | Function Packs     

Mobile app prototyping & cloud prototyping 

STM32Cube 

Hardware Abstraction Layer (HAL)

STM32Cube 

middleware

STM32Cube expansion SW 

High-value middleware



STM32 Supported IDEs 26



STM32CubeIDE
an All-in-1 Development Tool

27

Configuration

and

Code Generation

Edition

and

Debug

Programming

Monitoring

Complete multi platform family tools

Cover full development cycle

Integrated solution



“STM32CubeIDE”
development environment

“STM32CubeMX”
initialization code generator

“X-CUBE-MEMS1”
application code and drivers for sensors

28Software Development Tools
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STM32CubeIDE

an All-in-1 Development Tool

Dedicated IDE for all STM32 

microcontrollers

STM32CubeMX is natively integrated 

as code generator

Based on Eclipse (Text editor),

GCC (compiler) and GDB (debugger)
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STM32CubeMX

an All-in-1 Development Tool

Very powerful configuration and 

code generation

Support all STM32 MCU and MPU, 

with integrated powerful Finder 

Pinouts, clock tree, peripherals and 

middleware configuration.

STM32CubeL1 STM32CubeF1 STM32CubeF2 STM32CubeF4STM32CubeL0 STM32CubeL4

STM32CubeF0

STM32CubeF3

STM32CubeF7 STM32CubeH7STM32CubeG0

Expandable to support wireless 

connectivity, sensors and much 

more!
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X-CUBE-MEMS1

an All-in-1 Development Tool

Drivers for sensors

Board Support Package firmware 

architecture

Include Sample Applications

Magnetometer Gyroscope Temperature

Sensor

Humidity 

sensor
Pressure

Sensor

Accelerometer Inertial 

module
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X-CUBE-MEMS1

an All-in-1 Development Tool

Sample Applications

• Data Logging on Terminal 
All Sensors

• 6D Orientation, Wake Up, Self Test

• Self Test

• FIFO Mode

• 6D, FIFO Modes, FreeFall, Pedometer, 

Tap, Tilt, Wake Up, Self Test

• Temperature Limit

Magnetometer

Temperature

Sensor

Pressure

Sensor

Accelerometer

Inertial 

module



…STM32CubeIDE Installation 33

1. Click Next >

1



STM32CubeIDE Installation 34

1. Click Finish

1



STM32CubeIDE Configuration 35

1. Open STM32CubeIDE by double clicking the icon on your desktop

2. Wait until STM32CubeIDE is loading

1 2



STM32CubeIDE Configuration 36

1. Check Use this as the default and do not ask again

2. Click Launch

1

2



STM32CubeIDE Configuration 37

The main interface of STM32CubeIDE will appear differently, depending if it is 
the first time it has been run or not:



Tera Term Installation



Tera Term Setup 1/9

1. Lunch the teraterm-4.102.exe installer inside the 
X-CUBE-MEMS1_HandsOn\Software directory

39

1



Tera Term Setup 2/9 40

1. Accept the agreement

2. Click on Next

1

2



Tera Term Setup 3/9 41

1. Click on Next

1



Tera Term Setup 4/9 42

1. Click on Next

1



Tera Term Setup 5/9 43

1. Click on Next

1



Tera Term Setup 6/9 44

1. Click on Next

1



Tera Term Setup 7/9 45

1. Click on Next

1



Tera Term Setup 8/9 46

1. Click on Install

1



Tera Term Setup 9/9 47

1. Select Launch Tera Term

2. Click on Finish

2

1



Preparing the Hardware



In Your Hands 49

X-NUCLEO-IKS01A3NUCLEO-L476RG MINI USB CABLE

Motion MEMS and environmental 
sensor evaluation board system

Development board with 
STM32L476RG MCU, supports 

Arduino and ST morpho connectivity

Enable USB communication
to the laptop



Preparing the Hardware

1. Stack NUCLEO-L476RG and X-NUCLEO-IKS001A3 and connect it to 
the PC

50



Tera Term Configuration
This can only be done when the board is connected via USB



Tera Term Configuration 1/5 52

Plug the board to the PC using the micro USB cable provided

1. Select the STMicroelectronics Virtual COM Port

2. Click OK

1

2



Tera Term Configuration 2/5 53

1. Click Setup -> Serial port…

1



Tera Term Configuration 3/5 54

1. Set the following:
Baud Rate: 115200

Data: 8 bit
Parity: none

Stop: 1 bit

Flow control: none

2. Click OK

1 2



Tera Term Configuration 4/5 55

1. Click Setup -> Save setup…

1



Tera Term Configuration 5/5 56

1. Click Save

1



Hardware and Software Check 57

• At this point you should all have:

1. Installed STM32Cube libraries

2. Installed STM32CubeIDE

3. Stacked the Nucleo-L476 with X-Nucleo-IKS01A3 and plug it to the PC

4. Installed and configured Tera Term

1

2

4
3



NUCLEO-L476RG Header Pinout 58

In our labs we are going to use:

1. PB_8 and PB_9 for I2C interface

2. PB_0, PC_1 and PB_5 for interrupts

3. PC_13 for user button

4. PA_5 for the LED

2

2

1

3

4



X-NUCLEO-IKS01A3 Header Pinout 59

1

2

2

In our labs we are going to use:

1. PB_8 and PB_9 for I2C interface

2. PB_0, PC_1 and PB_5 for interrupts

3. PC_13 for user button

4. PA_5 for the LED



LAB0

Goals:
• Configure a new project using X-CUBE-

MEMS1
• Configure all sensors and read data in polling 

mode
• Visualizing sensor data on Tera Term



Leading Sensors for IoT 61

ULTRA LOW

POWER

ACCELEROMET

ER

IoT,  wearable, 
anti-tampering, 

security

MAGNETOMETER

COMPASS

Accuracy, 
Temperature 

Stability

HIGH ACCURACY

PRESSURE

SENSOR

Compact, low 
power, water 

resistant

LPS22HH LIS2MDLLIS2DW12 

• Flexibility Power 

Consumption vs. 

Noise

• Ecosystem (SW, 

libraries, ref design, 

Nucleo boards …)

• LPS22HH: high 

accuracy,

• Low Power 

Consumption 

• Skip One Point Cal. 

post Soldering 

• Power Consumption

• Thermal Stability & 

Precision
• The LIS2MDL has a 

magnetic field 
dynamic range of ±50 
gauss.

ACCELEROMETER

& GYROSCOPE

6-AXIS IMU

Wearables, 
Smartphones, IoT, 

AR/VR

LSM6DSO

• Best in class for 

Power/Noise 

• Embedded Digital 

Features including: 

New Pedo, FSM

• High speed I3C 

interface

• Real dual core

LOCAL

TEMPERATURE

SENSOR

Low Voltage,
Low Power

STTS751

• Ultra low power with 

one shot mode for 

superior power 

savings 

• SMBus 2.0 

compliant supporting 

ALERT command

• Very small package

HUMIDITY AND

TEMPERATURE

COMBO

Compact
Low Power

HTS221

• Direct H and T data 

readout

• Low current 

consumption (3.5uA)

• Industrial 

temperature 

operating range



Lab0 62

1. Click on File > New > STM32 Project

1



Lab0 63

1. Check Remember my decision*

2. Click on No

1
2

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



Lab0 64

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab0 65

1. Project Name Lab0

2. Click Finish
1

2



Lab0 66

1. Click Yes to init peripherals in default mode

1



Lab0 67

1. Check Remember my decision

2. Click Yes

1 2



Lab0 68

1. Check Remember my decision

2. Click No *

1 2

* We are using all the tools
in offline mode, so that internet 

connection is not strictly needed



Lab0 – Configure the I2C Bus 69

1. Left Click on PB9 pin

2. Select I2C1_SDA

1

2



Lab0 – Configure the I2C Bus 70

1. Left Click on PB8 pin

2. Select I2C1_SCL

1

2



Lab0 – Configure the I2C Bus 71

1. At this point I2C1 pins PB9 and PB8 should appear in yellow (selected but 
not configured)

1



Lab0 – Configure the I2C Bus 72

1

2

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green

3



Lab0 – Select the MEMS Library 73

1

1. Click on 
Additional Software



Additional Software Intro 74

X-CUBE-MEMS1/… will be
the Pack/Bundle we are
going to use in this hands-on

If multiple X-Cube packs,
use latest version: here
version 6.2.0

If needed, enlarge the column 
Selection to see the options 
available



Additional Software Intro 75

There are two ways to use the X-CUBE-MEMS1 Pack/Bundle:

• If you are using the X-NUCLEO from STMicroelectronics

1. Select the high level Device application. Example: IKS01A3_DataLogTerminal

2. Select the Board Extension that you are using. Example: IKS01A3

• If you are using a custom expansion board

1. Select the high level Device application. Example: DataLogTerminal

2. Select the middle level Board Support Pack (BSP). Example: Custom/MOTION_SENSOR

3. Select the low level Board Components. Example: AccGyr/LSM6DSO on I2C



Additional Software Intro 76

There are two ways to use the X-CUBE-MEMS1 Pack/Bundle:

• If you are using the X-NUCLEO from STMicroelectronics

1. Select the high level Device application. Example: IKS01A3_DataLogTerminal

2. Select the Board Extension that you are using. Example: IKS01A3

• If you are using a custom expansion board

1. Select the high level Device application. Example: DataLogTerminal

2. Select the middle level Board Support Pack (BSP). Example: Custom/MOTION_SENSOR

3. Select the low level Board Components. Example: AccGyr/LSM6DSO on I2C

Lab0 - Lab 5

Lab6



Lab0 – Select the MEMS Library 77

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK

1

3

Click to 
expand tree

2



Lab0 – Configure the MEMS Library 78

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture (details in

next page)

1

2

3



Lab0 – Configure the MEMS Library 79



Lab0 – Save the Project 80

1. Click the save button

1



Lab0 – Code Generation 81

1. Check Remember my decision

2. Click Yes

1 2



Lab0 – Code Editing 82

1. Expand Src

2. Double click on main.c

1
2



Lab0 - Compiling 83

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab0 - Debugging 84

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab0 - Debugging 85

1. Click OK

1



• The first time you debug the board by pressing , a Problem Occurred
because ST-LINK needs to be upgraded

86Lab0 - Debugging



87

1

1. Click OK to run upgrade to latest firmware

Lab0 – Updating ST-LINK
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1. Click Yes when is asked to upgrade the ST-LINK

1

Lab0 – Upgrading ST-LINK
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1. Click Open in update mode to force ST-LINK 

2. Click on Upgrade

1

2

Lab0 – Upgrading ST-LINK



90

Wait until update is finished and then close the window.

1. Click on X when
finished

1

Lab0 – Upgrading ST-LINK



Lab0 - Debugging 91

1. Click again on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab0 - Debugging 92

1. Click OK

1



Lab0 - Debugging 93

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab0 - Debugging 94

1. Open Tera Term to view the output

1



Lab0 - Debugging 95

1. Click stop         button to interrupt the debugging

1



Lab0 – Closing the Project 96

1. Right-Click on Lab0 project

2. Click on Close Project

1

2



LAB1

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LIS2DW12 accelerometer in order to 

generate an interrupt at every orientation change
• Enable interrupts in STM32CubeIDE
• Visualizing the new orientation on Tera Term



LIS2DW12 98

• Down to 0.38 µA power consumption (1.6Hz ODR)

• High Perf. mode: up to 1600Hz with noise density 
90 µg/√Hz

• 5 Power Modes + 2 Noise Modes

• 32-level FIFO buffer

• Digital Features

• Free fall

• Wake-up

• 6D / 4D

• Stationary/Motion detection

• Double Tap

Power saving and flexible Accelerometer

LGA-12L

(2.0 x 2.0 x 0.7 mm)

Accuracy

Enabling battery saving 

High Flexibility

System Power Saving & Smart Functions



Lab1 99

1. Click on File > New > STM32 Project

1



Lab1 100

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab1 101

1. Project Name Lab1

2. Click Finish
1

2



Lab1 102

1. Click Yes to init peripherals in default mode

1



Lab1 – Configure the I2C Bus 103

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab1 – Configure the I2C Bus 104

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab1 – Configure LIS2DW12 Interrupt 105

1. Left Click on PB0 and 
select GPIO_EXTI0

1



Lab1 – Configure LIS2DW12 Interrupt 106

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 
EXTI line0 interrupt

3



Lab1 – Select the MEMS Library 107

1

1. Click on 
Additional Software



Lab1 – Select the MEMS Library 108

1

3

Click to 
expand tree

2

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LIS2DW12_6DOrientation

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK



Lab1 – Configure the MEMS Library 109

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab1 – Configure the MEMS Library 110



Lab1 – Save the Project 111

1. Click the save button

This action will generate 

the source code of this lab

1



Lab1 – Code Editing 112

1. Expand Src in folder Lab1

2. Double click on main.c

1

2



Lab1 - Compiling 113

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab1 - Debugging 114

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab1 - Debugging 115

1. Click OK

1



Lab1 - Debugging 116

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab1 - Testing 117

1. Open Tera Term to view the output

Rotate the board to see 

the output changing

2. After testing close Tera Term

by clicking X

1

2



Lab1 - Debugging 118

1. Click stop         button to interrupt the debugging

1



Lab1 – Closing the Project 119

1. Right-Click on Lab1 project

2. Click on Close Project

1

2



LAB2

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LPS22HH pressure and temperature 

sensor to acquire data using internal FIFO
• Enable interrupts in STM32CubeIDE



LPS22HH 121

High-performance, high-ODR Barometer / Altimeter

• Absolute Accuracy: 0.5hPa

• Relative Accuracy: ±0.025hPa

• RMS Noise: ±0.65Pa (0.0065hPa)

• ODR up to 200Hz

• Embedded Temperature compensation

• Unique Full Molded Package

High Performance: excellent noise figure

High Resolution - ~5cm

Robustness

Skip One Point Cal. 
post Soldering
 Cost Saving

HLGA-10L

(2 x 2 x 0.73 mm)

Fast Response

System Power Saving



Lab2 122

1. Click on File > New > STM32 Project

1



Lab2 123

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab2 124

1. Project Name Lab2

2. Click Finish
1

2



Lab2 125

1. Click Yes to init peripherals in default mode

1



Lab2 – Configure the I2C Bus 126

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab2 – Configure the I2C Bus 127

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab2 – Configure LPS22HH Interrupt 128

1. Left Click on PB10 and 
select GPIO_EXTI10

1



Lab2 – Configure LPS22HH Interrupt 129

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 

EXTI line[15:10] interrupt

3



Lab2 – Select the MEMS Library 130

1

1. Click on 
Additional Software



Lab2 – Select the MEMS Library 131

1

3

Click to 
expand tree

2

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LPS22HH_FIFOMode

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK



Lab2 – Configure the MEMS Library 132

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab2 – Configure the MEMS Library 133



Lab2 – Save the Project 134

1. Click the save button

This action will generate 

the source code of this lab

1



Lab2 – Code Editing 135

1. Expand Src in folder Lab2

2. Double click on main.c

1

2



Lab2 - Compiling 136

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab2 - Debugging 137

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab2 - Debugging 138

1. Click OK

1



Lab2 - Debugging 139

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab2 - Testing 140

1. Open Tera Term to view the output

Press User button (blue) on

Nucleo board

2. After testing close Tera Term

by clicking X

1

2



Lab2 - Debugging 141

1. Click stop         button to interrupt the debugging

1



Lab2 – Closing the Project 142

1. Right-Click on Lab2 project

2. Click on Close Project

1

2



LAB3

Goals:
• Configure a new project using X-CUBE-

MEMS1
• Configure LSM6DSO accelerometer 

embedded step counter
• Enable interrupts in STM32CubeIDE



LSM6DSO 144

Accelerometer + Gyroscope Inertial Measurement Unit

• 0.45mA power consumption (normal mode)

• Accelerometer: 0.05mA, Gyroscope: 0.40mA

• Auxiliary SPI typically used for OIS / EIS or 
closed loop control; I3C Interface

• 9kB equivalent FIFO Memory for local data 
storage

• Finite State Machines (up to 16)

• Digital Features

• Free fall

• Pedometer 2.0

• 6D / 4D

• Tilt detection

• Tap/ Double Tap LGA-14L

(2.5 x 3 x 0.83 mm)

Design Flexibility and cost optimization

Lowest power consumption IMU  battery saving 

System power saving

Smart Functions with High Flexibility



Lab3 145

1. Click on File > New > STM32 Project

1



Lab3 146

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab3 147

1. Project Name Lab3

2. Click Finish
1

2



Lab3 148

1. Click Yes to init peripherals in default mode

1



Lab3 – Configure the I2C Bus 149

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab3 – Configure the I2C Bus 150

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab3 – Configure LSM6DSO Interrupt 151

1. Left Click on PB5 and 
select GPIO_EXTI5

1



Lab3 – Configure LSM6DSO Interrupt 152

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 

EXTI line[9:5] interrupt

3



Lab3 – Select the MEMS Library 153

1

1. Click on 
Additional Software



Lab3 – Select the MEMS Library 154

1

3

Click to 
expand tree

2

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LSM6DSO_Pedometer

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK



Lab3 – Configure the MEMS Library 155

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab3 – Configure the MEMS Library 156



Lab3 – Save the Project 157

1. Click the save button

This action will generate 

the source code of this lab

1



Lab3 – Code Editing 158

1. Expand Src in folder Lab3

2. Double click on main.c

1

2



Lab3 - Compiling 159

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab3 - Debugging 160

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab3 - Debugging 161

1. Click OK

1



Lab3 - Debugging 162

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab3 - Testing 163

1. Open Tera Term to view the output

Simulate a walk by giving

up/down movement to the

board. Steps will be updated

after about 10 steps

2. After testing close Tera Term

by clicking X

1

2



Lab3 - Debugging 164

1. Click stop         button to interrupt the debugging

1



Lab3 – Closing the Project 165

1. Right-Click on Lab3 project

2. Click on Close Project

1

2



LAB4

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LIS2DW12 accelerometer in order to 

generate an interrupt when an acceleration is 
detected

• Enable interrupts in STM32CubeIDE
• Turn the led ON at wake-up



LIS2DW12 167

• Down to 0.38 µA power consumption (1.6Hz ODR)

• High Perf. mode: up to 1600Hz with noise density 
90 µg/√Hz

• 5 Power Modes + 2 Noise Modes

• 32-level FIFO buffer

• Digital Features

• Free fall

• Wake-up

• 6D / 4D

• Stationary/Motion detection

• Double Tap

Power saving and flexible Accelerometer

LGA-12L

(2.0 x 2.0 x 0.7 mm)

Accuracy

Enabling battery saving 

High Flexibility

System Power Saving & Smart Functions



Lab4 168

1. Click on File > New > STM32 Project

1



Lab4 169

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab4 170

1. Project Name Lab4

2. Click Finish
1

2



Lab4 171

1. Click Yes to init peripherals in default mode

1



Lab4 – Configure the I2C Bus 172

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab4 – Configure the I2C Bus 173

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab4 – Configure LIS2DW12 Interrupt 174

1. Left Click on PB0 and 
select GPIO_EXTI0

1



Lab4 – Configure LIS2DW12 Interrupt 175

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 
EXTI line0 interrupt

3



Lab4 – Select the MEMS Library 176

1

1. Click on 
Additional Software



Lab4 – Select the MEMS Library 177

1

3

Click to 
expand tree

2

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LIS2DW12_WakeUp

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK



Lab4 – Configure the MEMS Library 178

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab4 – Configure the MEMS Library 179



Lab4 – Save the Project 180

1. Click the save button

This action will generate 

the source code of this lab

1



Lab4 – Code Editing 181

1. Expand Src in folder Lab4

2. Double click on main.c

1

2



Lab4 - Compiling 182

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab4 - Debugging 183

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab4 - Debugging 184

1. Click OK

1



Lab4 - Debugging 185

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab4 - Testing 186

1. Shake the board and the GREEN led will turn ON

1



Lab4 - Debugging 187

1. Click stop         button to interrupt the debugging

1



Lab4 – Closing the Project 188

1. Right-Click on Lab4 project

2. Click on Close Project

1

2



LAB5

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LSM6DSO single and double tap 

detection
• Enable interrupts in STM32CubeIDE
• Change tap threshold to increase sensitivity



LSM6DSO 190

Accelerometer + Gyroscope Inertial Measurement Unit

• 0.45mA power consumption (normal mode)

• Accelerometer: 0.05mA, Gyroscope: 0.40mA

• Auxiliary SPI typically used for OIS / EIS or 
closed loop control; I3C Interface

• 9kB equivalent FIFO Memory for local data 
storage

• Finite State Machines (up to 16)

• Digital Features

• Free fall

• Pedometer 2.0

• 6D / 4D

• Tilt detection

• Tap/ Double Tap LGA-14L

(2.5 x 3 x 0.83 mm)

Design Flexibility and cost optimization

Lowest power consumption IMU  battery saving 

System power saving

Smart Functions with High Flexibility



Lab5 191

1. Click on File > New > STM32 Project

1



Lab5 192

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab5 193

1. Project Name Lab5

2. Click Finish
1

2



Lab5 194

1. Click Yes to init peripherals in default mode

1



Lab5 – Configure the I2C Bus 195

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



Lab5 – Configure the I2C Bus 196

1

2

3

1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green



Lab5 – Configure LSM6DSO Interrupt 197

1. Left Click on PB5 and 
select GPIO_EXTI5

1



Lab5 – Configure LSM6DSO Interrupt 198

1

2

1. Check NVIC in tab
System Core

2. Select NVIC in NVIC
Mode and Configuration

3. Enable 

EXTI line[9:5] interrupt

3



Lab5 – Select the MEMS Library 199

1

1. Click on 
Additional Software



Lab5 – Select the MEMS Library 200

1

3

Click to 
expand tree

2

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select IKS01A3_LSM6DSO_SingleDoubleTap

2. In X-CUBE-MEMS1/MEMS, Class “Board Extension”:
Check IKS01A3/

3. Click OK



Lab5 – Configure the MEMS Library 201

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Extension MEMS

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab5 – Configure the MEMS Library 202



Lab5 – Save the Project 203

1. Click the save button

This action will generate 

the source code of this lab

1



Lab5 – Code Editing 204

1. Expand Src in folder Lab5

2. Double click on main.c

1

2



Lab5 - Compiling 205

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab5 - Debugging 206

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab5 - Debugging 207

1. Click OK

1



Lab5 - Debugging 208

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab5 - Testing 209

1

1. TAP or DOUBLE TAP the board and the GREEN led will turn ON



Lab5 - Debugging 210

1. Click stop         button to interrupt the debugging

1



Lab5 – Code Editing 211

1. Expand folder Drivers > BSP > Components > lsm6dso

2. Open file lsm6dso.c

3. Go to line #1574

1

2

3



Lab5 – Code Editing 212

1. In line #1574, edit the threshold from value 0x08 to value 0x02*

2. Save modification

3. Recompile

4. Launch debug

1

2 3 4

* This modification will reduce the threshold
of the tap detection, increasing sensitivity

of the recognized tap. For further details please
refer to Application Note AN5192 Section 5.5.1



Lab5 - Debugging 213

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab5 - Testing 214

1

1. TAP or DOUBLE TAP the board and the GREEN led will turn ON

You may notice that

the sensitivity of the TAP

recognition has been

increased



Lab5 – Closing the Project 215

1. Right-Click on Lab5 project

2. Click on Close Project

1

2



LAB6

Goals:
• Configure a new project using X-CUBE-MEMS1
• Configure LSM6DSO only for USB data logging
• Change Output Data Rate to log accelerometer 

and gyroscope at higher acquisition speed



Lab6 217

1. Click on File > New > STM32 Project

1



Lab6 218

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



Lab6 219

1. Project Name Lab6

2. Click Finish
1

2



Lab6 220

1. Click Yes to init peripherals in default mode

1



Lab6 – Configure the I2C Bus 221

1 2

1. Left Click on PB9 and 
select I2C1_SDA

2. Left Click on PB8 and
select I2C1_SCL



1. Expand Connectivity tab and check I2C1

2. Select I2C in I2C1 Mode

and Configuration

3. PB8 and PB9 should
now become green

4. Setup Fast Mode in
Parameter Settings

Lab6 – Configure the I2C Bus 222

1

2

3

4



Lab6 – Select the MEMS Library 223

1

1. Click on 
Additional Software



Lab6 – Select the MEMS Library 224

1

3

Click to 
expand tree

2

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Component”:
In AccGyr/LSM6DSO Selection I2C

3. In X-CUBE-MEMS1/MEMS, Class “Board Support”:
Check Custom/MOTION_SENSOR

4. Click OK

4



Lab6 – Select the MEMS Library 225

Click to 
expand tree

1. In X-CUBE-MEMS1/Application, Class “Device”:
Select DataLogTerminal

2. In X-CUBE-MEMS1/MEMS, Class “Board Component”:
In AccGyr/LSM6DSO Selection I2C

3. In X-CUBE-MEMS1/MEMS, Class “Board Support”:
Check Custom/MOTION_SENSOR

4. Click OK

1

2

3

4



Lab6 – Configure the MEMS Library 226

1. Expand Additional Software and select the X-CUBE-MEMS1

2. Check both:

Board Component MEMS

Board Support STM32…

Device Application

3. Configure Platform Settings

as in picture

1

2

3



Lab6 – Configure the MEMS Library 227



Lab6 – Configure the MEMS Library 228

1. Configure Parameter Settings as in picture

2. ODR_Accelerometer: 6667Hz

FS_Accelerometer: 16g

ODR_Gyroscope: 6667Hz

FS_Gyroscope: 2000dps

1

2



Lab6 – Configure the MEMS Library 229



Lab6 – Save the Project 230

1. Click the save button

This action will generate 

the source code of this lab

1



Lab6 – Code Editing 1/2 231

1. Expand Src in folder Lab6

2. Double click on

app_x-cube-mems1.c

3. Go to line #202

4. Change it from

HAL_Delay( 1000 );

to

HAL_Delay( 50 );

1

2

3
4

Note: Sensor ODR is 6667 Hz, meanwhile
output on serial terminal is updated every 

50 ms (20 Hz)



Lab6 – Code Editing 2/2 232

1. Go to line #50 of file app_x-cube-mems1.c

2. Change it from

static uint8_t verbose = 1;

to

static uint8_t verbose = 0;

1

This modification will reduce the serial terminal
output info to only RAW accelerometer and

gyroscope data 2



Lab6 - Compiling 233

1. Click on the hammer           to begin compilation, or press CTRL+B

2. Compilation should terminate

with 0 errors and 0 warning

1

2



Lab6 - Debugging 234

1. Click on the bug           to begin debugging

2. Select

STM32 MCU C/C++ App

3. Click OK

1

2

3



Lab6 - Debugging 235

1. Click OK

1



Lab6 - Debugging 236

1. Code start at the first line of the main function

2. Click play          button

to run the code

1

2



Lab6 - Debugging 237

1. Open Tera Term to view the output

1



Lab6 - Debugging 238

1. Click stop         button to interrupt the debugging

1



Lab6 – Closing the Project 239

1. Right-Click on Lab6 project

2. Click on Close Project

1

2
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Thank You!



Troubleshooting



Common Issue #1

• Description: when debugging is launched by pressing        , a Problem 
Occurred because ST-LINK need to be updated

242



Common Issue #1: Solution 243

1

1. Click OK to run upgrade to latest firmware



Common Issue #1: Solution 244

1. Click Yes when is asked to upgrade the ST-LINK

1



Common Issue #1: Solution 245

1. Click Open in update mode to force ST-LINK 

2. Click on Upgrade

1

2



Common Issue #1: Solution 246

Wait until update is finished and then close the window.

1. Click on X when
finished

1



Common Issue #2

• Description: when debugging is launched by pressing        , a Problem 
Occurred because ST-LINK is not detected even if it is plugged correctly to 
the PC

247



Common Issue #2: Solution 248

1

1. Click OK and proceed to install ST-LINK driver



Common Issue #2: Solution 249

1. Extract the archive en.stsw-link009.zip located in
C:\X-CUBE-MEMS1_HandsOn\Drivers

2. Run installer for your PC architecture (32bit or 64bit)

1 2



Common Issue #2: Solution 250

1. Click Next >

2. Click Finish

21



Common Issue #3

• Description: regenerating the code by saving the project            after modify 
the .ioc file may lead to some missed source file inclusion and compilation 
will fails.

251



Common Issue #3: Solution 252

1

1. Right click on the project

2. Click on Close Project

2



Common Issue #3: Solution 253

1

1. Double click the project to open it back



Common Issue #3: Solution 254

1. Open the .ioc file and modify something in the project in order that is possible 
to save it again

1



Common Issue #3: Solution 255

1. Save the project by clicking on
At this point included
files will be restored
correctly 

1



Common Issue #3: Solution 256

1. Expand Src folder and open main.c

2. Compile by 
clicking on

1

2

3



Common Issue #3: Solution 257

1. Compilation should now terminate without warnings/errors

1



Backup: How to Download and Install SW 

Tools from the Web

258

A1



Slide 258

A1 Title Length issue:

1- Shorten title or use 2 lines

2- Call the macro: B_TOOL_FixTitle_slide()
Author, 8/27/2019



Required HW & SW

259



Required HW & SW
• Laptop with USB type A

• 64 bit OS Win (7, 10), MacOS, Linux (Generic, Debian, RPM)

• Virtual Machine is also OK (example: Parallel, VM Fusion…)

• Administration rights are required for SW tools installation

• Terminal emulator

• TeraTerm under Windows is OK, download from https://ttssh2.osdn.jp/index.html.en

• Serial COM port settings: 115200 bps, 8N1, no flow control

• SW tools from STMicroelectronics installed

• STM32CubeIDE 1.0.2 integrated development environment, download from www.st.com

You will need to create a my.st.com account.

• X-Cube-MEMS1 6.2.0 software package extension for MEMS sensors, download from 

STM32CubeIDE after installation (see next slides)

260



STM32CubeIDE Installation



STM32CubeIDE Installation 262

1. Go to www.st.com and download the zip package STM32CubeIDE

2. Unzip and run the installer

1

required

2



STM32CubeIDE Installation 263

1. Click Next >

1



STM32CubeIDE Installation 264

1. Click I Agree

1



STM32CubeIDE Installation 265

1. Click Next >

1



STM32CubeIDE Installation 266

1. Click Install

1



STM32CubeIDE Installation… 267

1. Wait until installation is completed



…STM32CubeIDE Installation 268

1. Click Next >

1



STM32CubeIDE Installation 269

1. Click Finish

1



STM32CubeIDE Configuration 270

1. Open STM32CubeIDE by double clicking the icon on your desktop

2. Wait until STM32CubeIDE is loading

1 2



STM32CubeIDE Configuration 271

1. Check Use this as the default and do not ask again

2. Click Launch

1

2



STM32CubeIDE Configuration 272

The main interface of STM32CubeIDE will appear differently, depending if it is 
the first time it has been run or not:



X-Cube-MEMS1 Installation



X-Cube-MEMS1 Installation

X-Cube-MEMS1 can be downloaded from STM32CubeIDE

• X-Cube downloads can be managed only while a project is opened

• We will create a temporary project which will be deleted at the end of the installation, this is 
also an opportunity to test the STM32CubeIDE installation

• Cube downloads may be triggered if updates are available and deemed necessary

• Currently STM32CubeIDE 1.0.2 needs to download STM32Cube_FW_l4_v1140.zip package 

• NOTE: If you are in a VPN and/or behind a proxy that requires authentication, you may 

need to change the network connection setting. You will find details the relevant 

information in the section “Network Setting Configuration”

• It is always possible to configure network connection settings in Window > Preferences then in
General > Network Connections



X-Cube-MEMS1 Installation 275

1. Click on File > New > STM32 Project

1



X-Cube-MEMS1 Installation 276

1. Check Remember my decision*

2. Click No*

1
2

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



X-Cube-MEMS1 Installation 277

If you answer Yes and network settings are wrong, required downloads will not 
be completed. Just click Ok and ignore it. We can fix this later.



X-Cube-MEMS1 Installation 278

1. Click on Board Selector

2. Type NUCLEO-L476RG

3. Click on the board

4. Click Next >

1

2

3

4



X-Cube-MEMS1 Installation 279

1. Project Name Lab0 (any name is OK)

2. Click Finish
1

2



X-Cube-MEMS1 Installation 280

1. Click Yes to init peripherals in default mode

1



X-Cube-MEMS1 Installation 281

1. Check Remember my decision

2. Click Yes to open the
project perspective

1 2



X-Cube-MEMS1 Installation 282

1. Check Remember my decision

2. Click No*

1 2

* It is always possible to reconfigure
internet connection parameter

in Window > Preferences then in
General > Network Connections



STM32CubeIDE Configuration 283

1. Click No* (we will download it later)



STM32CubeIDE Configuration 284

1. Click Ok



STM32CubeIDE Configuration 285

1. Click on Help > Manage embedded software packages



STM32CubeIDE Configuration 286

1. Scroll down to STM32L4, click to expand tree, select latest package 1.14.0



STM32CubeIDE Configuration 287

1. Scroll down to X-CUBE-MEMS1, click to expand, select latest package 6.2.0
(older packages are marked as not compatible with this IDE version)



STM32CubeIDE Configuration 288

1. Click Install Now. If you get an error you must configure the network 
settings (see next slides). 



Network Setting Configuration
NOTE: this section applies only if you are in a VPN and/or behind a proxy that 
requires authentication. Otherwise you can go directly to the following section.



Network Setting Configuration 290

1. Click on Window > Preferences



Network Setting Configuration 291

1. Click on General > Network Connection



Network Setting Configuration 292

1. Change Active Provider to Manual



Network Setting Configuration 293

1. Select the protocol (repeat for each protocol, HTTP, HTTPS and SOCKS)

2. Press Edit

3. Insert proxy IP address and
port number

4. Check “Requires Authentication”
if needed, and insert user name
and password

5. Click OK



STM32CubeIDE Configuration

294



STM32CubeIDE Configuration 295

1. Click on Help > Manage embedded software packages



STM32CubeIDE Configuration 296

1. Scroll down to STM32L4, click to expand tree, select latest package 1.14.0



STM32CubeIDE Configuration 297

1. Scroll down to X-CUBE-MEMS1, click to expand, select latest package 6.2.0
(older packages are marked as not compatible with this IDE version)

2. Click 
Install Now

1

2



STM32CubeIDE Configuration 298

1. Wait for the download and unzip to be completed. Accept terms and 
conditions.



STM32CubeIDE Configuration 299

1. When STM32CUBE-L4 package is updated and X-CUBE-MEMS1 package 
is installed the corresponding checkboxs become green. Close window.



STM32CubeIDE Configuration 300

1. Let’s check the code generator: Project > Generate Code



STM32CubeIDE Configuration 301

1. Let’s have a look at the generated code: expand the Src folder.



STM32CubeIDE Configuration 302

1. Let’s have a look at the generated code: double click on main.c to open it.



STM32CubeIDE Configuration 303

1. Right click on the project name and select Close Project



STM32CubeIDE Configuration 304

1. Right click on the project name and select Delete



STM32CubeIDE Configuration 305

1. Check to delete files on disk and then click Ok



STM32CubeIDE Configuration 306

1. Close the window and confirm Exit



Tera Term Installation



Tera Term Setup 1/9

1. Lunch the teraterm-4.102.exe installer

308



Tera Term Setup 2/9 309

1. Accept the agreement

2. Click on Next

1

2



Tera Term Setup 3/9 310

1. Click on Next

1



Tera Term Setup 4/9 311

1. Click on Next

1



Tera Term Setup 5/9 312

1. Click on Next

1



Tera Term Setup 6/9 313

1. Click on Next

1



Tera Term Setup 7/9 314

1. Click on Next

1



Tera Term Setup 8/9 315

1. Click on Install

1



Tera Term Setup 9/9 316

1. Select Launch Tera Term

2. Click on Finish

2

1



Tera Term Configuration



Tera Term Configuration 1/5 318

Plug the board to the PC using the micro USB cable provided

1. Select the STMicroelectronics Virtual COM Port

2. Click OK

1

2



Tera Term Configuration 2/5 319

1. Click Setup -> Serial port…

1



Tera Term Configuration 3/5 320

1. Set the following:
Baud Rate: 115200

Data: 8 bit
Parity: none

Stop: 1 bit

Flow control: none

2. Click OK

1 2



Tera Term Configuration 4/5 321

1. Click Setup -> Save setup…

1



Tera Term Configuration 5/5 322

1. Click Save

1


