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User manual

STM32CubelDE user guide

Introduction

STM32CubelDE is an all-in-one multi-OS development tool, and is part of the STM32Cube software ecosystem. It contains an
advanced C/C++ development platform supporting software development of STM32-based products.

This document details the STM32CubelDE features and usage, including how to get started, create and build projects, debug
with standard and advanced techniques, and many other software analysis solutions. STM32CubelDE is based on the Eclipse
C/C++ Development Tools™ (CDT™), GCC, and LLVM toolchains, which cannot be entirely described in this user manual.
Additional information on Eclipse® is available from the STM32CubelDE embedded help system. Special documents covering
the details of the toolchain and GDB servers are included within the product.

-
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For further information, contact your local STMicroelectronics sales office.


https://www.st.com/en/product/stm32cubeide?ecmp=tt9470_gl_link_feb2019&rt=um&id=UM2609
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1 Getting started

STM32CubelDE supports STM32 products based on the Arm® Cortex® processor. Refer to STMicroelectronics
documents listed in Section 6: References for details.

Note: Arm is a registered trademark of Arm Limited (or its subsidiaries) in the US and/or elsewhere.

arm

1.1 Product information

STM32CubelDE is an advanced C/C++ development platform with peripheral configuration, code generation,
code compilation, linking, and debugging features. It is based on the Eclipse®/CDT™ framework and GCC and
LLVM toolchains for the development, and GDB for the debugging. It allows the integration of the hundreds of

existing plugins that complete the features of the Eclipse® IDE.
STM32CubelDE includes a build analyzer and a static stack analyzer that provide the user with useful information
about the project status and memory requirements.

STM32CubelDE also includes standard and advanced debugging features including views of CPU core registers,
memories, and peripheral registers, as well as live variable watch, and serial wire viewer interface. A fault
analyzer displays error information if an error is triggered by the STM32 processor during a debug session.

Figure 1. STM32CubelDE key features
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1.1.1 System requirements
STM32CubelDE is tested and verified on the Microsoft® Windows®, Linux®, and macOS® operating systems.
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Important: ~ STM32CubelDE supports only 64-bit OS versions. For more details about supported versions of operating
systems, refer to [ST-02].

Note: Microsoft and Windows are trademarks of the Microsoft group of companies.
Linux® is a registered trademark of Linus Torvalds.
macOS® is a trademark of Apple Inc., registered in the U.S. and other countries and regions.

1.1.2 Downloading the latest STM32CubelDE version
The latest version of STM32CubelDE is available for free download from the www.st.com/stm32softwaretools
website.

1.1.3 Installing STM32CubelDE

The STM32CubelDE installation guide [ST-04] gives directions on how to install on supported versions of
Windows®, Linux® and macOS®. It is possible to have several versions of STM32CubelDE installed in parallel.
Read the installation guide if STM32CubelDE is not already installed or if a new version must be installed.
Installing updates and additional Eclipse® plugins in this manual also provides information on how to install
updates.

114 License

STM32CubelDE is delivered under the Mix Ultimate Liberty+OSS+3rd-party V1 software license agreement
(SLA0048).

For more details about the license agreement of each component, refer to [ST-02].

1.1.5 Support

There are several different support options provided by STMicroelectronics. For instance, the ST Community is
offering places to meet people with similar mind-set all over the world at any time. Choose the support option by
visiting www.st.com/content/st_com/en/support/support-home.html.

1.2 Using STM32CubelDE

1.21 Basic concepts and terminology
The basic concepts using STM32CubelDE and Eclipse® terminology are outlined in this section.

Workspaces

When starting STM32CubelDE, a workspace is selected. The workspace contains the development environment
to be used. Technically, the workspace is a directory that may hold projects. The user may access any project
within the active workspace.

A project contains files, which may be organized into sub-directories. Files existing somewhere else on the
computer can also be linked to the project.
A single computer may hold several workspaces at various locations in the file system. The user may switch

between workspaces, but only one workspace can be active at a time. Switching workspace is a quick way of
switching from one set of projects to another.

In practice, the workspace and project model facilitate a well-structured hierarchy of workspaces, containing
projects, which in turn contain files.

Information center

The first time STM32CubelDE is started and a workspace is selected, the Information Center is opened. The
Information Center provides quick access to start a new project, get access to videos, read STM32CubelDE
documentation, or get access to ST support and community. The Information Center can be easily accessed at
any time via the Information Center toolbar button or from the Help menu.
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Perspectives, menu bar, toolbar

When the Information Center is closed, STM32CubelDE displays a perspective, which contains a menu bar,
toolbar, views and editors. Each perspective is optimized for a special type of work. For instance, the C/C++
perspective is meant for creating, editing and building projects. The Debug perspective is intended to be used
when debugging code on hardware.

Each perspective can be customized according to the user's need. It is possible to reset the perspective at any
time if, for instance, too many views are opened or if the views are reordered. It is also possible to create new
perspectives.

Views and editors

A perspective normally displays many views. Each view is developed to present specific information, which for
instance can be collected from the project or from an embedded system under debug.

A perspective has one editor area. The editor can be used to edit project files. Many files can be edited in different
tabs in the editor.

STM32CubelDE window
Figure 2. STM32CubelDE window
|Name of current workspace| | Project Explorer | |Too|bar | | Console view | |Editor area| |Build Analyzer| | Outline view
mworkspace71.17.0.24 - Static/Src/Static.c - STM32CubelDE — X
File Edit Source Refactor Navigate Search Project Run Window Help
DvERI®BrYa& @< i YA Y YO Y HFOYTRYI®S Y WE T Yy o|lvro e Q iE|[@
& Project Explorer % < — =0 e = O % Outline X © Build Tardets =
s I3 Empty 1o /*x AN
» [ static 2 ™ ok ok ok *xx ™ o myFunction(void) {void
3 * @file 1lib.c
4 * @author  Auto-generated by STM32CubeIDE
5 * @brief Default under dev library file.
6+ *kkk T [T T T kxR
7  * @attention
8 *
9  * Copyright (c) 2024 STMicroelectronics. v
10 * All rights reserved. v
11 *
12 * This software is licensed under terms thgt can be found in the LICENSE file
13 * in the root directory of this software cqmponent.
14 * If no LICENSE file comes with this softwgre, it is provided AS-IS.
15 *
16 * ™ ok ok ok ok k ™
17 */
18
19 /* Includes -=---==-===---mmomm oo oooooooooooooo- */
20
21 /¥¥ FUNCELIONS === === === - s o mm oo oo e e oo */
22=void myFunction(void)
23 {
24 /* Loop forever */
25 for(s;);
26 }
27
21 Problems & Tasks & Console X [ Properties “ B~y =8 GBuild Analyzer X = Static Stack Analyzer @ Cyclomatic Complexity ~ =% £ = 8 -
No consoles to display at this time. <
6}
v Memory Regions|Memory Details §
Region Start add.. End addr.. Size Free Used Usage (%) E
[a]
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1.2.2 Starting STM32CubelDE
Start STM32CubelDE by performing the following steps depending on the operating system used.

Windows®

If a desktop shortcut is created during the installation of the product, the shortcut can be used to start

STM32CubelDE. The product can also be started from the Windows® start menu under STMicroelectronics
programs.

Otherwise:

1. Locate where STM32CubelDE is installed, for instance in c:\sT\STM32CubeIDE 1.0.2
2. Open the STM32CubelDE folder

3. Start the stm32cubeide.exe program

Linux® or macOS®

When using Linux® or macOS®, the program can be started in a similar way by opening the STM32CubelDE
folder where the product is installed.

STM32CubelDE Launcher

When the product is started, it displays the STM32CubelDE Launcher dialog with workspace selection. The first
time the product is started, it presents a default location and workspace name. The dialog enables the user to
select the name and location of the active workspace for holding all the projects currently accessible by the user.
Any newly created project is stored in this workspace. The workspace is created if it does not yet exist.

Note: If Windows® is used, avoid locating the workspace folder too many levels below the file system root to avoid
exceeding the Windows® path length character limitations. Build errors occur if the file paths become longer
than what Windows® can handle.

Figure 3. STM32CubelDE Launcher — Workspace selection

[ sTM32CubelDE Launcher X

Select a directory as workspace

STM32CubelDE uses the workspace directory to store its preferences and development artifacts.

LU oI HMEC:\Users\abc\STM32Cubel DE\workspace_um ~ Browse...

|:| Use this as the default and do not ask again

» Recent Workspaces

Click on the [Launch] button to launch STM32CubelDE. The first time, it opens the Information Center, which is
described in Section 1.3: Information Center.

1.23 Help system

The [Help] menu provides several different help systems as seen in Figure 4. The Information Center contains
links to all available STM32CubelDE documentation. It is also recommended for new users to try different

Eclipse® built-in help systems to get an understanding of Eclipse® basics.
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Figure 4. Help menu
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About STM32CubelDE

1.3 Information Center
The Information Center provides quick access to:
Start a new project
Import an existing project
Get access to videos
Read STM32CubelDE documentation
Get access to Getting Started with STM32CubelDE (STM32CubelDE quick start guide [ST-03])
Explore the STM32 MPU and MCU wikis

Get access to STMicroelectronics support and community on Twitter™, Facebook™, YouTube™, or ST
community at community.st.com

8. Explore the STMicroelectronics application tools

It is not required to read all material before using the product for the first time. Rather, it is recommended to
consider the Information Center as a collection of reference information to return to, whenever required.

Nookwbdh-=

1.3.1 Accessing the Information Center
The Information Center can easily be accessed at any time, from any perspective, using the [Information Center]

toolbar button 0 . This icon is located at the right of the toolbar. It is also possible to open the Information Center
from the [Help]>[Information Center] menu command.
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1.3.2
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Figure 5. Help - Information Center menu
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Home page
When the Information Center is opened, the Home page is displayed. It contains links to start a new project,
import projects, read documentation, and access STMicroelectronics support and community.

Figure 6. Information Center — Home page
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When using an old workspace, the Information Center might not display valid information, showing “This page
can't be displayed” or opening old manuals when accessing documents. In such case, reload the page by clicking

iy

on the [Home] button at the top-right corner of the Information Center window.
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1.3.3 Videos

The Information Center also contains a video browser page (shown in Figure 8), which is opened from the Home
page when clicking on the Access to videos link. A shortcut in the Help menu also provides quick access to the
videos, as shown in Figure 7.

Figure 7. Help — Tutorial video
Help
) Information Center
-o Video tutorials

(7) Help Contents

Figure 8. Information Center — Video browser page

[ workspace_2.00 - STM32CubelDE - u] X
File Edit Source Refactor Mavigate Search Project Run Windew Help
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< >
S$TM32CubeMX

Scroll through the Videos page and click on a video thumbnail in the list to open it in a web browser. The videos
are listed in groups:

. STM32CubelDE Tutorials

. STM32CubeMX

. Discover your STM32 with STM32CubelDE

To navigate back to the Home page, press STM32CubelDE Home at the top left of the Information Center.

The new videos are marked with the keyword “New”. The videos are available from two servers: the YouTube™
server and a dedicated server for China.

<
DT69658V5

1.4 Perspectives, editors, and views

STM32CubelDE is a powerful product with many views, loaded with various features. Displaying all views
simultaneously would overload the user with information that may not be relevant to the task at hand.
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To overcome such a situation, views can be organized in perspectives, where a perspective contains a number of
predefined views and an editor area visible by default. A perspective typically handles one development task,
such as C/C++ Code Editing or Debugging.

1.4.1 Perspectives

The perspectives can be customized according to the user's need; Views can be moved, resized and new views
can be opened. It is possible to reset the perspective at any time if, for instance, too many views are opened or if
the views are reordered. The perspective is reset by right-clicking the perspective icon in the toolbar and selecting
[Reset] from the list. This resets the views; Added views in the perspective are closed and the default views are
moved to their original location.

Figure 9. Reset perspective

ccess| | = |G+ @ @
Customize...
Save As...
Reset

Close

Show Text

As seen in Figure 9, it is also possible to customize a perspective and save the perspective with a new name.

Switching from one perspective to another is a quick way to hide some views and display others. To switch
perspective, select the [Open Perspective] toolbar buttons at the right of the toolbar.

Figure 10. Toolbar buttons for switching perspective

| &0 E

Another way to switch perspective is to use the menu command [Window]>[Perspective]>[Open
Perspective]>[Other...] and select the perspective to use.

1.4.1.1 C/C++ perspective

The C/C++ perspective is intended for creating new projects, editing files, and building the project. The left part of
the perspective contains the Project Explorer view. The editor is located in the middle. The right part contains
some views for the project (Outline and Build Targets views). At the bottom in the example illustrated in Figure 11,
there are the Problems, Tasks, Console and Properties views. At the lowest right, the Build analyzer and Static
stack analyzer views are displayed.
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Figure 11. C/C++ perspective
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> @ mainc 7 * @attention
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Syscols.c 9 = Copyright (c) 2024 STMicroelectronics.
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» @ Debug 12 * This software is licensed under terms that can be found in the LICENSE file
& STM32H533RETX FLASH.Id 13 * in the root directory of this software component.
& STM32HS3IRETX_RAMIG | - If no LICENSE file comes with this software, it is provided As-IS.
16
17 =/

18
19 #include cstdint.h>
2

21 #1f Idefined(__SOFT_FP_) 8& defined(__ARM_FP)
@22 #warning "FPU is not initialized, but the project is compiling for an FPU. Please initialize the FPU before use.”

23 #endif
24
25-int main(void)
26
27 /* Loop forever */
28 for(;);
29 }
30
! Problems @ Tasks @ Console * [ Properties. | o vEl G S8 0Ty =0 g Analyzer X = Static Stack Analyzer @ Cyclomatic Complexity
CDT Build Console [Empty]
arm-none-eabi-size Empty.elf Al ———— ‘
arm-none-eabi-objdump -h -S Empty.elf > “Empty.list" Memory Reglons | RiGmcniDe ks
text data  bss  dec  hex filename Region  Startadd.. End addr.. Size Free Used Usage (%)

856 ® 1568 2424 978 Empty.elf
Finished building: default.size.stdout

Finished building: Empty.list

11:13:26 Build Finished. @ errors, @warnings. (took 25.749ms)
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1.4.1.2 Debug perspective
The Debug perspective is intended for debugging the code. The Debug perspective is normally opened
automatically when a new debug session is started. Later, when the debug session is closed, the perspective is
switched back to the C/C++ perspective.

Figure 12. Debug perspective
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Remote System Explorer perspective

The Remote System Explorer perspective is basically used when developing STM32 Arm® Cortex® MPU-based
systems. The Remote Systems view is used to view files and the Remote Shell view is used to run commands.

Figure 13. Remote System Explorer perspective

[Z workspace_um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
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Lo BSE ¥ 1 /* USER CODE BEGIN Header */ & EER TR e
v EfLocal 20 /** U mainh N
v ¥ Local Files 3 e * * * * * * * * * W malloch
> F My Home 4 . @fl%e ¢ main.c @ huart2 : UART Han
V}:?Drives 5 @brief : Main program body ® ° VERSION_NUMBEF
6 B L T L T T N -
> ZC + @attenti ® © CRC_NUMBER : co
> &DA\ ; | rartention ® ©BUILD_ID : const u
VG;cal Shells 9 * <h2><center>&copy; Copyright (c) 2019 STMicroelectronics. : Distance : uint32 4
Foce] 10 * ALl rights reserved.</center></h2> ® Seconds : uint32.t
1 * £+ SystemClock_Conf
s .
12 * This software component is licensed by ST under BSD 3-Clause license, HSMKGNOJ"'“"‘M
13 * the "License"; You may not use this file except in compliance with the ++7 MX_USART2_UART
14 * License. You may obtain a copy of the License at: ® ip:int
15 * opensource.org/licenses/BSD-3-Clause ® ramx:int
16 * ® mylP_read() : int
a7 st s s sk o sk sk sk ko ok ok ok ko ok ok ok ok ko ok sk ok sk ok sk ko ok ok ok ok ok ok ok ok ok ok ok ok sk ok sk ok ok ok sk sk ok ok ok ok ko ok ok ok ok ok ok Y & o BAM raadN - in T
< > < >
4 Remote System Details | Tasks [& Remote Shell &% L mPEE Y =0
ﬁ’ Local &2 ‘
09/19/2019 06:34 PM 424,456 stm32cubeide.exe ~
. ]09/19/2019 06:43 PM 464 stm32cubeide.ini
09/19/2019 06:34 PM 129,544 stm32cubeidec.exe
[w)09/23/2019 10:33 AM 600,878 uninstall.exe
< > 8 File(s) 1,306,519 bytes
= 1@ Dir(s) 599,160,823,808 bytes free
= Properties 50 (% Remote Scratchpad = S T 4
mAlER R v P C:\ST\STM32CubeIDE_1.1.0.19w38_targetplatform_2019-09\STM32CubeIDE>
Property Value
Name CAST\STM32CubelDE_1.1.0.19w38_... I C:\ST\STM32CubeIDE_1.1.0.19w38_targetplatform_2019-09\STM32CubeIDE> v
Number of children 0 ’ N
Type prompt
Command ol
prompt: C:\ST\STM32CubelDE_1.1.0.19w38_targetplatform_2019-09\STM32CubelDE> 2 Gtatic affline =

The Remote Systems view contains buttons to open a new connection via FTP, Linux®, Local, SSH, Telnet and
others.
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Figure 14. New connection
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1.4.2 Editors
The editor area in a perspective is used by editors. Any number of editors can be opened simultaneously but only
one can be active at a time. Different editors can be associated with different file extensions. Examples of editors
are; c-editor or linker script editor.
To open a file in the editor, double-click on the file in the Project Explorer view or open the file via the [File] menu.
When a file is modified in the editor, it is displayed with an asterisk (*) indicating that the file has unsaved
changes.

1.4.3 Views

Only the most common views associated with the perspective are displayed by default. There are many more
views in the product supporting different features. Some of these views only provide valid data when a debug
session is ongoing, while others always display data.
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Views can be opened from the [Window]>[Show View] menu by selecting one of the views in the list.

Figure 15. [Show View] menu

Eworkspace_um - NUCLEO-F401RE/Core/Src/main.c - STM32CubellC

File Edit Source Refactor Navigate Search Project Run Window

Myl ® v vEaidgvav[§: New Window
& Project Explorer 22 & B =0 Rgp Editor ’
v [E NUCLEO-F401RE Srpo ’
i Build Analyzer Show View b
! Build Targets Perspective >
1 C/C++ Projects o
) Console Alt+Shift+Q, C kit ’
¢ Include Browser Preferences
- Navigator S ®
* Outline Alt+Shift+Q,0 P * <h2><center>8
" Problem Details 2 - Ll e e
. Problems Alt+Shift+Q, X 5 ® This soEvisie
» Project Explorer 3 * the "License"
I Properties 4 * License. You
* Search Alt+Shift+Q, S 5 *
i SFRs | =

7 3 2K 2k 2k ok 3k ok ok ok ok K K ok %k Kk
. Static Stack Analyzer g8 x/
| Tasks © /* USER CODE END

Other... Alt+Shift+Q, Q @

‘ 21l /* Includes -----
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The above list of views in Figure 15 is still not complete. It contains only the most common views for the work task
related to the perspective currently selected. To access even more views, select [Other...] from the list. This
opens the Show View dialog box. Double-click on any view to open it and access its additional features.

Figure 16. Show View dialog

[ZE Show View O X

type filter text

> & C/C++

» = Connections

> & General

> = Debug

» & Device Configuration Tool
> & Help

> = Make

» = Remote Systems
v = SWV
“. SWV Data Trace
L SWV Data Trace Timeline Graph
L SWV Exception Timeline Graph
B SWV Exception Trace Log
B SWV ITM Data Console
£ SWV Statistical Profiling
B SWV Trace Log
» & Team

Open Cancel

The views can be resized and their positions can be changed: Simply drag the view to a new place in
STM32CubelDE. The view can also be dragged outside the STM32CubelDE window on the screen. Such
detached views are shown in separate windows. Detached views works like the other views but are always shown
in front of the workbench. Detached views can be attached again by dragging the tab in the detached view into
the STM32CubelDE window.

To restore the perspective to original state, right-click the perspective icon in the toolbar and select [Reset] from
the list. Another way to reset the perspective is to use the menu [Window]>[Perspective]>[Reset Perspective].

1.4.4 Quick Access edit field

The magnifying glass in the toolbar opens the Quick Access text box, where any search phrase or keyword can
be entered. GUI objects like menu commands, toolbar buttons, preference settings or views can be found using
the text box. As any search string is typed, the Quick Access shows all the GUI objects that match the criteria, in
real time. Type a couple of characters or more and see how the list of results is refined correspondingly on-the-fly.
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The Quick Access is a time saver when looking for a specific GUI object that cannot be found quickly otherwise,
such as a preference setting deeply buried in the configuration dialogs. It is also convenient to retrieve a menu
command or toolbar button hidden in the currently active perspective.

For example, in Figure 17, the search string “SWV” entered in the Quick Access provides immediately the list of
matching views, GUI commands and preference settings. To open the view or preference setting, click on the GUI
object in the search result list.

Figure 17. Quick access

' Q B EEsE
SWV |
Views ‘4 SWV Data Trace (SWV)
L= SWV Data Trace Timeline Graph (SWV)
L= SWV Exception Timeline Graph (SWV)
£ SWV Exception Trace Log (SWV)
E SWV ITM Data Console (SWV)
£ SWV Statistical Profiling (SWV)
£ SWV Trace Log (SWV)
@ Config - Configure SWV
® Show In (SWV Data Trace Timeline Graph)
® Show In (SWV Data Trace)
@ Show In (SWV Exception Timeline Graph)
-
-
-
-
-
®
-
-
-
-
-

i

Commands

Show In (SWV Exception Trace Log)
Show In (SWV ITM Data Console) b
Show In (SWV Statistical Profiling)
Show In (SWV Trace Log)
Show View (SWV Data Trace Timeline Graph) - Shows a particul
Show View (SWV Data Trace) - Shows a particular view
Show View (SWV Exception Timeline Graph) - Shows a particul:
Show View (SWV Exception Trace Log) - Shows a particular viev
Show View (SWV ITM Data Console) - Shows a particular view
Show View (SWV Statistical Profiling) - Shows a particular view
Show View (SWV Trace Log) - Shows a particular view

Help %' Search 'SWV' in Help
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1.5 Configuration - Preferences

STM32CubelDE can be customized in many ways. The menu [Window]>[Preferences] is used to open the
Preferences dialog. In this dialog, the left pane is used to navigate to certain preference pages. There is also a
filter field, which can be used to narrow down the content displayed. The arrow controls on the upper-right side of
the dialog can be used to navigate back and forth across pages. The right pane contains the setting of the
displayed preferences. Make any preferred change and press [Apply] to update the setting.

[Restore Defaults] resets all changes. The preference settings are stored in a metadata folder in the workspace
of the application. Section 1.7: Managing existing workspaces in this user manual provides information on how to
backup preferences and copy preferences across workspaces.

Figure 18. Preferences

E Preferences O X
|type filter text | C/C++ Gvoovw
> General
> C/C++ General settings for C/C++ development:
> Help . .
> Install/Update Outline view
> Remote Development [IFollow unindexed header files when producing the outline view
» Remote Systems Note: Enabling this preference may have negative impact on performance.
> Run/Debug
» STM32Cube
» Team Refactoring C/C++ code
Terminal [ Isave all modified resources automatically prior to refactoring
Rename in editor without dialog
C/C++ dialogs
Clear all 'do not show again' settings and show all hidden dialogs again
‘ Restore Defaults ‘ | Apply ‘
@ @ ﬁﬂ | Apply and Close | ‘ Cancel ‘

It is advised to walk through the preferences pages and get an understanding of the possible configuration
options. The following sections present some of them.
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1.5.1
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Preferences - Editors

The editor can be configured in many ways. For instance, the menu selection [General]>[Editors]>[Text Editors]
provides a Preferences pane containing general editor settings such as:

. Displayed tab width

. Insert spaces for tabs
. Highlight current tab
. Show line numbers
. Others
Figure 19. Preferences - Text Editors
EB preferences O X
line Text Editors Qe
+ General
Compare/Patch Some editors may not honor all of these settings.
v Editors See ‘Colors and Fonts' to configure the font
Text Editors ee 'Colors and Fonts' to configure the font.
Workspace T, o
v C/C++ ndo history size: 200
v Editor Displayed tab width:
Scalability Minsert spaces for tabs
Syntax Coloring Highlight current line
[Ishow print margin
Print margin column: 80
Allow editors to override the margin column
[M show line numbers
Show range indicator
[JShow whitespace characters (configure visibility)
Show affordance in hover on how to make it sticky
When mouse moved into hover: Enrich after delay v
Enable drag and drop of text
M warn before editing a derived file
Smart caret positioning at line start and end
Appearance color options:
Line number foreground Color:
Current line highlight
Print margin
Find scope
Selection foreground color
Selection background color
Background color
Foreground color
Hyperlink
More colors can be configured on the 'Colors and Fonts' preference page.
‘ Restore Defaults ‘ ‘ Apply ‘
@ m E’Zﬂ | Apply and Close | ‘ Cancel ‘
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1.5.2 Preferences - Code style formatter
It is possible to configure the editor to use special formatting.

The menu selection [C/C++]>[Code Style]>[Formatter] provides a Preferences pane containing settings to set an
active profile.

Figure 20. Preferences - Formatter

[ preferences O X
[type filter text " Formatter Py
Perspectives A
Project Natures Configure Project Specific Settings...
Search Active profile:
> Security K&R [built-in] v] | Edit... Remove
> Startup and Shutdown
Ul Responsiveness Monitoring | New... ‘ ‘ Import... |
> User Storage Service Preview:
Web Browser Iz ~
> Workspace * A sample source file for the code formatter preview
v C/C++ */
Appearance #include <math.h>
> Build
Code Analysis class Point {
v Code Style public:
Code Templates Point(double x, double y) :
Formatter x(x), y(y) {
Name Style }
> Organize Includes double distance(const Point& other) const;
Core Build Toolchains
> Debug double x;
w Editor double y;
> Content Assist 1 v
Folding
Hovers
Mark Occurrences v ‘ Restore Defaults ‘ | Apply ‘
@ m ﬁz‘ﬂ | Apply and Close | ‘ Cancel |
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At this point, if [Edit...] is pressed, a new dialog is opened, where the selected profile can be updated according
to specific coding rules. This is displayed in Figure 21.

Figure 21. Preferences - Code style edit

[ profile 'GNU [built-in]'

Profile name: ‘GNU [built-in] Export...

Indentation ~ Braces White Space New Lines Control Statements Line Wrapping Comments Off/On Tags

Brace positions

Preview: [Jshow invisible characters
Class declaration: ‘Next line v /* A
* Braces
Namespace declaration: ‘Next line v */
Function declaration: Next line v #include <math.h>
Blocks: Next line indented v int digits[] =
{e,1,2,3,4,5,6,7,8,9};
Blocks in case statement: Next line indented v
‘switch' statement: Next line indented v zlass Point
Initializer list: Next line indented v public:
o ) Point (double x, double y) :
[CIKeep empty initializer list on one line ?
pempty x (x), y (¥)
{
}
double
distance (const Point& other) const;
int
compareX (const Point& other) const;
double x;
double y;
s
v
@ Apply OK | ‘ Cancel
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1.5.3 Preferences - Network proxy settings

STM32CubelDE uses the Internet for instance to get access to STM32 devices information. If a proxy server is
used for Internet access, some configuration settings are required in STM32CubelDE. The proxy settings are set
in the Preferences pane obtained through [General]>[Network Connections]. To change the settings, set [Active
provider] to Manual and update the Proxy entries for HTTP and HTTPS with specific Host, Port, User and
Password using the [Edit...] button.

Figure 22. Preferences - Network Connections

m Preferences = X
Network " Network Connections vy
v General

v Network Connections Active Provider: Manual v

SSH2

Proxy entries

Schema Host Port Provider Auth User Password Edit...
HTTP Manual No Clear
HTTPS Manual No
SOCKS Manual No
O HrTP Dynamic Dyna.. Native No

Proxy bypass

Host Provider Add Host...
localhost Manual Edit..
127.0.0.1 Manual

Remove
Restore Defaults ‘ Apply
@ aed  cane
Note: If there is a problem to save the proxy settings, the reason can be a corrupt secure storage file. Proceed as

follows to solve the problem:
1. Close all running STM32CubelDE applications
2. Rename the file

C:\Users\user name\.eclipse\org.eclipse.equinox.security\secure storage
to a new name

3. Restart STM32CubelDE

4. Update the proxy network settings, with user and password information, and save them to create a new
secure_storage file
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1.54 Preferences - Build variables
The STM32CubelDE preferences feature build variables that are only visible in the IDE.

The menu selection [C/C++]>[Build]>[Build Variables] provides a Preferences pane with Build Variables, which
can be used as ${VAR} in STM32CubelDE. Enable [Show system variables] to display all available variables.

Figure 23. Preferences — Build variables

| [ preferences = X
| Liye ey b Build Variables Ao
¥ Gerseral A
| wcpes Hame Type Vahee A1 Add..
Appearange DviverData String CAWindews!System 3\ Drivers DriverData B
 Build eclipse home Strirwg <ECLIPSE DYNAMIC VARIABLE>
Build Targets o _var String <ECLIPSE DYNAMIC VARIABLE> Delete
Build Variables FPS_BROWSER_APP_ PROFILE_STRING String Internet Explorer
Consobe FPS_BROWSER_USER_PROFILE_STRING String Drefault
Environment gnu_arm_emibedded_compiler_path String <ECLIPSE DYNAMIC VARIABLE>
Logging g tools_for_stm3z_ compiler_path String <ECLIPSE DYMAMIC VARIABLE>
 Makafile Editor HOMEDRIVE String [~ v
Settings ) =
1] Shawar System vanables
Settings
Code Analysis
> Code Siyle Buid Variables are IDE only variables, which can be used for string substitution when defining external bulder configuration,
Core Build Toolchains such a5 environment variable value of command line parameter in form of ${VAR], intemal builder may use them directly.
< Bl = ¥ Restore Defaulis Apply
LYo o
|

Table 1. Examples of toolchain build variables

gnu_tools_for_stm32_compiler_path Path to GNU Tools for STM32 toolchain.
gnu_arm_embedded_compiler_path Path to GNU ARM Embedded toolchain.
stm32cubeide_make_path Path to make and BusyBox.

A pre-build step example using build variables to display toolchain version is given in Figure 24.

Figure 24. Pre-build step using build variables

m Properties for NUCLEO-F401RE O X
type filter text Settings v v §
> Resource o
Builders - . o~ i HM ot :
v C/C++ Build onfiguration: |Debug [ ive | anage Configurations...
Build Variables
Environment ® Tool Settings #* Build Steps Build Artifact Binary Parsers @ Error Parsers
Logging
Settings Pre-build steps
» C/C++ General Command:
CMSIS-SVD Settings ‘ ${gnu_tools_for_stm32_compiler_path}\arm-none-eabi-gcc.exe --version v |

Project References Description:

Run/Debug Settings ‘ Display toolchain version ~ |

Post-build steps

Command:

\ 7]
Description:

‘ e |

@ Apply and Close | | Cancel

UM2609 - Rev 16 page 21/258



https://www.st.com/en/product/stm32cubeide?ecmp=tt9470_gl_link_feb2019&rt=um&id=UM2609

‘_ UM2609
,’ Getting started

1.6 Workspaces and projects

The basic concepts of workspaces and projects compares as follows:

. A workspace contains projects. Technically, a workspace is a directory containing project directories or
references to them.

. A project contains files. Technically, a project is a directory containing files that may be organized in sub-
directories.

. A single computer may hold several workspaces at various locations in the file system. Each workspace
may contain several projects.

. The user may switch between workspaces, but only one workspace can be active at one time.

. The user may access any project within the active workspace. Projects located in another workspace
cannot be accessed, unless the user switches to that workspace.

. The files included in a project do not need to be physically located in a folder in the project but can be
located somewhere else and linked into the project.

. Switching workspaces is a quick way of shifting from one set of projects to another. It triggers a quick

restart of the product.

In practice, the project and workspace model facilitates a well-structured hierarchy of workspaces, containing
projects, containing files.

1.7 Managing existing workspaces

The workspace can be selected when starting STM32CubelDE. It is also possible to switch to another workspace
during the use of STM32CubelDE. In this case STM32CubelDE restarts after the new workspace is selected. To
restart STM32CubelDE with a new workspace, select menu [File]>[Switch Workspace].

The workspaces known to STM32CubelDE can be managed by selecting [Window]>[Preferences] then, in the
Preferences dialog, selecting [General]>[Startup and Shutdown]>[Workspaces]. In the right pane, it is possible
to enable [Prompt for workspace on startup] and set [Number of recent workspaces to remember] to the
desired value.

Figure 25. Preferences - Workspaces

[ Preferences ] X
type filter text Workspaces EvHvw
v General ~

> Appearance Prompt for workspace on startup
Compare/Patch Number of recent workspaces to remember: | 10 5~
Content Types

Recent workspaces
> Editors

Globalization
Keys
Link Handlers
> Network Connections
Perspectives
Project Natures
Search
> Security
v Startup and Shutdown
Workspaces
Ul Responsiveness Monitoring
> User Storage Service
Web Browser
> Workspace
> C/C++
> Help
> Install/Update
> Remote Development
> Remote Systems

Remove

> Run/Debug v Restore Defaults Apply
@ Ry ﬁi Apply and Close Cancel

It is also possible to select and remove recent workspaces from the list of recent workspaces. However, removing
a workspace from that list does not remove the files. Neither does it remove the files from the file system.
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1.71 Backup of preferences for a workspace
It is generally a good practice to take a copy of the existing preferences for a workspace. It can be especially
useful to recreate the workspace after a crash without the time-consuming process to redo the settings manually.
In the menu, select [File]>[Export]. Then, in the panel, select [General]>[Preferences]. Press the [Next] button
and, in the next page, enable [Export All] along with a correct filename.

1.7.2 Copy preferences between workspaces
To copy workspace preferences from one workspace to another, an existing export of preferences must first be
created as explained in Backup of preferences for a workspace.
Then select [File]>[Switch Workspace] and the new workspace. STM32CubelDE restarts and opens with the
new workspace.
In the menu, select [File]>[Import] and in the panel select [General]>[Preferences]. Press the [Next] button and,
on the next page, enable [Import All] and enter the file name. The preferences are now the same in both
workspaces.

1.7.3 Keeping track of Java heap space

To keep track on how much Java heap space is used, select the [Window]>[Preferences] menu. In the
Preferences page, select the [General] node and then enable [Show heap status]. The currently used and
available Java heap space is then displayed in the STM32CubelDE status bar. The garbage collector can also be
triggered manually from the status bar.

Figure 26. Display of Java heap space status

m Preferences o X
type filter text | General Py~
v General ~
> Appearance 4 Always run in background
Compare/Patch [[TKeep next/previous editor, view and perspectives dialog open
Content Types Show heap status
> Editors Workbench save interval (in minutes): ‘ 5
Globalization
Keys Open mode
Link Handlers @® Double click
> Network Connections O ssingle click
Perspectives Select on hover

Project Natures
Open when using arrow keys
Search P 9 4

> Security
+ Startup and Shutdown

Workspaces

Note: This preference may not take effect on all views

Ul Responsiveness Monitoring
> User Storage Service
Web Browser
> Workspace
C/C++
Help
Install/Update
Remote Development
Remote Systems
Run/Debug v

| Apply

‘ Restore Defaults

vV V vV VvV Vv Vv

@ @ ﬁ | Apply and Close | ‘ Cancel |
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1.74 Unavailable workspace

Only one instance of STM32CubelDE can access one workspace at a time. This is to prevent conflicting changes
in the workspace. If STM32CubelDE is started with a workspace that is already used by another instance of the
program, the following error message is displayed.

Figure 27. Workspace unavailable

mWorkspace Unavailable X

e The default workspace 'C:/Users/ +/STM32CubelDE/workspace_um' is in use or cannot be
\ created. Please choose a different one.

‘ Retry ‘ | Choose |

If this message is displayed, choose a different workspace, or return to the already running STM32CubelDE.

1.8 STM32CubelDE and Eclipse® basics

STM32CubelDE contains so many features that it is easy to miss some really useful capabilities. Noteworthy
features are spell checking of C/C++ comments, word- and code completion, content assist, parameter hints and
code templates. The editor also includes an include-file dependency browser, code navigation using hypertext-
links, bookmark and to-do lists, and powerful search mechanisms. The next sections remind some of the useful
tools that can be easily missed.

1.8.1 Keyboard shortcuts

It is convenient to use keyboard shortcuts instead of the mouse. One important shortcut to know is the shortcut
Ctrl+Shift+L. This shortcut opens a cheat sheet with all available shortcuts.

Figure 28. Shortcut keys

Activate Editor F12 LA

Backward History Alt+Left

Build All Ctrl+B

Build Target Build Shift+F9

Close Ctrl+F4

Close All Ctrl+Shift+F4

Collapse All Ctrl+Shift+Numpad_Divide

Content Assist Ctrl+Space

Context Information Ctrl+Shift+Space

Copy Ctrl+Insert

Cut Shift+Delete

Debug F11

Delete Delete

Expand All Ctrl+Shift+ Numpad_Multiply

Find Text in Workspace Ctrl+Alt+G

Find and Replace Ctrl+F

Forward History Alt+Right

Last Edit Location Ctrl+Q

Maximize Active View or Editor Ctrl+M v
Press 'Ctrl+Shift+L' to open the preference page
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Pressing Ctrl+Shift+L in this sheet opens the Keys pane in the Preferences dialog.

Figure 29. Shortcut preferences

m Preferences O X
‘type filter text Keys Ovpv w
v General
7 Appearance Scheme: ‘Default v
Compare/Patch
Content Types ‘ type filter text
> Editors ~
Globalization Command Binding When Category User o
Keys Activate Editor F12 In Windows Window
Link Handlers Add Block Comment Ctrl+Shift+/ C/C++ Editor C/C++ Source
> Network Connections Add Bookmark Edit
Perspectives Add Expression Group > Local Variable Run/Debug
Project Natures Add Expression Group > Registers Run/Debug
Quick Search Add Include Ctrl+Shift+N C/C++ Editor C/C++ Source
Search Add Memory Block Ctrl+Alt+M In Memory View Run/Debug
> Security Add RegisterGroup Register Grouping co...
> Startup and Shutdown Add Task... Edit
Ul Responsiveness Monit Add to Working Set Edit
> User Storage Service Align const qualifiers Ctrl+Shift+A C/C++ Editor C/C++ Source
Web Browser Apply Patch... Team
> Workspace Back Navigate v
> C/C++
> Help Copy Command ‘ ‘ Unbind Command ‘ ‘ Restore Command Filters... ‘ ‘ Export CSV...
> Install/Update
> Remote Development
> Remote Systems Name: Activate Editor
» Run/Debug Description: | Activate the editor Conflicts:
7 STM32Cube Command When
> Team
Terminal Binding: ‘ F12 ‘ <
When: ‘In Windows v ‘
[Ishow key binding when command is invoked
< > ‘ Restore Defaults ‘ ‘ Apply ‘
@ @ @ | Apply and Close | ‘ Cancel
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The Keys pane offers the possibility to examine the shortcuts in detail and change the scheme (default, GNU
Emacs, or Microsoft® Visual Studio®), reconfigure shortcut keys, and others.
Table 2 presents the default bindings of some of the keys to mention.

Table 2. Key shortcut examples

I N . R

Keyboard shortcut overview

Ctrl+Shift+L List keyboard shortcuts | Lists all the defined keyboard shortcuts.

Navigation in files and C symbols

Ctrl+Shift+R Open resource Finds files from any perspective.

Ctrl+H Search for keyword tSearches for a keyword in a defined scope with the possibility
O Use reg.exp.

Alt+Enter View properties Views the properties for the selected resource.

Ctrl+Page up or Ctrl+Page down
Alt+— or Alt+—

Switch editor Switches to an open editor to the left or to the right.

Moves to an open editor by filtering text or selecting in the

Ctri+E Select editor
menu.

Searches for elements (such as functions, symbols, or others)

Ctrl+Shift+T Search for elements )
in workspace resources.
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Ctri+Q Go to the last edit Goes to the editor, and to the position in this editor, where the

last edit was done.

Navigation through file information

Navigates through large files from perspectives lacking an

Ctrl+O Quick outline ; .
outline view.
Ctri+L Go to line Goes to a line in the editor.
Ctrl+F Search inside context | Searches within the file currently active in the editor.
Ctri+Alt+l Open include browser | Opens the include browser for the current resource.
Ctri+Alt+H Open call hierarchy Shovys how the function calls are made to and from a selected
function.
Ctri+Space Code completion Code completion using the parameter hints from the context

Parameter hints.

Code formatting and refactoring

Shift+Alt+A Toggle block select Edits one column across multiple rows.

Ctri+l Indent line Indents a source code line according to defined format rules.
Ctrl+Shift+F Eg:‘r:at the selected Formats the source code according to defined format rules.
Shift+AIt+R Quick renaming Renames any C symbol across all the files in all open

projects.

Version control

Ctrl+Alt+C Commit resources Commits the modified files within the active context.

F11 Debug project Starts a debug session of the project currently active.

F8 Resume Continues the debugging process until the next breakpoint.

F5 Step into Steps into the next method call at the currently executing line
of code.

F6 Step over Steps over the next method call at the currently executing line
of code.

F7 Step return Returns from a method that has been stepped into.

Shift+F5 Reverse step into Steps into the last method call at the currently executing line
of code.

Shift+F6 Reverse step over Steps over the last method call at the currently executing line
of code.

Ctrl+R Run to a line Runs to the position of the cursor in the code.

Ctri+F2 Terminate Stops the debugging process.

Ctrl+Alt+B Skip breakpoints Skips all breakpoints.

Good to know

Allows the users to define their own keyboard shortcuts. Also
[Window]>[Preferences]>[General]>[Keys] allows the choice of other keyboard shortcut schemes: GNU
Emacs, or Microsoft® Visual Studio®, or others.
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Note:

1.8.3
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Editor zoom in and zoom out

It is possible to increase or decrease the default font size for text editors by pressing Ctrl++ and Ctrl+-:
. Ctrl++ : zoom in text
. Ctrl+- : zoom out text

If a keyboard with a numeric keypad is used and the + or — keys are pressed on the numeric keypad, use the
Shift key in addition to make the zoom work (Ctrl+Shift+ or Ctrl+Shift-).

Figure 30. Editor with text zoomed in

mworkspace_um'\ - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - o X
File Edit Source Refactor Navigate Search Project Run Window Help
N HE S R @ QD E @@y IRIE 18 ooy @ Quick Access | 1| 5 |4
[ Project Explorer BHE Y S0 [ mainc 2 = O | B= outline 2 ® Build Targets =
> Emytio ® SR RNEE
v NUCLEO-F401RE . @ Distance : uint32.t ~
G * Configure the system clock *
> 3 Binaries ® Seconds: uint32.t
> g]lcnc\udes SystemClock_Config(); zSSysxemc\ock;an:g(va.:) void
v ore. “+ 5 MX_GPIO_Init(void) : voi
> E=Inc HS MX_USART2_UART _Init(void) : void
v & src /* USER CODE BEGIN SysInit */ ® ip:int
> [gl mainc @ ramx:int
> [ stm32f4xx_hal_msp.c . ® mylP_read() : int
> 9 stm32fx ite /* USER CODE END SysInit */ © myRAM read() : int
> [ syscalls.c ® _binary_data_start - int
> [g sysconf.c L. . . . © _writefint, char®, int) : int
> [ sysmem.c /* Initialize all configured peripherals */ O EElan
> [ system_stm32fdxxc | MX GPTO Tnit(): v © SystemClock Config(void) : void
> (= Startup < > °f MX_USART2_UART _Init{void) : void M
> (2 Drivers = = = =
> (Debug 21 Problems ¥ Tasks BD Console 52 [ Properties ™ B v 4~ = A [§ build Analyzer 7 == Static Stack Analyzer =#v=0
> (= Debug2 No consoles to display at this time. NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13 PM
7 [ Release
[CINUCLEO-F401RE el cfg Memory Regions - Memory Details
|Z] NUCLEO-F401RE.elflaunch Region Start address. End address Size Free
mNUCLEO—MCM REioc EEHRAM 0x20000000 0x20018000 96 KB 94.27 KB
2] readme.txt EHFLASH 0x08000000 0x08010000 64 KB 53.7KB
@ STM32F401RETX_FLASH_IPCodelnFlash.ld EHFLASH_D 0x08010000 0x08010800 2KB 1.99 KB
\ﬂ STM32F401RETX_FLASH_ORG.Id EHFLASH_V 0x0801f800 0x08020000 2KB 1.99 KB
E STM32F401RETX_FLASH_RAM_CODE ld
E STM32F401RETX_FLASH.Id
E STM32F401RETX_RAM.Id
> [ sTM32F401_AcE
< >
Writable Smart Insert 169: 16 : 4028 i H -

Quickly find and open a file

Pressing Ctrl+Shift+R to find and open a file quickly is one of the featured easily missed. Type a couple of
characters part of the name of the file to open. It is possible to add the * and ? search wildcards as appropriate.
The editor then lists the matching filenames. Select the desired file in the search result list, and open the file using
any of these three ways:

. [Show In]: sends the file to one of the views chosen in the drop-down list (such as the #include file
dependency browser view)

. [Open With]: opens the file in the editor selected in the drop-down list

. [Open]: probably the most commonly used option, simply opens the file in the standard C/C++ editor

page 27/258




‘,_l UM2609

Getting started

1.8.4 Branch folding

A block of code enclosed within #1if and #endif can be folded. To activate the functionality, go to
[Window]>[Preferences], then [C/C++]>[Editor]>[Folding] and check the [Enable folding of preprocessor
branches (#if/#endif)] checkbox. Once the checkbox is checked, the editor must be restarted. Close the file,
open it again, and the small icon in the left margin of the editor showing that the functionality is activated.

Figure 31. Editor folding

[T workspace_um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
R - R @I NGB E R [ rid i@y [ RE TG OO D20 Quick Access ||| 5 [[FE 4
[ Project Explorer i B Y =0 [ manc 2 = 0 | %2 outline X ® Build Targets =]
> [EmyLib 161 ~ LR e v
v FENUCLEO-F401RE 162 /* USER CODE BEGIN Init */ 21 main.h
> #¥ Binaries 163 2 malloch
> 164  /* USER CODE END Init */ .
> [l Includes ® huart2 : UART_HandleTypeDef
v [ Core 165 . ® © VERSION_NUMBER : const uint32_t
> EInc 166  /* Configure the system clock */ ® © CRC_NUMBER : const uint32.t
v =S 167 SystemClock_Config(); © BUILD.ID : const uinti6t
; 168 - -
> y :
N %TEI;;M ol 169  /* USER CODE BEGIN SysInit */ : E‘S‘anse'“’"gﬁ
stm. Xx_hal_msp.c econds @ uin’ -
’ 170 .
; %stmaiﬁtxx,n.c 171 /* USER CODE END SysInit */ ﬂsSys(emCIock_Conﬁg(vcld):vo\d
syscalls.c 172 ++ MX_GPIO_Init(void) : void
> L€ sysconf.c 173 /* Initialize all configured peripherals */ 49 MX_USART2_UART_Init(void) : void
> [ sysmem.c 174 MX_GPIO_Init(); ® ip:int
> [£] system_stm32f4xx.c 175© #ifdef TEST_MALLOC ® ramx:int
> (= Startup 176 mem3=malloc(12); ® mylP_read() : int
> [ Drivers 177 mem4=malloc(12); ® myRAM_read() : int
> [z Debug 178 mem5=malloc(12); @ _binary_data_start : int
> (= Debug2 179 mem6=malloc(12); ® _write(int, char*, int) : int
> (= Release 180 mev{l7=malltx(12); @ main(void) : int
[FINUCLEO-F401RE €lf.cfg 181 #endif @ SystemClock_Config(void) : void
5 NUCLEO-F401RE elflaunch 182 © ¥ MX_USART2_UART_Init(void) : void
[ NUCLEO-F401RE.joc 183 MX_USART2_UART_Init(); © $ MX_GPIO_Init(void) : void
2 readme.txt 1:: /* USER CODE BEGIN 2 */ ® Error_Handler(void) : void
[ STM32F401RETX_FLASH_IPCodelnFlash.Id .
%{ Cl _IPCodelnFlas 156 mememalloc(12); A assert_failed(uint8_t*, uint32_) : void
54 STM32F401RETX_FLASH_ORG.Id .
[ 38 STM32F401RETX_FLASH_RAM_CODE.Id 187 menZemabiccili
L ! -t - ! < >
34 STM32F401RETX_FLASH.Id B
34 STM32F401RETX_RAMId 21 Problems ] Tasks B Console %2 [=] Properties = O [ Build Analyzer 2 == Static Stack Analyzer =®v=0
> [ STM32F401_Ac6 v
o Ae B~ Y NUCLEO-FA01RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
No consoles to display at this time. M
Memory Regions  Memory Details
Writable Smart Insert 1:1:0 H [+

1.8.5 Block selection mode

Alt+Shift+A toggles the selection mode between normal and block. When the block mode is enabled, use either
the mouse or the Shift+Arrow keys of the keyboard to select a block of text.

Use of the block selection mode

To start using the block selection mode, press Alt+Shift+A. Click somewhere in the text and drag down. A column
is then marked as shown in Figure 32.
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Figure 32. Editor block selection

mworkspace,urm - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
N HO S - R BN G e [ @ itev i@y IRE TS GOy 2O Quick Access B |BE %
[ Project Explorer % ES Y =0 [ manc 2 = 0 Bz outline 3 (@ Build Targets =
> [EmyLib 161 ~ ElERR o ¥ v
v [ NUCLEO-F401RE 162 /* USER CODE BEGIN Init */ 2 mainh
> #¥ Binaries 163 21 malloch
> [llincludes 164 /* USER CODE END Init */ @ huart2 : UART_HandleTypeDef
v (2 Core 165 © confs . Lock * @ © VERSION_NUMBER : const uint32_t
> @ inc 166 /* Configure the system clock */ ® © CRC_NUMBER : const uint32. ¢
v &S 167 SystemClock_Config(); @ ©BUILD_ID : const uint16_t
168 - -
> in. . @ Di :
£ e 169  /* USER CODE BEGIN SysInit */ Distance : uint32.t
> [€] stm32faxx_hal_msp.c 70 @® Seconds : uint32_t
> [ stm32fxx_itc 171 /* USER CODE END SysInit */ 1?&5SystemCIcck,Config(void):vo\d
> [ syscalls.c 172 ++° MX_GPIO_Init(void) : void
5 - .
> [€] sysconf.c 173 /* Initialize all configured peripherals */ ++7 MX_USART2_UART_Init(void) : void
> [ sysmem.c 174 MX_GPTO_Init(); ® ip:int
> @system_stmszmxx.c 175© #ifdef TEST_MALLOC ® ramx:int
> (= Startup 176 mem3=malloc(12); ® mylP_read() : int
> [ Drivers 177 mem4=malloc(12); ©® myRAM _read() : int
> = Debug 178 mem5=malloc(12); @ _binary_data_start : int
> (= Debug2 179 mem6=malloc(12); @ _write(int, char*, int) : int
> (= Release 180  mem7=malloc(12); © main(void) : int
[FINUCLEO-F401RE elf.cfg 181 #endif °

SystemClock_Config(void) : void

°f MX_USART2_UART_Init(void) : void
°f MX_GPIO_Init(void) : void

@ Error_Handler(void) : void

/ assert_failed(uint8_t*, uint32_t) : void

NUCLEO-F401RE.elf.launch

m NUCLEO-F401RE.ioc

2 readme.txt

@ STM32F401RETX_FLASH_IPCodelnFlash.Id

183 MX_USART2_UART_Init();
184 /* USER CODE BEGIN 2 */

34 STM32F401RETX_FLASH_ORG.d 186 mem-malloc(12); .

[T STM32F401RETX_FLASH_RAM_CODE.Id 282 < Renzepalloc(i2) N

S STM32F401RETX_FLASH.Id

[T STM32F401RETX_RAM.Id 21 Problems V=) Tasks B Console 53 [ Properties =0 Build Analyzer 52 == Static Stack Analyzer #v=0
> [ STM32F401_Ac6 #E-S&

NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
No consoles to display at this time. PM

Memory Regions  Memory Details

 Wiitable | Smart Insert 176:3 [0] ; a

Add some text and see that this text is entered in all marked rows. As an example, the text “4y ”is added and
displayed in Figure 33.

Figure 33. Editor text block addition

[ workspace_um?1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - u] X

File Edit Source Refactor Navigate Search Project Run Window Help

- EHRB R BING E i@y SRE 18 H e O e [Quick Access ]| 34
[¢5 Project Explorer 52 EHES Y 70 (@ mainc 2 = O | %= outline X @ Build Targets =0
> [EmyLib 161 ~ ElLR o ¥ v
v [ NUCLEO-F401RE 162 /* USER CODE BEGIN Init */ 2 mainh
> #% Binaries 163 ) 2 malloch
> @l Includes 164 /* USER CODE END Init */ @ huart2 : UART HandleTypeDef
v (ECore 165 . o . Lock * @ © VERSION_NUMBER : const uint32_t
> = Inc 166 g ionciguiect ;})(/;t:em clock */ @ © CRC_NUMBER : const uint32_t
v &S ig; ystemClock_Contig(); @ SBUILDID : const uint16.t
> ! @ Di :
L= 160  /* USER CODE BEGIN SysInit */ Distance - ini32.¢
> [€] stm32faxx_hal_msp.c 70 ® Seconds: uint32_t
; %slm3if4xx_lt.c 171 /* USER CODE END SysInit */ ESSystemCIock,Concflig(voij):vo\d
syscalls.c 170 +$ MX_GPIO_Init(void) : voi
-5 - .
> [€] sysconf.c 173 /* Initialize all configured peripherals */ ++” MX_USART2_UART_Init(void) : void
> [€] sysmem.c 174 MX_GPIO_Init(); ® ip:int
> [] system_stm32fxx.c 175 #ifdef TEST_MALLOC ® ramx:int
> = Startup 176 My_| 1loc(12); ® mylP_read() : int
> (2 Drivers 177 My_pem4=malloc(12); ©® myRAM_read() : int
> [z=Debug 178 My_pem5=malloc(12); @ _binary_data_start : int
> (= Debug2 179 My_memé=malloc(12); ® _write(int, char®, int) : int
> (= Release 180 My_mem7=malloc(12); ® main(void) : int
[FINUCLEO-F401RE elf.cfg 181 #endif °

SystemClock_Config(void) : void

© S MX_USART2_UART_Init(void) : void

© ¥ MX_GPIO_Init(void) : void

@ Error_Handler(void) : void

/ assert_failed(uint8_t*, uint32_t) : void

NUCLEO-F401RE.elf.launch

[ NUCLEO-F401RE.ioc

readme.txt
STM32F401RETX_FLASH_IPCodelnFlash.Id

183 MX_USART2_UART_Init();
184  /* USER CODE BEGIN 2 */

i
gsmszmow RETX_FLASH_ORG.d 186 mem-malloc(12); .

[ 3 STM32F401RETX_FLASH_RAM_CODEId 187 mem2=malloc(12): R

[ 34 STM32F401RETX_FLASH.Id

54 STM32F401RETX_RAM.Id 1 Problems V£ Tasks B Console &2 [ Properties =0 Build Analyzer §2 == Static Stack Analyzer #v=0
> [ STM32F401_Ac6 #2E-N

NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
No consoles to display at this time. PM

Memory Regions  Memory Details

‘ Writable Smart Insert 180: 6 [0] -

Selection and edition of areas

Select a block. In Figure 34, the block starting with “mem3” to “mem7” is selected.
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Figure 34. Editor column block selection

mworkspace,urm - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
HHB®-Q- @ N Qg e - @ i i@y dRE 18 F 0o 20 Quick Access | 5 |[ERl%s:
[ Project Explorer % BES Y =0 @ manc 2 = 0 Bz outline 3 (@ Build Targets =
> [EmyLib 161 ~ BR o v
v [ NUCLEO-F401RE 162 /* USER CODE BEGIN Init */ 2 mainh
> #¥ Binaries 163 21 malloch
> @l Includes 164 /* USER CODE END Init */ @ huart2 : UART_HandleTypeDef
v (£ Core 165 @ © VERSION_NUMBER : const uint32_t
> Einc 166 /* Configure the system clock */ © € CRC_NUMBER : const uint32.t
v &S 167 SystemClock_Config(); ©CBUILDID : const uint16.t
168 - -
> in. . @ Di :
N %":a';';ﬂ ol 169  /* USER CODE BEGIN SysInit */ o ?'Sta”:e “‘”:3322’:
stm. Xx_hal_msp.c econds : uin -
) 170 - o
i %stm3if4xx_lt.c 171 /* USER CODE END SysInit */ Esaitzn;gc[clfforv\(:;g(volj):vo\d
syscalls.c 172 - (¢ )_Init(void) : voi
5 - .
> [€] sysconf.c 173 /* Initialize all configured peripherals */ ++7 MX_USART2_UART_Init(void) : void
> [ sysmem.c 174 MX_GPTO_Init(); ® ip:int
> [] system_stm32fxx.c 1755 #ifdef TEST_MALLOC ® ramx:int
> (= Startup 176 My. malloc(12); ® mylP_read() : int
> [ Drivers 177 My. malloc(12); ©® myRAM _read() : int
> = Debug 178 My malloc(12); @ _binary_data_start : int
> (= Debug2 179 My malloc(12); ® _write(int, char*, int) : int
> (= Release 180 My, malloc(12); © main(void) : int
[FINUCLEO-F401RE elf.cfg 181 #endif °

SystemClock_Config(void) : void

°f MX_USART2_UART_Init(void) : void
°f MX_GPIO_Init(void) : void

@ Error_Handler(void) : void

/ assert_failed(uint8_t*, uint32_t) : void

NUCLEO-F401RE.elf.launch

m NUCLEO-F401RE.ioc

= readme.txt

@ STM32F401RETX_FLASH_IPCodelnFlash.Id
|14 STM32F401RETX_FLASH_ORG.Id

183 MX_USART2_UART_Init();
184 /* USER CODE BEGIN 2 */

186 mem=malloc(12);

[T STM32F401RETX_FLASH_RAM_CODE.Id 282 " Renzepalloc(i2) N N

S STM32F401RETX_FLASH.Id

[T STM32F401RETX_RAM.Id 2 Problems ¥ Tasks B Console 3 [ Properties =0 Build Analyzer 52 == Static Stack Analyzer #v=0
> [ STM32F401_Ac6 #E-S&

NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
No consoles to display at this time. PM

Memory Regions  Memory Details

 Wiitable ' Smart Insert 180:1020] a

Copy the selected block by using Ctrl+C. This copied text can then be inserted elsewhere. To do so, type
Alt+Shift+A to toggle the selection mode back to the normal mode, move the cursor to another line, and type
Ctrl+V to paste the copied columns to the new lines.

Figure 35. Editor column block paste

[ workspace_um?1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m) X
File Edit Source Refactor Navigate Search Project Run Window Help
C-HR®-&-EBN@GIE -6 (@i i@y [IRE T 50020 Quick Access || 5| B4
(75 Project Explorer % EHS Y 0 (@ mainc 2 = O | 2= outline 52 ® Build Targets =
> mmyub 179 My_memé=malloc(12); ~ Bl R o ¥ ¥
v [ NUCLEO-F401RE 180 My_mem7=malloc(12); o mainh
> #¥ Binaries 181 #endif 21 malloch
> [l Includes 182 @® huart2 : UART_HandleTypeDef
v (2 Core 183 @ © VERSION_NUMBER : const uint32_t
> E=Inc iz‘; VX_USART2_UART_Init() @ © CRC_NUMBER : const uint32_t
ni H
v =Src - - = 4 @ ©BUILD_ID : const uint16_t
; 186 * USER CODE BEGIN 2 * - -
> [ mainc / / @ Distance : uint32 t

(8 stm32f4xx_hal_msp.c
[ €] stm32faxx_it.c

7 .
N 188 mem=malloc(12); ® Seconds: uint32 t
> [ syscalls.c

>

>

189 mem2=malloc(12); ﬂs SystemClock_Config(void) : void
190© #ifdef OLD ++* MX_GPIO_Init(void) : void

[€] sysconf.c 101 mem3=malloc(12); 45 MX_USART2_UART_Init(void) : void
6] sysmem.c 192 mem4=malloc(12); @ ip:int
> [] system_stm32f4xx.c 103 memS=malloc(12); = ® ramx:int
> (= Startup 194 memé=malloc(12); ® mylP_read() : int
> (2 Drivers 195 mem7=malloc(12); ©® myRAM _read() : int
> (= Debug 196 #endif @ _binary_data_start : int
> (= Debug2 /* USER CODE END 2 */ @ _write(int, char®, int) : int
> (= Release mem3 © main(void) : int
[FINuCLEO-F401RE €lf.cfg memé ® SystemClock_Config(void) : void
= NUCLEO-F401RE.elf.launch memS © ¥ MX_USART2_UART_Init(void) : void
[ NUCLEO-F401RE.ioc memé ®  MX_GPIO_Init(void) : void
mem7

readme.txt
@ STM32F401RETX_FLASH_IPCodelnFlash.Id
[T STM32F401RETX_FLASH_ORG.Id

@ Error_Handler(void) : void

/* Infinite loop */ / assert_failed(uint8_t*, uint32_t) : void

/* USER CODE BEGIN WHILE */ v
[T STM32F401RETX_FLASH_RAM_CODE.Id M N
|34 STM32F401RETX_FLASH.Id
[T STM32F401RETX_RAM.Id o Problems ¥ Tasks B Console &2 Properties =0 \Ej Build Analyzer °2 == Static Stack Analyzer = v=0
> STM32F401_Ac6
o -Ae %8 - NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
No consoles to display at this time. PM
Memory Regions  Memory Details
Writable Overwrite 202:7:4577 -
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1.8.6

Note:

UM2609 - Rev 16

Compare files

To compare two files easily in STM32CubelDE:

1. Select the two files in the Project Explorer view
Click on one file

Press Ctrl

Click on the other file
Both files are now marked in the Project Explorer view

5. Right-click and select [Compare With]>[Each Other]

2.
3.
4

It is possible to configure how the comparison of files is managed. For instance, ignoring white space can be
enabled from the preferences. Open the Preferences page using [Window]>[Preferences], select
[General][>[Compare/Patch], and enable [Ignore white space].

Figure 36. Editor - Compare files

[T} workspace_um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
CHR® - R BINQGIE G -G i i@y i ARE T 0G0 M0 |Quick Access | %[ %¢
) Project Explorer 3% HES Y 25 [8mainc = B 5= outline ¥ @ Build Targets =0
> ZInc ~ My_mem6=malloc(12); ~ LR o v
v [=Src My_mem7=malloc(12); = mainh
> [£ main.c #endif 2 malloch
> [€] stm32faxx_hal_msp.c @® huart2 : UART HandleTypeDef
> [€ stm32fdxc_itc @ © VERSION_NUMBER : const uint32_t
> [] syscalls.c ® © CRC_NUMBER : const uint32_t
> %sysc New > (LUSART2_UART_Init(); ©CBULDD  const i1
- USER CODE BEGIN 2 */ S -
> [ sysn Open @ Distance : uint32_t
> [Esystt  ShowIn Alt+Shift+W > Lnomalloc (12); 5 Seconds:uinBZJv )
> Esanup e o CleC m2=malloc(12); i?fsSystemCIocKConflg(vold) : void
> (2 Drivers Paste Cirlsv  fef OLD 1+ MX_GPIO_Init(void) : void
> (= Debug R Delete Delete EM3=malloc(12); ++9 MX_USART2_UART Init(void) : void
? (= Debug2 e— , pm4=malloc(12); ® ip:int
> [=Release ” m5=malloc(12); = ® ramx:int
[FInucteo-f ove.. me=malloc(12); ® mylP_read(): int
2 NUCLEO-F  Rename.. F2 m7=malloc(12); ® myRAM_read() : int
[INUCLEO-F g Import... if @ _binary_data_start : int
2l readme.txi 14y Export... USER CODE END 2 */ ® _write(int, char®, int) : int
3 STM32F4C 5 efresh Fs pM3 © main(void) : int
[T STM32F4C . s emd ® SystemClock_Config(void) : void
[T STM32F4C 2 — g em5 © ° MX_USART2_UART_Init(void) : void
[ STM32F4c  RESOUree tonfigurations pm6 ® S MX_GPIO_Init(void) : void
[ ST™M32FaC_ Team > pm7 ® Error_Handler(void) : void
v [ sTM32F401_ Compare With 4 Each Other A assert_failed(uint8_t*, uint32_1) : void
> $% Binaries Replace With > Local History.. e .
> [@lincludes 3" Run C/C++ Code Analysis 5
> [Bsrc =
> (Estartup 21 Problems ] Tasks B Console 52 [] Properties = Build Analyzer % == Static Stack Analyzer = v=0
> (= Deb =B
B_ ebug 8- NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
> [Zinc No consoles to display at this time. PM
|34 LinkerScript.d
[T]sTM32F401_Ac6 Debug.cf . Memory Regions Memory Details
g.cfg ry
@ 2 items selected -
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The File Differences editor opens and compares both files.

Figure 37. Editor - File differences

[ wrorksoaze_um! - Tuwe-woy compare of ‘NUCLEO-7401RE/Care Srefsyscalls.c. with "NUCLEO-FL01RE/ ore/Secfsysmem s - STMIZCubaIDE - a ®
Fie it Source Refector havigate Search Project Run Window Help
O RO &K@ % i@iBigreir Sr@riprids vile q FlroorormBiksa Quiccheezee 1 AR
& Project Explorer 17 BE Y9 [Gemaine 7 Compare MUCLED MOTRECorerScisyscallss - NUELEG- 01 RE/Core/Sressysmerc) 17 BN B Guine 7 ® buikd Targets ~E
> [Ermytie ] ¢ Compam Thers is ne aclive editer Lhal prevces n culie.
v FEnUCLES Fa0° oY g -
getcher
0 ia putchar
on_dise
| C compere viewss ¥ [ i £ G AT
maine HUCLED- AN RECorefSc/sysealise | HUCLEG R0 AT e Srsememe |
& szt hil g 17+ | 17+ -
5 smazrancite 3 .
[Elsyscalbc iy | =
& et [ e Heealls « e 1
5 16 mpstom stmiidee 60 muthor : futo-generated by STME2CubelDE &=+ uthor futo-generated by STMEICubeIDE
> (B Startan e s
+ B v [ == ST EMERTAE Ainina] Gy ien calls File o[ 85 hstract STHR3CubaTHE Wininal Sysien Memary calls FiLj
> =Dy 8= E
s (= Desig? 1+ For more infornation about which < functions 1+ For mare information about which ¢-functions o
e e ez wich of these Loulovel Tancrions e noad sich of thase. Louhevel funciions o
Elbucizo- okt ety 27 please consult the Newlib Libc-nanusl ha v blease consult the Newlib 1ibc-sanu. H
= 1 hs e
= HUCLED-F401RE S aunch . cbetne i
=t Environeont : STHIMubeTDE MOU St Emedronmont ; STMIMCubelDE MCU
[ Huc e F40 TRE o e fel “
= "7‘:;’“:“‘1 i . 167+ Distributicn: The file is distributed as is, without any warr| fis** oistribution: The Tile is distributed as is, witheut any wi [
STMAZEANRET FLESH IFCocde nFlashd ) af any kend by of any kind 1
S STMIEANTRETY Fl25H ORGIH Jam hs e
& STMI2EA0TRITY FLASH RAM EODE 19 " -
& SRR FLASI Zolee SN =
& STI2ZATIRET R 207 <hsccentersbeopy; COPYRIGHT(c) 2318 ST cjcente| 1+ Py: COPYRIGHT(c) 1818 STHicroslectronicse/cel
« [DsThszRaat fes 227t 2t
1 237 Redistribulion an P— i o ith or wit| B3 Redistribulion and use in source and binary forms, with or 4
Sams are permisted pravidnd that she falloving condieionms are et 4%+ are pormitted provided that tho folle e
23%¢ 1. Redistributions of source code nust retain the above copy| 05 ' 1. Redistributions of source code mist retain the above o
> Bstanp 267 thiz 1ist of conditions and the fallowing disclainer be this List of conditions and the follouing disclateer
5 G Dessg 27 2. Redistributions in binary fore aust repraduce the sbave cf 7= 2. Radistrdbutlons Ln binary forn st reproduce the b
> Bine 2% this st the following disclaimer in t| 5% list of conditions and the follou i
% Unkersaiptid 297+ and/or athor i ich e dieeivsion, oo s Sriar sther posarists peovides tion,
T35 5 Desug -+ 3. Mesther the name of Sierosiactranics nor the names 5t 4] | Dae+ 3. Neithar tha nans of SiMicroslactronics nor the nanss of
R 3 way be used w endorse or provets products derived from o b1t ey be used to endorse o promote products deraved frof
327 without specific prior weitl: o bz without specific prios weitten pernisston.
338 i3 s+
347 THIS SOFTUARE 15 PROVIOED BY THE COPYRIGHT HOLOENS AND CONTRIE| 4 ** THIS SOFTVANE LS PROVIOED BY THE COPTAIGHT HOLDENS A0 CONTY |
B Problams ) Tacks 1] Gorocte 20" [ Brapersias D" = M [ i Anbyaar &= g St Stack Ay =
Mo cansoles Lo displey st hislime. NUCLEG-F40'RE.2f - /NUCLEO-F40 1RE/Debug - Sep 23, 2019 2:05:13 PM
Hemury Regicrts Mermory Dot
Resion Stortaddres  ndsddies 5w free Used Usase ) B
fsn Ji— w2 stzrie e =
LA [y EEY 521 KE ws e i 1
BEHASH 0 LOAUIOKG0  GosAOEL 2KE 158 KE u it C
Lefi %, ight: 4 1, incarming chenge &1 [Left 4:4, Ught 4 14} =

Use the navigation buttons to navigate between differences, or simply navigate in the view using the scroll bar to
see the file differences.
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1.8.7 Local file history
It is recommended to maintain projects with a version control system such as Apache® Subversion® (SVN) or

Git™. Still, STM32CubelDE contains a local file with the history of edited files, which can be useful if some
investigation is needed after a file has become not functional. The workspace preferences contain a Local History

page.
Figure 38. Local history
[I preferences O X
"0‘:3' x‘ Local History Py
v General
Globalization Limit history size
v Workspace Days to keep files: ‘ 7 |
Local History ot ] . ‘ |
v C/C++ aximum entries per file: | 50
~ Editor Maximum file size (MB): ‘ 1 |
Syntax Coloring
Note: The 'Maximum entries per file' and the 'Days to keep files' values
are only applied when compacting the local history on shutdown.
‘ Restore Defaults ‘ ‘ Apply
® m ﬁz‘ﬂ | Apply and Close | ‘ Cancel
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To show the local history of a file:
1. Select the file in the Project Explorer view

2. Right-click

3. Select [Team]>[Show local History]

Figure 39. Show local history

mworkspace_um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

ORI NQIDEg - [(-@ i i@

[ Project Explorer 2 BE v =0
> [Hmytib ~
v [ NUCLEO-F401RE

> #¥ Binaries
> @]Includes
v (& Core
> [=Inc
v = Src
> [ main. New
> [€ stm3:
> [ stm3: CEFz
> @ sysca Show In
> [£ sysco Open With
> [2 sysmE] Copy
> [g] syster Paste
> =Startup 3 Delete
> [ Drivers Source
? (= Debug Move..
? (= Debug2 Rename...
¥ @Release |8 port..
> @ Core ot
> & Drivers = P
> %NUCLEO Refresh
[ @makefile  Index
[Z/INUCLEO  Resource Configurations
NUCLEO[™ aam
Elobjects]  compare with
[Bobjects Replace With
%ﬁ‘ge:@ Run C/C++ Code Analysis
NUCLEO-F4 Properties

IRE iRl e e [Quick Access |} g5 |[EE %
[€] main.c &2 = 8 Bz outline 2 @ Build Targets =8
1 /* USER CODE BEGIN Header */ ~ BARY o % v
20 /** o mainh A
3 e 4  malloch
4 ¥ @file : main.c @® huart2 : UART_HandleTypeDef
5 7 @rief : Main program body @ VERSION_NUMBER : const uint32.
6 RERERRR R R R R .
7 * @attention OGCRC,NUMBER:mT\st uint32_t
o . ® “BUILD_ID : const uint16_t
> kh2><center>&copy; Copyright (c) 2019 STMicroelectronics. e Dlstance:ufntBZ,t
All rights reserved.</center></h2> . Seconds : uint32_t
Alt+Shift+W > H . SystemClock_Config(void) : void
5 his software component is licensed by ST under BSD 3-Clause license, i?fSM)(,GP\O,Init(void):vo\d
the "License"; You may not use this file except in compliance with the ++7 MX_USART2_UART_Init(void) : voic
Ctrl+C | i cense. You may obtain a copy of the License at: ® ip:int
Ctrl+V opensource.org/licenses/BSD-3-Clause ® ramx:int
Delete © mylP_read( : int
b *okl @ myRAM_read() : int
@ _binary_data_start : int
F2 PER CODE END Header */ ® _write(int, char*, int) : int
® main(void) : int
peludes --------oooooo oo @ SystemClock_Config(void) : void
pudeganaing © ° MX_USART2_UART_Init(void) : voic
F5 lude <malloc.h> v ¥ MX_GPIO_Init(void) : void v
> > < >
> lem o (BT = s = O (@ Build Analyzer 52 == Static Stack Analyzer = v=0
> Show Local History 2B
> Apply Patch... NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Sep 23, 2019 2:05:13
> - PM
Share Project..

Memory Regions Memory Details

Alt+Enter

m NUCLEO-F401RE.ioc

readme.txt

@ STM32F401RETX_FLASH_IPCodelnFlash.d
|14 STM32F401RETX_FLASH_ORG.Id v

@ /NUCLEO-F401RE/Core/Src/main.c

Region Start address
RAM 0x20000000
EHFLASH 0x08000000
0x08010000

- [m] X

End address Size Free ~
0x20018000 96 KB 94.27
0x08010000 64 KB 53.7
0x08010800 2 KB 199 ¥
>
[}
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The History view opens and displays the file history.

Figure 40. File history

[Z workspace_um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
N EHRS- R BiINQDig e[ F-it-i®y i dRETiY- G- CE-o- 0 Quick Access || B[R4
(25 Project Explorer % B Y =0  [@manc 2 = 0 | % outline B @ Build Targets " O
> mmyle A 1 /* USER CODE BEGIN Header */ ~ lﬂz‘Q\S o % v
v [ NUCLEO-F401RE 20 /** U mainh ~
> 4% Binaries 3 e * 1 4 malloch
> il includes 4 T efile i main.c @ huart2 : UART_HandleTypeDef
v Bcone S LT LTI O eeviessiesenieenene | ® VERSON NUMBER const 2
> [=Inc 5 * @attention @ cCRC_NUMBER : const uint32_t
v (= Src g | = ® “BUILD_ID : const uint16_t
; %:t‘:;:fhx halmsp.c 9 ‘ <h2><center>&copy; Copyright (c) 2019 STMicroelectronics. : SD;?::;:E:::;;:
- 10 * All rights reserved.</center></h2> N . -
> [ stm32faxx_itc 1o ++ SystemClock_Config(void) : void
> [¢ syscalls.c 12 * This software component is licensed by ST under BSD 3-Clause license, #+° MX_GPIO_Init(void) : void
> @5)’55"”"-5 13 * the "License"; You may not use this file except in compliance with the HSMX—USARTZ»UARTJ“i(("“id):V°“3
> @5)’5"‘9"“ 14 * License. You may obtain a copy of the License at: ® ip:int
> [£] system_stm32f4xx.c 15 * opensource.org/licenses/BSD-3-Clause ® ramx:int
> (= Startup 16 * ® mylP_read() : int
> &3 Drivers 17 R R K R K K © myRAM_read(): int
> (= Debug 18 */ ® _binary_data_start : int
> (z=Debug2 19 /* USER CODE END Header */ @ _write(int, char*, int) : int
v (= Release 20 @ main(void) : int
> (= Core 21 /% INCIUdeS - - - oo -ooooo oo oo oo oooooooooooooooooooooooo- ® SystemClock_Config(void) : void
> (= Drivers 22 |ginciudeggnanEhg © ¥ MX_USART2_UART_Init(void) : voic
> %5 NUCLEO-FAOTRE.elf - [arm/le] 23 #include <malloc.h> v ® S MX_GPIO_Init(void) : void v
[ & makefile < > < >
gzﬂgtigi:gmiﬁp [0 Problems & Tasks & Console 52 [ Properties = B[S Build Analyzer £ Static Stack Analyzer [ History &2 =
] objectslist #E-- S - D EEE
| & objects.mk No consoles to display at this time. main.c
| & sources.mk Revision Time
[FINUCLEO-F401RE €lf.cfg B 9/24/19, 3:51 PM
NUCLEO-F401REelflaunch E 9/24/19, 1:57 PM
[ NUCLEO-F401RE.ioc & 9/20/19, 2:54 PM
readme.txt
@ STM32F401RETX_FLASH_IPCodelnFlash.ld
|1 STM32F401RETX_FLASH_ORG.Id v
| Wiitable ' Overwrite 2:18:802 - : a

In the case presented in Figure 40, there are three revisions of main.c. Double-click on a file in the History view to
open it in the editor.
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Right-click on a file in the history and select [Compare Current with Local] to compare it with the current version

of the file.

Figure 41. Compare current history with local history

mworkspace,um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

NS - R B NGDE [T E it i®my
B% Y-8

5 Project Explorer i2
> [ mylLib
v [ NUCLEO-F401RE
> 4% Binaries
> mllincludes
v (£ Core
> [=Inc
v = Src
> [€] mainc
> [i£] stm32f4xx_hal_msp.c
> [ stm32fdxc_itc
> [g] syscalls.c
> [ sysconf.c
> [£] sysmem.c
> g system_stm32fdxx.c
> (= Startup
> [ Drivers
> (= Debug
> (= Debug2
v (= Release
> [=Core
> (= Drivers
> %5 NUCLEO-F401RE.elf - [arm/le]
[ & makefile
[/ NUCLEO-F401RE list
|2 NUCLEO-F401RE.map
El objects.list
| & objects.mk
| & sources.mk
[FINUCLEO-F401RE €lf.cfg
NUCLEO-F401RE.elflaunch
[ NUCLEO-F401RE.ioc
readme.txt

@ STM32F401RETX_FLASH_IPCodelnFlash.ld

|1 STM32F401RETX_FLASH_ORG.Id

[€] main.c 2 =8
1 /* USER CODE BEGIN Header */ ~
20 /**

3 *oRkk K * ok
4 * @file : main.c

5 * @brief : Main program body

6 B T L B T T
7 * @attention

8 *

9 * <h2><center>&copy; Copyright (c) 2019 STMicroelectronics.

10 * All rights reserved.</center></h2>

11 =

12 * This software component is licensed by ST under BSD 3-Clause license,
13 * the "License"; You may not use this file except in compliance with the
14 * License. You may obtain a copy of the License at:

15 * opensource.org/licenses/BSD-3-Clause

16 *

17 K KKK K KKK K KR KK K KR K KRR
8 */

19 /* USER CODE END Header */

20

21 /* Includes -------m oo oo oo

22 #?nclude "main.h" © ¥ MX_USART2_UART_Init(void) : voic
23 #include <malloc.h> v ® S MX_GPIO_Init(void) : void ©

< > < >

182 Problems ] Tasks B Console 22 [ Properties = Build Analyzer == Static Stack Analyzer [ History ©% =
#E- SEH - P B

No consoles to display at this time.

IRIE g~ Fl-CE-D 20

main.c

- ] X

| Quick Access | {6 @i %6

5= outline &2 @ Build Targets  — O

BV o % ¥
® mainh ~
M malloch
@ huart2 : UART_HandleTypeDef
® © VERSION_NUMBER : const uint32..
® © CRC_NUMBER : const uint32_t
® ©BUILD_ID : const uint16_t
® Distance : uint32_t
® Seconds: uint32_t
++ SystemClock_Config(void) : void
-+ MX_GPIO_Init(void) : void
++9 MX_USART2_UART Init(void) : voic
® ip:int
® ramx:int
@ mylP_read() : int
® myRAM_read() : int
@ _binary_data_start : int
® _write(int, char, int) : int
@ main(void) : int
® SystemClock_Config(void) : void

Revision Time
E 9/24/19, 3:51 PM
B 9/24/19, 1:57 PM
B 9/20/19, 2:54 PM

Open
Open With >
Compare Current with Local

Get Contents
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This opens the File Differences editor and displays the file changes.

Figure 42. Compare local file differences

mworkspace,um1 - Compare /NUCLEO-F401RE/Core/Src/main.c Current and Local Revision - STM32CubelDE - [m] X
File Edit Source Refactor Navigate Search Project Run Window Help
N EHR® R @ NQGE S GG iR i@y IRE T CEy O OIELR Quick Access ] 5 |[El4+ [ €8
5 Project Explorer i2 & Y =0 [ maine £ Compare main.c Current and Local Revision % = O Bz outline 2 @ Build Targets ~ — O
> [l myLib ~ | g ccompare v
v m':‘lJCLEO'MMRE v [g Translation Unit There is no active editor that provides an
; *B%IB'"IETS ® main outline.
ncludes
v (£ Core
> [=Inc
Vv [=Src
> [ main.c €] € Compare Viewer ¥
> tm32f4xx_hal X
(6 stm32fdsac hal mep.c DM (<=l <=1/ 45 2 43 B
> [g] stm32fdxx_itc
> [@ syscallsc Local: main.c Local history: main.c Sep 20, 2019, 2:54:18 PM
> @ sysconf.c 171 /* USER CODE END SysInit */ 171 /* USER CODE END SysInit */ ~
> [8 sysmemc 172 172
> [6] system_stm32fdxx.c 173 /* Initialize all configured peri 173 /* Initialize all configured
N Bsmz; N ) 174  MX_GPIO_Init(); 174  MX_GPIO_Init();
s Bom P [R¥EY#ifdef TEST_MALLOC 175 MX_USART2_UART_Init();
< onivers E¥E  My_mem3=malloc(12); 176 /* USER CODE BEGIN 2 */ -
7 & Debug E%d My_mema=malloc(12); 177 =
7 EBDEb”gz W) My _mem5=malloc(12); 178 mem=malloc(12);
v & Release f¥] My_memé=malloc(12); 179  mem2=malloc(12);
? (&= Core JEL]  My_mem7=malloc(12); 180 #ifdef OLD
7 (= Drivers [k endif 181 mem3=malloc(12);
> %5 NUCLEO-F401RE.elf - [arm/le] 182 182 memd=malloc(12): v
[ & makefile & > < >
=/ NUCLEO-F401RE.list — = =
gNUCLEO—MmRE.:ap 182 Problems £ Tasks EJ Console 32 [ Properties B [ Build Analyzer == Static Stack Analyzer [ History 53 |
] objectslist #E-- SE= - |P BT
| & objects.mk No consoles to display at this time. main.c
| & sources.mk Revision Time
[FINUCLEO-F401RE €lf.cfg 5 9/24/19, 3:51 PM
NUCLEO-F401RE.elf.launch B 9/24/19, 1:57 PM
[ NUCLEO-F401RE.ioc 5 9/20/19, 2:54 PM
readme.txt
@ STM32F401RETX_FLASH_IPCodelnFlash.ld
|1 STM32F401RETX_FLASH_ORG.Id v
Left: 185 : 1, Right: 175 : 1, incoming deletion #1 (Left: 175 : 184, Right: before line 175) H i Statue offline =
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2 Project set up and build

2.1 Create and import C/C++ projects

As mentioned in Section 1.6: Workspaces and projects, a workspace is a directory containing projects. The first
time a workspace is created, it is empty without any projects. The projects must be created or imported in the
workspace. This section contains information on how to create projects in the workspace and build projects. It
also covers how to import and export projects.

211 Introduction to projects

A project is a directory in the workspace containing files that may be organized in sub-directories. It is possible to
access any project within the active workspace. The files included in a project do not need to be physically
located in a folder in the project but can be located somewhere else and linked into the project. Projects located in
another workspace cannot be accessed, unless the user switches to that workspace or import some of these
projects into the workspace in use.

It is possible to rename and delete a project. If a workspace contains many projects, it is also possible to close
some of them to make the work easier. Closed projects can be reopened again at any time.

This section focuses on the two types of STM32 projects supported by STM32CubelDE:

. Executable programs

. Static library projects

However, the EcIipse® C/C++ Development Toolkit (CDTT"'), which STM32CubelDE is based on, contains also
basic project wizards, which can be used to create C managed build, C++ managed build, and makefile projects.
The STM32 projects can be:

. Cor C++

. Generated executable or library file

. Based on STM32Cube (using STM32 firmware library package) or empty projects

STM32 projects also support an advanced umbrella project structure, where one project contains many projects,
for instance one project per core for multi-core devices.

21.2 Creating a new STM32 project

2.1.2.1 Creating a new STM32 executable project

The easiest way to create a new STM32 C/C++ project is to use the STM32 project wizard. It is selected through
the menu [File]>[STM32 Project Create/Import].

Another way to create a new C/C++ project is to open the Information Center and press [Create/Import STM32
Project]. As mentioned in Section 1.3: Information Center, the Information Center can be opened using the
button on the toolbar or via the menu [Help]>[Information Center].
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Figure 43. STM32 target selection

[[ sTM32CubelDE Empty Project O b4

Create STM32CubelDE Empty Project

Select device to start project creation

MCU/MPU Selector Board Selector

Found ltems: 2684 No device is selected
Mecu Name filter:  Search
[Reterence ——Jcore ——|vadage _Fah fam |
Series: ™ STM32C011D6Yx Arm Cortex-M@plus WLCSP12 32 KBytes 6 KByttI
Core: . STM32C011F4Px Arm Cortex-Meplus TSS0P2@ 16 KBytes 6 KByte
STM32C011F4Ux Arm Cortex-Méplus UFQFPN2@ 16 KBytes 6 KByte
STM32C011F6Px Arm Cortex-M@plus TSSOP2@ 32 KBytes 6 KByte
STM32C011F6Ux Arm Cortex-Méplus UFQFPN2@ 32 KBytes 6 KByte
STM32C011J4Mx Arm Cortex-M8plus SO8N 16 KBytes 6 KByte
STM32C011J6Mx Arm Cortex-M@plus SO8N 32 KBytes 6 KByte
STM32C031C4Tx Arm Cortex-M8plus LQFP48 16 KBytes 12 KByl
STM32C031C4Ux Arm Cortex-M@plus UFQFPN4E 16 KBytes 12 KByt
STM32C031C6Tx Arm Cortex-M8plus LQFP48 32 KBytes 12 KByl
STM32C031C6Ux Arm Cortex-Meplus UFQFPN48 32 KBytes 12 KByl
@ < Back Next > Finish Cancel

Use either the MCU/MPU Selector or the Board Selector tab and select the desired target to create an empty
project. Use the first tab to create a project for a specific device and the second if a project for a specific board is
needed.

In the MCU/MPU Selector, users can filter by series and core, while in the Board Selector, filtering is available by
series and type.

Pressing [Next] when any board is selected opens the Project setup page. Enter a project name and select the
desired setting for the project in the dialog boxes.
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Figure 44. Project setup

[[]] STM32CubelDE Empty Project O X

e Empty project name is not supported

Project

Project Name: |

@ Use default location

Location: C:/Users/ /STM32CubelDE/workspace_2.0.0.25A1 Browse

Options
Targeted Language

Oc Oc++

Targeted Binary Type
O Executable () Static Library

@ < Back Next > Finish Cancel

According to the settings in Figure 44, the project is meant to be stored in the default location with the following
options set:

. C project
. Executable binary type
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2.1.2.2 Creating a new STM32 static library project

The method described in Section 2.1.2.1: Creating a new STM32 executable project can be used also to create a
static library project, which simplifies the configuration of hardware or software components by the designer.

Figure 45. STM32 static library project

[ STM32CubelDE Empty Project m] X

o Empty project name is not supported

Project

Project Name:

B Use default location

Location: C:/Users/ /STM32Cubel DE/workspace_2.0.0.25A1 Browse...

Options
Targeted Language

OC QC++

Targeted Binary Type
() Executable © static Library

@ < Back Next > Finish Cancel

2.1.2.3 Creating a new CDT™ project

Eclipse®CDT™ projects can be used instead of the normal STM32 project wizard to produce both executable and
static library project types. Static libraries are often reused in multiple application projects, possibly targeting
different STM32 products per build configuration, with full control over both the source code and the build system.
The STM32 project wizard does not support changing the MCU or MPU device.

The recommended way to create static library projects is therefore to rely on Eclipse®/CDT™ projects as
described below.

Furthermore, it is possible to take advantage of both ways of project creation as a general recommendation for
flexibility. Since, for the CDT™ project, the user must add all the files manually, it is interesting to rely on an
STM32Cube project as a basis for prototyping and learning and to use a CDT™ project for production. The most
efficient way is to keep both projects side by side in the same workspace to bring efficiently the new
configurations and files from the STM32Cube project into the CDT™ project.
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To create an Eclipse®/CDT™, go to [File]>[New]>[C/C++ Project]. This opens the window displayed in Figure 46.

Figure 46. New C/C++ project

m New C/C++ Project a x

Templates for New C/C++ Project

C Managed Build
Make @ A C Project build using the CDT's managed build system.

C++ Managed Build
@‘ A C++ Project build using the COT's managed build system.

Makefile Project
@‘ (Experimental) Create a new project that builds with the'make’ build tool using CDT's new Core Build System.

@ < Back Next > Finish Cancel

Select either C Managed Build or C++ Managed Build depending on what the project requires and click on [Next].

This brings up the project type selector. The Empty Project type is the only type supporting the MCU ARM GCC
toolchain. Make sure to select Empty Project under the Executable folder and then select the MCU ARM GCC
toolchain as seen in Figure 47.
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Once the project naming and type selection are done, click on [Next].

Figure 47. Project type

10E| O X

- <>
C Project F

1= !
Create C project of selected type

Project name: ‘ MyProject |
Use default location
Location: | LA smisyluzlium\STM32CubelDEWworkspace_1.12.0\MyProject Browse...

Choose file system: |default

Project type: Toolchains:

v (= Executable

& Empty Project

@ Hello World ANSI C Project
* = Shared Library
~ (= Static Library

® Empty Project

v o Maleafila mrainct v

~ Craoss GCC
Cygwin GCC
MCU ARM GCC

Show project types and toolchains only if they are supported on the platform

< Back

@ e

There is also another way to create a new CDT™ project: Go to [File]>[STM32 Project Create/lmport]. This
opens the window displayed in Figure 48.
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Figure 48. Create/lmport STM32 CDT™ project

[l Create / Import STM32 Project O X

Select

Wizards:

» & Create New STM32 Project
2 5TM32CubelDE Empty Project
B C++ Project
[ C Project
[0 STM32 CMake Project
v &= Import STM32 Project
[ STM32CubeMX/STM32CubelDE Project
& Makefile Project
& Ack Systern Workbench for STM32 Project
Bl Atollic TrueSTUDIO Project
[0 STM32 CMake Project
£ Debug via elf-file import

) < Back Mext = Finish Cancel

Select either [C Project] or [C++ Project] depending on what the project requires and click on [Next].
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Both creation ways launch a standard Eclipse® project configuration window as shown in Figure 49. Click on
[Next].

Figure 49. Project configuration selection

10E] O X

Select Configurations Jl_-‘c’
(=l
Select platforms and configurations you wish to deploy on

Project type:  Static Library
Toolchains: Cross GCC

Configurations:

® Debug ‘

Select all ‘
¥ Release

‘ Deselect all ‘

‘Advanced settings... ‘

Use "Advanced settings” button to edit project's properties.

Additional configurations can be added after project creation.
Use "Manage configurations" buttons either on toolbar or on property pages.

@) < Back ‘l MNext > Finish Cancel
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In the target selector screen shown in Figure 50, make sure to select the appropriate target by clicking on the
[Select...] button and filtering the correct target for the project. The target selector helps to set the
-mcpu=cortex-mX toolchain flag correctly in the already defined build configurations seen in the previous step
(see Figure 49).

Figure 50. Project default target selector

0] o X

Select default target for the project | "
The selected target can be changed, per build configuration, later o

mcu:| | [seleet..]

CPU: | |

Core: | ~
@ < Back Next > Einish Cancel
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When clicking on [Select...], the filter dialog shown in Figure 51 shows up, allowing users to filter and select the
correct device.

Figure 51. Project MCU/MPU selector

[I3 Mcu/MPU Selector O X

Please select your STM32 target device

STM32F407

MCU/MPU
STM32F407IEHx
STM32F407IETx
STM32F4071GHx
STM32F407IGTx
STM32F407VETx

. STM32F407VGTx
STM32F407ZETx
STM32F407ZGTx

@ OK | ‘ Cancel
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After the target selection (MCU), the CPU and Core fields are automatically populated in the simple single-core
case as shown in Figure 52.

Figure 52. Project target selection

ing| u| X

Select default target for the project |

The selected target can be changed, per build configuration, later

MCU:| STM32F407VGTx [Select...

CPU: Cortex-M4 (0)
Core: 0

@ | <Back Met> [ Bsh ] Cancel

For more advanced devices such as multi-core STM32H7 microcontrollers, the user must select the CPU and
Core that the project targets to make sure that the code is built correctly. These settings are also used later to set
up the debug configurations properly. Make sure that the settings are as needed for the project and click on

[Finish].
Figure 53. Project target selection (advanced)
ot} o x

Select default target for the project |
The selected target can be changed, per build configuration, later '

ML STM32HTALZITx

CPLE

Care: [COTtex-M7 () |
Cortex-hd (1)

i/ < Back Mot > Einish Cancel
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After the project creation, it is possible to create different build configurations for different targets as described in
Section 2.3.2.1.2. After a new build configuration is created, right-click the project in the Project Explorer, go to
[Properties]>[C/C++ Build]>[Settings]>[Tool Settings]>[MCU Settings], and click on [Select...] to select a new
target for the specific build configuration.

Figure 54. Project target change

[ properties for myLib a X
type.fiiten text Settings Hw v f
> Resource

Builders . i Beb i = -
v C/C++ Build Configuration: ug [ Active ] Manage Configurations...
Build Variables
Environment ® Tool Settings # Build Steps * Build Artifact [ Binary Parsers @ Error Parsers
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2.1.24 Creating a new CMake project

STM32CubelDE supports CMake, another way to build a user's application. Building a CMake project is done in
three steps:

1. The first step is the creation of the project itself. STM32CubelDE offers several possibilities, such as creating it
from scratch or deriving its structures from an existing CMake project.

2. The second step is the project configuration, during which the cMakeLists. txt build scripts are executed.

3. Ultimately, once the configuration is complete, STM32CubelDE can generate build scripts native to the host
platform.
For detailed information, refer to [ST-15].
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21.3 Importing existing projects

This section describes different ways to import existing projects into an STM32CubelDE workspace. The standard
Eclipse® importer is capable of importing Eclipse® projects. This is used to import projects created with
STM32CubelDE. The project importer is also extended to support the import of ac6é System Workbench for
STM32 projects and Atollic® projects. Such projects are converted during the import phase to STM32CubelDE
projects.

It is possible to import and debug an existing e1£ file developed by another IDE or toolchain. More information on
how this is done is available in Section 3.1.9.

2.1.3.1 Importing an STM32CubelDE project

A project can be imported in many different ways. This section shows how to import a project that was exported
as a compressed zip file.

. One way to open the Import dialog is to use the menu [File]>[Import...] or the menu [File]>[STM32
Project Create/lmport] (see Figure 55 and Figure 56)
. Another way is to select [Create/Import STM32 Project] in the Information Center (see Figure 57)

Figure 55. Import project
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[@ STM32 Project Create/Import
New Alt+Shift+N >
Open File...
. Open Projects from File System...

Recent Files >

Close Editor Ctrl+W
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Move...

Rename... F2
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Convert Line Delimiters To >

Print... Ctrl+P

E

Import...
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[

Properties Alt+Enter

Switch Workspace >
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Figure 56. Import dialog

3 impart O x
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Figure 57. Import STM32 project from the create/import menu

[ Create / Import STM32 Project ] X
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£ C++ Project
[ C Project
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[0 STM32 CMake Project
B Debug via elf-file import

i) < Back MNext = Finish Cancel

The user must choose [Select root directory] or [Select archive file]. If the chosen option is [Select root
directory]:

1. Click on the [Browse...] button.

2. Locate project Files: Navigate to the folder containing the .project and .cproject files. Once located,
click [Select Folder].

3. Review the detected projects: STM32CubelDE lists the projects found in the selected directory.
4. Choose and import: Select the project to import from the list and click [Finish] to complete the process.
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Figure 58. Import projects from the root directory

m Import O oy
Import Projects L
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Figure 59. Import projects from an archive file

[ import O X
Import Projects
Select a directory to search for existing Eclipse projects. /4
O select root directory: A Browse...
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Working sets
] Add project to working sets New...
Working sets: &7 Select...
@ < Back Next > Finish | ‘ Cancel

2.1.3.2 Importing System Workbench and TrueSTUDIO projects

To import an ac6 System Workbench for STM32 project or an Atollic® TrueSTUDIO project into STM32CubelDE,
it is advised to work on a project copy:

1. Create a copy of the project, either as a copy of the project folder or an export of the project in a zip file
2. Use the copied project for the import into STM32CubelDE

The way to import the copied project is to open the Import dialog by means of the menu [File]>[ STM32 Project
Create/lmport ] or by right-clicking the Project Explorer view.
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Select [Import acé System Workbench for STM32 project] or [Import Atollic TrueSTUDIO project] depending
on the original tool used to create the project and press [Next >].

Figure 60. Import System Workbench projects (1 of 3)
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In this example, the ac6 project is copied into the STM32CubelDE workspace, hence the [Directory...] button is
used and project STM32F401_Ac6 is selected. The import wizard detects that this is a System Workbench
project.

Figure 61. Import System Workbench projects (2 of 3)

m Import Projects from File System or Archive O X

Import Projects from File System or Archive
This wizard analyzes the content of your folder or archive file to find projects and import them in the IDE. @

Import source: | C:\Users\johansse\STM32CubelDE\workspace_um1\STM32F401_Ac6 V[ Directory.. | Archive..

‘ type filter text ‘ Select All

Folder Import as Deselect All
] _Ac onvert 'System Workben...
[ sTM32F401_Ac6 C ‘Sy: Workb

1 of 1 selected
[JHide already open projects
[ Close newly imported projects upon completion
Use installed project configurators to:
Search for nested projects
Detect and configure project natures
Working sets
[JAdd project to working sets New...

Working sets: 7 Select...

Show other specialized import wizards

@ < Back Next > Finish Cancel

Press [Finish] to open the Project converter dialog.

Figure 62. Import System Workbench projects (3 of 3)

[T project converter X

@ This project requires a conversion in order to be used with STM32CubelDE.
Project-files are automatically backed-up (.project_org/.cproject_org) in project root folder before
conversion.

Convert project STM32F401 to an STM32CubelDE project?

| OK | ‘ Cancel

Press [OK] to convert the project to an STM32CubelDE project.

There are two migration guides explaining how to migrate from ac6 System Workbench for STM32 ([ST-06]) and
Atollic® to STM32CubelDE ([ST-05]). These guides can be opened from the Technical Documentation page in
the Information Center.
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2.1.3.3 Importing using project files association
When STM32CubelDE is started, a pop-up window asks if .cproject and .project files must be associated to
the program.

Figure 63. Import using project files association

[L override.. X

@ The .project file extension is currently associated to another STM32CubelDE installation
(CAST\STM32CubelDE_1.1.0.19w38_targetplatform_2019-09\STM32CubelDE\stm32cubeide.exe).
Would you like to associate the .project files to the STM32CubelDE instance in use?

[JrRemember my decision

Yes | ‘ No

If the association is selected, double-clicking on a .project file in the personal computer file browser triggers the
project import by STM32CubelDE into the current workspace. The project converter investigates the project,
which is imported directly if made for STM32CubelDE. If the project comes from another tool, the project
converter tries to identify if it is a known project format and, in such case, converts the project to an
STM32CubelDE project as described in Section 2.1.3.2: Importing System Workbench and TrueSTUDIO projects.

2.1.3.4 Prevent “GCC not found in path” error

When importing old projects, an error in the Problems view can state “Program “gcc” not found in PATH”. The

error is caused by the project use of a deprecated discovery method setting. The error can be removed by

updating the Window Preferences and Project Properties settings.

1. Open [Window]>[Preferences]. In the Preferences dialog, select [C/C++]>[Property Pages Settings] and
enable checkbox [Display “Discovery Options” pagel].

2. Open [Project Properties]>[C/C++ Build]>[Discovery Options] and disable checkbox [Automate discovery
of paths and symbols].
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2.2 Edit C/C++ projects

2.21 Linking the project

This section contains basic information about the linker and linker script files. Detailed information about the linker
can be found in the GNU Linker manual ([EXT-05]), which is accessed from the Information Center. Click on the

[Information Center] toolbar button B ang open the Information Center view. Open the linker documentation
using the [C/C++ Linker The GNU Linker PDF] link.

Figure 64. Linker documentation
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2.2.1.1 Run time library

The toolchains included in STM32CubelDE contain two prebuilt run time C libraries based on newlib. One is the
standard C newlib library and the other is the reduced C newlib-nano. Use newlib-nano to achieve smaller
code size. For information about the differences between newl ib-nano and the standard newlib, refer to the
newlib-nano readme file ([ST-09]), accessible from the Information Center.

To select the desired run time library for use in the project.

1. Right-click on the project in the Project Explorer view

2. Select menu [Project]>[Properties]

3. Select [C/C++ Build]>[Settings] in the Properties panel

4. Open the Tool Settings tab, select [MCU Settings] and configure the [Runtime library] setting

Figure 65. Linker run time library
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When newlib-nano is used while floating-point numbers must be handled by scanf/printf, additional options
are required. The reason is that newlib-nano and newlib handle floating-point numbers differently. In
newlib-nano, formatted floating-point number inputs and outputs are implemented as weak symbols. Therefore,
the symbols must be pulled by specifying explicitly if % is used with scanf/printf using the —u option:

* -u scanf float

. -u _printf float
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For example, to enable output f1oat with printf, the command line is as follows:
$ arm-none-eabi-gcc --specs=nano.specs -u _printf float $(OTHER LINK OPTIONS)
The options can be enabled using the [Use float ...] checkboxes in [MCU Settings] in the Tool Settings tab.

Figure 66. Linker newlib-nano library and floating-point numbers
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2.2.1.2 Discard unused sections

Linker optimization is the process where the linker removes unused code and data sections, dead code, from the
output binary. Run time and middleware libraries typically include many functions that are not used by all
applications, thus wasting valuable memory unless removed from the output binary.

When using the project wizard to create new projects, the default configuration is that the linker discards unused

sections. To check or change the setting about unused sections, open at any time the build settings for the
project:

Right-click the project in the Project Explorer view and select [Properties]
In the dialog, select [C/C++ Build]>[Settings]

Select the Tool Settings tab in the panel

Select [MCU GCC Linker]>[General]

Configure [Discard unused sections (-WI,--gc-sections)] according to the project requirements
Rebuild the project

o0 wN =

Figure 67. Linker discard unused sections
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2.2.1.3 Page size allocation for malloc
When the GNU Tools for STM32 toolchain is used with the standard C newlib library, the page size setting for
malloc can be changed. The newlib default page size is 4096 bytes. If a sysconf () function is implemented
in the user project, this user function is called by malloc r ().

The following example shows how to implement a sysconf () function with a 128-byte page size. Add a similar
function if there is a need for the application to use a smaller page size than the default 4096 bytes.

/**

Rk h h h kb b b b b b b b S b bk b R

**  File : sysconf.c
Rk kb b bk b b b h S b bk i R b
**/

/* Includes */
#include <errno.h>
#include <unistd.h>

long sysconf (int name)

{
if (name== SC_PAGESIZE)
{

return 128;

}

else
{
errno=EINVAL;
return -1;
}
}

Note: If the “GNU ARM Embedded” toolchain is used, it does not call any sysconf () function implemented in the
application but always uses the default sysconf () function in newlib. Also, no call to sysconf () is made if
the “GNU Tools for STM32” toolchain is used with the reduced C newlib-nano library.
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2.2.14 Include additional object files

STM32CubelDE makes it easy to include additional object files that must be linked to a project. They can be files

from other projects, precompiled libraries where no source code is available, or object files created with other
compilers.

1. Right-click the project in the Project Explorer view and select [Properties]

2. In the dialog, select [C/C++ Build]>[Settings]
3. Select the Tool Settings tab in the panel
4. Select [MCU GCC Linker]>[Miscellaneous]
5. Use the [Add...] icon to add additional object files in several possible ways:
- Enter the filenames in the Add file path dialog
- Use the [Workspace...] or [File system...] buttons to locate the files
Figure 68. Linker include additional object files
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2.2.1.5 Treat linker warnings and errors
The GNU linker is normally silent for warnings. One example of such silent warning is seen if the startup code
containing the normal Reset Handler function is missing in the project. The GNU linker in normal silent mode
creates an e1f file and only report a warning output in the Console window about the missing Reset Handler.

Example of warning message:

arm—-none-eabi-gcc -o "NUCLEO-F401RE.elf" @"objects.list" -mcpu=cortex-m4
-T"C:\Users\username\STM32CubeIDE\workspace um\NUCLEO-

F401RE\STM32F401RETX FLASH.1ld" --specs=nosys.specs -Wl,-Map="NUCLEO-F401RE.map"
-Wl,--gc-sections -static -mfpu=fpv4-sp-dl6e -mfloat-abi=hard -mthumb -Wl,--start-
group -lc -lm -Wl,--end-group

c:\st\stm32cubeide 1.1.0.19w37\stm32cubeide\plugins\com.st.stm32cube.ide.mcu.extern
altools.gnu-tools-for-stm32.7-2018-g2-update.win32 1.0.0.201904181610\tools\arm-
none-eabil\bin\ld.exe: warning: cannot find entry symbol Reset Handler; defaulting
to 0000000008000000

Finished building target: NUCLEO-F40lRE.elf

In this case, a new e1f file is created but, if the warning is not detected, it does not work to debug the project
because the program does not contain the Reset Handler function. It is possible to configure the linker to treat
warnings as errors by adding the --fatal-warnings option.

When the --fatal-warnings option is used, the linker does not generate the <1 file but displays an error in
the console log:

c:\st\stm32cubeide 1.1.0.19w37\stm32cubeide\plugins\com.st.stm32cube.ide.mcu.extern
altools.gnu-tools-for-stm32.7-2018-g2-update.win32 1.0.0.201904181610\tools\arm-
none-eabi\bin\ld.exe: warning: cannot find entry symbol Reset Handler; defaulting
to 0000000008000000

collect2.exe: error: 1ld returned 1 exit status
make: *** [makefile:40: NUCLEO-F401RE.elf] Error 1
"make -j4 all" terminated with exit code 2. Build might be incomplete.

11:26:30 Build Failed. 1 errors, 6 warnings. (took 7s.193ms)
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To use the -W1, --fatal-warnings option:
1. Right-click the project in the Project Explorer view and select [Properties]

2. In the dialog, select [C/C++ Build]>[Settings]
3. Select the Tool Settings tab in the panel
4. Select [MCU GCC Linker]>[Miscellaneous]
5. Add -w1l, --fatal-warnings to the [Other flags] field.
Figure 69. Linker fatal warnings
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2.2.1.6 Linker script

The linker script file (. 1d) defines the files to include and where things end up in memory. Some important parts of
the linker script file are described in the next sections. For detailed information about the linker, read the C/C++
linker GNU Linker manual ([ST-05]). This manual is available in the documentation section of the Information
Center. Consider sections 3.6 and 3.7 especially.

The linker script specifies the memory regions and the location of the stack, heap, bss, data, rodata, text, and
program entry. The size of stack and heap are configurable by editing the Min Stack Size and

~Min Heap Size values in the linker script file. However, these values are only used by the linker to validate
that stack and heap fit in memory. When running the program, the stack or heap may require more memory, which
may lead to unexpected results if data is overwritten.

Table 3 presents as an example the typical program and memory layout of an STM32F4 device with 512-Kbyte

flash memory and 96-Kbyte SRAM. The device is based on the Cortex®-M core with 32-bit address space
(0x0000 0000 to OXFFFF FFFF).
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Example: STM32F4
96-Kbyte SRAM

512-Kbyte flash memory

Table 3. Memory map layout

Files

Linker script . 1d,
or .h and .c files

Comment

OXFFFF FFFF

0xE000 0000
OXDFFF FFFF

0x6000 0000
OX5FFF FFFF

0x4000 0000
0x2001 8000

0x2000 0000

0x0808 0000

0x0800 0000

Cortex®-M4 internal
peripherals.

External memory
FMC (Flexible
memory controller).

STM32 peripherals.

96-Kbyte SRAM
Stack

Heap

Data

512-Kbyte
flash memory
Data

Program

Interrupt
vector table

.hand .c files.

Must be added in linker script,

and .h and .cfiles.

.hand .c files.

Linker script
_estack
_Min Stack Size

_Min Heap Size
. _user heap stack

.bss

.data

Linker script
.data
.rodata

ENTRY
Reset Handler®
.text

.isr vector®

SysTick, NVIC, ITM, debug, and others.

NOR flash memory, NAND flash memory, SPI flash
memory, PSRAM, SDRAM, and others.

GPIO, ADC, timers, USB, USART, and others.

The stack contains local data'®

@)

Heap used by malloc)
Data

Static global data (.bss and .data)
.bss == Uninitialized data
Cleared to zero by the startup code.

.data == Initialized data
Copied from flash memory to SRAM by the startup code.

Initialized data to copy to SRAM.

Read-only data placed in flash memory.

.text == Program,suchasmain () inmain.c,
SystemInit () in system stm32f4xx.c,

Reset Handlerin startup_stm32*.s,

g _pfnVectorsin startup stm32*.s,

Vector table in startup stm32*.s.

Color legend

Cortex®-M internal peripherals and STM32 peripherals.

External memory. Normally the linker script, header files, and C files must be updated to use external memories.

Flash memory and SRAM where program, data, heap, and stack are located. Usually, when creating a project with STM32CubelDE, these
flash memory and RAM regions are accessible and usable without any updates of the linker script or other files. The linker script file defines
how to place code, data, heap, and stack in memory.

1. If external memory is used, the memory must be added into the linker script file. See in chapter Section 2.2.1.7.1 how to add a new memory

region.

S A W N

The stack grows downwards and may go into the heap.
When running the program, the stack or heap may require more memory, which might lead to unexpected results if data is overwritten.
The heap grows upwards and may go into the stack.

The linker script file contains the entry point definition of the program. Normally, ENTRY (Reset Handler).
The interrupt vector table contains the reset value of the stack pointer, the start addresses of the program (Reset Handler), exception

handlers, and interrupt handlers. Normally the Reset Handler code and vector table (g _pfnVectors) are available in file <startup st
m32xxx.s>.
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See below the default linker script generated by STM32CubelDE for an STM32F4 device with 512-Kbyte flash
memory and 96-Kbyte SRAM.

The beginning of the code excerpt shows the linker script header, entry, stack, heap and memory definitions.

/**

Ak khkhkhkhkhkh A hkhkhhhAhhhh A hkhhh Ak h kb bk hhrhhhhhh bk hhrh bk hhrhhkhhrhhkhhrhhkhkhrhhkhkdrhkhkhkhrhhrkx

* @file LinkerScript.1ld

* @author Auto-generated by STM32CubeIDE

* Abstract : Linker script for NUCLEO-F401RE Board embedding STM32F401RETx Device from s

tm32f4 series
512Kbytes FLASH
96Kbytes RAM

Set heap size, stack size and stack location according
to application requirements.

Set memory bank area and size if external memory is used
Ak Kk kA hkhkhkh A hhhh A hhhh A hhkhh Ak hhh A hhkhkh Ak hhh Ak hhkrkh Ak hhrhhhkhkhkrhhkhkhkrhhhkdkrhkhkhkhkrhkhkhkhrhxkr*k

Qattention

<h2><center>&copy; Copyright (c) 2020 STMicroelectronics.
All rights reserved.</center></h2>

This software component is licensed by ST under BSD 3-Clause license,

the "License"; You may not use this file except in compliance with the

License. You may obtain a copy of the License at:
opensource.org/licenses/BSD-3-Clause

S T T S S S S S S S

*
LRSS RS SR RS E RS EE RS TR RS EE R T EE SRR SRR R SRR SRR EEEEEEEEEEEEEEEEEEEEEEEEEEE S S

*/

/* Entry Point */
ENTRY (Reset Handler)

/* Highest address of the user mode stack */

_estack = ORIGIN (RAM) + LENGTH (RAM) ; /* end of "RAM" Ram type memory */
_Min Heap_Size = 0x200; /* required amount of heap */
_Min Stack Size = 0x400; /* required amount of stack */

/* Memories definition */

MEMORY

{
RAM (xrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K

}

The continuation of the code excerpt shows the definition of sections.

/* Sections */
SECTIONS
{
/* The startup code into "FLASH" Rom type memory */
.isr vector
{
= ALIGN (4);
KEEP (* (.isr vector)) /* Startup code */
= ALIGN (4);
} >FLASH

/* The program code and other data into "FLASH" Rom type memory */

.text
{
= ALIGN (4) ;

* (.text) /* .text sections (code) */
* (.text*) /* .text* sections (code) */
*(.glue_ 7) /* glue arm to thumb code */
* (.glue 7t) /* glue thumb to arm code */
*(.eh frame)
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KEEP (*(.init))
KEEP (*(.fini))
= ALIGN (4) ;
_@text = ¢ /* define a global symbols at end of code */
} >FLASH

/* Constant data into "FLASH" Rom type memory */

.rodata
{
= ALIGN (4) ;
*(.rodata) /* .rodata sections (constants, strings, etc.) */
*(.rodata%*) /* .rodata* sections (constants, strings, etc.) */
= ALIGN (4) ;
} >FLASH
.ARM.extab g {
= ALIGN (4) ;
*(.ARM.extab* .gnu.linkonce.armextab.*)
= ALIGN (4) ;
} >FLASH
.ARM : {
= ALIGN (4) ;
__exidx _start = .;
*(.ARM.exidx*)
__exidx end = .;
= ALIGN (4) ;
} >FLASH

.preinit array

{

= ALIGN (4);
PROVIDE HIDDEN (_ preinit array start = .);
KEEP (*(.preinit_array*))
PROVIDE HIDDEN (_ preinit array end = .);
= ALIGN (4) ;
} >FLASH

.init array
{
= ALIGN (4) ;
PROVIDE HIDDEN ( init array start = .);
KEEP (*(SORT(.init array.*)))
KEEP (*(.init array*))
PROVIDE HIDDEN ( init array end = .);
= ALIGN (4);
} >FLASH

.fini_array
{
= ALIGN (4) ;
PROVIDE HIDDEN ( fini array start = .);
KEEP (*(SORT(.fini array.*)))
KEEP (*(.fini_array*))
PROVIDE HIDDEN ( fini array end = .);
= ALIGN (4);
} >FLASH

/* Used by the startup to initialize data */

_sidata = LOADADDR(.data);

/* Initialized data sections into "RAM" Ram type memory */

.data
{
= ALIGN (4) ;
_sdata = .; /* create a global symbol at data start */
*(.data) /* .data sections */
*(.data*) /* .data* sections */
* (.RamFunc) /* .RamFunc sections */
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* (.RamFunc¥*) /* .RamFunc* sections */
= ALIGN (4) ;
_edata = .; /* define a global symbol at data end */

} >RAM AT> FLASH

/* Uninitialized data section into "RAM" Ram type memory */
= ALIGN (4) ;

.bss :

{

/* This 1is used by the startup in order to initialize the .bss section */

_sbss = .; /* define a global symbol at bss start */
__bss start = _sbss;
*(.bss)
¥ (. Jogm™)
* (COMMON)
= ALIGN (4) ;
_ebss = .; /* define a global symbol at bss end */
__bss end = _ebss;
} >RAM

/* User _heap stack section, used to check that there is enough "RAM" Ram type memory left

*/
._user_heap stack
{
= ALIGN(8);
PROVIDE ( end = . );
PROVIDE ( _end = . );
= . + Min Heap_ Size;
= . + Min Stack Size;
. = ALIGN (8);
} >RAM

/* Remove information from the compiler libraries */
/DISCARD/

.ARM.attributes 0 : { *(.ARM.attributes) }

2.2.1.6.1 The ENTRY command defines the start of the program
The first instruction to execute in a program is defined with the ENTRY command.

Example:

/* Entry Point */
ENTRY (Reset Handler)

The ENTRY information is used by GDB so that the program counter (PC) is set to the value of the ENTRY address
when a program is loaded. In the example, the program starts to execute from Reset Handler when a step or
continue command is given to GDB after a load.

Note: The start of the program can be overridden if the GDB script contains a monitor reset command after the load
command. Then the code starts to run from reset.
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2.21.6.2 Stack location
The stack location is normally used by the startup file using the _estack symbol. The startup code normally

initializes the stack pointer with the address given in the linker script. For Cortex®-M based devices, the stack
address is also set at the first address in the interrupt vector table.

Example:

/* Highest address of the user mode stack */

_estack = ORIGIN (RAM) + LENGTH (RAM) ; /* end of "RAM" Ram type memory */
2.21.6.3 Define heap and stack minimum sizes

It is common to define in the linker script the heap and stack minimum sizes to be used by the system.

Example:
_Min Heap Size = 0x200; /* required amount of heap */
_Min Stack Size = 0x400; /* required amount of stack */

The values defined here are normally used later in the linker script to make it possible for the linker to test if the
heap and stack fit in the memory. The linker can then issue an error if there is not enough memory available.

22164 Specify memory regions
The memory regions are specified with names ORIGIN and LENGTH. It is common also to have an attribute list

“_ 9 “_»

specifying the usage of a particular memory region, such as (rx) with “r” standing for read-only section and “x
for executable section. It is not required to specify any attribute.

Example:

/* Memories definition */

MEMORY

{
RAM (xrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K

2.21.6.5 Specify output sections (.text and .rodata)

The output sections define where the sections such as “.text’, ‘.data’ or others are located in the memory. The
example below tells the linker to put all sections such as . text, .rodata and others in the flash memory region.
The glue sections mentioned in the example are used by GCC if there are some mixed code in the program. For
instance, the glue code is used if some Arm® code makes a call to thumb code or vice versa.
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Example:

/* Sections */
SECTIONS
{
/* The startup code into "FLASH" Rom type memory */
.isr vector
{
= ALIGN (4);
KEEP (* (.isr vector)) /* Startup code */
= ALIGN (4);
} >FLASH

/* The program code and other data into "FLASH" Rom type memory */

.text
{
= ALIGN (4) ;

* (.text) /* .text sections (code) */
* (.text*) /* .text* sections (code) */
*(.glue 7) /* glue arm to thumb code */
*(.glue 7t) /* glue thumb to arm code */
*(.eh frame)

KEEP (*(.init))
KEEP (*(.fini))

= ALIGN (4) ;
Cetext =7 /* define a global symbols at end of code */
} >FLASH

2.2.1.6.6 Specify initialized data (.data)

Initialized data values require extra handling as the initialization values must be placed in the flash memory and
the startup code must be able to initialize the RAM variables with correct values. The example below creates
symbols sidata, sdataand edata. The startup code can then use these symbols to copy the values from
flash memory to RAM during program start.

Example:

/* Used by the startup to initialize data */
_sidata = LOADADDR(.data);

/* Initialized data sections into "RAM" Ram type memory */

.data
{
= ALIGN (4) ;
_sdata = .; /* create a global symbol at data start */
*(.data) /* .data sections */
* (.data*) /* .data* sections */
* (.RamFunc) /* .RamFunc sections */
* (.RamFunc¥*) /* .RamFunc* sections */
= ALIGN (4) ;
_edata = .; /* define a global symbol at data end */

} >RAM AT> FLASH

2.21.6.7 Specify uninitialized data (.bss)
Uninitialized data values must be reset to 0 by the startup code: the linker script file must identify the locations of
these variables. The example below creates symbols sbss and _ebss. The startup code can then use these
symbols to set the values of the uninitialized variables to 0.
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Example:

/* Uninitialized data section into "RAM" Ram type memory */
. = ALIGN(4) ;
.bss :

{

/* This is used by the startup in order to initialize the .bss section */

_sbss = .; /* define a global symbol at bss start */
__bss start = sbss;
*(.bss)
*(.bss*)
* (COMMON)
. = ALIGN (4) ;
_ebss = .; /* define a global symbol at bss end */
__bss end = ebss;
} >RAM

221.6.8 Check if user heap and stack fit in the RAM

One section of the code is normally dedicated to linker checks about the fact that the needed heap and stack fit
into the RAM together with all other data.

Example:
/* User heap stack section, used to check that there is enough "RAM" Ram type memory left *
/
._user heap stack :
{
. = ALIGN(8);
PROVIDE ( end = . );
PROVIDE ( end = . );
. = . + Min Heap Size;
. = . + Min Stack Size;
. = ALIGN(8);
} >RAM
Note: The stack is placed on top of RAM and heap after data with a gap in between. See Table 3. Memory map layout.

2.21.6.9 Linker map and list files
When building a project generated with STM32CubelDE, a map and a list file are created in the debug or release
build output folders. These files contain detailed information on the final locations of code and data in the
program.
The Build Analyzer view can be used to analyse the size and location of a program in detail. Read more about
this in Section 2.4: Build Analyzer.

2.21.7 Modify the linker script

This section presents common use cases requiring to edit the linker script. Editing and managing the script allows
for more exact placements of the code and data.
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22171

Place code in a new memory region

Many devices have more than one memory region. It is possible to use the linker script to specifically place code
in different areas. The example below shows how to update a linker script to support code to be placed in a new
memory region named IP_CODE.

Example:
Original MEMORY AREA

/* Memories definition */

MEMORY

{
RAM (xxrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K

}
Add IP_CODE into MEMORY AREA

/* Memories definition */

MEMORY

{
RAM (xxrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 256K

IP CODE (rx) : ORIGIN = 0x8040000, LENGTH = 256K

}

Place the following code a bit further down in the script, between the .data { }andthe .bss { ... }

section in the linker script file:

Example:

.ip code
{

*(.IP_Code*) ;
} > IP_CODE

This tells the linker to place all sections named . IP_Code* into the IP_CODE memory region, which is specified
to start at target memory address 0x804 0000.

In the C code, tell the compiler which functions must go to this section by adding
__attribute ((section(".IP Code"))) before the function declaration.

Example:

__attribute ((section(".IP Code"))) int myIP read()

{
// Add code here...
return 1;

The myIP read () function is now placed in the IP_CODE memory region by the linker.
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2.21.7.2 Place code in RAM

To place code in the RAM, some modifications of the linker script and startup code are needed. The example

below describes the changes to be applied when the internal RAM is split into a few sections and the code is
placed and executed in one of the internal RAM sections.

Define a new memory region in the MEMORY {} region in the linker script:
Original MEMORY AREA

/* Memories definition */

MEMORY

{
RAM (xxrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K

}

Split RAM into memory areas RAM1l, RAM CODE, RAM

/* Memories definition */

MEMORY

{
RAM1 (xxrw) : ORIGIN = 0x20000000, LENGTH = 16K
RAM CODE (xXrw) : ORIGIN = 0x20004000, LENGTH = 16K
RAM (xxrw) : ORIGIN = 0x20008000, LENGTH = 64K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K

Define an output section for the code in the linker script. This must be placed with a Load Memory Address (LMA)
belonging to the flash memory, and a Virtual Memory Address (VMA) in RAM:

/* load code used by the startup code to initialize the ram code */
_siram code = LOADADDR (.RAM CODE) ;

.RAM CODE
{
= ALIGN (4) ;
_sram code = .; /* create a global symbol at ram code start */
* (.RAM Code) /* .RAM Code sections */
* (.RAM Code*) /* .RAM Code* sections */
= ALIGN (4) ;
_eram code = .; /* define a global symbol at ram code end */

} >RAM CODE AT> FLASH

The RAM code area must be initialized and code copied from the flash memory to the RAM code area. The
startup code can access the location information symbols _siram code, _sram code and eram code.

Add load address symbols for RAM CODE into the startup file:
/* Load address for RAM CODE */
.word _siram_code;

.word _sram_ code;
.word _eram code;
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Add a piece of code into the startup code to copy the RAM code from the flash memory (LMA) to the RAM (VMA):

Reset Handler:
1ldr sp, = estack /* set stack pointer */

/* Copy the ram code from flash to RAM */
movs rl, #0
b LoopRamCodeInit

RamCodeInit:
ldr r3, =_siram code
1ldr r3, [r3, rl]
str r3, [r0, rl]

adds rl, rl, #4

LoopRamCodeInit:
ldr r0, = sram code
ldr r3, = eram code

adds r2, r0, rl
cmp r2, r3
bcc RamCodelInit

/* Copy the data segment initializers from flash to SRAM */
movs rl, #0
b LoopCopyDatalInit

CopyDataInit:

In the C code, instruct the compiler about which functions must go to this section by adding
__attribute ((section(".RAM Code"))) before the functions declarations:

__attribute ((section(".RAM Code"))) int myRAM read()
{

// Add code here...

return 2;

Refer to [ST-14] for information on how to execute application code from CCM RAM using STM32CubelDE. It
contains examples on how to setup the linker script and startup code to execute a function or an interrupt handler
from RAM. The example in the chapter 4 of [ST-14] can be used as an inspiration on how to add other RAM
regions and setup code sections to be located in RAM.

2.21.7.3 Place variables at specific addresses

It is possible to place variables at specific addresses in the memory. To achieve this, the linker script must be
modified. The example presented in this section places constant variables handling a product VERSION NUMBER,
CRC_NUMBER, and BUILD ID in memory.

The first step is to create a new memory region in the linker script:

Original MEMORY AREA

/* Memories definition */

MEMORY

{
RAM (xrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K

}

Add a new 2K FLASH V memory region at end of flash

/* Memories definition */

MEMORY

{
RAM (xrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K-2K
FLASH V (rx) : ORIGIN = 0x807F800, LENGTH = 2K

}
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At this point, the memory section must be added:
Place the following a bit further down in the script, between the .data { ... } and the .bss

{ ... } section

.flash v :

{

* (.flash v*);
} > FLASH V

This instructs the linker to place all sections named flash v* into the f1lash v output section in the FLASH V
memory region, which is specified to start at target memory address 0x807 F800.

A section can be called almost anything except some predefined names such as “data”.

Now, the variables that must be located into the FLASH v memory must be defined with attributes in the C files:

__attribute ((section(".flash v.VERSION"))) const uint32 t VERSION NUMBER=0x00010003;
__attribute ((section(".flash v.CRC"))) const uint32 t CRC_ NUMBER=0x55667788;
__attribute ((section(".flash v.BUILD ID"))) const uintl6 t BUILD ID=0x1234;

Important: Unless the variable is referenced in the code, the linker is allowed to garbage collect it.

When debugging this example and examining the memory, it can be observed that:

. Address 0x807 £800 contains VERSION NUMBER
. Address 0x807 £804 contains CRC_NUMBER
. Address 0x807 £808 contains BUILD ID

Figure 70. Linker memory output

= o X
0 Memory i 1019 1910 |_|<> d‘#ﬁé |§|§|<=-=4>| Eﬁ v T = 5
Monitors + & & ‘0x807f800 : 0x807F800 <Hex> = l ar New Renderings...‘
@ 0x807f800 Address © - 3 4 -7 8 - B Cc-F A
©807F80@ 03000100 88776655 3412FFFF  FFFFFFFF
IPPPEIT™ ceecrerr EEEEEEEE EEEEEEEE EEEEEEEE v

If the inserted data order in the flash memory is important, map the order of the variables in the linker script. This
makes it possible to define the variables in any file. The linker outputs the variables in the defined order
independently on how the files are linked. As a result, if the CRC_NUMBER is calculated in some way after the
linker has built the file, the CRC_NUMBER can be inserted into the flash memory file by another tool:

Decide the order in the linker script by adding the specially named sections in order BUILD I
D, VERSION NUMBER, CRC NUMBER, and others(*).

.flash v :

{
*(.flash v.BUILD ID¥);
*(.flash v.VERSIONY*) ;
*(.flash v.CRC*);
*(.flash v¥*);

} > FLASH V
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When debugging this example and examining the memory, it can be observed that:

. Address 0x807 £800 contains BUILD ID
. Address 0x807 £804 contains VERSION NUMBER
. Address 0x807 £808 contains CRC_NUMBER

Figure 71. Linker memory output specified order

K O X
0 Memory 2 101 1010 Lloﬁ‘iﬁ EEIEHE" - =g
Monitors 4k 3¢ % 0x807f800 : 0x807F800 <Hex> ©3 < New Renderings.. |
@ 0x807f800 Address @ - 3 4 -7 s -8 c - f R
% 0x807f800 ©807F80@ 34120000 03008100 88776655  FFFFFFFF

22174 Linking in a block of binary data

It is possible to link in a block of binary data into the linked file. The example below describes how to include a . .
/readme. txt file.

Example:

File: readme.txt
Revision: Version 2
Product news: This release ...

One way to include this in the project is to make a reference in a C file to include it using the incbin directive
and the allocatable (“a”) option on the section:

asm(".section .binary data,\"a\";"
".incbin \"../readme.txt\";"
);

The new section binary data is then added into the linker script with instructions that the section must be put in
the flash memory. The KEEP () keyword can be used to surround an input section so that the linker garbage
collector does not eliminate the section even if not called:

.binary data :

{
_binary data start = .;
KEEP (* (.binary data));
_binary data end = .;

} > FLASH

This block can then be accessed from the C code:

extern int binary data start;
int main (void)
{
/* USER CODE BEGIN 1 */
int *bin area = & binary data start;
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The binary data, in this case the readme file, can be observed in the Memory view when the project is debugged.

Figure 72. Linker memory displaying file readme

@ o x
0 Memory &% 101 1010 L‘<> d|§>&-‘ mﬂ%‘ Ea v — =7
Monitors 4 8 % 0x800261c : 0x800261C <Hex> o3 | 4 New Renderings.. 0x800261c <Floating.. | 0x800261c : 0x80026.. °% =i New Renderings...
@ 0x800261c Address @ - 3 4 -7 8 - B cC-F A || ©x8800261C 656C6946 6572203A File : re A
08002610 9D220008 B9010008 95010008 0x08002624  656D6461 7478742E adme  .txt
08002620 3A207265 61646D65  2E747874  208DOA52 0x0800262C  520A0D20 73697665 ..R evis
08002630 65766973 696F6E3A 20566572  73696F6E ©0x08002634  3A6E6F69 72655620 ion: ver
08002640 2032200D OAS0726F 64756374  206E6577 ©x0800263C  6E6FE973 00203220 sion 2
08002650 733A2054 68697320  72656C65 61736520 ©x068602644  6F72500A 74637564 -Pro duct
08002660 2E2E2EGD OAG30000  ©OOCEEEO  0OBO24F4 0x0800264C  77656E20 54203A73 new  s: T
08002670 00100000 00010000 00180000 20000000 ©x08002654 26736968 656C6572 his rele
08002680 00040300  206C0300  20D40300 20000000 6x0800265C 20657561 ©D2E2E2E ase
08002690 00000000 00000000 00000000 00000000 v || @xe8002664 @000030A 00000CE0 e e v

22175 Locate uninitialized data in memory (NOLOAD)

There is sometimes a need to have variables located into the flash memory, or some other non-volatile memory,
which must not be initialized at startup. In such cases, it is possible to create a specific MEMORY AREA in the
linker script (FLASH_D) and use the NOLOAD directive in the section using the area.

Example:

The MEMORY AREA can be defined like this

/* Memories definition */

MEMORY

{
RAM (xrw) : ORIGIN = 0x20000000, LENGTH = 96K
FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 512K-4K
FLASH D (rx) : ORIGIN = 0x807F000, LENGTH = 2K
FLASH V (rx) : ORIGIN = 0x807F800, LENGTH = 2K

}

Add a section for FLASH D using the NOLOAD directive. This can be done using the following code a bit further
down in the linker script:

Place the following a bit further down in the script

.flash d (NOLOAD)
{

* (o Elasin_ @) 7
} > FLASH D

Finally, data can be used somewhere in the program by adding a section attribute when declaring the variables
that must be located in the FLASH D memory.

__attribute ((section(".flash d"))) uint32 t Distance;
__attribute ((section(".flash d"))) uint32 t Seconds;

2.2.1.8 Include libraries
To include a library into a project:
1. Right-click the project where the library must be included in the Project Explorer view and select [Properties]
2. In the dialog, select [C/C++ Build]>[Settings]
3. Select the Tool Settings tab in the panel
4. Select [C Linker]>[Libraries]
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5. Add the library name to the [Libraries] field.
Make sure the libray name is added and not the path. According to the GCC convention, the library name is its
filename without the “1ib™ prefix and “. 2” extension.
Example: for a library file named 1ibmyLib.a, add the library name myLib.
If by any chance the library name do not comply with the GCC convention, the full library name can be
entered, preceded by a colon “:”
Example: for a library file named sTemwin524b cM4 GccC. a, add the library
name :STemWin524b_CM4_GCC.a.

6. In the [Library Paths] list, set the library location path. Do not include the name of the library in the path.
Example: s {workspace loc:/myLib/Debug} is the path to the archive file of the library project myLib residing
in the same workspace as the application project.

7. Enable [Place libraries in a linker group (-WI,--start-group $(LIBS) -WI,--end-group)] if libraries need to be

linked several times to resolve circular dependencies.

Figure 73. Include a library

m workspace_um? - NUCLEO-FA01RE/Core/Src/main.c - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help
vl R B vR >RSI @Sy @i vO v R y®IviIE 1

1

S s
v & w s

re v o vt e

I& Project Explorer 2 S|7 § = ¢
v [E mylib
v . m Properties for NUCLEO-F401RE O X
> B Archives
¥ Elne > Resource
> 8 mylib.h .
Builders
~ @ Src v C/C++ Build Configuration: Debug [Active ] VHManage Configurations...
> 8 mylib.c

Build Variables

* [ syscalls.c Environment

® Tool Settings  # Build Steps Build Artifact It Binary Parsers @ Error Parsers

> 8 sysmem.c

Logging
> @ Debug Settings # MCU Toolchain Libraries (-I) ea8id
~ EINUCLEOTAOTRE | , c/c.s conmrol | | &MU Setings
> ¥ Binaries CMSIS-SVD Settir (# MCU Post build outputs
> @l Includes Project Reference: v ® MCU GCC Assembler
v 2 Core Run/Debug Settir 2 General
> &Inc &% Debugging
» = myThreadSa (2 Preprocessor
v & Src 2 Include paths
> & main.c 2 Miscellaneous

> g stm32fdx
> 8 stm32fdy
> 18 syscalls.c

v ® MCU GCC Compiler
2 General
2 Debugging

> 2 sysmem. 2 Preprocessor

> [ system_s & Include paths

» & Startup & Optimization
’ z g”gers & Warnings Library search path (-L) a8 8 il
~ ebu = Mi
g & Miscellaneous "${workspace_loc;/mylib/Debug}"
> = Core v & MCU GCC Linker
> = Drivers & General
» % NUCLEO-F4! (# Libraries
L& makefile 2 Miscellaneous
5 NUCLEO-F4
5 NUCLEO-F4
[E NUCLEO-F4t
= objects list

l& objects.mk
L& sources.mk

v

= Release
2 NUCLEO-F401R
[ NUCLEO-F401R
2 NUCLEO-F401R
[ STM32F401RET|
[ie STM32F401RET|
T STM32F401Empty,
U STM32F401RE_em

[_]Place libraries in a linker group (-WI--start-group $(LIBS) -Wl,—end-group)
Use C math library (-Wl--start-group -lc -Im -WI|,--end-group)

‘ Restore Defaults || Apply ‘

| Apply and Close | | Cancel ‘
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The source folders for the header files must also be added to the [Include paths] field:
1. Select [MCU GCC Compiler]>[Include paths]
2. press the [Add...] button and add the paths to the source folders for the header files in the library

Figure 74. Add library header files to the include paths

mworkspace R e — - 2 I
: X mPropemes for NUCLEO-F401RE O X
File Edit Source Refactor
L-j v &l \u_u,‘ B ‘i v | | type filter text Settings v vw
> Resource
% X v C/C++ Build
Project Explorer & Build Variables Configuration: Debug [Active ] ¥ Manage Configurations...
v mmyLib Discovery Options
> @;Archives Environment
> M Includes Logging i) Tool Settings & Build Steps "’ Build Artifact Binary Parsers @ Error Parsers o
v (Einc Settings
> [h myLib.h > C/C++ General (# MCU Settings Include paths (-I) a8 &85 Y
v s CMSIS-SVD Settings 2 MCU Post build output:
Bsre ) ) 9 =4 ost bulld outputs _/Drivers/CMSIS/Include
> @ myLib.c Project Natures v B MCU GCC Assembler "${workspace_loc/myLib/Inc}"
Project References G | : o :
> [€l syscalls.c Ject Reterel (& General ./Drivers/STM32F4xx_HAL_Driver/Inc
> [ sysmem.c Refactoring History (22 Debugging /Core/Inc
v (= Debug Run/Debug Settings (£ Preprocessor ./Drivers/CMSIS/Device/ST/STM32F4xx/Include
> (=Src (2 Include paths ./Drivers/STM32F4xx_HAL_Driver/Inc/Legac,
= gacy
> [ libmyLib.a ( Miscellaneous
[ makefile v & MCU GCC Compiler
= b}
=) objects.list %;General.
[ & objects.mk % Debugging
[(\@sources.mk %Preprocessor
v [ZINUCLEO-F401RE L=lncludelpattis
Po
> %«_\ Binaries E‘m Edit directory path X
> [} Includes Q‘
v (B Core . ®% Directory:
7 Eine £ ["gqwork loc;/myLib/Inc}" |
> @ src % workspace_loc:/myLib/Inc
> [= Startup g
> [ Drivers
> [=Debug
>
& Debug2 OK Cancel Workspace... File system...
S (= DRalasca
<
.l NUCLEO-F401RE H

Note: Libraries added by include paths are considered as static libraries because they are provided by external

parties. The header files are not rescanned as the content must not have changed for external header files. If
external libraries must be treated as normal source folders, the folders must also be added as source folders to
the project.

Refer to Section 2.2.1.9: Referring to projects for more information if a project is referring to another project, a
library or a normal project.

2.2.1.9 Referring to projects

Whenever a project is using code from another project, both projects must be referring to each other.
For a project to refer to a specific build of another project:

1. Select instead [Project]>[Properties]

2. Select [C/C++ General]>[Paths and Symbols]

3. Open the References tab
4

select the [Configuration] that the current project is referring to
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Figure 75. Set project references

[ Properties for NUCLEO-FAO1RE O X

type filter text Paths and Symbols LYYy

> Resource
> C/C++ Build ~
v C/C++ General
> Code Analysis
Documentation

Configuration: ‘Debug [ Active ] v ‘ ‘Manage Configurations...

File Types (2 Includes # Symbols i Libraries (B Library Paths (2 Source Location | References
Formatter
Indexer [JF401 Expand All
Language Mappings > [] NUCLEO-F401RE
Paths and Symbols > [J STM32F4xx-Nucleo Cellzpse Al
Preprocessor Include Patl v [ myLib
CMSIS-SVD Settings ] [Active] Move Up
Project Natures Debug Move Down
Project References [[] Release
Refactoring History
Run/Debug Settings
= ~ ‘ Restore Defaults ‘ ‘ Apply ‘ v
@ | Apply and Close | | Cancel ‘
Note: When multiple projects are used as references, use the [Move Up] and [Move Down] buttons to setup the
priorities.
There are many advantages to set project references correctly:
. The projects involved are not rebuilt more than necessary.
. The indexer is able to find functions from the library and open them. To use this possibility, press the Ctrl
key and, in the editor, click the library function where it is used to open the library source file in the editor.
. It is possible to create the call hierarchy for the functions in the library. To find the call hierarchy, mark the

function name and press Ctrl+Alt+H to display the call hierarchy in the Call Hierarchy view.

If a library project is added as a reference, all the correct settings in the Paths and Symbols property page for the
library is set. The tool settings that depend on this property page are adjusted also.

This is the recommended method of adding libraries developed locally. For more information about adding
libraries, refer to Section 2.2.1.8: Include libraries.

Another way to have projects referring to each other is as follows:
1. Select [Project]>[Properties]
2. Select [Project References]

3. Select and mark the project for reference
With this method, however, it is not possible to refer to different build configurations and libraries are not set up
automatically.

2.2.2 1/0 redirection

The C run time library contains many functions, including some to handle 1/Os. The I/O-related run time functions
include printf (), fopen (), fclose (), and many others. It is common practice to redirect the I/O from these
functions to the actual embedded platform. For instance, the printf () output can be redirected to an LCD
display or serial cable while file operations like fopen () and fclose () can be redirected to a flash memory file
system middleware.
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2.2.2.1 printf() redirection

There are several ways to perform printf () redirection, such as using UART or SWV/ITM. Another solution is
the Real-Time Transfer technology (RTT) provided by SEGGER.

The three techniques compare as follows:

. The UART output is maybe the most commonly used method, where the output from the embedded system
is sent for instance to a terminal using RS-232. It requires some CPU overhead and medium bandwidth.

. The Instrumentation Trace Macrocell (ITM) output is efficient but requires that the Arm® CoreSight™
debugger technology with Serial Wire Viewer (SWV) is supported by the device. This is normally the case
for Cortex®-M3, Cortex®-M4, Cortex®-M7, and Cortex®-M33 based devices. However, the SWV signals
must be available and connected to the board also. It requires low CPU overhead but limited bandwidth.
ITM output is explained in Section 3.2: Debug with Serial Wire Viewer tracing (SWV).

. The RTT solution is described by SEGGER on their website. RTT is a fast solution but requires
SEGGER J-LINK debug probe.

To enable /O redirection with UART or ITM output, the file syscalls.c must be included and built into the project.
When printf () is used, it calls the write () function, which is implemented in syscalls.c.

The syscalls.c file is normally created and included in the project when creating a new STM32CubelDE project.
The write () function in this file must be modified to enable printf£ () redirection by modifying the call to
__io putchar (). The way to modify write () depends on the hardware and library implementation.

The example below shows how to update syscalls.c so that printf ouput is redirected to ITM with an
STM32F4 Series device. This is done by adding some header files to access ITM_SendChar () and make a call
to ITM SendChar ().

Original write() function

__attribute ((weak)) int write(int file, char *ptr, int len)
{
int Dataldx;

for (DatalIdx = 0; DatalIdx < len; Dataldx++)
{

__ 1o putchar (*ptr++) ;
}

return len;

}
Modified with added header files calling ITM SendChar (*ptr++);

#include "stm32f4xx.h"
#include "core cm4.h"

__attribute ((weak)) int write(int file, char *ptr, int len)
{
int Dataldx;

for (Dataldx = 0; Dataldx < len; Dataldx++)
{

//__io putchar (*ptr++) ;

ITM SendChar (*ptr++) ;
}

return len;

It can be noticed that the write functionin syscalls.c contains a weak attribute. This means that the
_write function can be implemented in any C file used by the project.
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For instance, the new write () function can be added directly into main.c. Omit the weak attribute in that
case, as shown in the example below.

int write(int file, char *ptr, int len)
{
int Dataldx;

for (DatalIdx = 0; Dataldx < len; DatalIdx++)
{

//__io putchar (*ptr++) ;

ITM SendChar (*ptr++);
}

return len;

223 Thread-safe wizard for empty projects and CDT " projects

STM32CubelDE includes a thread-safe wizard to generate files to support the use of resources that can be
updated by application code and interrupts or when using a real-time operating system.

Note: The thread-safe wizard may only be used for STM32CubelDE empty projects. For projects managed by
STM32CubelMX, the thread-safe implementation configuration must be made using STM32CubeMX dialogs.

The thread-safe wizard creates three files and adds the STM32 THREAD SAFE STRATEGY define to the project.

The files are:

. newlib lock glue.c
° stm32 lock user.h
° stm32 lock.h

First, in the example below, a myThreadsafe folder is created in the empty project. This folder is selected in the
Thread-Safe Solution wizard so that files are generated in this folder.
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Open the menu [File]>[New]>[Other...] to obtain the wizard selection window shown in Figure 76.

Figure 76. Select a wizard

- [ select a wizard O x

Select a wizard >
Generate a set of files that provide the 5T thread-safe solution, I

Wizards:
type filter text

% =% General
» (= C/C++
» [= Create New 5TM32 Project
» [= Launch Targets
w = Other
[ Thread-Safe Solution

@ < Back [ Mext = ] Finish Cancel
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In the [ST] node select [Thread-Safe Solution] and press [Next >] to open the Thread-Safe Solution wizard.

Figure 77. Thread-Safe Solution wizard

m Generate Thread-Safe Solution U X

Thread-Safe Solution

© Folder 'STM32F401 RE_empty' is not in a source folder.

Source folder: | STM32F401RE_empty ‘ Browse... |

Strategy: M ‘
@ < Back Next > Finish Cancel
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Press [Browse] to open the Generate Into Source Folder dialog.

Figure 78. Thread-safe source folder location

m Generate Into Source Folder L] X

Select the folder to generate into.

By & D
> [ NUCLEO-F401RE
v [ STM32F401RE_empty
= settings
= Inc
= myThreadSafe
= Src
= Startup
@ oK Cancel

Select the source folder to generate the files into and press [OK].

The wizard proposes to select among five different thread-safe strategies:
1. User-defined thread-safe implementation.

Allow lock usage from interrupts.

Deny lock usage from interrupts.

Allow lock usage from interrupts. Implemented using FreeRTOS™ locks.

o & ebn

Deny lock usage from interrupts. Implemented using FreeRTOS™ locks.
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The different strategies are explained in file stm32 lock.h.

=

User defined thread-safe implementation.

User defined solution for handling thread-safety.

NOTE: The stubs in stm32 lock user.h needs to be implemented to gain
thread-safety.

N

. Allow lock usage from interrupts.
This implementation will ensure thread-safety by disabling all interrupts
during e.g. calls to malloc.
NOTE: Disabling all interrupts creates interrupt latency which
might not be desired for this application!

w

Deny lock usage from interrupts.

This implementation assumes single thread of execution.
Thread-safety dependent functions will enter an infinity loop
if used in interrupt context.

S

. Allow lock usage from interrupts. Implemented using FreeRTOS locks.
This implementation will ensure thread-safety by entering RTOS ISR capable
critical sections during e.g. calls to malloc.
By default this implementation supports 2 levels of recursive locking.
Adding additional levels requires 4 bytes per lock per level of RAM.
NOTE: Interrupts with high priority are not disabled. This implies
that the lock is not thread-safe from high priority interrupts!

a1

Deny lock usage from interrupts. Implemented using FreeRTOS locks.
This implementation will ensure thread-safety by suspending all tasks
during e.g. calls to malloc.

NOTE: Thread-safety dependent functions will enter an infinity loop
if used in interrupt context.

B S S T S S S S S S A A I T T S S

Select a strategy as shown in Figure 79.

Figure 79. Thread-safe strategy selection

m Generate Thread-Safe Solution O X

Thread-Safe Solution

Generate a set of files that provide the ST thread-safe solution.

Source folder: | STM32F401RE_empty/myThreadSafe ‘Browse___|

Strategy: Generic Strategy #3 - Deny lock usage from interrupts o

Generic Strategy #1 - Custom implementation
Generic Strategy #2 - Allow lock usage from interrupts

Generic Strategy #3 - Deny lock usage from interrupts
FreeRTOS Strategy #4 - Allow lock usage from interrupts
FreeRTOS Strategy #5 - Deny lock usage from interrupts

@ < Back Next > Finish | ‘ Cancel
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Select a strategy and press [Finish] to generate the files into the selected source folder.

The files generated are the same and contain the same information independently of the selected strategy.

A new define, STM32 THREAD SAFE STRATEGY=3, is added by the wizard to the project for use by the
preprocessor when building the project. The define value is set according to the strategy selected in the wizard.
The define can be observed by opening the project properties and looking into the Tool Settings tab.

Figure 80. Thread-safe properties

type filter text

> Resource
Builders
v C/C++ Build
Build Variables
Environment
Logging
Settings
» C/C++ General
CMSIS-SVD Settir
Project Reference:
Run/Debug Settir

m Properties for STM32F401RE_empty

Settings

Configuration: |Debug [ Active ]

4 | ‘ Manage Configurations...

® Tool Settings # Build Steps

Build Artifact Binary Parsers @ Error Parsers

# MCU Toolchain
# MCU Settings
# MCU Post build outputs
~ & MCU GCC Assembler
£ General
2 Debugging
# Preprocessor
# Include paths
# Miscellaneous
v & MCU GCC Compiler
£ General
# Debugging
# Preprocessor
# Include paths

# Ontimization

Define symbols (-D)

a8 8§

DEBUG
STM32
STM32F401RETx

STM32F4
STM32 THREAD SAFE STRATEGY=3

Undefine symbols (-U)
I

FRERE
1

Apply and Close | | Cancel ‘
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The generated files are shown in the Project Explorer.

Note: The generated files require that some CMSIS header files are included in the project. The files must be copied

and added manually into the project if they are missing.
Figure 81. Thread-safe files

File Edit Source Refactor Navigate Search Prc
OvEd@Q ®~vyR~vEa @vearyEdye-
& Project Explorer 2 57 § - 0O
> [ NUCLEO-F401RE
v [ STM32F401RE_empty
> &l Includes
> ®lnc
» 2 Src
» & Startup
v & myThreadSafe
> [2 newlib_lock_glue.c
» [0 stm32_lock user.h
> [ stm32_lock.h
STM32F401RETX_FLASH.Id
STM32F401RETX_RAM.Id

If the wizard is started while the project is managed by STM32CubeMX, an error is displayed stating that
STM32CubeMX must be used to manage the thread-safe strategy.

Figure 82. Thread-safe error dialog

m Generate Thread-Safe Solution U X
Thread-Safe Solution

o Project is managed by STM32CubeMX. Use STM32CubeMX to manage the strategy.

Source folder: | NUCLEO-F401RE ‘Browse...|
Strategy: o ‘
@ < Back Next > Finish Cancel
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224 Position-independent code

This section is of interest to users working on applications where the final address location is not defined in the
system. This occurs for instance when using a bootloader: the system designer must be able to define the final
location of the application. In such case, position-independent code (PIC) can be used. The -fPIE compiler
option enables the compiler/linker to generate position-independent executable.

Compiling with option -fPIE generates position-independent executable so that if the application is linked for
address 0x800 0000 but placed at 0x800 1000, it still runs.

However, the information in this section is not complete. The solution it describes works when using global data
initialized to zero (.bss) but it does not work when using initialized data and has several other limitations. One
such limitation is that run time libraries included in the STM32 toolchain cannot be used as these libraries are built
without the - £PIE option for optimization. Instead of using position-independent code in a system, it is worth
considering other solutions.

Alternate solution example:

If a system is designed to have a bootloader and multiple versions of an application in flash memory at different
slots, it may be easier to setup multiple build configurations for the application. Each build configuration is based
on its own linker script file. In this case, there is no need to use position-independent code since run time libraries
can be used. Each build configuration links the application to a unique slot in flash memory, generating one single
elf file per slot. When downloading a new version of the application into a slot, the correct e1£ file must be used.
The bootloader can be designed to validate the addresses in the e1f file and generate an error if it contains
addresses that are out of the slot. The application can copy the interrupt vector table to RAM and update vector
copies depending on the slot where the application is stored.

2.24.1 Adding the —fPIE option
To add the —£PIE option into the tool settings:
1. Right-click the project in the Project Explorer view and select [Properties]
In the dialog, select [C/C++ Build]>[Settings]
Select the Tool Settings tab in the panel
Select [MCU GCC Compiler]>[Miscellaneous]
Add -fPIE to the [Other flags] field.

S
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Figure 83. Position independent code, —-fPIE

[T properties for NUCLEO-F401RE O X
‘type filter text Settings ERASE 4
> Resource
v C/C++ Build
Build Variables Configuration: ‘Debug [ Active ] V‘ ‘Manage Configurations...‘

Discovery Options
Environment

Logging 5 Tool Settings & Build Steps Build Artifact Binary Parsers €3 Error Parsers EIZ‘
Settings
> C/C++ General (2 MCU Settings Other flags L ER= Ry
CMSIS-SVD Settings (2 MCU Post build outputs
Project Natures v 3 MCU GCC Assembler
Project References 2 General
Refactoring History @ Debugging
Run/Debug Settings @ Preprocessor

2 Include paths

@ Miscellaneous
v B MCU GCC Compiler

(#2 General

(22 Debugging

@ Preprocessor

@ Include paths

@ Optimization

@Warnings

@ Miscellaneous
v £ MCU GCC Linker

@ General

22 Libraries

(# Miscellaneous

[ Verbose (-v)
I position Independent Code (-fPIC)

Enable stack usage analysis (-fstack-usage)

‘ Restore Defaults ‘ | Apply |

® | Apply and Close ‘ | Cancel ‘

2.24.2 Run time library

The C run time library is compiled without using the —£fPIE option. So any call to the library must be avoided
when generating position-independent executable. The startup code normally has a call to
~ libc init array. This call must be removed as in the example below:

/* Call static constructors */
/* bl libc init array */

2.24.3 Stack pointer configuration

Make sure that the stack pointer is set up correctly. The stack pointer must be set in the Reset Handler in the

startup file as shown in the example below. It must not be assumed that the stack pointer is set by a reset reading
it from the vector table.

Reset Handler:

1ldr sp, = _estack /* set stack pointer */
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2.24.4 Interrupt vector table
The vectors in the vector table must be updated if the program is loaded to an offset address. If a program needs
to add the offset to each vector in the table, it can copy the interrupt vector table to the RAM and add the offset to
this vector table.
The vector base register must also be changed so that it points to the new located vector table as shown in the
example below:

/* Set Vector Base Address */
SCB->VTOR=RAM VectorTable;

2245 Global offset table
The global offset table (GOT) is a table of addresses normally stored in the data section when building and using
the -£PIE option. It is used by the executed program to find, during run time, addresses of global variables,
unknown at compile time. If no global variable location change is needed, the variables can be located at same
place as located when linking the program. Then the GOT table can be placed in the . text section in the flash
memory area instead.
The example below shows how to update the linker script with the . got * section. In this case the GOT START
and GOT_END symbols are added also so that the tools are able to know the GOT location and size.

/* The program code and other data into "ROM" Rom type memory */

.text :

{
. = ALIGN (4) ;
* (.text) /* .text sections (code) */
* (.text*) /* .text* sections (code) */
GOT_START = .;
*(.got*)
GOT_END = .;
*(.glue 7) /* glue arm to thumb code */
*(.glue 7t) /* glue thumb to arm code */

*(.eh frame)

KEEP (*(.init))
KEEP (*(.fini))

. = ALIGN (4);

Cetext =7 /* define a global symbols at end of code */
} >ROM
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2.2.4.6 Interrupt vector table and symbols

When debugging the code with an offset, both the load offset and the new symbol address must be specified. The
symbol address to provide is the . text section address. The linker script can be updated by
defining .isr vector to be located into . text. This avoids the issue of finding the location of . text.

Remove the following

.isr vector :

{
. = ALIGN (4);
KEEP (* (.isr_vector)) /* Startup code */
. = ALIGN (4);

} >FLASH

Add KEEP(* (.isr vector)) instead to first location of .text
/* The program code and other data into "FLASH" Rom type memory */

o EEXE 8

{
. = ALIGN (4);
KEEP (* (.isr_vector)) /* Startup code */
* (.text) /* .text sections (code) */
* (.text*) /* .text* sections (code) */
GOT_START = .;
*(.got*)
GOT_END = .;
*(.glue 7) /* glue arm to thumb code */
*(.glue 7t) /* glue thumb to arm code */

*(.eh frame)

KEEP (*(.init))
KEEP (*(.fini))

. = ALIGN(4);
_etext = .; /* define a global symbols at end of code */
} >FLASH
2.24.7 Debugging position-independent code
When debugging position-independent code located at an offset, the download offset and new symbol address
must be set.
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Figure 84. Debugging position independent code

B8 pebug Configurations [m} X
Create, manage, and run configurations ﬁv
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[ Resume
Download
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ok Cancel
Filter matched 11 of 11 items Bevert Gplly

® Close

Figure 84 illustrates an example where the download offset is 0x1000 and the symbol address is 0x800 1000. It
is possible to set the symbol address to 0x800 1000 in this case because the .isr vector is added into
the . text section as described in Section 2.2.4.6: Interrupt vector table and symbols.

Ifinstead the . isr vector is located in another section outside . text, the start address of the . text section
must be used with the offset added. For instance, if the map file states that . text starts at
0x0000 0000 0800 0194, the symbol address in this case must be setto 0x800 1194.

Figure 84 shows that the breakpoint is set at main and that the program counter (spc) is set to the

Reset Handler symbol into [Run Commands]. This symbol contains the correct address to the

Reset Handler because gdb uses the base symbol address 0x800 1000. If $pc is not setup during this
debug configuration, the [Resume] checkbox must be disabled to make the program stop after load. In this case,
the program counter must be set manually in the Registers view before starting the program.
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225 Exporting projects
A project can be exported in many different ways. This section shows how to export a project as a compressed
zip file.
Right-click the project in the Project Explorer view and select [Export...].

Figure 85. Export project

v [ENUCLEO-F -~
B New >
> ﬁ,Blnarles Go Int
> @Includes e
v 2 Core Open in New Window
> [=Inc Copy Ctrl+C
7 [=5rc Paste Ctrl+V
v (= Startt 3¢ Delete Delete
> 3] st Source >
=l st Move...
Sl st Rename... F2
> = Drivers e Imoort
> [=Debug = mpor-
/5 Export...

> E;Debug2u
> [=Release Build Project
NUCLEC Clean Project

=/ NUCLEC & | Refresh F5
EZINUCLEC  Close Project
= readme Close Unrelated Projects
>TM32F Build Configurations >
STM32¥ Build Targets >
STM32F
= Index >
STM32F
STM32F Show in Remote Systems view
> [T stm32r40 © Run As ?
> T sTM32Mp- ¥ Debug As >
> LJ sw4sTM3:  Profile As >
Team >
Compare With >

Restore from Local History...

Generate Code

]
L

Convert to C++
Run C/C++ Code Analysis

Configure >

ey

Properties Alt+Enter
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The Export dialog opens. Select [General]>[Archive File] and press [Next >].

Figure 86. Export dialog

[ export O X
Select /“
Export resources to an archive file on the local file system. Q

Select an export wizard:

‘ type filter text ‘

v [ General
,@ Archive File
£ File System
,'j Preferences

> [ C/CH+

> [~ Install

> [/~ Remote Systems

> [ Run/Debug

> [ Team

@

The Export dialog is updated. Select the project to be exported. It is possible to exclude some project files from
the export. In the example in Figure 87, all project and library files are included. A file name must be entered into
the [To archive file] field, possibly browsing to a folder location for the file with the [Browse...] button. In the
example, the default options values are kept unchanged. Press [Finish] to export the project and create the zip
file.

Figure 87. Export archive

[ Export O X
Archive file

Export resources to an archive file on the local file system. ) |

> Dm F401 .cproject o

> ML NUCLEO-F401RE
[J= RemoteSystemsTempFiles
> O STM32F401_empty
> =5 STM32F4xx-Nucleo
> [JEE sTM32MP151C_MPU_CM4

> ML myLib

.mxproject

.project
NUCLEO-F401RE.elf.cfg
NUCLEO-F401RE.elf.launch
NUCLEO-F401RE.ioc

i STM32F401RETX_FLASH.Id

KHRREE
i [

Hm

TM32F401RETX_FLASH_IPCodelnFlash.ld
TM32F401RETX_FLASH_ORG.Id )
Filter Types... ‘ ‘ Select All ‘ ‘ Deselect All ‘
To archive file: ‘ ive - STMicroelectronics\dev\CubelDE\Manuals\STM32CubelDE_UG\nucleo-f401.zip v ‘ ‘ Browse...
Options
@® Save in zip format @ Create directory structure for files
(O save in tar format QO Create only selected directories

Compress the contents of the file

[JResolve and export linked resources

@ Next > Finish | ‘ Cancel
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2.3 Build and compile C/C++ projects

2.31 Toolchain Manager

The Toolchain Manager is used to install toolchains, uninstall toolchains and select the default workspace
toolchain when building a project.

To open the Toolchain Manager from the Tool Settings tab in project properties:
1. Select the [MCU Toolchain] node

Figure 88. Open Toolchain Manager

m Praoperties for NUCLEO-F401RE O s
I I I
type filter text Settings SR
> Resource } } h}
Builders -
v C/C++ Build Configuration: Debug [ Active ] ~  Manage Configurations...

Build Variables

Environment ; 7 T : =
® Tool Settings 4 Build Steps ' Build Artifact ks Binary Parsers @ Error Parsers

Logging
Settings #® MCU Toolchain Select what toolchain to use
» C/C++ General #MCU Settings ® Use workspace setting (GNU Tools for STM32 (9-2020-q2-update

CMSIS-SVD Setti -
S92 EMCU Post build outputs | (Y ijyed [GNU Tools for STM32 (9-2020-q2-update)

Project References v ®MCU GCC Assembler
Run/Debug Settings EGeneral Toolchain Manager
#Debugging Configure the workspace toolchain, and manage installed toolchain:

= Preprocessor
#lInclude paths
EMiscellaneous

v B MCU GCC Compiler

Open Toolchain Manager...

v
- I S |
@ Apply and Close Cancel
2. Click on [Open Toolchain Manager...]
The Toolchain Manager can also be opened from the [Window]>[Preferences] menu:
1. Select [STM32Cube]>[Toolchain Manager]
Figure 89. Toolchain Manager
O X
o
type filter text Toolchain Manager GT=el
> Help ~ The Toolchain Manager allows users to configure the workspace toolchain, and man‘age installed toolchains.
> Install/Update
» Remote Development Default Name State Add Local...
> Remote Systems GNU ARM Embedded (7-2018-q2-update) Not installed Edit Local
> Run/Debug GNU ARM Embedded (9-2020-q2-update)  Not installed
v STM32Cube GNU Tools for STM32 (7-2018-q2-update) Not installed Uninstall...
Build B GNU Tools for STM32 (9-2020-qg2-update) Installed with STM32CubelDE 1.6....
Device Configuration Tool Reload
End User Agreements Set Default
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer
Target Status X
R By default let STM32CubelDE select the toolchain to use.
Toolchain Manager X i X i . .
» Teamn Nate: installing and uninstalling toolchains requires a restart of STM32CubelDE.
Terminal v Restore Defaults
@ s Apply and Close Cancel
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The columns in the Toolchain Manager are described in Table 4.

Table 4. Toolchain Manager column details

s T e ]

A green/grey arrow symbol indicates the default workspace toolchain.

The arrow color is:

Default
. green when the toolchain is manually set as default by the user
. grey when the toolchain is selected as default by STM32CubelDE logic
Name The name of the toolchain.
The state of the toolchain. Toolchains available for download from STMicroelectronics online
State repository are listed as “installed” or “not installed”. Local toolchains added by the user are listed as

“local”.
The buttons in the Toolchain Manager are described in Table 5.

Table 5. Toolchain Manager button information

I T

Add Local... Add reference to local toolchain.
Edit Local... Edit reference to local toolchain.
Install... The button text depends on the type of the selected toolchain. It is used to:
Uninstall... . Install / Uninstall the selected toolchain provided by the repository
Remove... . Remove the selected local toolchain
Reload Reload the toolchain list from the repository.
Set Default Set selected toolchain to be used by default.
Restore Defaults Restore and use the default toolchain.
Apply and Close Apply selection and close dialog.
Cancel Cancel dialog.
2.3.1.1 Install a new toolchain

Open the Toolchain Manager to install a new toolchain.

Figure 90. Install toolchain

E Preferences U X
type filter text Toolchain Manager VR
~
Help The Toolchain Manager allows users to configure the workspace toolchain, and manage installed toolchains.
Install/Update
Remote Development Default Name State Add Local...
Remote Systems GNU ARM Embedded (7-2018-g2-update) Not installed Edit Local
Run/Debug GNU ARM Embedded (3-2020-g2-update) Not installed
v STM32Cube GNU Tools for STM32 (7-2018-q2-update) Not installed Install...
Build b GNU Tools for STM32 (9-2020-qg2-update) Installed with ST.
; 1 ; Reload
Device Configuration Tool
End User Agreements Set Default
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer
Target Status i
) By default let STM32CubelDE select the toolchain to use.
Toolchain Manager
Team Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.
Terminal v Restore Defaults
@ Raed Apply and Close Cancel
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Select the toolchain to install and click on [Install...]. The Install dialog opens and displays the items to be
installed.

Figure 91. Check items to install

m Install O x

Install 1
o9

Check the items that you wish to install. |

Name Version Id
M4STM32CubelDE MCU External Tools GNU Tools for STM32 - Binaries (7-2018-q2-update) ~ 1.5.0.202011040924 comst.stm32cube.ide feature. mcu.externaltools....

Select All Deselect All

Details
STMicroelectronics STM32CubelDE MCU External Tools GNU Tools for STM32 - Binaries (7-2018-g2-update) o

@ < Back Finish Cancel

Check the items to install and click on [Next].

Figure 92. Review items to install

m Install O X

Install Details I |
¥

Review the items to be installed. |

Name Version Id
v 4STM32CubelDE MCU External Tools GNU Too 1.5.0.202011040924 com.st.stm32cube.ide.feature.mcu.externaltools.gnu_tools_for_stm32.7_2018_qg2_upda...
4 STM32CubelDE MCU External Tools GNU ~1.5.0.202011040924 com.st.stm32cube.ide.feature.mcu.externaltools.gnu_tools_for_stm32.7_2018_g2_upda...

Details

STMicroelectronics STM32CubelDE MCU External Tools GNU Tools for STM32 - Binaries (7-2018-g2-update) o

@ < Back Finish Cancel

Review the items and click on [Next].
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Figure 93. Review and accept licenses

[ = Ins1all O 4
Review Licenses [_l.]
Ligensaes misst Be reviewed and aocepted Eices the softwane can b indtalled, o
Lo Licerma :rtﬂ:
¥ STMicroskectronics Softwane Licerco Agreemset SIMicrostectronics Softwarne Licirse Agreement ~
SLADDAE Resed/March 2018

B INSTALLING COPYING, DOWNLOADSNG, ACCESSING OR OTHERWISE LISING THIS SDFTWARE
PACKAGE OR ANY PART THEREQF (AND THE RELATED DOCUMENTATION, FROM
STMICROELECTRONICS IMTERMATHOMNAL BN, SWISS BRANCH ANDYOR ITS AFFILLATED
COMPANIES (STMICROELECTRONICS), THE RECEMIENT, ON BEHALF OF HIMSELF OR HERSELF, OR
O BEHALF OF ANY ENTITY BY WHICH SUCH RECIFENT 15 EMPLOYED AMNDVOR ENGAGED AGREES
O BE BOUMD BY THIS SOF TWARE PACKAGE LICEMNSE AGREEMENT

Urdher STMmmcbectranics’ mlellectual praperty fghts and subject to applicable boensing berms bor

any third-party software incorporated in this software package and applicable Open Scurce Terms

(as deefiresd here below], the redistribution, reproduction and use in Sowtee and binery farrs of the
software package or ary pan therect, with or without modification, are pramitted provided thet the
(®)1] accept the terms of the licenos agreesment

) o not socept the terms of the license sgiesment

2 < Back Nest > Cancel

Review the licenses, select [| accept the terms of the license agreements] and click on [Finish].

At this point, the software installation starts. The progress bar displayed at the bottom of the STM32CubelDE
window shows the installation completion rate. Wait until the installation is completed.

The following warning may appear before the installation is finished.

Figure 94. Security warning

[ Security Warning O X

j Warning: Installing unsigned software for which the authenticity or validity cannot be
established. Continue with the installation?

Install anyway Details > >

In this case, to finalize the installation, click on [Install anyway]. After some time, the following dialog is
displayed.

Figure 95. Restart to apply software update

E Software Updates x

I@ Restart STM32CubelDE to apply the software update?

Click on [Restart Now] to be able to use the installed toolchain in STM32CubelDE. STM32CubelDE is restarted
and the new toolchain can be used.
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Open the Toolchain Manager to verify the installation.

Figure 96. Toolchain installed

O X
[
type filter text Toolchain Manager erei

> i

. g;?f:al The Toolchain Manager allows users to configure the workspace toolchain, and manage installed toolchains.

> Help Default Name State Add Local...

> Install/Update GNU ARM Embedded (7-2018-q2-update) Not installed Edit Local

> Remote Development GNU ARM Embedded (9-2020-q2-update) Not installed

> Remote Systems GNU Tools for STM32 (7-2018-g2-update)  Installed Uninstall...

> Run/Debug B GNU Tools for STM32 (9-2020-q2-update)  Installed with STM32CubelDE 1.6....

v STM32Cube Reloal
Build Set Default
Device Configuration Tool
End User Agreements
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer |
Target Status By default let STM32CubelDE select the toolchain to use.

T Tookchain Manager Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.

eam )
Terminal Restore Defaults
OIS Cancel
In this case, Figure 96 shows that two versions of GNU Tools for STM32 are installed.
2.3.1.2 Manage the default toolchain
The Toolchain Manager highlights the default workspace toolchain with an arrow in the Default column.
Figure 97. Default toolchain

[T preferences O X

r a m

type filter text Toolchain Manager A

> i

. g;?f:al The Toolchain Manager allows users to configure the workspace toolchain, and manage installed toolchains.

> Help Default  MName State Add Local...

> Install/Update GNU ARM Embedded (7-2018-q2-update) Not installed Edit Local

> Remote Development GNU ARM Embedded (9-2020-q2-update)  Not installed

> Remote Systems GNU Tools for STM32 (7-2018-q2-update)  Installed Uninstall...

> Run/Debug B GNU Tools for STM32 (9-2020-q2-update)  Installed with STM32CubelDE 1.6

v STM32Cube Reload
Build Set Default
Device Configuration Tool
End User Agreements
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer |
Target Status By default let STM32CubelDE select the toolchain to use.

. T Tookchain Manager Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.

eam !
Terminal Restore Defaults
OIS Cancel

Figure 97 shows that GNU Tools for STM32 version 9-2020-q2-update is the default workspace toolchain. The
GNU Tools for STM32 version 7-2018-q2-update line is marked in blue, which indicates that this toolchain
selected. Any line in the table can be selected with the mouse.
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Click on [Set default]: the selected toolchain to be used as the default workspace toolchain is highlighted with an
arrow symbol in the Default colum of the Toolchain Manager.

Figure 98. Default toolchain updated

m Preferences

type filter text

> General

> C/C++

> Help

> Install/Update

> Remote Development

> Remote Systems

> Run/Debug

v STM32Cube
Build
Device Configuration Tool
End User Agreements
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer
Target Status
Toolchain Manager

> Team

Terminal

Q@ eueh

Toolchain Manager wYE

The Toolchain Manager allows users to configure the workspace toolchain, and manage installed toolchains.

Default Name State
GNU ARM Embedded (7-2018-q2-update) Not installed Edit Local...
GNU ARM Embedded (9-2020-q2-update) Not installed
L4 GNU Tools for STM32 (7-2018-q2-update)  Installed Uninstall...
GNU Tools for STM32 (9-2020-q2-update)  Installed with STM32CubelDE 1.6
Reload
Set Default

By default let STM32CubelDE select the toolchain to use.
Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.

Restore Defaults

Apply and Close Cancel

Click on [Apply and Close] to apply the setting and update which toolchain is set to be the default workspace

toolchain.
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2.3.1.3 Uninstall a toolchain

It is not possible to uninstall the GNU Tools for STM32 toolchain, which is installed by default with
STM32CubelDE. Any other installed toolchain can be uninstalled.

Figure 99. Uninstall toolchain

m Preferences O X

| type filter text | Toolchain Manager
> Help o]
> Install/Update
> Remote Development

The Toolchain Manager allows users to configure the workspace toolchain, and
manage installed toolchains.

» Remote Systems Def... Name State Add Local...
» Run/Debug GNU ARM Embedded (7-2018-q2-... Not installed Edit Local...
v STM32Cube GNU ARM Embedded (9-2020-g2-... Not installed
Build GNU Tools for STM32 (7-2018-g2-u... Installed Uninstall...
Device Configuration Tool & GNU Tools for STM32 (9-2020-q2-u... Installed with ST...
End User Agreements Reload
File Association Set Default
Firmware Updater
MPU Serial
Serial Wire Viewer By default let STM32CubelDE select the toolchain to use.

Target Status
Toolchain Manager
> Team

Terminal v Restore Defaults

@ dued Apply and Close Cancel

Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.

To uninstall a toolchain, select it in the Toolchain Manager and click on [Uninstall...].
This opens the Uninstall dialog.

Figure 100. Uninstall details

m Uninstall O X

Uninstall Details (5}
¥ )
=

Review and confirm the items to be uninstalled.

Name Version Id
> {xSTM32CubelDE MCU External Tools GNU Tools for STM32 - Binaries (7-2018-g2-update) 1.5.0.202011040924 com.st.stm32cube.ide feature....

Details

@ < Back Next > Cancel
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Click on [Finish] to start the software uninstallation. The Software Updates dialog is displayed.

Figure 101. Software updates

E Software Updates x

,@ Restart STM32CubelDE to apply the software update?

=

Click on [Restart Now] to apply the software update.
The product is restarted.
Open the Toolchain Manager to verify the installation.

Figure 102. Toolchain uninstalled

[T preferences O X
type filter text | Toolchain Manager Grovi
» C/C++ ~ ) . . .
> Help The Toglchaln Manager allows users to configure the workspace toolchain, and manage installed
toolchains.
> Install/Update
> Remote Development Default  Name State Add Local...
> Remote Systems GNU ARM Embedded (7-2018-q2-update) Not installed Edit Local..
> Run/Debug GNU ARM Embedded (9-2020-q2-update) Not installed
v STM32Cube GNU Tools for STM32 (7-2018-q2-update)  Not installed Uninstall...
Build [ g GNU Tools for STM32 (9-2020-g2-update)  Installed with ST...
Device Configuration Tool Reload
End User Agreements S
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer
Target Status .
. By default let STM32CubelDE select the toolchain to use.
Toolchain Manager
> Team Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.
Terminal > Restore Defaults
@ac

In this case, Figure 102 shows that only one version of GNU Tools for STM32 is installed.
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2.3.1.4 Using a toolchain

It is possible to add and use an already installed local GNU ARM toolchain. To add a local toolchain, follow the
steps below:

1. Open Toolchain Manager and press the [Add Local...] button.

Figure 103. Add local toolchain

10E 0 X

Add local toolchain

9 Give the toolchain a name

Name:

Prefix:  arm-none-eabi-

Location: Browse...
@ Finish Cancel
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2. Add a name and specify location.

Figure 104. Specify local toolchain location

10E O X

Add local toolchain

O The following toolchain applications are missing: arm-none-eabi-addr2line.exe, arm-
none-eabi-gcc.exe, arm-none-eabi-nm.exe, arm-none-eabi-objcopy.exe, arm-none-

Name:  TrueSTUDIO

Prefix:  arm-none-eabi-

Location: C:\Program Files (x86)\Atollic\TrueSTUDIO for STM32 9.3.0\ARMTools\bin

@ Finish

Cancel

As seen in Figure 104, some naming problems can occur. In this case, the problem results from a wrong prefix
that prevents the toolchain application validation.

Update the toolchain prefix. The prefix must end with a dash (-).

Figure 105. Specify local toolchain prefix
10E} O X

Add local toolchain

Name:  TrueSTUDIO

Prefix: arm-atollic-eabi-

Location: C:\Program Files (x86)\Atollic\TrueSTUDIO for STM32 9.3.0\ARMTools\bin Browse...

@ Cancel
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3. Press [Finish].

Figure 106. Local toolchain added

m Preferences O e
‘type filter text | Toolchain Manager Sy i

> Install/Update ™ The Toolchain Manager allows users to configure the workspace toolchain, and

? Remote Development manage installed toolchains.

> Remote Systems

> Run/Debug De.. Name State Add Local...

GNU ARM Embedded (7-2018-q2... Not installed
v STM32Cube .
Build GNU ARM Embedded (9-2020-g2.. Mot installed

Device Configuration Tool GNU Tools for STM32 (7-2018-g2-... Installed

End User Agreements B GNU Tools for STM32 (9-2020-q2-... Installed with ST...

File Association TrueSTUDIO Local
Fi Updat
irmware Updater oot Default

MPU Serial
Serial Wire Viewer

Target Status

Toolchain Manager By default let STM32CubelDE select the toolchain to use.
> Team Note: installing and uninstalling toolchains requires a restart of STM32CubelDE.
Terminal
ermina v Restore Defaults
@ i & | Apply and Close | | Cancel

4. Use the [Edit Local...] button to edit local toolchain. The Edit local toolchain dialog opens, and it is possible to
update Prefix and Location.

Figure 107. Edit local toolchain

10E} 0 X

Edit local toolchain

Name:  TrueSTUDIO
Prefix: | |arm-ato||ic-eabi-
Location: C:\Program Files (x86)\Atollic\TrueSTUDIO for STM32 9.3.0\ARMTools\bin Browse...

@ Cancel

5. Update Prefix or Location and press [Finish] to update local toolchain settings.
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2.3.1.5 Network error
In case of problem to access the update site, the Network error... dialog is displayed.

Figure 108. Toolchain network error

ﬁ Metwork error... W

@ Failed to fetch the toochain list, please check your network settings.

Check the network settings. Information on how to configure network proxy settings are described in
Section 1.5.3: Preferences - Network proxy settings.

2.3.2 Configure the project build setting

When an STM32 project is created, it contains default C/C++ build settings for the project. There are however a
lot of different options that can be used by GCC, each embedded system having its own requirements. It is
therefore possible to configure the project build settings further than the default build settings.

It is also common to have different requirements on build settings during different phases of the project
development; for instance during the debugging and release phases. To handle this, different build configurations
for each project are supported by STM32CubelDE. This section presents the build configurations first, and then
the project build settings.

2.3.2.1 Project build configuration

Each build configuration allows different variants of a project and contains a specific build setting. When an
STM32 project is created in STM32CubelDE, two build configurations, Debug and Release, are created by
default. The Debug configuration makes the project built with debug information and without any optimization. The
Release configuration makes the project optimized for smaller code size and with no debug information. By
default, the Debug configuration is set as the active build configuration when the project is created.

It is possible to create new build configurations for a project at any time. Such new build configuration can be
based on an earlier available build configuration.

When building the project, the active build configuration is used and during build the files generated are written
into a folder with the same name as the active build configuration.

Note: The build configuration only handles the build settings. How to configure debug settings is described later in this
manual.

23.2141 Change the active build configuration
To change the active build configuration:
1. Select the project name in the Project Explorer

2. Use the toolbar in the C/C++ perspective and click on the arrow to the right of the [Build] toolbar button &~
3. The build configurations are listed
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Select the build configuration to use from the list.

Figure 109. Set the active build configuration using the toolbar

Eworkspace_um - myLib/Sr¢/mylib.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

R ® - | -@ @ E a8 [ it

5 Project Explorer Bl 1 Debug

v mmyLib

> @;Archives = FER R

D T T P - e

2 Debug2 (My own debug2 configuration)

3 Release

Another way to change the active build configuration is to right-click on the project name in the Project Explorer
view, select [Build Configurations]>[Set Active], and select the preferred build configuration.
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Figure 110. Set active build configuration using right-click

Eworkspacefum - myLib/Src/myLib.c - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help
N-ERI®S-R-B QLGB -G iHid
% Project Explorer 2% =0 [€
v mmyLib
> @%Archives
> |@]Inc|udes
> [Binc
v (Esrc
> EI myLib.c
> || syscalls.c
> |g] sysmem.c
> [=Debug
' mNUCLEr\ CAN4ADE
> ﬁ.: Bina New >
> |@]|F‘IC|L Go Into
v £ Core Open in New Window

7 2N copy Ctrl+C
? 2SS [ Ppaste Ctri+V
> =S x Delete Delete
v 2 Driv Source >
>
> gg Move...
> = Deb Rename... F2

MNUU\‘Q Import...
STN@ Export...
STV Build Project
Clean Project
& | Refresh F5

Close Project

Close Unrelated Projects

Build Configurations v 1 Debug Set Active >
Build Targets 2 Release Manage...
Index > Build Al
Show in Remote Systems view Clean All
0 Run As > Build Selected...
"til Debug As >
Profile As >
Team >
Compare With >
Restore from Local History...
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It is also possible to select the active build configurations using the menu [Project]>[Build Configurations]>[Set
Active] and select the chosen build configuration.

Figure 111. Set active build configuration using menu
Eworkspace_um - myLib/Src¢/myLib.c - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help

‘M9 v [l  Open Project Biv dv@vitsvi@qg v

Close Project

Project Exf - ® = O
©5 Project Ex; o Build All Ctrl+B B
v E%Y'-'b Build Config v 1 Debug Set Active >
’ |j]DArCh Build Project 2 Release Manage...
2 [ritInclu . :
> 8 Inc Build Working Set ’ Build by Working Set >
v (s Clean... Set Active by Working Set >
> @m ' Build Automatically Manage Working Sets...
> [d sy Build Targets >
> @ sy C/C++ Index >
> [=Debt Generate Report
v L NUCLEC Generate Code
.
> 45 Binal Properties
« SR 1
2.3.21.2 Create a new build configuration
To create a new build configuration:
1. Right-click on the project name in the Project Explorer view
2. Either:
- Select [Build Configurations]>[Manage... ]
- Use the menu [Project]>[Build Configurations]>[Manage... ]
Both methodes open the Manage Configurations dialog.
Figure 112. Manage Configurations dialog
. NUCLEO-F401RE: Manage Configurations X
Configuration Description Status
Debug Active
Release
Set Active ‘ ‘ New... ‘ ‘ Delete ‘ ‘ Rename... ‘
| oK | ‘ Cancel ‘
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As shown in Figure 112, some buttons in the dialog are used to manage the configurations:

. [Set Active] is used to change and select another configuration to be active
. [New...] is used to create a new build configuration

. [Delete] is used to delete an existing build configuration

. [Rename...] is used to rename the build configuration

To create a new build configuration, press the [New...] button. This opens the Create New Configuration dialog. In
this dialog, a name and description is entered. The name must be a valid directory name since it is used as the
directory name when building the project with the new configuration.

Figure 113. Create a new build configuration

E Create New Configuration X

Note: The configuration name will be used as a directory name in the file
system. Please ensure that it is valid for your platform.

Name: ‘ Debug2 |

Description: ‘ My own debug configuration |

Copy settings from

® Existing configuration

O Default configuration
Release
O Import from projects - not selected -- b
O Import predefined -- not selected -- %
OK | ‘ Cancel

As seen in Figure 113, the new build configuration is based on an existing build configuration. In the case
illustrated, the new configuration is based on the existing Debug configuration. Press [OK] when finished with the
settings.

The Manage Configurations dialog opens and the new debug configuration is displayed.

Figure 114. Updated Manage Configurations dialog

I NUCLEO-F401RE: Manage Configurations X
Configuration Description Status
Debug Active
Debug2 My own debug con...
Release
Set Active ‘ New... ‘ ‘ Delete ‘ ‘ Rename... ‘
| OK | ‘ Cancel ‘

Change the active configuration to another configuration if needed and press [OK] to save and close the
configurations dialog when finished managing configurations.
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2.3.21.3 Delete a build configuration
To delete a build configuration:
1. Open the Manage Configurations dialog
2. Select the configuration to be deleted
3. Press the [Delete] button

For instance, if the Debug?2 configuration is selected and [Delete] button is pressed, the following confirmation
dialog opens.

Figure 115. Configuration deletion dialog

[ confirm Delete X

@ Are you sure you want to delete the "Debug2" configuration?

Yes | ‘ No

In this case, select [No] to keep the Debug?2 configuration.

23214 Rename a build configuration
To rename a build configuration:
1. Open the Manage Configurations dialog
2. Select the configuration to be renamed
3. Press the [Rename...] button

For instance, if the Debug?2 configuration is selected and [Rename...] button is pressed, the following
confirmation dialog opens.

Figure 116. Configuration renaming dialog

E Rename Configuration X

Note: The configuration name will be used as a
directory name in the file system. Please ensure that it
is valid for your platform.

Name: ‘ ‘Debug2 ‘

Description: ‘ My own debug2 configuration ‘

| oK | ‘ Cancel ‘

Update the name, description, or both and press [OK] to rename the Debug?2 configuration. In this case, press
[Cancel] and keep the name.

2.3.2.2 Project C/C++ build settings

Each build configuration contains one project C/C++ build setting. The project C/C++ build setting is updated in
project properties. To update the build setting, right-click on the project name in the Project Explorer view and
select [Properties]or use the menu [Project]>[Properties]. Both these ways open the Properties window for the
project.
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Select [C/C++ Build]>[Settings] in the Properties left pane. The right part is then filled with tabs Tool Settings,
Build Steps, Build Artifact, Binary Parsers, and Error Parsers. The first two tabs are the most useful ones.

Figure 117. Properties tabs

m Properties for NUCLEQ-F401RE O X
:type filter text Settings Frov g
> Resource ~ A
Builders : -
v C/C++ Build Configuration: Debug [ Active ] ~  Manage Configurations...
Build Variak
Environmer ® Tool Settings . . . —
Logging gs * Build Steps Build Artifact 44 Binary Parsers @ Error Parsers
Settings # MCU Toolchain Mcu STM32F401RETx
> a2 :
C/Cs+ Generg EMCU Settings Board NUCLEO-F401RE
CMSIS-SVD Se 2MCU Post build outputs . . )
Project Referel ¥ « ®MCU GCC Assembler Floating-point unit FPv4-SP-D16 v
< > o~ . Cla=tina_naint ARl Harduars imnlamantatinn {_mflast_ahi—haedl ~ .
@ Cancel
Note: Resize the dialog window or use the top-right arrow buttons if all tabs are not visible.
The Settings pane contains a [Configuration] selection to decide if new selections are used in the active
configuration only, in another configuration, in all configurations or in multiple configurations. Press [Manage
Configurations] to open the Manage Configurations dialog.
Figure 118. Properties configurations
[CE Properties for NUCLEO-F401RE O X
I I I
type filter text Settings CR A
> Resource A } : n :
Builders - -
v C/C++ Build Configuration: |Debug [ Active ] ~ | Manage Configurations...
Build Variak afaiid
Ervi Debug?2
nvironmer .
Loagin ® Tool SettingRelease Error Parsers
< ?tg 9 [ All configurations ]
ettings € MCU Toc| Multiple configurations...]
» C/C++ Geners =MCU Settinas

[ IR AILIAIEA CANADC

The Tool Settings tab is further split into MCU Toolchain, MCU Settings, MCU Post build outputs, MCU GCC
Assembler, MCU GCC Compiler and MCU GCC Linker.

MCU Toolchain is used to change toolchains. STM32CubelDE includes one version of the GNU Tools for STM32

toolchain. The Toolchain Manager is used to download other GNU ARM Embedded toolchains and to configure to
use local GNU ARM Embedded toolchains.
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Information about patches made in GNU Tools for STM32 can be read in [EXT-12]. The document can be opened
from the Technical Documentation page in the Information Center.

Figure 119. Properties toolchain version

m Properties for NUCLEO-F401RE

O X
1
type filter text Settings vyeow g
> Resource 1’\
Builders .
v C/C++ Build Configuration: Debug [ Active |

~ Manage Configurations...
Build Variables

Environment - =T : 5 -
Logging % Tool Settings # Build Steps Build Artifact i Binary Parsers @ Error Parsers
Settings
> C/C++ General
CMSIS-SVD Settin
Project Reference
Run/Debug Settin

# MCU Toolchain Select what toolchain to use

#MCU Settings

= MCU Post build outputs
» ®MCU GCC Assembler
> ®MCU GCC Compiler Toolchain Manager
> ®MCU GCC Linker

® Use workspace setting (GNU Tools for STM32 (3-2020-q2-update))
(OFixed GNU Tools for STM32 (9-2020-q2-update)

Configure the workspace toolchain, and manage installed toolchains.

Open Toolchain Manager...

< > =
@ Apply and Close Cancel
Select [Fixed] to enable the toolchain selection.
Figure 120. Properties toolchain selection
m Properties for NUCLEQO-F401RE O X
1
type filter text Settings yalhd
> Resource ‘A
Builders . - -
v C/C++ Build Configuration: Debug [ Active ] ~ Manage Configurations...
Build Variables
Environment . S > _ —
Logging % Tool Settings  # Build Steps Build Artifact &l Binary Parsers @ Error Parsers
Settings # MCU Toolchain Select what toolchain to use
’ Eﬁ;; ;3\7895'3' _ EMCU Settings (O Use workspace setting (GNU Tools for STM32 (9-2020-q2-update))
- tt E . - i
Lo SN EMCU Post build outputs @ Fixed 'GNU Tools for STM32 (9-2020-g2-update) -
roject Reference ||, ®MCU GCC Assembler GNU Tools for STM32 (9-2020-g2-update)
Run/Debug Settin > ®MCU GCC Compiler Toolchain Manager ' '
» ®MCU GCC Linker Configure the workspace toolchain, and manage installed toolchains.
Open Toolchain Manager...
< > ¥
@ Apply and Close Cancel

As shown in Figure 120, only the default toolchain GNU Tools for STM32 is available by default. To install
additional toolchains, click on the [Open Toolchain Manager...] button to open the Toolchain Manager.

Section 2.3.1: Toolchain Manager contains detailed information on how to install, uninstall toolchains and select
the default workspace toolchain.
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MCU Settings displays the selected MCU and board for the project and proposes to select how to handle floating
point, instruction set and runtime library.

Figure 121. Properties tool MCU settings

m Properties for NUCLEQO-F401RE O X
|
type filter text Settings v g
> Resource ‘A
Builders . -
w C/C++ Build Configuration: Debug [ Active | ~ Manage Configurations...

Build Variables

Environment @ % z 5 :
® Tool Settings # Build Steps Build Artifact & Binary Parsers @ Error Parsers

Logging
Settings @ MCU Toolchain Meu STM32F401RETx
> C/C++ General (MCU Settings Board NUCLEO-F401RE
CMSIS-5VD Settin 2 MCU Post build outputs . X .
Project Reference v BMCU GCC Assembler Floating-point unit FPv4-SP-D16 i
Run/Debug Settin &General Floating-point ABl Hardware implementation (-mfloat-abi=hard) i
(**Debugging Instruction set Thumb2 X
31
& Preprocessor Runtime library ~ Reduced C (--specs=nano.specs) v

#Include paths
= Miscellaneous
v ®MCU GCC Compiler [Juse float with scanf from newlib-nane (-u _scanf_float)
=General
(2 Debugging
(= Preprocessor
#Include paths
(= Optimization
(#Warnings
=Miscellaneous
v ®MCU GCC Linker

D Use float with printf from newlib-nano (-u _printf_float)

=General

FLibraries
z 3 (=Miscellaneous o
@ Apply and Close Cancel

page 116/258




UM2609

Project set up and build

UM2609 - Rev 16

MCU Post build outputs proposes to convert the e1t file to another file format, show build size information, and
generate list file. The output file can be converted to:

. Binary file

. Intel Hex file
. Motorola S-record file
. Motorola S-record symbols file

. Verilog file

Figure 122. Properties tool MCU post-build settings

m Properties for NUCLEO-F401RE OJ K
: type filter text Settings st
|
> Re.source A
Builders - -
v C/C++ Build Configuration: Debug [ Active ] ~ Manage Configurations...

Build Variables
Environment
Logging
Settings # MCU Toolchain |2| Convert to binary file (-O binary)
7 C/C++ General ) = MCU Settings [ convert to Intel Hex file (-O ihex)
CMSIS-SVD) Settin EMCU Post build outputs [ Convert to Motorola S-record file (-O srec)

Project Reference . ® mMcU GCC Assembler
Run/Debug Settin &General

® Tool Settings # Build Steps ' Build Artifact = Binary Parsers @ Error Parsers

[ convert to Verilog file (-O verilog)

(2 Debugging [] Convert to Motorola S-record (symbols) file (-O symbolsrec)
(= Preprocessor
#lnclude paths Generate list file

[~ Show size information about built artifact

(= Miscellaneous
v BMCU GCC Compiler
= General
(#Debugging
(#Preprocessor
ZInclude paths
(#Optimization
#Warnings
= Miscellaneous
~ ®MCU GCC Linker
* General
ELibraries
(#Miscellaneous

@ Apply and Close Cancel
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The MCU GCC Assembler settings contains selections for the assembler. The main node presents all the
assembler command-line options that are currently enabled in the sub-node settings. The sub-nodes are used to
view the current settings or change any settings for the assembler.

Figure 123. Properties tool GCC assembler settings

m Properties for NUCLEQO-F401RE O X
1
type filter text Settings bl
> Resource ‘A
Builders
v C/C++ Build Configuration: Debug [ Active ] ~ Manage Configurations...
Build Variables
Environment ; T - ™ .
" % Tool Settings # Build Steps * Build Artifact & Binary Parsers © Error Parsers
Settings # MCU Toolchain Command:  gcc
’ Eﬁ;;—g\fge;:ltin Emcu Settings. All options: | -mcpu=cortex-mé4 -g3 -c -x assembler-with-cpp -
? &MCU Post build outputs specs=nano.specs -mfpu=fpv4-sp-d16 -mfloat-abi=hard -mthumb
Project Reference  » & MCU GCC Assembler
Run/Debug Settin (= General
&Debugging Expert settings:
(#Preprocessor
#lnclude paths ﬁ:em;::tr::n: ${COMMAND} ${FLAGS} ${OUTPUT_FLAG} ${OUTPUT_PREFIX}${OUTPU
(#Miscellaneous
v ®MCU GCC Compiler
= General
(**Debugging
(#Preprocessor
#Include paths
(= Optimization
#Warnings
=Miscellaneous
v ®MCU GCC Linker
= General
FLibraries
=Miscellaneous
< > ot
@ Cancel
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The MCU GCC Compiler settings contains selections for the compiler. The main node presents all the compiler
command-line options that are currently enabled in the sub-node settings. The sub-nodes are used to view the
current settings or change any settings for the compiler.

Figure 124. Properties tool GCC compiler settings

m Properties for NUCLEQO-F401RE O X
|
type filter text Settings Cvopw §
|
> Resource ~
Builders . -
~ C/C++ Build Configuration: Debug [Active ] ~ Manage Configurations...

Build Variables
Environment

Logging

Settings # MCU Toolchain Command:  gcc
» C/C++ General EMCU Settings

® Tool Settings * Build Steps Build Artifact i Binary Parsers @ Error Parsers

; All options:  -mcpu=cortex-m4 -std=gnu11 -g3 -DDEBUG -DUSE_HAL_DRIVER A
EMSIS-5VD Settin EMCU Post build outputs -DSTM32F407xE —c -./Core/Inc -

Project Reference | . ®MCU GCC Assembler I./Drivers/STM32F4xx_HAL Driver/Inc - v
Run/Debug Settin &General _HAL |

2 Debugging
(= Preprocessor
#Include paths
(= Miscellaneous
v ®BMCU GCC Compiler
(= General
=Debugging
(#Preprocessor
ZInclude paths
(% Optimization
EWarnings
(#Miscellaneous
v ®MCU GCC Linker
= General
ZLibraries
(#Miscellaneous

Expert settings:

Command |

: ${COMMAND]} ${INPUTS} ${FLAGS} ${OUTPUT_FLAG} ${OUTPUT_PREFI}
line pattern; - - —

@ Apply and Close Cancel
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The MCU GCC Linker settings contains selections for the linker. The main node presents all the linker command-
line options that are currently enabled in the sub-node settings. The sub-nodes are used to view the current
settings or change any settings for the linker.

Figure 125. Properties tool GCC linker settings

m Properties for NUCLEQO-F401RE O X
1
type filter text Settings G
> Resource ‘A
Builders
~ C/C++ Build Configuration: Debug [ Active ] ~ Manage Configurations...
Build Variables
Environment 2
— % Tool Settings . Build Steps ** Build Artifact i Binary Parsers © Error Parsers
Settings # MCU Toolchain Command:  gec
> i ;
Eﬁ;; g\fge;a:t_ EMCU Settings All options: | -mepu=cortex-mé -T"C:\Users\johansse\STM32CubelDE N
Moz L EMCU Post build outputs \workspace_um5\NUCLEO-FA01RE\STM32F401RETX_FLASH.Id" --
Rijent Reterence ¥ ®MCU GCC Assembler specs=nosys.specs -WI|,-Map="${BuildArtifactFileBaseName}.map" ¥
Run/Debug Settin (= General
n ;
W Debugging Expert settings:
(#Preprocessor c d
&lnclude paths -OmMMand ¢ aMIMAND) ${OUTPUT_FLAG) ${OUTPUT_PREFIX}${OUTPUT} ${INPU
X line pattern:
(#Miscellaneous
v ®MCU GCC Compiler
= General
(**Debugging
(#Preprocessor
#Include paths
(= Optimization
#Warnings
= Miscellaneous
~ ®MCU GCC Linker
= General
FLibraries
=Miscellaneous
< > =
@ Apply and Close Cancel
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The Build Steps settings contains fields used to provide pre-build and post-build steps, which run before and after
building the project. Edit the fields to run any pre-build or post-build step.

Figure 126. Properties build steps settings

[ properties for NUCLEO-F401RE O X
‘type filter text Settings LPryvw
> Resource
~ C/C++ Build o
Build Variables Configuration: ‘Debug [ Active | v ‘ |Manage Configurations...|

Discovery Options
Environment

Logging &3 Tool Settings A Build Steps Build Artifact Binary Parsers & Error Parsers Elz‘
Settings
> C/C++ General Pre-build steps
CMSIS-SVD Settings Command:
Project Natures ‘ o ‘
Project References
Run/Debug Settings Description:

‘ v ‘

Post-build steps

Command:
Description:
@ | Apply and Close ‘ | Cancel ‘
Note: It is possible to add more advanced post-build operations using makefile targets as described in Section 2.3.3.7.

233 Building the project

To start a build, select the corresponding project in the Project Explorer view and click on the [Build] 4~
toolbar button.

Figure 127. Project build toolbar

E workspace_um4 - NUCLEQ-F401RE/Core/Src/main.c - 5TM32CubelDE
File Edit Source Refactor Mavigate Search Project Run Window Help

MR - Q- mig- & itsr 0~ Q-

B Project Bxplorer 3¢ | | Build Debug' for project NUCLEO-FAOIRE | = = 5

The build can also be started from menu [Project]>[Build Project]. The [Project] menu contains also some other
usable build commands such as [Build All], [Build Project] or [Clean].

Another way to start a build is to right-click on the project in the Project Explorer view. This opens the context
menu with the [Build] command and some other build options.

During the build, the Console view lists the build process. At the end, when the <1t file is created normally, it lists
size information.
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Figure 128. Project build console

[;__Z Problems ¥ Tasks & Console &2 [ Properties G '1/} <-===!>‘ '—E Eﬁ ] =~ l.-ﬁ v = 0
CDT Build Console [NUCLEOQ-F401RE]
arm-none-eabl-gcc “../CoOre/Src/main.c” -mcpuscortex-mé4 -std=gnull -g3 -DUSE_HAL_DRLVER -DSIM32F401XE -DDEBUG -C -L.

arm-none-eabi-gcc "../Core/Src/stm32f4xx_hal_msp.c" -mcpu=cortex-m4 -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32F401xE -
arm-none-eabi-gcc "../Core/Src/stm32f4xx_it.c" -mcpu=cortex-m4 -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32F4@1xE -DDEBU
arm-none-eabi-gcc "../Core/Src/syscalls.c" -mcpu=cortex-m4 -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32F4@1xE -DDEBUG -c
arm-none-eabi-gcc "../Core/Src/sysmem.c" -mcpu=cortex-m4 -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32F4@1xE -DDEBUG -c -
arm-none-eabi-gcc "../Core/Src/system_stm32f4xx.c" -mcpu=cortex-md -std=gnull -g3 -DUSE_HAL_DRIVER -DSTM32F4@1xE -D|
arm-none-eabi-gcc -o "NUCLEO-F4@1RE.elf" @"objects.list” -mcpu=cortex-m4 -T"C:\Users\johansse\STM32CubeIDE\worksp
Finished building target: NUCLEO-F4@1RE.elf

arm-none-eabi-size  NUCLEO-F481RE.elf

arm-none-eabi-objdump -h -S NUCLEO-F481RE.elf > "NUCLEO-F4@1RE.list"
text data bss dec hex filename
7308 20 1636 8964 2304 NUCLEO-F4@1RE.elf

Finished building: default.size.stdout

Finished building: NUCLEO-F4@1RE.list

12:42:04 Build Finished. @ errors, @ warnings. (took 5s5.932ms)

2.3.3.1 Building all projects

The toolbar contains the [Build all] 1o button, which is used to build the active build configuration for all open
projects in workspace.

It is also possible to use the menu [Project]>[Build All] to start a build of all projects.

Figure 129. Project build all

Eworkspacefum - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help

;rﬁ'ul\ﬂJ Open Project g% v @'@vé
% Close Project = g
Project E <
IR o Build Al Ctrl+B
v E%yhb Build Configurations >
> g Arch Build Project
> @]Inclu . .
Build Working Set >
> [Blnc
Clean...
> BSC 90 Build Automatical
uild Automatica
> (= Deby Y
[ ENUCLEC Build Targets >
> ﬁﬁBinal C/C++ Index >

> @]]Inclu Generate Report

v (£ Core Generate Code
> =In
> 7= Sre

Properties

2.3.3.2 Build all build configurations

To build all build configurations for a project, right-click the project and select [Build Configurations]>[Build All]
in the context menu.
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Figure 130. Project build-all configurations

5 Project Explorer 52 g == 0 [g
v mmyLib
> ﬁ,Archives
> [l Includes
> [Einc
> [Bsrc
> (= Debug
v [ENUCLED- ~ -
> ﬁ'}Binariw
N @]Includ Go Into
v [ Core Open in New Window

> =InclE) Copy Ctrl+C
v =S¢ Paste Ctrl+V
> (2] 3¢ Delete Delete
> [g] Source >
> g Move...
> @ Rename... F2
> (g
> @ 2 Import..
/5
> EbStau Export...

> [“2 Driver Build Project
> (= Debu Clean Project
> (= Debu( & | Refresh F5
> [=>Releas Close Project
mNUCL Close Unrelated Projects

[1d STM3 Build Configurations > Set Active
[ STM3 Build Targets > Manage...
Index > Build All
Show in Remote Systems view Clean All
0 Run As > Build Selected...
B A N x .

2.3.3.3 Headless build

Headless build is intended to be used to build projects that must be integrated into script-controlled builds, such
as nightly builds on build servers for continuous integration process methods or others. The STM32CubelDE GUI
is never displayed in this case, and the user is not requested any manual interaction with STM32CubelDE.
STM32CubelDE includes a headless-build command file to run headless builds. For instance, when using
Windows®, it is located in the c: \ST\STM32CubeIDE_1.7.0\STM32CubeTDE STM32CubelDE installation folder.
The headless-build.bat file is intended to be run from a command prompt.

Note: Before running any headless build, make sure that the workspace is not opened by STM32CubelDE. If there is
an STM32CubelDE running already using the workspace, it is not possible for the headless-build process to
open and build the project.

To run headless build in Windows®, use the following procedure:

1. Open a command prompt.

2. Navigate to the STM32CubelDE installation directory. Open the folder in which the IDE is stored.
For example: cd C:\ST\STM32CubeIDE 1.7.0\STM32CubeIDE

3. Enter the following command to build the NUCLEO-F401RE project in the workspace
C:\Users\Name\STM32CubeIDE\workspace 1.7.0:
$ headless-build.bat -data C:\Users\Name\STM32CubeIDE\workspace 1.7.0
-cleanBuild NUCLEO-F401RE
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To get help on headless build parameters, use headless build with option —help. Figure 131 shows the result of
command $ headless-build.bat -help.

Headless build

EX Command Prompt — O X

C:\ST>cd STM32CubeIDE_1.7.8.21alphal

IC:\ST\STM32CubeIDE_1.7.8.21alphal>headless-build.bat -help
Usage: PROGRAM -data <workspace> -application org.eclipse.cdt.managedbuilder.core.headlessbuild [ OPTIONS ]

-data {/path/to/workspace}

-import {[uri:/]/path/to/project}

-importAll {[uri:/]/path/to/projectTreeURI} Import all projects under URI

-build {project_name_reg_ex{/config_reg_ex} | all}

-cleanBuild {project_name_reg_ex{/config_reg ex} | all}

-markerType Marker types to fail build on {all | cdt | marker_id}

-no-indexer Disable indexer

-printErrorMarkers Print all error markers

-1 {include_path} additional include_path to add to tools

-include {include_file} additional include_file to pass to tools

-D {prepoc_define} addition preprocessor defines to pass to the tools

-E {var=value} replace/add value to environment variable when running all tools

-Ea {var=value} append value to environment variable when running all tools

-Ep {var=value} prepend value to environment variable when running all tools

-Er {var} remove/unset the given environment variable

-T {toolid} {optionid=value} replace a tool option value in each configuration built

-Ta {toolid} {optionid=value} append to a tool option value in each configuration built

-Tp {toolid} {optionid=value} prepend to a tool option value in each configuration built

-Tr {toolid} {optionid=value} remove a tool option value in each configuration built
Tool option values are parsed as a string, comma separated list of strings or a boolean based on the options type

C:\ST\STM32CubeIDE_1.7.0.21alphal>

Temporary assembly file and preprocessed C code

Save the temporary assembly file by adding the -save-temps flag to the compiler:
In the menu, select [Project]>[Properties]

Select [C/C++ build]>[Settings]

Open the Tool Settings tab

Add -save-temps in the [C Compiler]>[Miscellaneous] settings

o N =

. Rebuild the project
The assembler file is located in the build output directory with name filename.s.

The file filenamz.i containing the preprocessed C code is generated also. It shows the code after the
preprocessor but before the compilation. It is advise to examine the content of this file in case of problems with
defines.

Build logging
To enable or disable project build logging, right-click on the project in the Project Explorer view and select
[Properties]. Then, select [C/C++ Build]>[Logging]. The log file location and name are also specified.

To enable a global build log for all projects in a workspace, select [Window], [Preferences], and open [C/C++,
Build, Logging]>[Enable global build logging].

Parallel build and build behaviour

Parallel build occurs when more than one thread is used at the same time to compile and build the code. Most
often, it reduces build time significantly. The optimal number of threads to use is usually equal to the number of
CPU cores of the computer. Parallel build can be enabled and disabled.

To configure parallel build:

1. Right-click on the project in the Project Explorer view

2. Select menu [Project]>[Properties]

3. Select [C/C++ Build] in the Properties panel

4. Open the Behavior tab and configure [Enable parallel build]

The Behavior tab also contains build settings on how to behave on errors, build on resource save, incremental
build, and clean.
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2.3.3.7

Note:

24

241
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Figure 132. Parallel build

[ Properties for NUCLEO-FAO1RE O X
type filter text ~ C/C++ Build Ly y Y
> Resource
> C/C++ Build
> C/C++ General Configuration: ‘Debug [ Active ] V‘ ‘Manage Configurations...

CMSIS-SVD Settings
Project Natures

Project References E| Builder Settings Behavior Q§° Refresh Policy
Run/Debug Settings

Build settings

Stop on first build error Enable parallel build
® Use optimal jobs (4)
O Use parallel jobs: 4 z
O Use unlimited jobs

Workbench Build Behavior
Workbench build type: Make build target:

[]Build on resource save (Auto build) ‘all ‘ Variables...

Note: See Workbench automatic build preference

Build (Incremental build) ‘all ‘ ‘Variables...‘
Clean ‘ clean ‘ ‘Variables...‘
‘ Restore Defaults ‘ ‘ Apply ‘
@ | Apply and Close | | Cancel ‘

Post-build with makefile targets

It is possible to add advanced post-build scripts by using makefile targets. To do this:
1. Create a new file

2. Name it makefile.targets

3. Place itin the root directory of the project

The content of the file must be similar to the example presented below. The example just copies the e1f
generated file to a new file and uses macros BUILD ARTIFACT, BUILD ARTIFACT PREFIX,

BUILD ARTIFACT NAME, and BUILD ARTIFACT EXTENSION, which are generated into the makefile by
STM32CubelDE from v1.5.0.

secure target := \
S (BUILD ARTIFACT PREFIX)$(BUILD ARTIFACT NAME)-secure.$ (BUILD ARTIFACT EXTENSION)
main-build: $ (secure target)

$ (secure_target): $(BUILD ARTIFACT)
# Do what you want here... simple copy file for demo
Cp ll$<ll "$@"

make requires that tabs are used instead of spaces.
Build Analyzer

Introduction to the Build Analyzer

The STM32CubelDE Build Analyzer feature interprets program information from the e1£ file in detail and presents
the information in a view. If a map file, with similar name, is found in the same folder as the e1r file the information
from the map file is also used and even more information can be presented.
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The Build Analyzer view is useful to optimize or simplify a program. The view contains two tabs, the Memory
Regions and Memory Details tabs:

. The Memory Regions tab is populated with data if the e1¢ file contains a corresponding map file. When the
map file is available, this tab can be seen as a brief summary of the memory regions with information about
the region name, start address and size. The size information also comprises the total size, free and used
part of the region, and usage percentage.

. The Memory Details tab contains detailed program information based on the 1t file. The different section
names are presented with address and size information. Each section can be expanded and collapsed.
When a section is expanded, functions/data in this section is listed. Each presented function/data contains
address and size information.

24.2 Using the Build Analyzer

The Build Analyzer view is by default open in the C/C++perspective. If the view is closed it can be opened from
the menu. Select the menu command [Window]>[Show View]>[Build Analyzer] or use the [Quick Access] field,
search for “Build Analyzer” and select it from the views.

When the Build Analyzer view is open, select an e1f file in the Project Explorer view. The Build Analyzer view is
then updated with the information from this file. When an e1£ file is selected and a map file, with similar name, is
found in the same folder, additional information from the map file is also used by the view.

The Build Analyzer view is also updated if a project node in the Project Explorer view is selected. In this case the
Build Analyzer uses the el file that corresponds to the current active build configuration of the project.

Figure 133. Build analyzer

10E O X

o Build Analyzer - #y=o
STM3ZF 40 Nucleo.elf - ISTMI2F4x¢-Nucleo/Debug - Oct 21, 2019 2:44:29 PM
Memory Regions  Memory Details
Region Start address End address Size Free Used Usage (%)
=FLASH 0x08000000 0x08080000 524288 518840 5448 ‘ 1.04%
=RAM 0x20000000 0x20018000 98304 96604 1700 | 1.73%

2.4.21 Memory Regions tab

The Memory Regions tab in the Build Analyzer view displays information based on the corresponding map file. If
no information is displayed, it means that there is no corresponding map file found. When a map file is found, the
region names, start address, end address, total size of region, free size, used size and usage information are
presented.

These regions are usually defined in the linker script file (. 1d) used when building the program. Update the linker
script file if a memory region location or size must be changed.

Note: The Memory Regions tab is empty if the e1r file has no corresponding map file.
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Figure 134. Memory Regions tab

10} O X
o Build Analyzer = #voo
NUCLEO-F401RE.elf - INUCLEO-FA01RE/Debug - Oct 25, 2019 10:24:05 AM
Memory Regions  Memory Details
Region Start address End address Size Free Used Usage (%)
=RAM 0x20000000 0x20018000 96 KB 16.23 KB 79.77 KB 83.09%
=FLASH 0x08000000 0x08040000 256 KB 236.17KB  19.83 KB I7.75%
=FLASH_ICONS 0x08040000 0x08050000 64 KB 4447 KB 19.53 KB -52%
=ELASH_IMAGES 0x08050000 0x08070000 128 KB 1081 KB 117.19KB
=FLASH_SOUND 0x08070000 0x0807f000 60 KB 7.75 KB 52.25 KB 87.08%
=IFLASH_D 0x0807f000 0x0807f800 2 KB 1.99 KB 8B 0.39%
=FLASH V 0x0807f800 0x08080000 2KB 1.99 KB 12B ‘ 0.59%

The column information is described in the Table 6.

Table 6. Memory Regions tab information

I T

Region Name of memory region (if a corresponding map file is found).
Start address ' The start address of the region, defined in the linker script.

End address ' End address of the region.

Size The total size of memory region.

Free The free size in the memory region.

Used The used size in the memory region.

Usage % The percentage of used size relative to the total memory region size. See Table 7 for the bar icon color

information.

The Usage (%) column contains a bar icon corresponding to the percentage value. The bar has different colors
depending on the percentage of used memory.

Table 7. Memory Regions usage color

2.4.2.2
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Green Less than 75% of memory used.
Yellow 75% to 90% of memory used.
Red More than 90% of memory used.

Memory Details tab

The Memory Details tab of the Build Analyzer view contains information for the e1f file. Each section in the
Memory Details tab can be expanded so that individual functions and data can be seen. The tab presents
columns with name, run address, load address, and size information.
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Figure 135. Memory Details tab

10} O X
o Build Analyzer = ®voo
NUCLEO-FA01RE.elf - INUCLEO-FA01RE/Debug - Oct 25, 2019 11:15:52 AM
Memory Regions Memory Details
Search
Name Run address (VMA) Load address (LMA) Size
v BERAM 0x20000000 96 KB
> E data 0x20000000 0x0800449 128
> bss 0x2000000c 78.25 KB
& ._user_heap_stack 0x2001390c 1.5 KB
> FLASH 0x08000000 256 KB
> = FLASH_ICONS 0x08040000 64 KB
v = FLASH_IMAGES 0x08050000 128 KB
vk flash_images 0x08050000 0x08050000 117.19 KB
= image3 0x08064c08 0x08064c08 34.18 KB
* image2 0x080561a8 0x080561a8 58.59 KB
* image1 0x08050000 0x08050000 2441 KB
v B FLASH_SOUND 0x08070000 60 KB
> & flash_sound 0x08070000 0x08070000 52.25 KB
v BELASH_D 0x0807f000 2 KB
> E flash_ d 0x0807f000 8B
v BEEFLASH_V 0x0807f800 2 KB
> E flash_v 0x0807f800 0x0807f800 128

The column information is described in Table 8.

Table 8. Memory Details tab information

I

Name of memory region, section, function, and data. A green icon is used to mark functions while the

Name ) . .
blue icon is used for data variables.

Run Address (VMA) | The Virtual Memory Address contains the address used when the program is running.

The Load Memory Address is the address used for load, for instance for the initialization values of

Load Address (LMA) global variables.

Size Used size (total size for Memory Regions).

Note: The memory region name is only displayed if a corresponding map file is found.

24221 Size information
The size information in the Memory Details tab is calculated from the symbol size in the e1x file. If a
corresponding map file is investigated, it may contain a different size value. The size is usually correct for C files
but the value presented for assembler files depends on how the size information is written in the assembler files.
The constants used by the function must be defined within the section definition. At the end of the section, the
size directive is used by the linker to calculate the size of the function.
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Example: Reset_Handler in startup.s file

This example shows how to write the Reset Handler in an assembler startup file to include the constants
_sidata, _sdata, _edata, _sbss, and _ebss inthe Reset Handler size information in the e1rx file. If these
constants are defined out of the Reset Handler section definition, their sizes are not included in the calculated
size of the Reset Handler. To include them in the size of the Reset Handler, these definitions must be
placed inside the Reset Handler section as presented in the code example below.

.section .text.Reset Handler
.weak Reset Handler
.type Reset Handler, 3%function

Reset Handler:
ldr sp, = estack /* set stack pointer */

/* Copy the data segment initializers from flash to SRAM */
movs rl, #0

b LoopCopyDatalInit

CopyDatalInit:
ldr r3, = sidata

/* initialization code data, bss, ... */

/* Call the application's entry point */
bl main
bx 1r

/* start address for the initialization values defined in linker script */
.word sidata

.word sdata

.word edata

.word sbss

.word ebss

.size Reset Handler, .-Reset Handler
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24.2.2.2 Sorting
The sort order of a Memory Details tab column can be changed by clicking on the column name.

Figure 136. Memory Details sorted by size

10E} O X
o Build Analyzer =voo
NUCLEQ-F401RE.lf - INUCLEQ-FADIRE/Debug - Oct 25, 2019 11:15:52 AM
Memory Regions Memory Details
Search
Name Run address (VMA) Load address (LMA) Size 7
> = FLASH 0x08000000 256 KB
v B FLASH_IMAGES 0x08050000 128 KB
v E flash_images 0x08050000 0x08050000 117.19 KB
* image2 0x080561a8 0x080561a8 58.59 KB
= image3 0x08064c08 0x08064c08 34.18 KB
= image1 0x08050000 0x08050000 24.41 KB
v ERAM 0x20000000 96 KB
> H bss 0x2000000c 78.25 KB
& _user_heap_stack 0x2001390¢ 1.5 KB
> E data 0x20000000 0x08004f49 128
> ®FLASH_ICONS 0x08040000 64 KB
> EFLASH_SOUND 0x08070000 60 KB
v ®ELASH D 0x0807f000 2 KB
>k flash_d 0x0807f000 8B
v B ELASH_V 0x0807f800 2 KB
>k flash_v 0x0807f800 0x0807f800 12B
24223 Search and filter
The information in the Memory Detailstab can be filtered by entering a string in the search field.
Figure 137 shows a search example for names including the string “sound”.
Figure 137. Memory Details search and filter
10} O X
=

a Build Analyzer =

NUCLEO-F401RE.elf - INUCLEO-F401RE/Debug - Oct 25, 2019 11:15:52 AM

Memory Regions Memory Details

sound|

Name Run address (VMA) Load address (LMA) Size 7

v ®EFLASH_SOUND 0x08070000 60 KB

v & flash_sound 0x08070000 0x08070000 52.25 KB

= sound1 0x08070000 0x08070000 19.53 KB
= sound2 0x08074e20 0x08074e20 19.53 KB
= sound4 0x0807afc8 0x0807afc8 8.3 KB
= sound3 0x08079¢40 0x08079¢40 4,88 KB
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24.2.24 Calculate the sum of sizes

The sum of the sizes of several lines in the Memory Details tab can be calculated by selecting these lines in the
view. The sum of the selection is presented above the Name column in the view.

Figure 138. Sum of sizes

10E} O X

a6 Build Analyzer = B

NUCLEQ-FADIRE.elf - INUCLEQ-FAD1RE/Debug - Oct 25, 2019 11:15:52 AM

Memory Regions Memory Details
Selection: 92.77 KB

Search

Name Run address (VMA) Load address (LMA) Size 7

> mEFLASH 0x08000000 256 KB

v EFLASH_IMAGES 0x08050000 128 KB

v E flash_images 0x08050000 0x08050000 117.19 KB

* image2 0x080561a8 0x080561a8 58.59 KB
= image3 0x08064c08 0x08064c08 34.18 KB
= imagel 0x08050000 0x08050000 2441 KB

> ERAM 0x20000000 96 KB

> mIELASH_ICONS 0x08040000 64 KB
v B FLASH_SOUND 0x08070000 60 KB
> 1 flash_sound 0x08070000 0x08070000 52.25 KB
> ®mFELASH_D 0x0807f000 2 KB
> EFLASH_V 0x0807f800 2 KB

24225 Display the size information in byte format

The Build Analyzer view can display size information in different format according to the [Show Byte], [Show
Hex] or [Show Human] selection. The icon in the Build Analyzer toolbar is used to switch between these formats.

Prefer [Show Byte] or [Show Hex] when copying and pasting of data into an Excel® document for later

calculations.
Figure 139. Show byte count
10E] O X
o . R
o Build Analyzer = =
NUCLE O-FA01RE elf - INUCLE O-FA01RE/Debug - Oct 25, 2019 11:15:52 AM . Show Bwe
Memory Regions Memory Details ::OW :ex
ow Human
Selection: 85000
Search
Name v Run address (VMA) Load address (LMA) Size
> =mRAM 0x20000000 98304
> EFLASH_V 0x0807f800 2048
v = FLASH_SOUND 0x08070000 61440
>k flash_sound 0x08070000 0x08070000 53500
v = FLASH_IMAGES 0x08050000 131072
v & flash_images 0x08050000 0x08050000 120000
* image3 0x08064c08 0x08064c08 35000
* image2 0x080561a8 0x080561a8 60000
= image1 0x08050000 0x08050000 25000
> = FLASH_ICONS 0x08040000 65536
> FLASH_D 0x0807f000 2048
> FLASH 0x08000000 262144
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Figure 140. Show hex count

24.2.2.6
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Selection: 0x14c08
Search

Memory Regions Memory Details

10¢ O X

= . - v O

w0 Build Analyzer

NUCLE O-FA01RE.elf - INUCLE O-F401RE/Debug - Oct 25,2019 11:15:52 AM Show Byte
. Show Hex

Show Human

Name Run address (VMA) Load address (LMA) Size
> =RAM 0x20000000 0x18000
> BEFLASH_V 0x0807f800 0x800
v B FLASH_SOUND 0x08070000 0xf000
>k flash_sound 0x08070000 0x08070000 0xdOfc
v B FLASH_IMAGES 0x08050000 0x20000
v & flash_images 0x08050000 0x08050000 0Ox1d4c0
= image3 0x08064c08 0x08064c08 0x88b8
* image2 0x080561a8 0x080561a8 Oxeab0
* imageT 0x08050000 0x08050000 Ox61a8
> B FLASH_ICONS 0x08040000 0x10000
> ®FLASH D 0x0807f000 0x800
> @ FLASH 0x08000000 0x40000

Copy and paste

The data in the Memory Details tab can be copied to other applications in CSV format by selecting the rows to
copy and typing Ctrl+C. The copied data can be pasted into another application with the Ctrl+V command.

Figure 141. Copy and paste

10} O X
a Build Analyzer = ¥ =d
NUGLEO-FADIRE sif - NUCLEG-FADIREIDebug - Oct 25, 2018 11:15:52 AM
Memory Regions Memory Details
Selection: 193500
Search
Name e Run address (VMA) Load address (LMA) Size
> ERAM 0x20000000 98304
> BIFLASH_V 0x0807f800 2048
v ®EFLASH_SOUND 0x08070000 61440
~ & flash_sound 0x08070000 0x08070000 53500
* sound4 0x0807afc8 0x0807afc8 8500
= sound3 0x08079¢40 0x08079¢40 5000
= sound2 0x08074e20 0x08074e20 20000
= sound1 0x08070000 0x08070000 20000
v 8 FLASH_IMAGES 0x08050000 131072
v & flash_images 0x08050000 0x08050000 120000
= image3 0x08064c08 0x08064¢c08 35000
= image2 0x080561a8 0x080561a8 60000
= image1 0x08050000 0x08050000 25000
v @ ELASH_ICONS 0x08040000 65536
v 5 flash_icons 0x08040000 0x08040000 20000
= icons 0x08040000 0x08040000 20000
> BFLASH_D 0x0807f000 2048
> EELASH 0x08000000 262144
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The Ctrl+C copy of the lines selected in Figure 141 provides the Ctrl+V results below:

"sound4";"0x0807afc8";"0x0807afc8";"8500"
"sound3";"0x08079c40";"0x08079c40";"5000"
"sound2";"0x08074e20";"0x08074e20";"20000"
"soundl";"0x08070000";"0x08070000";"20000"
"image3";"0x08064c08";"0x08064c08";"35000"
"image2";"0x080561a8";"0x080561a8";"60000"
"imagel";"0x08050000";"0x08050000";"25000"
"icons";"0x08040000";"0x08040000";"20000"

2.5 Build view setting
The build views require some setting. To apply manual refresh, follow the steps below:
1. Select the [Window]>[Preferences] menu.
2. Select the Build Views settings option of STM32Cube in the left pane.
3. Select [On request] for the Build Views Refresh Mode option as shown in Figure 142.
4. Use the refresh button of the build view each time a refresh is required as illustrated in Figure 143.

Once the refresh on request is selected for the build views, the values in the build views are updated only once
the refresh button is pressed.

This setting applies to:

. The Build Analyzer view
. The Static Stack Analyzer view
. The Cyclomatic Complexity view

On the contrary, if the [Auto] option is selected for the refresh mode, the build values are automatically refreshed.

Figure 142. On request build view refresh mode

m Preferences O X

| type filter text Build Views settings

> General

> C/C++

> Help

> Install/Update

Build Views Options
Build Views Refresh Mode

Aut
> Remote Development 8 oo
> Run/Debug -_On request

v STM32Cube Cyclomatic Complexity View
Complexity Ceiling: | 10

Build Views settings
Default GDB Server

Device Configuration Tool

End User Agreements
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer
Target Status
Toolchain Manager
Terminal
> Version Control (Team)

| Restore Defaults ‘ | Apply ‘

@ a4 | Apply and Close | | Cancel |

-
S
N
©
re}
[
N~
=
[a]
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Figure 143. Build view refresh button

B & Build Analyzer & Static Stack Analyzer % @ Cyclomatic Complexity -“@" =l
. Refresh Stack Analyzer I
List| Call graph|
A5 Hide dead code
Function Local cost  Type Location Info
2
2.6 Static Stack Analyzer
2.6.1 Introduction to the Static Stack Analyzer

The STM32CubelDE Static Stack Analyzer calculates the stack usage based on the built program. It analyzes the
.su files, generated by gcc, and the e1t file in detail, and presents the resulting information in the view.

The view contains two tabs, the List and Call Graph tabs.
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The List tab is populated with the stack usage for each function included in the program. The tab lists one line per
function, each line consisting of the Function, Local cost, Type, Location and Info columns.

Figure 144. Static Stack Analyzer List tab

1DE} O X
= Static Stack Analyzer i
STMA2F ot Nucleo,elf-ISTMAZFbox NuclealDebug - Oct 25, 201 12:03:09 PM

List Call graph

Hide dead code

|

Function M Local cost  Type Location Info 2

@ main 88 STATIC  main.c:79

© TIM_TI1_SetConfig 16 STATIC  stm32fdxx_hal_tim.c:4540

© TIM_SlaveTimer_SetConfig 12 STATIC  stm32fdxx_hal_tim.c:4983

@ TIM_CCxChannelCmd 8 STATIC  stm32fdxx_hal_tim.c:4739

@ TIM_Base_SetConfig 0 STATIC  stm32f4xx_hal_tim.c:4481

@ Systemlnit 0 STATIC  system_stm32f4xx.c:148

@ HAL_TIM_TriggerCallback 0 STATIC  stm32fdxx_hal_tim.c:4364

@ HAL_TIM_SlaveConfigSync... 16 STATIC  stm32fdxx_hal_tim.c:4143

@ HAL_TIM_ReadCapturedVal... 0 STATIC  stm32fdxx_hal_tim.c:4217

© HAL_TIM_PeriodElapsedCal... 0 STATIC  stm32fdxx_hal_tim.c:4304

@ HAL_TIM_PWM_PulseFinish... 0 STATIC  stm32fdxx_hal_tim.c:4349

© HAL_TIM_OC_DelayElapsed... 0 STATIC  stm32fdxx_hal_tim.c:4319

@ HAL_TIM_IRQHandler 8 STATIC  stm32fdxx_hal_tim.c:2809

@ HAL_TIM_IC_Start_IT 8 STATIC  stm32fdxx_hal_tim.c:1672 v

< >

The Call Graph tab contains an expandable list with functions included in the program. Lines representing
functions calling other functions can be expanded to see the call hierarchy.

Figure 145. Static Stack Analyzer Call Graph tab

10¢] m] X
= Static Stack Analyzer ®=0
STMIZF4ucNucko. ot - ISTM2F b NuleolDebug - Oct 25, 2019 120309 P
List Call graph
main Search... Case sensitive
Function Depth Max cost  Local cost Type Location Info
< UsageFault_Handler ? % 0 STATIC  stm32f4xx_it.c:116 Max cost uncertain. Recursive
$¥ADC_IRQHandler T I 0 Max cost uncertain. Recursive. No stack usage information available for this ...
+¥BusFault_Handler 2 2 0 STATIC  stm32fdxx_it.c:103 Max cost uncertain. Recursive
$¥HardFault_Handler ? 2 0 STATIC  stm32fdxx_it.c:77 Max cost uncertain. Recursive
'\'tMemManage_Handler ? ? 0 STATIC  stm32f4xx_it.c:90 Max cost uncertain. Recursive
> |as Reset_Handler 7 184 0 Max cost uncertain. No stack usage information available for this function
> @ TIM4_IRQHandler 3 8 0 STATIC  stm32f4xx_it.c:173 Max cost uncertain
@ NMI_Handler 0 0 0 STATIC  stm32f4xx_it.c:68
® PendSV_Handler 0 0 0 STATIC ~ stm32fdxx_it.c:147
o frame_dummy 0 0 0 Max cost uncertain. No stack usage information available for this function
> @ SysTick_Handler 1 0 0 STATIC  stm32f4xx_it.c:156
© SVC_Handler 0 0 0 STATIC ~ stm32fdxx_it.c:129
@ DebugMon_Handler 0 0 0 STATIC  stm32f4xx_it.c:138
la» __do_global_dtors_aux 0 0 0 Max cost uncertain. No stack usage information available for this function
oo _fini 0 0 0 Max cost uncertain. No stack usage information available for this function
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2.6.2 Using the Static Stack Analyzer

The Static Stack Analyzerview is by default open in the C/C++perspective. If the view is closed, it can be opened
from the menu. Select the menu command [Window]>[Show View]>[Static Stack Analyzer]. Another way to
open the Static Stack Analyzerview is to type “Static Stack Analyzer” in the [Quick Access search bar] and
select it from the views.

Figure 146. Open the Static Stack Analyzer view

E workspace_um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

Sy v ain@digvye NewWindow FrifEETifivrdrooro (@O
I&5 Project Explorer il ’ & main.c stm32fdxx_it.c w STM32F40
: Appearance 2 e
¥ rfriEBCll;\i?l;Tm RE Show View > -_u Build Analyzer
> @includes Perspective > "‘4_‘. Build Targe_ts
v §2Core Navigation > E‘-;C/ C++ Projects _
Console Alt+Shift+Q, C
> &lnc Preferences — ‘2 Include Browser
v @5rc % Navigator (Deprecated)
> &mainc & Outline Alt+Shift+Q, O
> lgstm32f4xx_hal_msp.c & Problem Details
> 8 stm32f4xx_it.c £ Problems Alt+Shift+Q, X
> lésyscalls.c & Project Explorer
> g sysconf.c [ Properties
> 8 sysmem.c % Search Alt+Shift+Q, S
> lg system_stm32f4xx.c B SFRs
> @ Startup = Static Stack Analyzer
> &Drivers &1 Tasks
v @ Debug Other... Alt+Shift+Q, Q

The Static Stack Analyzer view is populated when a built project is selected in the Project Explorer. The project
must be built with option [Generate per function stack usage information] enabled, otherwise the view cannot
present any stack information.

How to setup the compiler to generate stack usage information is explained in the next section.

2.6.2.1 Enable stack usage information

If the top of the view displays the message No stack usage information found, please enable in
the compiler settings, the build configuration must be updated for the compiler to generate stack
information:

1. Open the project properties, for instance with a right-click on the project in the Project Explorer view
Select Properties and, in the dialog, select [C/C++ Build]>[Settings]

Select the Tool Settings tab

Select [MCU GCC Compiler]>[Miscellanous]

Select [Enable stack usage information (-fstack-usage)] as shown in Figure 147

Save the setting and rebuild the program

oo wN
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Figure 147. Enable generate per function stack usage information

[ZH properties for NUCLEO-F401RE O X
‘type filter text Settings LYy
> Resource
v C/C++ Build -
Build Variables Configuration: Debug [ Active | ~ Manage Configurations...
Discovery Options
Environment .
Logai & Tool Settings  # Build Steps * Build Artifact Binary Parsers @ Error Parsers e
ogging
Settings EMCU Settings Other flags a0 85 8
# C/C++ General _ =MCU Post build outputs
CMSIS-SVD Settings v ®MCU GCC Assembler
Project References 2 General
Refactoring History Debugging
Run/Debug Settings & Preprocessor

#Include paths

(#Miscellaneous
v ®MCU GCC Compiler

#General

(2 Debugging

(= Preprocessor

#Include paths

(#Optimization

(#Warnings

(**Miscellaneous
v ®MCU GCC Linker

= General

(= Libraries

(2 Miscellaneous

[ verbose (-v)
[1Position Independent Code (-fPIC)
Enable stack usage analysis (-fstack-usage)

Restore Defaults Apply

@ Apply and Close Cancel

2.6.2.2 List tab

The List tab contains a list of all functions included in the selected program with options to [Hide dead code]
functions and [Filter] visible functions.

Use the [Hide dead code] selection to enable or disable the listing of dead code functions.
If used, the [Filter] field restricts the display to functions matching the characters it contains.
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Figure 148. Static Stack Analyzer List tab

10| O 5
= Static Stack Analyzer ** =
NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Oct 25, 2019 1:58:05 PM

List Call graph

[JHide dead code

Function Local cost  Type Location Info 2

@ SystemClock_Config 88 STATIC  main.c:410

@ HAL_RCC_MCOConfig 56 STATIC  stm32fdxx_hal_rcc.c:749

@ MX_GPIO_Init 48 STATIC  main.c:487

& HAL_UART_Msplnit 48 STATIC  stm32fdxx_hal_msp.c:88

@ HAL_DMA_PollForTransfer 48 STATIC  stm32fdxx_hal_dma.c:612

@ main 40 STATIC  main.c:183

@ NVIC_EncodePriority 40 STATIC  core_cm4.h:1863

@ NVIC_DecodePriority 40 STATIC  core_cm4.h:1890

@ HAL_FLASH_Program 40 STATIC  stm32fdxx_hal_flash.c:156

@ HAL_GPIO_Init 40 STATIC  stm32f4xx_hal_gpio.c:171

@ HAL_RCC_GetSysClockFreq 40 STATIC  stm32fdxx_hal_rcc.c:859

@ HAL_UART_Transmit 40 STATIC  stm32f4xx_hal_uart.c:1019

@ HAL_UART_Receive 40 STATIC  stm32f4xx_hal uart.c:1101

@ HAL_UART_IRQHandler 40 STATIC  stm32fdxx_hal_uart.c:1998

& aiviba 29 CTATI main ~1NE N

The column information in the List tab is described in Table 9.

Table 9. Static Stack Analyzer List tab details

Ciame | i

Function | Function name.
Local cost The number displays how many bytes of stack the function uses.

Tells if the function uses a STATIC or DYNAMIC stack allocation. When DYNAMIC allocation is used the actual

Type stack size is run-time dependent and the the Local cost value is uncertain due to the dynamic size of stack.
. Indicates where the function is declared. It is possible to double-click on a line and open the file with the defined
Location g .
function in the editor.
Info Additional information about the calculation.

The List tab sort order can be changed by clicking on a column name.

Note: By double-clicking on a line that displays the file location and line number in the List tab, the function is opened
in the Editor view.

2.6.2.3 Call Graph tab

The Call Graph tab contains detailed program information in a tree view. Each function included in the program
but not called by any other function is presented at the top level. It is possible to expand the tree to see called
functions. Only functions available in the e1£ file can be visible in the tab.

When used, the [Search...] button triggers the display of the functions matching the characters in the search field.
The search can be made case sensitive or not depending on the selection in checkbox [Case sensitive].

UM2609 - Rev 16 page 138/258



UM2609

Project set up and build

Note:

UM2609 - Rev 16

Figure 149. Static Stack Analyzer Call Graph tab

10| O X
= Static Stack Analyzer ®=8
NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Oct 25, 2019 1:58:05 PM
List Call graph
Search... [] Case sensitive
Function Depth Max cost  Local cost  Type Location Info a
$¥ADC_IRQHandler ? ? 0 Max cost uncertain. Recursive. No stack usage information available for this...
> [a Reset_Handler 16 248 0 Max cost uncertain. No stack usage information available for this function
> [ao__swrite 3 48 0 Max cost uncertain. No stack usage information available for this function
> |aw__sread 2 32 0 Max cost uncertain. No stack usage information available for this function
> [a__sseek 2 24 0 Max cost uncertain. No stack usage information available for this function
> [ao__sclose 2 16 0 Max cost uncertain. No stack usage information available for this function
> © SysTick_Handler 1 12 8 STATIC  stm32fdxx_it.c:182
© NMI_Handler 0 4 4 STATIC  stm32fdxx_it.c:70
© DebugMon_Handler 0 4 4 STATIC  stm32fdxx_it.c:156
© MemManage_Handler 0 4 4 STATIC  stm32fdxx_it.c:98
© UsageFault_Handler 0 4 4 STATIC  stm32fdxx_it.c:128
@ PendSV_Handler 0 4 4 STATIC ~ stm32fdxx_it.c:169
© BusFault_Handler 0 4 4 STATIC  stm32fdxx_it.c:113
@ HardFault_Handler 0 4 4 STATIC  stm32fdxx_it.c:83
©® SVC_Handler 0 4 4 STATIC  stm32fdxx_it.c:143
[ frame_dummy 0 0 0 Max cost uncertain. No stack usage information available for this function v

The column information in the Call Graph tab is described in Table 10.

Table 10. Static Stack Analyzer Call Graph tab details

=

Function ' Function name.

Specifies the call stack depth this function uses:

Depth . 0: the function does not call any other functions
. Number = 1: the function calls other functions
. ?: the function makes recursive calls or the depth cannot be calculated

Max cost = Specifies how many bytes of stack the function uses including stack needed for called functions.

Specifies how many bytes of stack the function uses. This column does not take into account any stack that may

Local cost be needed by the functions it may call.
Specifies if the function uses a STATIC or DYNAMIC stack allocation.
Type STATIC: the function uses a fixed stack
DYNAMIC: the function uses a run-time dependent stack
. Empty field: no stack usage information available for the function
. Indicates where the function is declared. It is possible to double-click on a line and open the file with the defined
Location g .
function in the editor.
Contains specific information about the stack usage calculation. For instance, it can hold a combination of the
following messages:
. Max cost uncertain:the reason can be that the function makes a call to some sub-function where
the stack information is not known, the function makes recursive calls, or others
Info . Recursive: the function makes recursive calls
. No stack usage information available for this function: no stack usage
information available for this function
. Local cost uncertain due to dynamic size, verify at run-time:the function

allocates stack dynamically, for instance depending on a parameter

The Call Graph tab sort order can be changed by clicking on a column name.

By double-clicking on a line that displays the file location and line number in the tab, the function is opened in the
Editor view.

The main function is usually called by the Reset Handler and can in those cases be seen when expanding
the Reset Handler node.

If unused functions are listed in the tab, check if linker option [dead code removal] is enabled to remove unused
code from the program. Read more on this in Section 2.2.1.2: Discard unused sections.
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The small icon left of the function name in column Function column indicates the following:

. Green dot: the function uses STATIC stack allocation (fixed stack).

. Blue square: the function uses DYNAMIC stack allocation (run-time dependent).

. 010 icon: used if the stack information is not known. This can be the case for library functions or assembler
functions.

. Three arrows in a circle: used in the Call Graph tab when the function makes recursive calls.

Figure 150. Function symbols in Static Stack Analyzer

= Static Stack Analyzer
NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug
List Call graph

Function Depth
SrADC_IRQHandler ?
v [as Reset_Handler 16
v i LoopCopyDatalnit 15
~ |is LoopFillZerobss 14
v @ main
» @ SystemClock_Config
> @ MX_USART2_UART _Init
> @ MX_GPIO Init
@ SystemCoreClockUpdate
> [miprintf
@ readTemp
@ readSpeed
@ writeSpeed
@ writeTemp
@ Systemlnit
lsis FillZerobss

OOOOOO;O—‘#W—\

2.6.2.4 Using the filter and search field

The List and Call Graph tabs contain a filter/search field, which can be used to search a specific function or
functions matching the characters entered in the field.
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Figure 151 displays the List tab where the [Filter] field is used to seek functions containing the “read” string in
their name.

Figure 151. Static Stack Analyzer List tab using search

10E} O X

e

= Static Stack Analyzer
NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Oct 25, 2019 1:58:05 PM
List Call graph

Hide dead code

‘ read|

Function Localcost Type Location Info
® read 32 STATIC  syscalls.c:97

@ readSpeed 16 STATIC  main.c:133

@ readTemp 16 STATIC  main.c:146

Figure 152 shows a use example of the [Search...] field in the Call Graph tab for filtering functions with name
matching the “read” string.

Figure 152. Static Stack Analyzer Call Graph using search

0¢] o X
= Static Stack Analyzer -
NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Oct 28, 2019 1:09:29 PM

List Call graph

read Search... @ Case sensitive
Function v Depth Max cost  Local cost  Type Location Info A
© _read 0 32 32 STATIC  syscalls.c:97
> lw__sclose 2 16 0 Max cost uncertain. No stack usage information available for this function
lm__do_global_dtors_aux 0 0 0 Max cost uncertain. No stack usage information available for this function
© UsageFault_Handler 0 4 4 STATIC  stm32fdxx_it.c:128
> © SysTick_Handler 1 12 8 STATIC  stm32f4xx_it.c:182
@ SVC_Handler 0 4 4 STATIC  stm32fdxx_it.c:143
v s Reset_Handler 16 232 0 Max cost uncertain. No stack usage information available for this function
v s LoopCopyDatalnit 15 232 0 Max cost uncertain. No stack usage information available for this function
v LoopFillZerobss 14 232 0 Max cost uncertain. No stack usage information available for this function
v © main 13 232 32 STATIC  main.c:183 Max cost uncertain
© writeTemp 0 16 16 STATIC  main.c:164
© writeSpeed 0 16 16 STATIC  main.c:156
© readTemp 0 16 16 STATIC  main.c:146
© readSpeed 0 16 16 STATIC  main.c:133
> lasiprintf 12 24 0 Max cost uncertain. No stack usage information available for this function
© SystemCoreClockUpdate 0 32 32 STATIC  system_stm32f4xx.c:239
> @ SystemClock_Config 5 200 88 STATIC  main.c:410 Max cost uncertain ~
< >
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2.6.2.5 Copy and paste

The data in the List tab can be copied to other applications in CSV format by selecting the rows to copy and
typing Ctrl+C. The copied data can be pasted into another application with the Ctrl+V command.

Figure 153. Copy and paste

m O X
= Static Stack Analyzer
NUCLEO-F401RE.elf - /NUCLEO-F401RE/Debug - Oct 25, 2019 1:58:05 PM
List Call graph
Hide dead code

Function Local cost  Type Location Info )
@ SystemClock_Config 88 STATIC  main.c:410

@ MX_GPIO_Init 48 STATIC  main.c:487

@ HAL_UART_Msplnit 48 STATIC  stm32f4xx_hal_msp.c:88

@ main 40 STATIC  main.c:183

@ NVIC_EncodePriority 40 STATIC  core_cm4.h:1863

@ HAL_GPIO_Init 40 STATIC  stm32fdxx_hal_gpio.c:171

@ HAL_RCC_GetSysClockFreq 40 STATIC ~ stm32fdxx_hal_rcc.c:859

@ _write 32 STATIC  main.c:106

@ read 32 STATIC  syscalls.c:97

@ _write 32 STATIC  syscalls.c:109

@ SystemCoreClockUpdate 32 STATIC  system_stm32f4xx.c:239 o

The Ctrl+C copy of the lines selected in Figure 153 provides the Ctrl+V results below:

"SystemClock Config";"88";"STATIC";"main.c:410";""
"main";"40"; "STATIC"; "main.c:183";""
"HAL GPIO Init";"40";"STATIC";"stm32f4xx hal gpio.c:171";""
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3 Debug
3.1 Basic debug functions
3141 Introduction to debugging

STM32CubelDE includes a powerful graphical debugger based on the GDB command-line debugger. It also
bundles GDB servers for the ST-LINK and SEGGER J-Link JTAG probes.

The GDB server is a program that connects GDB on the PC to a target system. The STM32CubelDE debug
session can autostart a local GDB server or connect to a remote GDB server.

The remote GDB server can be running on the same PC, or on a PC that is accessible via the network and
specified with Host name or IP address and a Port number. When connecting to a remote GDB server, this GDB
server must be started first before a debug session is started in STM32CubelDE.

When autostart local debugging is selected, STM32CubelDE automatically starts and stops the GDB server as
required during debugging, thus integrating the GDB server seamlessly.

Note: It is recommended to use compiler optimization level —00 when building a project that must be debugged.
Debugging with optimization level —0g may work but higher optimization level is hard to debug because of
compiler code optimization.

It is also possible to use the GDB server only to download the application into the target system and run it without
starting a debug session. This is performed by creating run configurations, which is described later in this chapter
(refer to Section 3.1.7: Program and reset the device).

STM32CubelDE can be used to debug an existing 1+ file developed with another IDE or toolchain by importing
the e1t file using the import of STM32 Cortex®-M executable. This is described in Section 3.1.9: Import STM32
Cortex®-M executable.
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3.1.1.1

3.1.2

General debug and run launch flow

Debug configurations are used to debug an STM32 program. Run configurations are used to flash a new program
into the STM32 and start it. The flowchart in Figure 154 presents the order of starting the GDB server, reset the
device, load the program, set run time options, exceptions, program counter, breakpoints, Standby/Stop/Sleep,
watchdog, and external loader initialization when starting a debug session. It also displays the differences

between debug and run sessions.

Figure 154. General debug and run launch flowchart

Debug using debug configuration

Run using run configuration

A

A

Start GDB server or connect to running GDB server

Reset board?

No

A 4

Reset board

Attach to board

A

Any files in loadlist?

Download program?

No

Load / Program memory

A

Any more files in loadlist?

Debug?

Yes

No

Set run-time options for debug
Exception on divide by zero
Exception on unaligned access
Halt on exception
Set PC to entry or specific address
Set breakpoints
Set Standby/Stop/Sleep
Set watchdog
(External loader initialize)

Set run-time options for run
Set PC to entry or specific address

Debug

DT67147V1

Debug configurations

A debug configuration for the project is needed before a debug session can be started. To create the first debug
configuration for the project, right click on the project name in the Project Explorer view and select [Debug

As]>[STM32 C/C++ Application].
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Figure 155. Debug as STM32 MCU
[ workspace-umd4 - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help
= - By Gon i gGrar @y gy G i - - ¥l
& Project Explorer x 887§ ° 0 Emaincx
» [ NUCLEO-F401 /* USER CODE BEGIN Header */
Mew b b /e
Go Into T E T T ]
. * @file ; main.c
Open in New Window * gbrief : Main progran
Show In Alt+Shift+W » T T e T P T T T T T
& ;
® Copy CtidsC . @attention
Paste Ctri+V * Copyright (c) 2822 5TMicroelec
X Delete Delete * All rights reserved.
Source > "
e * This software is licensed unde
* in the root directory of this
Rename... F2 * If no LICENSE file comes with
- Impon"" EREAEBEAETRETNEERECRE SRR RRC R T
i Export... Y,
Build Project #/* USER CODE END Header */
. /* Includes ---------mmmmmimmaao
Cl Pri
£ xcpect #include "main.h"
21 Refresh F5
Close Project k/* Private includes --------------
Close Unrelated Project /* USER CODE BEGIN Includes */
Build Configurations /™ USER CODE END Includes */
Build Targets > :
F/* Private typedef -----e--emeea-.
Index > | /* USER CODE BEGIN PTD */
O RunAs > [ 15TM32 C/C++ Application.
# Debug As 2 Run Configurations...
Teamn 3
Com ‘With » =
ek blems % £ Tasks & Conscle © Properties
Restore from Local History... i
Generate Code e ~
2 iption
e Convert to C++
% Run C/C++ Code Analysis
Configure 3
Properties Alt+Enter
<
£ NUCLEO-F401RE

Another way to create a new debug configuration is to select the project name in the Project Explorer view and

use the menu [Run]>[Debug As]>[STM32 C/C++ Application].
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Figure 156. Debug as STM32 MCU menu

E workspace_umd - NUCLEQ-F401RE/Core/Src/main.c - 5STM32CubelDE

File Edit Source Refactor Mavigate Search Project | Run Window Help

0~ E @& Run FrO-~Q-inid @y~
3%, Debug F11
f?"‘_-, Praoject Expli Run History »
D RunAs » [DE BEGIN Header */
> E myLib Run Configurations... kR ERERE R R R R R R R R R R
~ [} NUCLED .
> @ Incluc Debug History »
v @ Core %5 Debugés > [ 15TM32 C/C++ Application |

» = Inc Debug Configurations... |

v e Cem

A third way to create a new debug configuration is to select a project name in the Project Explorer view and press
[F11].
All three different ways open the Debug Configuration dialog.

3.1.2.1 Debug configuration
The Debug Configuration dialog contains the following tabs:
. Main
. Debugger
. Startup
. Source
. Common

The Debugger and Startup tabs must be updated when creating a new debug configuration while the others do
not require update.

3.1.2.2 Main tab

The Main tab contains the configuration of the C/C++ application to debug. Usually, when creating a debug
configuration using the sequence described earlier in this chapter, there is no need to make any change in the
Main tab. Make sure the correct e1r file and project are selected.
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Figure 157. Debug configuration main tab

m Edit Configuration

Edit launch configuration properties

Name: ‘ NUCLEO-F401RE

-7 Source| = Common

Mainl*ﬁ* Debugger| ® Startup

Project:
| NUCLEO-F401RE |

C/C++ Application:

| Debug/NUCLEO-FA01RE elf | SearchProject.. | Browse.. |

Build (if required) before launching

Build Configuration: |Select Automatically
(O Enable auto build (O Disable auto build
Configure Workspace Settings...

v ‘

® Use workspace settings

Revert Apply

(0]4 | ‘ Cancel

@

Note: It is possible in the Main tab to define if a build must be made before the debug session is started.

3.1.2.3 Debugger tab
The Debugger tab configures how to start the GDB server and connect to it. It also defines which GDB server

must be used if [Autostart local GDB server] is selected.
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Figure 158. Debug configuration debugger tab

m Edit Configuration O X

Edit launch configuration properties 'ﬁ\

Name: | NUCLEO-FA01RE |
2 Main| % Debugger| ® Startup % Source & Common|

GDB Connection Settings
(®) Autostart local GDB server Host name or IP address localhost
O Connect to remote GDB server Port number | 61234

Debug probe ST-LINK (ST-LINK GDB server) ~
GDB Server Command Line Options
Show Command Line

Interface
(®)swD O maG

[ 1ST-LINK 5/ Scan
Frequency {I(Hz}.-| Auto w |
Access port: | 0 - Cortex-M4 v

Reset behaviour
Type: | Connect under reset

Device settings

Debug in low power modes: Enable ~
Suspend watchdog counters while halted: Disable v
Serial Wire Viewer [SWV) RTOS Kernel Awareness
[]Enable [ ] Enable RTOS Proxy

ok (M Hz 16.0 Driver settings
Limit SWO dock var (ThreadX
Maximum 5W ck (kHz) | auto detect i |cortex_m0
61235
60000
External loaders
-Lclad-er EnaEIed ) Initialize . Add...

Misc
Verify flash download
Enable live expressions

l:‘ Log- to file: CEd L d wk w 2a\STM32Cubel DE\wor kf,parrﬂ 1.12.0\NUCLEQ-F401RE\( )ehug\qt-li Browse...
[ shared ST-LINK
[ ] Max halt timeout(s): 2

Revert Apply
@ Gance

The [Port number] edit field contains the default value used by the GDB server selected in the field [Debug
probe].
Field [Host name or IP address] must be set when [Connect to remote GDB server] is selected.
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Field [Debug probe] selects the probe and GDB server to be used for debugging. When using an ST-LINK debug
probe, the ST-LINK GDB server or OpenOCD can be used. When using a SEGGER J-LINK probe, use the
SEGGER J-LINK GDB server.

Pressing the [Show Command Line] button opens the GDB Server command line dialog. The dialog displays
how the GDB server is started according to the current [GDB Server Command Line options] settings.

Figure 159. GDB server command line dialog

m GDB Server command line ([l X

t:\ST\STM32CubeIDE_1.7.0.21w21\STM32CubeIDE\pIugins
\com.st.stm32cube.ide.mcu.externaltools.stlink-gdb-
server.win32_2.0.0.202105051205\tools\bin\ST-LINK_gdbserver.exe -p 61234 -| 1
-d -s -cp C\ST\STM32CubelDE_1.7.0.2 Tw2 \STM32CubelDE\plugins
\com.st.stm32cube.ide.mcu.externaltools.cubeprogrammer.win32_2.0.0.20210506
1353\tools\bin -m 0 -k

Use the [Copy & Close] button to copy the current command line settings to the clipboard, for instance to start
the GDB server manually in a command line window by pasting the command.

The [GDB Server Command Line options] selections are updated as a function of the [Debug probe] selected.
Detailed information about these settings is available in Section 3.1.4: Debug using different GDB servers and
subsections.

Debug authentication

Several STM32 products support the Arm® TrustZone® technology, which partitions the system into secure and
nonsecure regions. When the CPU is in the secure state, it is not possible to connect to the target through JTAG/
SWD. TZEN/RDP regression is not possible and software developers must authenticate to handle the debug.

STMicroelectronics provides the STM32 Trusted Package Creator tool with its graphical user interface to generate
the authentication key and certificate or password. Refer to the section about certificate generation for debug
authentication in the tool user manual [ST-18].

Note: TrustZone is a registered trademark of Arm Limited (or its subsidiaries) in the US and/or elsewhere.
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The user must enable the debug authentication during the project creation to be able to use it afterwards. Once
the key and the certificate are generated, the user must indicate their locations in the fields [Key path] and
[Certificate path], as shown in Figure 160. The user must also define the permission type in the field
[Permissions] If the device supports only debug authentication via password, the user must indicate the location
of the field [Password file] as shown in Figure 161.

Figure 160. Debug configuration debugger tab (secure)
[m
| Create, manage, and run configurations ﬁk ‘

@ ExX BT~ Namf_-_-i h5_debug_Auth_Secure Debug |

type filter text

|3 Main ESelaioey > Startup & Source| @ Common| |
RCICH+ Ayphcation GDB Connection Settings Al
F1C/C++ Attach to Applicati
® Autostart local GDB server Host name or IP address localhost

1 C/C++ Postmortem Debu
E1C/C+ + Remote Applicatio O Connect to remote GDB server  Port number 61234

T1 GDB Hardware Debuggine Debug probe |ST-LINK (ST-LINK GDB e

% Launch Group
GDB Server Command Line Options

~ [STM32 C/C++ Applicatior
1 h5_debug Auth Secure | | Show Command Line

[ STM32 Cortex-A Remote . e

® SWD OITAG
OST-LINK S/N Scan

Frequency (kHz): | Auto -
Accessport | 1- Cortex-M33 ]

Reset behaviour

Type: Connect under reset  ~

Debug Authentication
& Enable
Key path: | CADAkeyYkey_1_rool.pem Browse..,
Certificate path: | C\DAkey\my cert_roothed Browse...
Permissions:  Debug Non Secure L3 ~
Device settings
Debug in low power modes: Enable o
Suspend watchdog counters while halted: No configuration -
Serial Wire Viewer (SWV) RTOS Kemnel Awareness
[] Enable [ Enable RTOS Proxy
; 16.0 Driver settings
Limit SWO dock Cower ThreadX
auto detect t cortex mO
61235 - vl
< ?
Filter matched 9 of 10 iterns Revert Apply
@ Close
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Figure 161. Debug configuration - Debugger tab (debug authentication with password file)

[B8 Debug Configurations u] *

Create, manage, and run configurations

CEeEX|BY- MName: | STM32N6570-DK_Appli Debug
[typefitter text | Main [%5 Debugger| @ Startup| i Source| (] Commen|
[€] C/C++ Application GDB Connection Settings ~

[E] i+ Attach to Application @ Autostart local GDB server  Host name or IP address localhost
[] C/C++ Postmortem Debugger

[E] C/C++ Remote Application (O) Connect ta remote GDB server Port number 61234

[£] GDE Hardware Debugging
@ Launch Group Debug probe | ST-LINK (ST-LINK GDB server) ~

v [] 5TM32 C/C++ Application GDB Server Command Line Options

[17] STM32N6570-DK_Appli Debug
Show Command Line

Interface

@ SWD O ImAG

[IST-LINK /N - |5can
Frequency (kHz): | Auto - |
Accessport: | 1- Cortex-M33 ~]

Reset behaviour
Type: Connect under reset
Debug Authentication

[ Enable

Password file | C:\password.bin

Device settings
Debug in low power modes: [Enable ~|
Suspend watchdag counters while halted:  No configuration ~|
Serial Wire Viewer (SWV) RTOS Kernel Awareness
[JEnable [JEnable RTOS Proxy
Core Clock (MHz2): 00 Driver seftings

Limit SWO clock Driver: | ThreadX .
Masirnurn SWO elock (kHz): | auto detect ror; [ 5
Port nurber: 61235

Port nurnber: | 60000

External loaders

Loader Enabled Initialize Add...

Remove

Filter matched 8 of 9 items pphe
@

3.1.24 Startup tab
The Startup tab configures how to start a debug session.
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Figure 162. Debug configuration startup tab

[I Edit Configuration O x

Edit launch configuration properties

Name: | NUCLEO-F4D1RE
Main H}- Debugger [ =3 Starlupl E_f Source| [C] Common

Initializatien Commands

Load Image and Symbols

File Build Download Load symbaols dd.
= Debug\NUCLED-F401RE.elf [NUCLEO-F401RE] See Main tab Qj? true J true

Remowve

L

Move down

Runtime Options
Start Address
(®) Default start address

() Set program counter (hex):
() Specify vector table (hex):

Exception on divide by zero
[[] Exception on unaligned access
Halt on exception

Resume

Run Commands

| Revert | | Apply |

@ [ ok || cance

The [Initialization Commands] edit field can be updated with any kind of GDB or GDB server monitor commands
if there is any special need to send some commands to the GDB server before load commands are sent. For
instance, when using ST-LINK GDB server amonitor flash mass_erase command can be entered here if a
flash memory erase is needed before load.
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The [Load Image and Symbols] list box must contain the file(s) to debug. This list is associated with the
following command buttons:

. [Add...]: Add new lines for files for download and/or load symbols
. [Edit...]: Edit the selected line

. [Remove]: Remove the selected line from the list

. [Move up]: Move the selected line upwards

. [Move down]: Move selected line downwards

The [Runtime Options] section contains checkboxes to set the start address and breakpoint, and enable
exception handling and resume.

The start address can be selected as:

. [Default start address]: spc is set to the start address found in the last loaded e1t file
. [Set program counter (hex)]: Spc is set to the hex value specified in the edit field
. [Specify vector table (hex)]: Spc is updated with the value found in memory using specified address +

offset of 4. This is similar to how $pc is set by a reset using vector table in a Cortex®-M device

The [Set breakpoint at:] checkbox is enabled by default and the edit field displays main. It means that, by
default, a breakpoint is set at main when the program is debugged.

Three exception checkboxes, [Exception on divide by zero], [Exception on unaligned access] and [Halt on
exception], are used to make it easier to find problems when debugging an application.

. [Exception on divide by zero] is enabled by default to make it easier to trap a divide-by-zero error when
debugging
. [Exception on unaligned access] can be enabled to get exceptions if there are any unaligned accesses
. [Halt on exception] is enabled by default so that program execution halts when an exception error occurs
during debugging. If an exception occurs, the Fault Analyzer view can be used to find the location of the
problem
Note: The application software needs to enable Exception on divide by zero and Exception on unaligned access if

they must be issued also when running the application and not only during debugging. The CMSIS Cortex®-M
header files contain defines to update the SCB Configuration Control Register. For instance, core cm4.h
contains the SCB->CCR register, and SCB_CCR DIV 0 TRPand SCB_CCR _UNALIGN_ TRP defines.

When the [Resume] selection is enabled, a continue command is issued to GDB after load to start the program.
Usually, in this case, the program breaks at main if a breakpoint at main is set. Otherwise, when the [Resume]
selection is disabled, the program stays at the ENTRY location specified in the linker script, normally the

Reset Handler function. A step may be needed in this case to display the Reset Handler function in the
editor.

When a line in the listbox is selected and [Edit...] is pressed, the following dialog appears for selecting if the file
must be downloaded and if symbols must be loaded.

Figure 163. Add/Edit item

[l Add/Edit item O X

Some properties of this item can only
be changed in the “Main" tab.

Project: NUCLEO-F401RE
Program path: Debug\NUCLEO-F401RE.elf
Download

Use download offset (hex)

Load symbols
Use symbol address (hex)

Cancel
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313 Manage debug configurations

Each project can have several debug configurations. It is easy to create a copy of an existing debug configuration
and update it with some changes. For instance, one configuration may contain flash memory loading of new
programs while another does not load any program.

When opening debug configurations from the menu [Run]>[Debug Configurations...], the Debug Configurations
dialog opens. This dialog contains a navigation window on the left side with a toolbar, and the debug configuration
on the right side with the tabs and fields described in Section 3.1.2: Debug configurations.

Figure 164. Manage debug configurations

[I Debug Configurations O X

Create, manage, and run configurations

CHeEX B Y-~ Name: | NUCLEO-FAD1RE
| type filter text | Main] <3 Debugger| = Startup| Ep Source| [C] Common
[©] C/C++ Application Project
[E] C/C++ Attach to Application
[E] C/C++ Postmortemn Debugger | NUCLEQ-F401RE | | Browse.. |
[€] C/C++ Remote Application C/C++ Application:
[c] GDB Hardware Debugging
. Launch Group | Debug/NUCLEO-FA0TRE.eff | searchProject.. | Browse.. |
w [[I] STM32 C/C++ Application Build (if required) before launching
[I] NUCLEO-F401RE
Build Cenfiguration: | Select Automatically V|
(O Enable auto build () Disable auto build
@ Use workspace settings Configure Workspace Settings...

Revert Apply

Filter matched 8 of 8 items

® | Debug | | Close |

The [Name] field on top of the right pane can be edited using a name for the debug configuration, which reflects
the configuration. This name then appears in the navigation window under the [STM32 C/C++ Application] node
to the left when pressing [Apply].

The toolbar left of the navigation window contains icons to manage configurations, for instance to duplicate or
delete a selected configuration.

Figure 165. Manage debug configurations toolbar

G EHeEX B Y-~

These icons are used for the following purpose, from left to right:

. Create new launch configuration

. New launch of configuration prototype

. Export launch configuration

. Duplicate currently selected launch configuration
. Delete selected launch configuration(s)

. Collapse all expanded launch configurations

. Filter launch configurations
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314 Debug using different GDB servers
STM32CubelDE includes the following GDB servers:
. ST-LINK GDB server
. OpenOCD GDB server
. SEGGER J-Link GDB server
All three GDB servers support normal debug, live expressions and SWV.
All GDB servers also support RTOS Kernel Awareness debugging for Microsoft® Azure® RTOS ThreadX and
FreeRTOS™ operating systems using an RTOS proxy. The RTOS proxy is included in STM32CubelDE.

Different command-line options are used when starting these GDB servers. Therefore the Debugger tab in the
Debug Configurations dialog displays different settings depending on the GDB server selected. This section
describes the individual settings for each server.

3.1.4.1 Debug using the ST-LINK GDB server

Usually, when the ST-LINK GDB server is used for debugging, there is no need to update the [GDB Server
Command Line Options] in the Debugger tab. In some cases, the default configuration must be updated, for
instance if SWV is used or if several STM32 boards are connected to the PC.
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Figure 166. ST-LINK GDB server debugger tab

E Debug Configurations O x
Create, manage, and run configurations 'ﬁt
CRLETR =B

Name: | NUCLEO-FAD1RE
[ Main| % Debugger # Startup % Source| & Common.

|_£¥}_1_9__ﬁhm text |

» [E1C/C++ Application

GDB Connection Settings 4
[E] C/C++ Attach to Application =
= (®) Autostart local GDB server Host name or IP address localhost
1 C/C++ Postmortem Debugger
[£] C/C++ Remote Application () Connect to remote GDB server Port number | 61234

TG00 Herdwars Deaiggeg Debug probe ST-LINK (ST-LINK GDB server) v

& Launch Group . :
v [ 5TM32 C/C++ Application GDB Server Command Line Options

[ NUCLEO-F401RE Show Command Line

& NUCLEQ-F401RE (OpenOCD) It

= NUCLEO-F401RE (SEGGER) @ SWD O 1TAG
] ST-LINK S/N Scan
Frequency (kHz): | Auto v |
Access port: 0 - Cortex-M4 v |
Reset behaviour

Type: Connect under reset  ~

Device settings
Debug in low power modes: Enable e
Suspend watchdog counters while halted: No configuration v
Serial Wire Viewer (SWV) RTOS Kernel Awareness
] Enable ["]Enable RTOS Proxy
¢ 16.0 Driver settings
Limit SWO clock ver ThreadX
auto detect Port: comeximo
61235
60000
External loaders
Loader . Enabled Initialize . I Add...
Edit...
| Remove
Misc
[] Verify flash download
[~] Enable live expressions
[iog to file: ChatEreE i mansTM32Cubel DE\workspace_1.12.00\NUCLEC-F |Browse..
[Ishared ST-LINK
[ Max halt timeout(s): 2 w
Filter matched 11 of 11 items Resvigt Apply
@ Debug Close

Select [SWD] or [JTAG] in [Interface] to define how the ST-LINK probe must connect with the microcontroller. The
SWD interface is usually the preferred choice. It must be selected if SWV is to be used.

When [ST-LINK S/N] is enabled, the serial number of the ST-LINK probe to be used must be entered in the edit/
list field. The [Scan] button can be used to scan and list all detected ST-LINK devices connected to the PC. After
a scan, the S/N of these ST-LINK devices are listed in the list box from which the desired ST-LINK can be
selected. When [Use specific ST-LINK S/N] is enabled, the ST-LINK GDB server is started and connects only to
the ST-LINK with the selected S/N.
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The [Frequency (kHz)] selection defines the communication speed between the ST-LINK and STM32 device.
When [Auto] is selected, the maximum speed provided by ST-LINK is used. Reduce the frequency in case of
hardware limitations.

The [Access port] selection is used only when debugging a multi-core STM32 device. In such case, the ST-LINK
is connected to the device and the ST-LINK GDB server must be informed of the core to debug.

The [Reset behaviour] contains selections for [Type] and [Halt all cores]. The [Halt all cores] selection is only
visible for multi-core devices.

The [Type] can be set as follows:

. [Connect under reset] (default): ST-LINK reset line is activated and ST-LINK connects in the SWD or
JTAG mode while reset is active. Then the reset line is deactivated.

. [Software system reset]: System reset is activated by software writing in a register. This resets the core
and peripherals, and can reset the whole system as the reset pin of the target is asserted by itself.

. [Hardware reset]: ST-LINK reset line is activated and deactivated (pulse on reset line), then ST-LINK
connects in the SWD or JTAG mode.

. [Core reset]: Core reset is activated by software writing in a register (not possible on Cortex®-M0,
Cortex®-M0+, and Cortex®-M33 cores). This only resets the core, not the peripherals or the reset pin.

. [None]: For attachment to a running target where the program is downloaded into the device already. There

must not be any file program command in the Startup tab.

Note: The selected reset behavior is overridden if the debug configuration includes flash memory programming, in
which case the ST-LINK GDB server uses the STM32CubeProgrammer (STM32CubeProg) command-line
program STM32 Programmer CLI to program the flash memory. This program is always started by the ST-
LINK GDB server with mode=UR reset=hwRst SO that a device reset is done when loading a new program,
disregarding the selection of the [None] option. This ensures that device programming is made correctly.

[Halt all cores] can be used only when debugging multi-core devices. The [Halt all cores] selection is not visible
for single-core devices.

[Device settings] contains selections for [Debug in low power modes] and [Suspend watchdog counters
while halted]. These can be defined as:

. [No configuration]
. [Enable]
. [Disable]

The [Serial Wire Viewer (SWV)] selections can be used only when the [SWD] interface is selected. When [SWV]
is enabled, it is required to configure the [Clock Settings]. The [Core Clock] must be set to the device speed.
More information about SWV configuration is available in Section 3.2.2.1: SWV debug configuration.

The [RTOS Kernel Awareness] selections are used to enable RTOS-kernel-aware debugging with the ThreadX
and FreeRTOS™ operating systems. When RTOS-kernel-aware debugging is enabled and a debug session is
started, all threads are listed in the Debug view. By selecting a thread in the Debug view the current line executed
by the thread is displayed in the editor. More information about RTOS-kernel-aware debugging is available in
Section 3.4.3.

The [Misc] selections contain:

. The [External Loaders] selections can be used to add one or more external loaders to extend the memory
programming capabilities and cover non-internal STM32 memories.
The [Add] button allows the selection of both built-in STM32CubeProgrammer external loader files and
custom external loaders available on the disk or in the workspace.
When the [Initialize] property of an external loader is enabled, the loaders Init () function is
automatically called after reset operations. It can be used to configure the device for external memory
access. Usually, the debugged application must perform the initialization.

. [Verify flash download]

. [Enable live expressions] (To be able to use the Live Expressions view during debugging, the live
expression mechanism must be enabled during startup. It is enabled by default.)

. [Log to file] (Enable in case of debugging problems. It starts the ST-LINK GDB server with a higher log
level and saves the log into a file.)

. [Shared ST-LINK] (Shared ST-LINK must be enabled if other programs must be able to connect to the
same ST-LINK during a debug session.). Refer to Section 3.1.6.2: Shared ST-LINK for details.
A detailed description of the ST-LINK GDB server is available in the ST-LINK GDB server manual ([ST-07]),
which is available from the Information Center.
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STM32 Programmer CLI is used by the ST-LINK GDB server to program the STM32 or external flash
memory. In this case, such external flash memory programming is automatically done using the external loader.

Debug using OpenOCD and ST-LINK

When OpenOCD is used, the [GDB Server Command Line Options] in the Debugger tab contains a generator
options toggle field, which alternates between [Show generator options...] and [Hide generator options...].
When the field is set to [Hide generator options...], the dialog displays additional [GDB Server Command Line
Options] as shown in Figure 167.

Figure 167. OpenOCD debugger tab

[I Debug Configurations O X

Create, manage, and run configurations

CEeEX BY- Mame: | NUCLEO-FADIRE (OpenOCD)
| type filter text | Main | %5 Debuggerl " 3 Startup| 17 Source| =] Common|
[E] C/C++ Application GDEB Connection Settings

[£] C/C+ Attach to Application (®) Autostart local GDB server Host name or [P address  |localhost
[€] €/C++ Postmortem Debugger

[E] C/C++ Remote Application (O Connect to remote GDB server Port number 3333
[£] GDB Hardware Debugging . -
0 Launch Group Debug probe |?ST-LINK (OpenOCD) R

v E 5TM32 C/C++ Application GDE Server Command Line Options
[[] NUCLEO-F401RE

[} NUCLEO-FAD1RE (Open0CD) Show Command Line

E MNUCLEO-FADTRE (SEGGER) OpenOCD Setup

OpenQOCD Command:

| "8§{stm32cubeide_openocd_path}\openocd.exe” | | Browse...

OpenOCD Options : | |

Configuration Script

(® Automated Generation () User Defined | Show generator options... |

Script File: | ${ProjDirPath ANUCLED-F401RE (OpenOCD).cfg | Browse... Reload
Serial Wire Viewer (SWV) RTOS Kernel Awareness
[ Enable [ Enable RTOS Proxy
Core Clock (MHz): 16.0 Driver settings

Limit SWO clock Driver: [Threadi v

Iaximurm SWO clock (kHz): | auto detect Port: | cortex_mi i
Part nurnber: 3344

Fort number: | 60000
Misc
Enable live expressions

ST-LINK Client Setup
[ Shared ST-LINK

Filter matched 10 of 10 items | Revet || Apply |

@ | Debug | | Close |

The [OpenOCD Command] edit field contains the openocd. exe file to be used when debugging. The [Browse]
button can be used to select another version of OpenOCD.

The [OpenOCD Options] edit field can be used to add additional command-line parameters to be used when
starting OpenOCD.
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The [Configuration Script] selections can be [Automated Generation] or [User Defined]. When [Automated
Generation] is selected, an openocd. cfq file is created automatically based on the selections made in the
Debugger tab. When [User Defined] is selected, the file must be specified in the [Script File] edit field.

The [Interface]selection [Swd] or [Jtag] selects how the ST-LINK probe must connect with the microcontroller.
[Swd] is usually the preferred choice.

The Frequency selection configures the communication speed between the ST-LINK and STM32 device.
The [Reset Mode] selection contains:

. [Connect under reset] (default): ST-LINK reset line is activated and ST-LINK connects in the SWD or
JTAG mode while reset is active. Then the reset line is deactivated.

. [Hardware reset]: ST-LINK reset line is activated and deactivated (pulse on reset line), then ST-LINK
connects in the SWD or JTAG mode.
. [Software system reset]: System reset is activated by software writing in a register. This is resetting the

core and peripherals, and can reset the whole system as the reset pin of the target is asserted by itself.

. [Core reset]: Core reset is activated by software writing in a register (not possible on Cortex®-Mo,
Cortex®-M0+ and Cortex®-M33 cores). This is only resetting the core, not the peripherals nor the reset pin.

. [None]: For attachment to a running target where the program is downloaded into the device already. There
must not be any file program command in the Startup tab.

[Enable debug in low power modes] enables debug also with the STM32 device in low-power mode.

[Stop watchdog counters when halt] stops the watchdog when the debug session halts the STM32 device.

Otherwise, a watchdog interrupt may be triggered.

The [Serial Wire Viewer (SWV)] selections can be used only when the [SWD] interface is selected. When [SWV]
is enabled, it is required to configure the [Clock Settings]. The [Core Clock] must be set to the device speed.
More information about SWV configuration is available in Section 3.2.2.1: SWV debug configuration.

The [RTOS Kernel Awareness] selections are used to to enable RTOS-kernel-aware debugging with the
ThreadX and FreeRTOS™ operating systems. When RTOS-kernel-aware debugging is enabled and a debug
session is started, all threads are listed in the Debug view. By selecting a thread in the Debug view the current
line executed by the thread is displayed in the editor. More information about RTOS-kernel-aware debugging is
available in Section 3.4.3.

[Enable live expressions] must be enabled if the Live Expressions view is meant to be used during debugging.
[Shared ST-LINK] must be enabled if other programs have to connect to the same ST-LINK during a debug
session. Refer to Section 3.1.6.2: Shared ST-LINK for details.

3.1.4.3 Debug using SEGGER J-Link

When [SEGGER J-LINK] is selected in the Debugger tab, the [GDB Server Command Line Options]
corresponds to SEGGER J-Link GDB server.
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Figure 168. SEGGER debugger tab
m Debug Configurations O X
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Create, manage, and run configurations

SEERECRER M= Name: | NUCLEO-F401RE (SEGGER)
| type filter text | Main | % Debugger] = Startup| 73 Source| i=| Common|
[E] C/C++ Application GDB Connection Settings
[c] C/C++ Attach to Application @® Autostart local GDB server Host name or IP address  localhost

[E] C/C++ Postrortem Debugger
[€] C/C++ Remate Application () Connect to remote GDB server Port number 233

[£] GDB Hardware Debugging
& Launch Group Debug probe |§’SEGGERJ-I_INK i

W m 5TM32 C/C++ Application GDE Server Command Line Options
[I] NUCLEO-FA0RE

[} NUCLEQ-FAD1RE (Open0CD) Show Command Line

m MNUCLEQ-F40MRE (SEGGER) Interface

@SWD O JTAG  Initial Speed kHz [] Use specific J-Link 5/N

Device | STM32F401RE

Reset strategy | Type O: Nermal

JTAG Scan Chain

Auto Manual Paosition IRPre | O

Serial Wire Viewer (SWV) RTOS Kernel Awareness
[JEnable [JEnable RTOS Proxy J-Link
Core Clock (MHz): 8.0 Driver seftings

Limit SWO clock Driver: | Threadi -
Faximurm S0 clock (kHz): | auto detect Port: | cortex_mi0 w
Paort nurmber: 2332

Paort nurber: | 60000

Misc
[JUse J-Link script file Search Project... | | Browse...

Enable live expressions
[ Verify flash download

Filter matched 10 of 10 items | Revet || Apply |

® | Debug | | Close |

The [Interface] selection [SWD] or [JTAG] selects how the SEGGER J-Link probe must connect with the
microcontroller. The [SWD] interface is usually the preferred choice; it is required if SWV is used.

The [Initial Speed] selection configures the communication speed used between SEGGER J-Link and the STM32
device.

When [Use specific J-Link S/N] is enabled, enter the S/N of the J-Link to be used when debugging in the edit/list
field. When [Use specific J-Link S/N] is enabled, the SEGGER J-Link GDB server is started and connects only
to the J-Link with the selected S/N.

The Device edit field is used if it contains an entry. This field can be used if there is a problem to start the
SEGGER J-Link GDB server with the default device name used in STM32CubelDE. In such case, enter the
device name used by the SEGGER GDB server in the edit field.
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The [Reset strategy] selection contains:

. [Type 0: Normal] - Default.

. [None] - Intended to be used for attaching to the running target. In this case, the program must already be
downloaded into the device. There must not be any file program command in the Startup tab.

The [JTAG Scan Chain] selections can be used only when the [JTAG] interface is selected.

The [Serial Wire Viewer (SWV)] selections can be used only when the [SWD] interface is selected. When [SWV]
is enabled, it is required to configure the [Clock Settings]. The [Core Clock] must be set to the device speed.
More information about SWV configuration is available in Section 3.2.2.1: SWV debug configuration.

The [RTOS Kernel Awareness] selections are used to to enable RTOS-kernel-aware debugging with the

ThreadX and FreeRTOS™ operating systems. When RTOS-kernel-aware debugging is enabled and a debug
session is started, all threads are listed in the Debug view. By selecting a thread in the Debug view the current
line executed by the thread is displayed in the editor. More information about RTOS-kernel-aware debugging is
available in Section 3.4.3.

The [Misc] selections contains:
. [Use J-Link script file]

. [Enable live expressions]
To be able to use the Live Expressions view during debug, the live expression mechanism must be enabled
during startup.

. [Verify flash download]

. [Select RTOS variant] list box can be used if [Thread-aware RTOS support] is used with [FreeRTOS]
and [embOS].
When [Thread-aware RTOS support] is used, update the Startup tab: disable [Resume] and [in Run
Commands], add thread 2 and continue. This forces a thread context switch before the continue
command is sent.

Note: A detailed description of SEGGER J-Link GDB server is available in the SEGGER J-Link manual, which can be
accessed from the “Information Center”.

3.1.5 Start and stop debugging

When a debug configuration is created for the project with the preferred JTAG probe, it is ready for debugging. In
the following sections, the ST-LINK GDB server is used. However, the way to debug the STM32 project is quite
independent of the choice among ST-LINK GDB server, OpenOCD or SEGGER J-Link.

Perform the following steps to prepare for debug:

1. Determine whether the board supports the JTAG debug, SWD debug, or both.
SWD-mode debug is usually the preferred choice.

2. Connect the JTAG cable between the JTAG probe and the target board.
When using STMicroelectronics STM32 Nucleo and Discovery boards, the ST-LINK is usually integrated on
the board. Also, most STMicroelectronics STM32 Evaluation boards contain an embedded ST-LINK.

3. Connect the USB cable between the PC and the JTAG probe.
4. Make sure that the target board has a proper power supply attached.
Once the steps above are performed, a debug session can be started.

3.1.5.1 Start debugging

Open the Debug Configurations dialog with a right click on the project name in the Project Explorer view and
select [Debug As]>[Debug Configurations...].

It is also possible to open the dialog using the menu [Run]>[Debug Configurations...].
This opens the Debug Configurations dialog.

Note: It is possible to select the project in the “Project Explorer” view and press [F11] to restart a debug session after it
has been closed.
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Figure 169. Debug configurations
[ Debug Configurations O s
Create, manage, and run configurations ‘ﬁ\
Y BT v
CERm¥ | Name: | NUCLEO-F401RE
l type: fitet:te 2 Main | % Debugger # Startup| % Source ™ Common |
> BGrnapplication GDB Connection Settings A
[E] C/C++ Attach to Application
(®) Autostart local GDB server Host name or IP address localhost
[ C/C++ Postmortem Debugger
&1 C/C++ Remate Application () Connect to remote GDB server Port number 61234
B GDB Hardwire Debugging Debug probe  ST-LINK (ST-LINK GDB server) ~
@ Launch Group : .
v [ STM32 C/C++ Application GDB Server Command Line Options
1 NUCLEO-F4D1RE Show Command Line
I NUCLEO-FA0D1RE (OpenOCD) {tes foce
@ NUCLEO-F401RE (SEGGER) @ SWD O JTAG
ST-LINK S/N | 066FFF505252717267065926 ~ | Scan|
Frequency {kHz}:| Auto - |
Access port: | El_-Cl;:rtex—iu:‘:! ~ i
Reset behaviour
Type: Connect under reset
Device settings
Debug in low power modes: No configuration v
Suspend watchdog counters while halted: No configuration ¥
Serial Wire Viewer (SWV) RTOS Kernel Awareness
[ Enable [] Enable RTOS Proxy
& Clodk (MH:z 16.0 Driver settings
Limit SWO dock river: [SNGEOR
Maximum SW i (kHz)  auto detect Port lcortex mi
61235
60000
External loaders
| Loader Enabled Initialize Add...
Edit...
| Remave
Misc
Verify flash download
Enable live expressions
[ iog to file: 5 ke m e S TM32Cubel DE\workspace_1.12.0\NUCLEQ-F401RE\Debug\s Browse..
[[] shared ST-LINK
[] Max halt timeout(s): 2 "
| Filter matched 11 of 11 items Rt Apply

@ [ Debig | close

Select in the left pane the debug configuration to use. Press the [Debug] button to start a debug session if all
debug configurations have been made. The project is built if file updates are made, but the building depends on
the debug configuration.

STM32CubelDE launches the debugger and the following dialog is opened.
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Figure 170. Confirm perspective switch

mConfirm Perspective Switch X

@ This kind of launch is configured to open the Debug perspective when it suspends.

This Debug perspective is designed to support application debugging. It incorporates views
for displaying the debug stack, variables and breakpoint management.

Do you want to switch to this perspective now?

[] Remember my decision

| Switch | ‘ No

It is recommended to enable [Remember my decision] and press [Switch]. It opens the Debug perspective,
which provides a number of views and windows suitable for debugging.

3.1.5.2 Debug perspective and views
The Debug perspective contains menus, toolbars and views frequently used during debugging.

Figure 171. Debug perspective
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The most important views opened by default in the Debug perspective are:

. The Debug view, which displays the program under debug. It also lists threads and offers the possibility to
navigate in the thread by selecting a line in threads.
. The Editor view, which displays the program file. It is possible to set break points and follow program

execution in the file. It is also possible to hoover the cursor over a variable to display its current value. The
features available during file edition are available also during debug, such as opening the declaration of a
function and others.

. The Variables view, which displays local variables automatically with their current value when the program
is not running.
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. The Breakpoints view, which displays current breakpoints. It is possible to disable and enable breakpoints
in the list. The Breakpoints view also contains a toolbar, which, for instance, enables to remove
breakpoints, and skip breakpoints with one click on the [Skip All Breakpoints] icon.

. The Expressions view, which is used to add and view expressions. An expression may be a single global
variable, structure, or an expression calculating some variables. The values are only updated when the
program is stopped. It is possible to select a global variable in the Editor and drag it over to the
Expressions view instead of entering the variable name.

. The Registers view, which displays the debugged device current values. The values are only updated when
the program is stopped.
. The Live Expressions view, which displays expression values sampled and updated regularly during

program execution. The view allows the creation of mathematical expressions that are evaluated
automatically, such as (Index*4+0ffset). The Live Expressions view update requires that live

expressions are enabled in the debug configuration. Refer to Section 3.1.6.1: Live Expressions view for
details.

. The SFRs view, which displays the Special Function Registers in the debugged device. Refer to
Section 3.3: Special Function Registers (SFRs) for details.

. The Console view, which displays different console outputs. By default, the console output from the GDB
server log is displayed. It is possible to change the console log by pressing the [Display Selected
Console] icon to the right of the Console view.

Other views are also useful during debug, among which:

. The Debugger Console view, which can be used if there is a need to manually enter GDB commands. The
easiest way to open the Debugger Console view is to use the [Quick Access] field and enter Debugger in
this field. It lists choices containing the Debugger Console view. Select it to open the view. GDB can be
entered in the Debugger Console view.

For instance, to display 16 words of memory from address 0x800 0000, enter the GDB command x /16

0x8000000.
x /16 0x8000000
0x8000000: 0x20018000 0x080008bl 0x080007e9 0x080007£7
0x8000010: 0x080007£d 0x08000803 0x08000809 0x00000000
0x8000020: 0x00000000 0x00000000 0x00000000 0x0800080£
0x8000030: 0x0800081d 0x00000000 0x0800082b 0x08000839
. The Memory and Memory Browser views, which can be used to display and update memory data.
. The Disassembly view, which is used to view and step in the assembly code.
. The SWV views. Refer to Section 3.2: Debug with Serial Wire Viewer tracing (SWV) for details.
. The Fault Analyzer view. Refer to Section 3.5: Fault Analyzer for details.
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3.1.5.3 Main controls for debugging
The [Run] menu in the Debug perspective contains a number of execution control functions.

Figure 172. [Run] menu

mworkspace_um‘l - NUCLEO-F401RE/Core/Src/main.c

File Edit Source Refactor Navigate Search Project Run '
‘= v % Terminate And Relaunch
i+ |nstruction Stepping Mode
# Del 2. Move to Line (C/C++)
v Bl = Resume at Line (C/C++)

v > Resume F8
Il Suspend
® Terminate Ctrl+F2

& Disconnect
» Resume Without Signal

& Reset
. Step Into E5
= Step Over F6
.2 Step Return ET
“#/ Run to Line Ctrl+R
. Use Step Filters
Step Into Selection Ctrl+F5
* Debug F11
Debug History >
% Debug As >
Debug Configurations...
Breakpoint Types >
' Toggle Breakpoint Ctrl+Shift+B

Toggle Line Breakpoint
" Toggle Watchpoint
@ Toggle Method Breakpoint
= Skip All Breakpoints Ctrl+Alt+B
% Remove All Breakpoints

Alternatively, the Debug perspective toolbar has the following main debug control icons.

Figure 173. Debug toolbar
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These icons are used for the following purpose, from left to right:

. Reset the device and restart the debug session
. Skip all breakpoints (Ctrl+Alt+B)

. Terminate and relaunch

. Resume (F8)

. Suspend

. Terminate (Ctrl+F2)

. Disconnect

. Step into (F5)

. Step over (F6)

. Step return (F7)

. Instruction stepping mode (assembler stepping)

Press [Terminate and relaunch] to terminate the current debug session, build a new program if the source code
is modified, and relaunch the debug session.

When pressing [Instruction stepping mode], the Disassembly view is opened and further stepping uses
assembiler instruction stepping level. Press [Instruction stepping mode] again to toggle back to C/C++ level

stepping.
3.1.54 Run, start, and stop a program
Use the toolbar icons as follows to run, step, or stop the program:
. Run the program with the [Resume] toolbar icon ([F8])
. Step into a function with the [Step into] toolbar icon ([F5])
. Step over a function with the [Step over] toolbar icon ([F6])
. Step until return from a function with the [Step return] toolbar icon ([F7])
. Abort running program with the [Suspend] toolbar icon
3.1.5.5 Set breakpoints

It is common during a debug session to set breakpoints and let the code execute until it reaches a breakpoint.

3.1.5.51 Standard breakpoint

A standard code breakpoint at a source code line can easily be inserted by double-clicking in the left editor
margin, or by right-clicking in the left margin of the C/C++ source code editor. A context menu is proposed in the
latter case.

Figure 174. Debug breakpoint

1cA . /¥ 1ICCD rNANC CAN LILUTIE X/
Toggle Breakpoint Ctrl+Shift+B
Add Breakpoint... Ctrl+Double Click
Add Dynamic Printf...

Disable Breakpoint Shift+Double Click
Breakpoint Properties... Ctrl+Double Click
Breakpoint Types >
Go to Annotation Ctrl+1
Add Bookmark...

Add Task...

v Show Quick Diff Ctrl+Shift+Q

v Show Line Numbers
Folding >
Preferences...
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Select the [Toggle Breakpoint] menu command to set or remove a breakpoint at the corresponding source code
line.

3.1.5.5.2 Conditional breakpoint

When setting a standard breakpoint at a source code line, the program breaks each time it reaches this line. If
that is not the desired behaviour, a condition can be set on the breakpoint that regulates if the program should
actually break or not on that breakpoint.

Update breakpoint properties with a right-click on the breakpoint icon visible left of the editor on a line with
breakpoint set. The [Breakpoint Properties] can also be opened from the Breakpoints view.

Figure 175. Breakpoint properties
1 r - TN

Toggle Breakpoint Ctrl+Shift+B
Add Breakpoint... Ctrl+Double Click
Add Dynamic Printf...
Disable Breakpoint Shift+Double Click
Breakpoint Properties..  Ctrl+Double Click
Breakpoint Types >
Go to Annotation Ctrl+1
Add Bookmark...
Add Task...
v Show Quick Diff Ctrl+Shift+Q
v Show Line Numbers
Folding >
Preferences...

Select [Breakpoint Properties...]. The following window opens. In the example illustrated below, i>20 is entered
as a condition.

Figure 176. Conditional breakpoint

[I Properties for C/C++ Line Breakpoint O X
‘ Common Ty
Cor_nmon Class: C/C++ Line Breakpoint
Actions
Filter Type: Regular v
File: C\Users\johansse\STM32CubelDE\workspace_um T\NUCLEO-F401RE\Core\Src\main.c
Line number: 156
Enabled
Condition: i>20

Ignore count: 0

@ Apply and Close Cancel

With the condition above set, the program breaks each time the line is executed, then GDB tests the condition
and restarts execution if the variable i is not greater than 20. It takes some time for GDB to evaluate the
condition.

The conditions are written in C-style. It is therefore possible to write expressions such as 1%2==0" to set more
complex conditions.
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3.1.5.6 Restart or terminate debugging
This section presents various ways to restart and stop a debug session.

3.1.5.6.1 Restart

During debugging, it is sometimes needed to restart the program to examine more carefully problems observed
during debug. In such case, restart the program using the [Reset the chip and restart debug session] toolbar
button or [Run]>[Restart] menu command. This resets the device, and starts the program if [Resume] is enabled
in the debug configuration.

Note: To make restart work, the interrupt vector must be configured and used with the hardware reset. This is usually
the case for STM32 programs located in the flash memory. However, if the program is located elsewhere such
as in RAM, some manual handling may be needed to make the program start from the expected
Reset Handler

3.1.5.6.2 Restart configurations

It is possible to create restart configurations defining how the reset and restart of a debug session must be
performed. Click on the arrow to the right of the [Reset the chip and restart debug session] toolbar icon.

Figure 177. Reset the chip toolbar

P AR W S S T

ﬂjECt| Reset the chip and restart debug session

This expands the menu with the [Restart Configurations...] selection.

Figure 178. Restart configurations selection

AR W L S AT I B N

Reset %

Restart Configurations...
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When [Restart Configurations...] is selected, the restart configurations dialog opens.

Figure 179. Restart configurations dialog

[ Restart configurations O >
Reset and restart configurations @
B e 4 Mame | Reset |
Reset Type: |Reset V|
Additional commands:
Apply
@ ok || Cancel

The dialog contains a left and right pane:

The left pane is used to select and create new restart configuration, duplicate an existing restart
configuration, and delete the selected restart configuration. The default restart configurations cannot be
deleted.

The right pane is used to set [Name] and select the [Type] of reset to be used for the selected
configuration. It is also possible to add additional commands to be used with the reset.
Press [Apply] to save a setting.
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Figure 180 shows a setting where a new restart configuration is created, which contains an additional command
to set pc to 0x8000ca0.

Figure 180. Restart configurations dialog with additional command

[ Restart configurations O >

Reset and restart configurations @

Mame | Reset_and_set_pc |

Type: | Reset w |

Additional commands:

set Spe=0x8000cal

Apply

@ oK || Cancel

When several reset configurations are defined, they appear in the toolbar dropdown menu in order of use. Select
the desired one to perform a reset.

Figure 181. Select restart configuration

LS B S T
Reset

EEEE

o

Reset_and_set_pc

Restart Configurations...

I'E 1 I Y | |

3.1.5.6.3 Terminate

The most common way to stop a debug session is by clicking the [Terminate] toolbar button. It is also possible to
stop the debug session with the [Run]>[Terminate] menu. When the debug session is stopped, STM32CubelDE
switches automatically to the C/C++ perspective.
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3.1.5.6.4

3.1.6

3.1.6.1

UM2609 - Rev 16

Terminate and relaunch

Use the [Terminate And Relaunch] toolbar button if changes in the source code have been made during the
debug session. Menu command [Run]>[Terminate And Relaunch] can also be used for this purpose. This stops
the debug session, rebuild the program, and relaunches a debug session with the new program loaded.

Debug features

Live Expressions view

The Live Expressions view in STM32CubelDE works very much like the Expression view with the exceptions that
all the expressions are sampled live during debug execution. The number of expressions being sampled
determines the sampling speed. An increased number of expressions being sampled results in a slower sample
rate.

The view displays many different types of global variables. The view also allows users to create mathematical
expressions that are evaluated automatically, suchas (i * 4 + offset). The address column shows the
memory addresses of the evaluated variables and expressions.

Figure 182. Live Expressions

Q E| @O

- Variables ° Breakpoints % Expressions ! Registers % Live Expressions X ®8SFRs % & -0

Expression Type Value Address View Menu

©= uint32_t 2 0x20000000
®= offset uint32 t 8 0x20000004
0= j* 4 + offset unsigned int 16 0x80000008

<= Add new expression

The view can parse complicated data types and display complex data types like C-language structures. Only one
format of numbers is used at the same time. To change this format, use the dropdown menu.

Figure 183. Live expressions number format (selection)

@Fo0ioc  [@mainc X [@system stm32.. B startup stm3..  ([@stm32f0xchale ™ = B erVariables % Breakpoints ‘% Expressions ! Registers & Live Expressions % ®SFRs Emit
71 /% MCU CONfiguration-=====sssmmmmmmm oo A [Expression Type Value Default Number Format
72 T ile ui Hex
73 /* Reset of all peripherals, Initializes the Flash interface and e ke volatila uint32 ¢ SRR ]

74 HAL_Init(); - var uint32. t 1909.215087890625 Decimal
75 4 Add new expression Octal
;; /* USER CODE BEGIN Init */ Binary
78  /* USER CODE END Init */ Qioanat IS Q-Value(l)
79 Q-Value(2)
8@ /* Configure the.system clock */ Q-Value(3)
81  SystemClock_Config();
82 Q-Value(4)
83  /* USER CODE BEGIN SysInit */ Q-Value(5)
84
Q-Value(6)

85 /* USER CODE END SysInit */ il
86 Q-Value(7)
87 /* Initialize all configured peripherals */ Q-Value(8)
g: /* USER CODE BEGIN 2 */ Q-Value(@)
98 /* USER CODE END 2 */ Q-Value(10)
91 Q-Value(11)
92  /* Infinite loop */ it
93  /* USER CODE BEGIN WHILE */ )
94 while (1) ® Q-Value(13)
5 Q-Value(14)
96 * USER CODE END WHILE *
97 var :=1- L Q-Value(15)

;
98 /* USER CODE BEGIN 3 */ Q-Value(16)
99 }- , Q-Value(17)

100 * USER CODE END 3 *

101 } Q-Value(18)
102 Q-Value(19)
103= /%= i ) i Q-Value(20)
184  * @brief System Clock Configuration
185 * @retval None Q-Value(21)
186 */ Q-Value(22)
187-void SystemClock_Config(void) Q-Value(23)
108 { v
P PO P VO S PO ran Q-Value(24)

< 2 Q-Value(25)

B Fancale X * Brmhlomc O Fvanitahloc @ Nahinnor Cnncala Ml Momnans 8 X x| &b P
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The variable values can be changed on the fly in the Live Expressions view while the program is running. Select
the variable and change its value. It requires that only a single variable name is used in the expression, and that
no calculation is involved. In Figure 184 for example, the variable i is selected and its value is changed from 2 to
4. Consequently, the result is also changed and highlighted in yellow. Note that any value that changes during a
halt/run/halt cycle is highlighted in yellow.

Figure 184. Live expressions number format (example)

Q 6%
i+ Variables ®s Breakpoints % Expressions & Disassembly % Registers %1 Live Expressions ¥ ®SFRs e
x %
Expression Type Value Address
B uint32_t 4 020000000
w- offset uint32_t 8 0x20000004
w=j* 4 4+ offset unsigned int 24 0xB0000008
+ Add new expression
Note: To be able to use the Live Expressions view during debug, the live expression mechanism must be enabled
during startup.
3.1.6.2 Shared ST-LINK

In the Debugger tab in Debug Configurations for ST-LINK GDB server and OpenOCD, a selection enables shared
ST-LINK. When shared ST-LINK is enabled, the communication to ST-LINK goes via the ST-LINK server. The ST-
LINK server makes it possible for several programs to access the same ST-LINK when shared ST-LINK is
enabled.

STM32CubeProgrammer (STM32CubeProg) also contains a configuration for shared ST-LINK. This means that
when shared ST-LINK is enabled in the debug configuration in STM32CubelDE, it is possible to debug a program
and let STM32CubeProgrammer access and read the device flash memory and RAM at the same time.

Enabling the shared mode causes STM32CubelDE to launch the ST-LINK server, if it is not already running, with
the default port 7184 for listening to the TCP connection. This default port is not editable from STM32CubelDE.

3.1.6.3 Debug multiple boards

Debugging with multiple boards is possible using two ST-LINK or SEGGER J-Link probes at the same time.
Connected to two different microcontrollers, both probes are connected to one PC on different USB ports. In this
section, let us suppose that two different boards/microcontrollers are used: HW_A and HW_B.

It is possible to run one instance of STM32CubelDE containing one project for HW_A and one project for HW_B.
The default port to be used is:

. 61234 for ST-LINK GDB server

. 3333 for OpenOCD

. 2331 SEGGER J-Link

This is presented in the Debugger tab in the Debug Configurations dialog. The port number must be changed for
one of the projects to use another port, such as port 61244.

The debug configuration can use GDB connection selection [Autostart local GDB server]. Note that when
debugging multiple boards, two or more debug probes are connected to the PC; the correct serial number must
be selected for each debug configuration.
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When the debug configurations has been configured for both projects so that each board is associated to a
specific probe, it is time to test and debug each board individually first. When it is confirmed that this is working,
the debug of both targets at the same time can be started as follow:

1. Start to debug HW_A.

2. The perspective switches automatically to the Debug perspective in STM32CubelDE when a debug session
for HW_A is started.

3. Switch to the C/C++ perspective.
Select the project for HW_B and start debugging it. The Debug perspective opens again.

5. There are two application stacks/nodes in the Debug view, one for each project. When changing the selected
node in the Debug view, the related editor, variable view and others are updated to present information
associated to the selected project.

It is also possible to start the GDB servers manually: select [Connect to remote GDB server] in the debug
configuration. In such case, make sure that the GDB servers are started with parameters defining the individual
ports and serial numbers to be used, and that the corresponding port numbers are used in the Debug
Configurations dialog for each project.

Below is an example using SEGGER J-Link GDB server connecting to SEGGER J-Link, with port=2341 and S/
N=123456789:

>JLinkGDBServerCL.exe -port 2341 -if SWD -select usb=123456789

P

Information on command-line parameters to be used when starting the GDB servers manually are provided in the
GDB server manuals available from the Information Center.

3.1.6.4 STM32H7 multicore debugging
Information about how to use STM32H7 multicore devices in STM32CubelDE is available in [ST-09].

3.1.6.5 STM32MP1 debugging
Information about how to use STM32MP1 devices in STM32CubelDE is available in [ST-08].

Users are advised to keep updated with the documentation evolution of the STM32MP1 Series at www.st.com/en/
microcontrollers-microprocessors/stm32mp1-series.

3.1.6.6 STM32L5 debugging
Information about how to use STM32L5 devices with Arm® TrustZone® in STM32CubelDE is available in [ST-11].
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3.1.6.7 Incremental flash memory programming

This feature allows users to program only the modified memory sectors. To activate it, select [Incremental flash
programming (experimental)] in the debug configuration options.

Figure 185. Incremental flash memory programming
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3.1.6.8 Semihosting

To enable the semihosting feature, select [Debug Configurations...] and create a new configuration.

The semihosting feature is displayed, with the option to enable either the terminal mode or the terminal and file

I/O mode. Refer to [ST-07] for more details regarding this feature. For each option, the user has the possibility to
set a port value.

To launch a debug session, select [Windows]>[Show View]>[TCP Console]. In the console, set the server URL
and the service port to start viewing the results displayed.
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Figure 186. Semihosting selection
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Figure 187. TCP console selection
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Figure 188. TCP console configuration
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Figure 189. TCP settings
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3.1.7 Program and reset the device

It is possible to create run configurations to download applications and reset the target without launching a full
debug session. The Run Configurations dialog is similar to the Debug Configurations dialog, however disabled
widgets in the lower part of the Startup tab are not performed. When running a run configuration, the specified
program is flashed but, after the program counter is set, the program execution is started in the target and the
"run" session in STM32CubelDE is closed.

To create a run configuration for the project, right-click on the project name in the Project Explorer view and select
[Run As]>[STM32 C/C++ Application].
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Another way to create a run configuration is to select the project name in the Project Explorer view and use the
menu [Run]>[Run As]>[STM32 C/C++ Application].

Figure 190. Run configurations startup tab

E Debug Configurations O X
Create, manage, and run configurations
CRPeEX B Y- Mame: | NUCLEO-F401RE |
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[T NUCLEO-FADIRE (OpenCCD) [ Debug/NUCLEO-FAD1RE.lf [NUCLEO-F401RE
g Lelf [ 1 See Main tab true true -
[[] NUCLEO-FAD1RE (SEGGER)
Move down
Runtime Options
Start Address
(®) Default start address
() Set program counter (hex):
() Specify vector table (hex):
Set breakpoint at:
Exception on divide by zero
[ Exception on unaligned access
Halt on exception
Resume
Run Cemrmands
Revert Appl
Filter matched 10 of 10 items == heY
® Debug | | Close
3.1.8 Attach the debugger to the running target

It is possible to connect STM32CubelDE and a debugger via JTAG/SWD to the embedded target without
performing a reset. This approach is useful when trying to resolve problems that occur at rare occasions. Finding
the root cause of the problem in case of a CPU crash is further simplified by learning how to use the Fault
Analyzer view (refer to Section 3.5: Fault Analyzer).

Before trying this approach, consider whether halting the application in the wrong state could potentially harm the
hardware (for instance in the case of a motor controller application). This is because when GDB connects to the
target, the CPU is halted. This behaviour cannot be modified.

The following three or four steps are needed to update the debug configuration and to attach to running target:
1. Modify the debug configuration to attach to the running target

2. Connect the debug probe to the embedded target

3. Start a debug session using the modified debug configuration

4. Optionally, analyze the CPU fault condition with the Fault Analyzer tool (refer to Fault Analyzer)
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Step 1: Modify the debug configuration

The default generated debug configurations in STM32CubelDE contains settings to reset the device and
download new program, and sets a breakpoint at main. This is not of any use when connecting to a running
system which may, or may not, have crashed.

In order to create a modified debug configuration, perform these steps:
1. Open the Debug Configurations dialog.

2. In the left frame of the Debug Configurations dialog, select the debug configuration associated to the project to
debug and make a copy of this by right-clicking it and selecting [Duplicate].

3. Give the duplicate debug configuration a name.

4. Update the Debugger tab in Debug Configurations:
- When using ST-LINK GDB server and OpenOCD, select [None] as [Reset behaviour].
- When using SEGGER J-Link GDB server, select [None] as [Reset strategy].

5. Change needed/recommended in the Startup tab of Debug Configurations for both ST-LINK GDB server and
SEGGER J-Link GDB server:

- Disable file [Download] in [Load Image and Symbols].

- Disable [Set program counter at (hex)].

- Disable [Set breakpoint at].

- [Exception on divide by zero]and [Exception on unaligned access] can be disabled or enabled.

- Disable [Resume].
If the [Resume] is enabled, the debugger stops the target during connection and, after a short period of
time, sends a continue command.
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Figure 191. Startup tab attach
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Move down
Runtime Options
Start Address
(®) Default start address
() Set program counter (hex):
(O Specify vector table (hex):
Set breakpoint at:
Exception on divide by zero
[ Exception on unaligned access
Halt on exception
Resume
Run Commands
Revert A
Filter matched 11 of 11 items LT T
@ | Debug | ‘ Close ‘

Important:

UM2609 - Rev 16

Step 2: Connect ST-LINK or SEGGER J-Link to the embedded target

Connect first ST-LINK or the SEGGER J-link to the computer. Then connect it to the embedded target. No reset is
issued.

Step 3: Start a debug session using the modified debug configuration

Do not launch the debug session using the wrong debug configuration, which may reprogram and reset the
target. Use [Run]>[Debug Configurations...], select the modified debug configuration in the left frame, and click
[Debug]. This is the safest way to launch a debug session with full control of the debug configuration applied
and prevents from a potential reset.

The debugger is now connected to the embedded target, which is automatically halted. At this point, different
status registers and variables can be investigated in the application. If the CPU has crashed, the Fault Analyzer
can be used to get a better understanding of the root causes.
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3.1.9 Import STM32 Cortex®-M executable
Use menu [File]>[Import...] to open the Import dialog.

Figure 192. Cortex®-M executable import dialog

m Import O et

Select @

Imports an externally built STM32 Cortex-M executable into a new project and configures the debugger.

Select an import wizard:

type filter text

* = General
v =C/C++
] C/C++ Executable
& C/C++ Project Settings
Existing Code as Makefile Project
[ STM32 Cortex-M Executable
> & Install
» = Remote Systems
> = Run/Debug
» = Team

@ < Back Next > Finish Cancel
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Select [STM32 Cortex-M Executable] and press [Next >].

Figure 193. STM32 Cortex®-M executable dialog

m STM32 Cortex-M Executable [l X

Select executable to debug and configure a matching STM32 device.

Executable: ‘ C:\dev\STM32F401_Nucleo_ExtBuilt.elf ‘ ‘ Browse... ‘

STM32 device

Mcu: | | Select...|
CPU: | ]
Core: ‘ ™ ‘
@ < Back Next > Finish Cancel

Use the [Browse...] button and select the e1r file to import. When the e1f file is selected, the STM32 device must
be selected manually so that STM32CubelDE can be used for debugging.

Press [Select...] to open the MCU/MPU Selector dialog.

Figure 194. STM32 Cortex®-M executable MCU/MPU selection

[l MCU/MPU Selector O X

Please select your STM32 target device

401

MCU/MPU A
5TM32F401RDTx

STM32F401RETx

STM32F401VBHx

STM32F401VBTx

5TM32F401VCHx

5TM32F401VCTx v

@ OK | ‘ Cancel
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Select the microcontroller or microprocessor to be used. The search field can be used to find the device. Press
[OK] once the device is selected.

As a result, the CPU and core are presented in the dialog.

Figure 195. STM32 Cortex®-M CPU and core

m STM32 Cortex-M Executable

Select executable to debug and configure a matching STM32 device.

Executable: ‘ C\dev\STM32F401_Nucleo_ExtBuilt.elf ‘ ‘ Browse... ‘

STM32 device
MCU: ‘ STM32F401RETx

‘ ‘ Select... |

CPU: Cortex-M4 (0)

v ‘

Core: ‘0

e ‘

@ < Back Next > Finish | ‘ Cancel
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Press [Finish] and the debug configuration dialog automatically opens.

Figure 196. Cortex®-M debug configuration for imported project

m Edit Configuration

Edit configuration and launch.

Name: | STM32F401_Nudleo_ExtBilt.elf |

Main‘ i Debugger‘ g Startup“‘i./ Source‘ B Common

Project:
| STM32F401_Nucleo_ExtBuilt.elf |

Browse... ‘

C/C++ Application:

‘STM32F401_Nucleo_E)rtBuiIt.eIf ‘ ‘ Search Project... ‘ ‘ Browse... ‘

Build (if required) before launching

Build Configuration: |Use Active

(O Enable auto build (® Disable auto build

(O Use workspace settings Configure Workspace Settings...

‘ Revert ‘ ‘ Apply ‘

@ |

Debug | | Close ‘

The debug configuration can then be set up in similar way as with any other STM32CubelDE project. Once the
configuration is completed, press [Debug] to start a debug session.
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The imported project is displayed in the Project Explorer view.

Figure 197. Project explorer view with imported project

m workspace_um7 - Device Configuration Tool - £

File Edit Source Refactor Navigate Search Prc
v @~/ veigvra~y[d~y -
5 Project Explorer = BE%Y § -0
~ [ NUCLEO-F401RE
> & Includes
» 2 Core
» (2 Drivers
[ NUCLEO-F401RE.ioc
& STM32F401RETX_FLASH.Id
& STM32F401RETX_RAM.Id
v 5 STM32F401 Nucleo ExtBuilt.elf
> & Includes
STM32F401 Nucleo ExtBuilt.elf

3.2 Debug with Serial Wire Viewer tracing (SWV)

3.21 Introduction to SWV and ITM
This section provides information on how to use Serial Wire Viewer tracing (SWV) in STM32CubelDE.
System analysis and real-time tracing in STM32 requires a number of interaction technologies: Serial Wire Viewer
(SWV), Serial Wire Debug (SWD), Instrumentation Trace Macrocell (ITM) and Serial Wire Output (SWO). These
technologies are part of the Arm® CoreSight™ debugger technology. They are explained below.
Serial Wire Debug (SWD) is a debug port similar to JTAG. It provides the same debug capabilities (run, stop on

breakpoints, single-step) but with fewer pins. It replaces the JTAG connector with a 2-pin interface (one clock pin
and one bi-directional data pin). The SWD port alone does not allow real-time tracing.

The Serial Wire Output (SWO) pin can be used in combination with SWD. It is used by the processor to emit real-
time trace data, thus extending the two SWD pins with a third pin. The combination of the two SWD pins and
SWO pin enables Serial Wire Viewer (SWV) real-time tracing in compatible Arm® processors.

Beware that, SWO being just one pin, it is easy to set a configuration that produces more data than the SWO is
able to send.

The Serial Wire Viewer (SWV) is a real-time trace technology that uses the Serial Wire Debug (SWD) port and the
Serial Wire Output (SWO) pin. The Serial Wire Viewer provides advanced system analysis and real-time tracing
without the need to halt the processor to extract the debug information.

Serial Wire Viewer (SWD) provides the following types of target information:

. Event notification on data reading and writing

. Event notification on exception entry and exit

. Event counters

. Timestamp and CPU cycle information, which can be used for program statistical profiling

The Instrumentation Trace Macrocell (ITM) enables applications to write arbitrary data to the SWO pin, which can
be interpreted and visualized in the debugger. For example, ITM can be used to redirect printf () outputto a
SWV console view in the debugger. The standard is to use port 0 for this purpose.

The ITM port has 32 channels. Writing different types of data to different ITM channels allows the debugger to
interpret or visualize the data on various channels differently.

Writing a byte to the ITM port takes only one write cycle, thus taking almost no execution time from the application
logic.
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Based on SWV, and ITM trace data, STM32CubelDE can provide advanced debugger capabilities with special
SWV views.

Note: Arm® does not include SWV/ITM in Cortex®-MO or Cortex®-M0+ cores. Therefore, STM32 devices based on
these cores, such as STM32L053 microcontrollers, do not support SWV/ITM.

3.2.2 SWV debugging

To debug and use the Serial Wire Viewer (SWV) in STM32CubelDE, the JTAG probe and the GDB server must
support SWV. The board must also support SWD, and the SWO pin needs to be available and connected to the
JTAG probe.

The following sections describe the process to create a debug configuration, SWV settings configuration, and how
to use SWV tracing in a debug session.

3.22.1 SWYV debug configuration

Step 1: Open the Debug Configurations dialog

Use for instance menu [Run]>[Debug Configurations...] and select the STM32 Cortex®-M debug configuration
to update.

Step 2: Select the SWD interface
Select the [SWD] interface in the Debug Configurations dialog.

Step 3: Enable SWV
Enable [SWV] in the Debug Configurations dialog.

Step 4: Enter the core clock frequency

Enter the [Core Clock] frequency in the Debug Configurations dialog. This must correspond to the value set by
the application program to be executed.

Usually, the core clock setting is stored in the SystemCoreClock variable when using projects imported from
STM32 firmware examples or created with STM32CubeMX. One method to inspect the core clock value is to start
a debug session and add the SystemCoreClock variable to the Expressions view. Make sure that the system
core clock is configured by the application before reading the value.

If the SystemCoreClock is not updated, change the program and add a call to the function
SystemCoreClockUpdate (). Rebuild the program, restart debugging and inspect the SystemCoreClock
value again.

Figure 198. SWV core clock

m O X
&' Expressions 53 =8 El'ﬂ:‘ %S&|rﬁ=._.’§' i =0
Expression Type Value

()= SysternCoreClock uint32 t 84000000

op Add new expression
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Step 5: Enter the SWO clock frequency

The [Serial Wire Viewer (SWV)] selections in the Debug Configurations dialog can be used only when the [SWD]
interface is selected. When [SWV] is enabled, it is required to configure the [Clock Settings]. The [Core Clock]
must be set to the device speed. The SWO clock is automatically set to the highest possible speed depending on
debug probe used and core clock. However, if the debugged hardware does not allow too-high SWO clock speed,
it is possible to enable [Limit SWO clock] and enter the maximum SWO clock speed in kHz. The SWV [Port
number] must be set to the port to be used for SWV data communication. The SWV port cannot be set equal to
the GDB connection [Port number].

Figure 199. SWV debug configuration

Serial Wire Viewer (SWV)
Enable

Core Clock (MHz): 84.0
[ Limit SWO clock
Maximum SWO clock (kHz): | auto detect

Port number: 61235

Step 6: Save the configuration

Press [Applylin the Debug Configurations dialog to save the configuration.

Step 7: Start a debug session

Press [Debug] to start a debug session. Make sure that the probe and board are connected.

Step 8: Possibly suspend the target
[Suspend] the target if it has not stopped at a breakpoint.

Step 9: Open a SWV view

Open one of the SWV views. For first-time users, it is recommended to open the SWV Trace log view because it
gives a good overview of incoming SWV packets and how well the tracing is working.

Select the [Window]>[Show View]>[SWV]>[SWV Trace log ] menu command to open the SWV Trace log view.
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Figure 200. SWV show view

>roject Run Window Help

New Window el Yy §ly oo vy v (D
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Perspective > % Breakpoints Alt+Shift+Q, B El SWV Exception Trace log

Navigation = Build Analyzer L= SWV Exception Timeline Graph

& Console Alt+Shift+Q, C L SWV Data Trace

Hifimances % Debug e SWV Data Trace Timeline Graph
penided =Signal.: 0 - & Debugger Console & SWV ITM Data Console
f6 = Disassembly £ SWV Statistical Profiling
n32f407retx.s:113 ( @ Error Log Alt+Shift+Q, L

“ubelDE/plugins/cc O Eiecutshiles
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® Fault Analyzer peripherals */
4 Live Expressions

0 Memory

0 Memory Browser

E. Modules

&= Outline Alt+Shift+Q, O
! Problems Alt+Shift+Q, X
= Progress

‘s Project Explorer

it Registers

SFRs

5 Signals

= Static Stack Analyzer

& Templates

% Trace Control

= Variables Alt+Shift+Q, V
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Step 10: View the trace log

The SWV Trace log view is now visible.

Figure 201. SWV Trace log view

B Console [ Problems O Executables B SWV Trace Log * KOX|EE~ D

Index Type Data Cycles Time(s) Extra info

Overflow packets: 0

3.2.2.2 SWV settings configuration

Step 1: Open the Serial Wire Viewer settings

Click on the [Configure Trace] toolbar button in the SWV Trace Log view to open the Serial Wire Viewer settings
dialog.
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Figure 202. SWV [Configure Trace] toolbar button

",

Note: The [Configure Trace] toolbar button is available in all SWV views.

Step 2: Configure the trace data

Configure the data to be traced in the Serial Wire Viewer settings dialog.
For this example [PC Sampling] and [Timestamps] are enabled.

Figure 203. SWV settings dialog

mSeriaI Wire Viewer settings for NUCLEO-F401RE Debug (ST-LINK) X
Clock Settings Trace Events PC Sampling
Core Clock: 84 MHz [JCPI: Cycles per instruction [] EXC: Exception overhead [“]Enable Resolution: 16384  Cycles/sample
Clock Prescaler: 42 [T SLEEP: Sleep cycles (] LSU: Load store unit cycles =
. . . tamps
. [_1FOLD: Folded instructions [_] EXETRC: Trace Exceptions fmes
sl lock LLLULr []Enable Prescaler: 1 2
Data Trace
Comparator 0 Comparator 1 Comparator 2 Comparator 3
[JEnable [JEnable [JEnable [JEnable
Var/Addr: 0x0 Var/Addr: 0x0 Var/Addr: 0x0 Var/Addr: 0x0
Access: Read/Write Access: Read/Write ~ Access: Read/Write Access: Read/Write
Size: Word : Size: Word Size: Word - Size: Word
Generate: Data Value Generate: Data Value Generate: Data Value Generate: Data Value
ITM Stimulus Ports
Enable port: 31O T24 230 IO T 15 s 7CICICICICIC I o
Privileged only ports: [_] Port 31..24 [ Port 23..16 [_]Port 15.8 [_]Port 7.0
Cancel

The SWV settings dialog has the following configurations:

. [Clock Settings]: These fields are disabled and only present the values used and configured in the Debug
Configurations for the debug session. If these values need to be changed, close the debug session and

open the Debug Configurations to modify them.
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. [Trace Events]: The following events can be traced.

- [CPI]: Cycles per instruction. For each cycle beyond the first one that an instruction uses, an internal
counter is increased with one. The counter (DWT CPI count) can count up to 256 and is then set to
0. Each time that happens, one of these packets are sent. This is one aspect of the processors
performance and used to calculate instructions per seconds. The lower the value, the better the
performance.

- [SLEEP]: Sleep cycles. The number of cycles the CPU is in sleep mode. Counted in DWT Sleep
count register. Each time the CPU has been in sleep mode for 256 cycles, one of these packets is
sent. This is used when debugging for power consumption or waiting for external devices.

- [FOLD]: Folded instructions. A counter for how many instructions are folded (removed). Every 256
instruction folded (taken zero cycles) will receive one of these events. Counted in DWT Fold count
register.

Branch folding is a technique where, on the prediction of most branches, the branch instruction is
completely removed from the instruction stream presented to the execution pipeline. Branch folding
can significantly improve the performance of branches, taking the CPI for branches below 1.

- [EXC]: Exception overhead. The DWT Exception count register keeps track of the number of
CPU cycles spent in exception overhead. This includes stack operations and returns but not the time
spent processing the exception code. When the timer overflows, one of these events is sent. Used to
calculate the actuel exception handling cost to the program.

- [LSU]: Load Store Unit Cycles. The DWT LSU count register counts the total number of cycles the
processor is processing an LSU operation beyond the first cycle. When the timer overflows, one of
these events is sent.

With this measurement, it is possible to track the amount of time spent in memory operations.

- [EXETRC]: Trace Exceptions. Whenever an exception occurs, exception entry, exception exit and
exception return events are sent. These events can be monitored in the SWV Exception Trace Log
view. From this view, it is possible to jump to the exception handler code for that exception.

. [PC Sampling]: Enabling this starts sampling the Program Counter at some cycle interval. Since the SWO
pin has a limited bandwidth, it is not advised to sample to fast. Experiment with the [Resolution] (cycles/
sample setting) to be able to sample often enough. The results from the sampling are used, among other
things, for the SWYV Statistical Profiling view.

. [Timestamps]: Must be enabled to know when an event occurred. The [Prescaler] should only be
changed as a last effort to reduce overflow packets.
. [Data Trace]: It is possible to trace up to four different C variable symbols, or fixed numeric areas of the

memory. To do that, enable one comparator and enter the name of the variable or the memory-address to
trace. The value of the traced variables can be displayed both in the Data Trace and Data Trace Timeline
Graph views.

. [ITM Stimulus Ports]: There are 32 ITM ports available, which can be used by the application. For
instance, the CMSIS function ITM SendChar can be used to send characters to port O refer to
Section 3.2.3.5: SWV ITM Data Console and printf redirection). The packets from the ITM ports are
displayed in the SWV ITM Data Console view.

Note: It is recommended to limit the amount of data traced. Most STM32 microcontrollers read and write data faster
than the maximum SWO pin throughput. Too many trace data result in data overflow, lost packets and possibly
corrupt data. For optimum performance, trace only data necessary to the task at hand.

Overflow while running SWV is an indication that SWV is configured to trace more data than the SWO pin is able
to process. In such a case, decrease the amount of data traced.

Enable [Timestamps] to use any of the timeline views in STM32CubelDE. The default [Prescaler] is 1. Keep this
value, unless problems occur related to SWV packet overflow.

Three examples are provided below for illustrating SWV trace configuration:

. Example 1: To trace the value of a global variable, enable [Comparator] and enter the name of the

variable or the memory address to be traced.
The value of the traced variable is displayed both in the Data Trace and Data Trace Timeline Graph views.

. Example 2: To profile program execution, enable [PC sampling]. In the beginning, a high value for the
[Cycles/sample] is recommended.
The result from the PC sampling is then displayed in the SWV Statistical Profilingview.

. Example 3: To trace the exceptions occurring during program execution, enable [Trace Event EXETRC:
Trace Exceptions].
Information about the exceptions is then displayed in the SWV Exception Trace Log view.
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Step 3: Save the SWV configuration

Click on the [OK] button to save the SWV configuration. The configuration is saved together with other debug
configurations and remains effective until changed.

3.223 SWYV tracing

Step 1: Start SWV trace recoding

Press the [Start/Stop Trace] toolbar button in one of the SWV views to send the SWV settings to the target board
and start the SWV trace recoding. This toolbar button is available in all SWV views. The board does not send any
SWV packet until it is properly configured. The SWV configuration must be resent if the configuration registers on
the target board are reset. Actual tracing does not start until the target starts to execute.

Figure 204. SWV [Start/Stop Trace] toolbar button

Note: The tracing cannot be configured while the target is running. Pause the debugging before attempting to send a
new configuration to the board. Each new or updated configuration must be sent to the board to take effect. The
configuration is sent to the board when the [Start/Stop Trace] button is pressed.

Step 2: Start the target

Press the [Resume] toolbar button on top of the Debug perspective to start the target.

Step 3: SWV Trace Log view
SWV packets are displayed in the SWV Trace Log view.

Figure 205. SWV Trace Log PC sampling

= o X
B SWV Trace Log * Xex|5E- o
Index Type Data Cycles Time(s) Extra info -

10362 PCSample 0x8000508 169777034 2.021155s
10363 PC Sample 0x8000516 169793417 2.021350 s
10364 PC Sample 0x8000528 169809800 2.021545s
10365 PC Sample 0x8000500 169826183 2.021740 s
10366 PC Sample 0x8000510 169842566 2.021935s
10367 PC Sample  0x80004f2 169858949 2.022130s
10368 PC Sample 0x8000504 169875332 2.022325s
10369 PC Sample 0x8000516 169891715 2.022520 s
10370 PC Sample 0x8000528 169908098 2022715 s

Overflow packets: 0

Step 4: Clear collected SWV data

When the target is not running, the collected SWV data can be cleared by pressing the [Remove all collected
SWV data] toolbar button. This toolbar button is available in all SWV views.

Figure 206. [Remove all collected SWV data] toolbar button

b 4
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3.23 SWV views

The SWV views that display SWV traces data are:

. SWV Trace Log: Lists all incoming SWV packets in a spreadsheet. Useful as a first diagnostic for the trace
quality.

. SWV Exception Trace Log: The view has two tabs, one is similar to the SWV Trace Log view and the other
tab displays statistical information about exception events.

. SWV Data Trace: Tracks up to four different symbols or areas in the memory.

. SWV Data Trace Timeline Graph: A graphical display that shows the distribution of variable values over
time.

. SWV ITM Data Console: Prints readable text output from the target application. Typically this is done via
printf () with output redirected to ITM channel 0.

. SWV Statistical Profiling: Displays statistics based on the Program Counter (PC) sampling. Shows the
amount of execution time spent within various functions.

Figure 207. SWV views selectable from the menu

SWV Trace log

SWV Exception Trace log

SWV Data Trace

SWV Data Trace Timeline Graph
SWV ITM Data Console

SWV Statistical Profiling

| E

HmE »

Note: More than one SWV view may be open at the same time for the simultaneous tracking of various events.

The SWV views toolbars contain these usual control icons.

Figure 208. SVW views common toolbar

K®IX|58 - O

These icons are used for the following purpose, from left to right:

. Configure trace

. Start/Stop trace

. Remove all collected SWV data
. Scroll lock

. Minimize

. Maximize

The SWV graph views toolbars contain these extra control icons.

Figure 209. SVW graph views extra toolbar

@0 il & 2

These icons are used for the following purpose, from left to right:

. Save graph as image

. Switch between seconds and cycle scale
. Adjust the Y-axis to best fit

. Zoom in

. Zoom out
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3.2.3.1 SWV Trace Log
The SWV Trace Log view lists all incoming SWV packets in a spreadsheet. The data in this view can be copied to
other applications in CSV format by selecting the rows to copy and type Ctrl+C. The copied data can be pasted
into another application with the Ctrl+V command.

Figure 210. SWV Trace Log PC sampling and exceptions

10 O 4
= SWV Trace Log Kimixian~ o
Index Type Data Cycles Time(s) Extra info L
25012 PC Sample 0x80004f6 258481871 3.077165s
25013 PC Sample 0x8000508 258498254 3.077360 s
25014 PC Sample 0x8000518 258514637 3.077555 s
25015 Exception entry SYSTICK (EXC 15) 258522309 3.077647 s
25016 Exception exit SYSTICK (EXC 15) 258522367 3.077647 s
25017 Exception return N/A (EXC0) 258522374 3.077647 s
25018 PC Sample 0xB80004fc 258531017 3.077750 s
25019 PC Sample 0x800050e 258547400 3.077945s
25020 PC Sample 0x800051e 258563783 3.078140s
28021 D Camnla NuANNNAFA ACQEQN1E6A 2 NTRAIAE ~ -
Overflow packets: 0

The column information in the SWV Trace Log view is described in Table 11.

Table 11. SWV Trace Log columns details

I S

Index The packet ID. Shared with the other SWV packets.

Type The type of packet (example PC sample, data PC value (comp 1), exceptions, overflow).
Data The packet data information.

Cycles The timestamp of the packet in cycles.

Time(s) The timestamp of the packet in seconds.

Extra info Optional extra packet information.

3.2.3.2 SWYV Exception Trace Log
The SWV Exception Trace Log view is composed of two tabs.

Data tab

The first tab is similar to the SWV Trace Log view, but is restricted to exception events. It also provides additional
information about the type of event. The data can be copied and pasted into other applications. Each row is linked
to the code for the corresponding exception handler. Double-click on the event to open the corresponding
interrupt hander source code in the Editor view.

Note: Enable [Trace Event EXETRC: Trace Exceptions] in the Serial Wire Viewer settings dialog to trace exceptions
during program execution. Enable [Timestamps] to log cycle and time for each interrupt packet.
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Figure 211. SWV Exception Trace Log — Data tab
@ o x
[ SWV Exception Trace Log # x|z
Data  Statistics
Index Type Name Peripheral  Function Cycles Time(s) Extra info o
17629 Exception exit SYSTICK (EXC 15) SysTick_Handler() 58204401 692.909536 ms
17630  Exception return N/A (EXC 0) 58205926 692927690 ms Timestamp delayed. Packet delayed.
17636  Exception entry SYSTICK (EXC 15) SysTick_Handler() 58288335  693.908750 ms
17637  Exception exit SYSTICK (EXC 15) SysTick_Handler() 58288393  693.909440 ms
17638 Exception return N/A (EXC 0) 58288400 693.909524 ms
17644 Exception entry SYSTICK (EXC 15) SysTick_Handler() 58372327 694.908655 ms
17645  Exception exit SYSTICK (EXC 15) SysTick_Handler() 58372385  694.909345 ms
17646 Exception return N/A (EXC 0) 58372392 694909429 ms
v
Overflow packets: 0
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The column information in the SWV Exception Trace Log — Data tab is described in Table 12.

Table 12. SWV Exception Trace Log — Data columns details

Come | i

Index The exception packet ID. Shared with the other SWV packets.
Type Each exception generates three packets: Exception entry, Exception exit and then an Exception return packet.
Name The name of the exception. Also the exception or interrupt number.

Peripheral ' The peripheral for the exception.

The name of the interrupt handler function for this interrupt. Updated when debug is paused. Is cached during the

Function whole debug session. By double clicking the function, the editor will open that function in the source code.

Cycles The timestamp for the exception in cycles.
Time(s) The timestamp for the exception in seconds.

Extra info = Optional extra information about that packet.

Statistics tab

The second tab displays statistical information about exception events. This information may be of great value
when optimizing the code. Hypertext links to exception handler source code in the editor is included.

Figure 212. SWV Exception Trace Log — Statistics tab

¢ [mN
= SWV Exception Trace Log PO RE
Data Statistics

Exception Handler % of Number of % of excepti.. % of debug time Total runtime  Avg runtime  Fastest Slowest  First First (s) Latest Latest (s)

SYSTICK (EXC 15) SysTick_Handler() ~ 100.0000% 2172 100.0000% 0.0690% 40309 57 57 58 71567 851.988095 us 58372327 694.908655 ms

Total for all 2172 0.0690% 40309 18

Qverflow packets: 0
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The column information in the SWV Exception Trace Log — Statistics tab is described in Table 13.

Table 13. SWV Exception Trace Log — Statistics columns details

e [ EmEw ]

Exception The name of the exception provided by the manufacturer. Also the exception or interrupt number.

The name of the interrupt handler for this interrupt. Updated when debug is paused. Is cached during the
Handler whole debug session.

By double clicking the handler, the editor will open that function in the source code.
% of This exception type’s share, in percentage, of all exceptions.
Number of The total number of entry packets received by SWV of this exception type.
% of exception time = How big part of the execution time for all exceptions that this exception type have.

How big part of the total execution time for this debug session that this exception type have. All the

o )
% of debug time timers are restarted when the Empty SWV-Data button is pressed.

Total runtime The total execution time in cycles for this exception type.

Avg runtime The average execution time in cycles for this exception type.

Fastest The execution time in cycles for the fastest exception of this exception type.

Slowest The execution time in cycles for the slowest exception of this exception type.

First The first encounter of an entry event for this exception type in cycles.

First(s) The first encounter of an entry event for this exception type in seconds.

Latest The latest encounter of an entry event for this exception type in cycles.

Latest(s) The latest encounter of an entry event for this exception type in seconds.
3.2.3.3 SWYV Data Trace

The SWV Data Trace view tracks up to four different symbols or areas in the memory. For example, global
variables can be referenced by name. The data can be traced on Read, Write and Read/Write.

Enable [Data Trace] in Serial Wire Viewer settings. In Figure 213, two global variables pos1 and pos2 in the
program are traced on [Write] access.

Figure 213. SWV Data Trace configuration

mSeriaI Wire Viewer settings for NUCLEO-F401RE Debug (ST-LINK) X
Clock Settings Trace Events PC Sampling
Core Clock: 84 MHz []CPI: Cycles per instruction [] EXC: Exception overhead [V]Enable Resolution: 16384  Cycles/sample
Clock Prescaler: 42 [ SLEEP: Sleep cycles ] LSU: Load store unit cycles -
. ; 9 tamps
" []1FOLD: Folded instructions [_] EXETRC: Trace Exceptions e
sitlack UL e [“]Enable Prescaler: 1 v
Data Trace
Comparator 0 Comparator 1 Comparator 2 Comparator 3
Enable M Enable [lEnable [lEnable
Var/Addr: pos1 Var/Addr: pos2 Var/Addr: 0x0 Var/Addr: 0x0
Access: Write v Access: Read S Access: Read/Write Access: Read/Write
Size: Word Size: Word Size: Word Size: Word
Generate: Data Value + PC Generate: Data Value + PC Generate: Data Value Generate: Data Value

ITM Stimulus Ports
Enable port: 31[JJLICICICICIC 24 2310 I0ICICIOIE e 1sECCICICCIEM s 7ECIECIEEE o

Privileged only ports: [_]Port 31..24 [ Port 23.16 [_]Port 15.8 [_]Port 7.0

Cancel
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When running the program in debugger with SWV trace enabled the SWV Data Trace view displays this
information when [Comparator 0] with pos1 data is selected in the [Watch] list.

Figure 214. SWV Data Trace

1DE| O X
L SWV Data Trace ™ KMX|GoR ¥ = O
Watch

Comp Name Value A
0 pos1 10

1 pos2 0 v
History (pos1) _
Access Value PC Cycles Time =
WRITE 8 0x8000578 642414276 7.647789 s

WRITE 1 0x8000578 645655051 7.686370 s

WRITE 2 0x8000578 649164268 7.728146 s

WRITE 3 0x8000578 652673485 7.769922 s

WRITE 4 0x8000578 656182631 7.811698 s

WRITE 5 0x8000578 659691850 7.853474 s

WRITE 6 0x8000578 663004479 7.892910s

WRITE 7 0x8000578 666513696 7.934687 s

WRITE 9 0x8000578 673532061 8.018239 s

WRITE 10 0x8000578 677041280 8.060015 s v

The column information in the SWV Data Trace described in Table 14.

Table 14. SWV Data Trace columns details

I

Access Read or Write access type.
Value The value of data read or written.
PC The PC location where read or write access occurs.
Cycles The timestamp for the packet in cycles.
Time(s) The timestamp for the packet in seconds.
3.2.34 SWV Data Trace Timeline Graph

The SWV Data Trace Timeline Graph view contains a graphical display that shows the distribution of variable
values over time. It applies to the variables or memory areas in the SWV Data Trace. The following is displayed
when using the timeline graph displaying global variables pos1 and pos2 counting up and down.
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Figure 215. SWV Data Trace Timeline Graph

10E O X

L= SWV Data Trace Timeline Graph GO QXX ™

— posl — pos2

10410 JJ J

The SWV Data Trace Timeline Graph has the following features:

. The graph can be saved as a JPEG image file by clicking on the camera toolbar button.
. The graph shows the time in seconds by default but can be changed to cycles by clicking on the clock
toolbar button.
. Y-axis can be adjusted to best fit by clicking on the y-axis toolbar button.
. Zoom in and out by clicking on the [+] and [-] toolbar buttons.
. The zoom range is limited while debug is running. Zoom details are available when debug is paused.
3.2.3.5 SWYV ITM Data Console and printf redirection

The SWV ITM Data Console prints readable text output from the target application. Typically, this is done via
printf () with output redirected to ITM channel 0. Other ITM channels can get their own console views.

To use the SWV ITM Data Console view, first enable one or more of the 32 ITM ports in the Serial Wire Viewer
settings dialog.
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Figure 216. SWV settings

ESeriaI Wire Viewer settings for NUCLEO-F401RE Debug (ST-LINK)

Clock Settings Trace Events

Core Clock: 84 MHz [ CPI: Cycles per instruction [_] EXC: Exception overhead
Clock Prescaler: 42 [C1SLEEP: Sleep cycles []LSU: Load store unit cycles
SWO Clock: 20000 kHz []FOLD: Folded instructions [_] EXETRC: Trace Exceptions
Data Trace

Comparator 1
[JEnable
Var/Addr: pos2

Comparator 2
[JEnable
Var/Addr: 0x0
Access: Read/Write
Size: Word

Comparator 0

[JEnable
Var/Addr: pos1

Access: Write
Size: Word

Access: Write
Size: Word
Generate: Data Value + PC

Generate: Data Value + PC Generate: Data Value

PC Sampling
[CJEnable Resolution: 16384

Timestamps

[ Enable Prescaler: 1

Comparator 3
[lEnable
Var/Addr: 0x0
Access: Read/Write
Size: Word

Generate: Data Value

Cycles/sample

ITM Stimulus Ports
Enable port: 31[JLILILICILICIC 24 230 IO e +sOCICIOICICICICds 700 ICIC T o

Privileged only ports: [ ] Port 31.24 [ ] Port 23.16 [ ] Port 15.8 [ ]Port 7.0

Cancel

The packets from the ITM ports are displayed in the SWV ITM Data Console view. The CMSIS function
ITM SendChar () can be used by the application to send characters to the port 0, and the print £() function
can be redirected to use the ITM SendChar () function.

The following describes how to setup printf redirection over ITM:

1. Configure first file syscalls.c. Usually, the syscalls.c file is located in the same source folder as main.c.
If no syscalls.c file is available in the project, it can be copied from another STM32CubelDE project. One
way to get the file is to create a new STM32 empty project for the device. In the src folder, this project
contains a syscall.c file. Copy this file to a source folder in the project where it is needed.

2. Inside the syscalls.c file, replace the write () function with code calling ITM SendChar () instead of
1o putchar()

int write(int file, char *ptr, int len)
{
int Dataldx;

for (Dataldx = 0;
{

Dataldx < len; DataIdx++)

//__io putchar (*ptr++) ;
ITM SendChar (*ptr++) ;
}

return len;

}

3. Locate the core cmx.h file, which contains the function ITM SendChar (). The core cmx.h file is included
by the Device Peripheral Access Layer header file (for instance stm32f4xx.h, which in turn must be included
in the syscalls.c file).

#include "stm32f4xx.h"

Use the Include Browser view to find the Device Peripheral Access Layer header file. Drop the core file in the
Include Browser view, and check which files are including the core cmx.nh file.

4. Test by adding include stdio.h and call to printf () into the application. Make sure that printf () is not
called too often.

#include <stdio.h>

printf ("Hello World %d\n", posl);
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5. Start a debug session and enable [ITM port 0] in the SWV ITM Data Console view.

6. Open the SWV ITM Data Console view and start tracing using the red [Start/Stop Trace] button on the toolbar
in this view.

7. Start the program. Print commands are logged to the Port 0 tab in the view.

Figure 217. SWV ITM Data Console

3 O <

& SWV ITM Data Console # @ X[kl O

Port 0

Hello World
Hello World
Hello World
Hello World
Hello World
Hello World
Hello World
Hello World
Hello World
Hello World

i =+ <N s YRV B R VU S o

®

8. ltis possible to open new port x tabs (x from 1 to 31) by pressing the green [+] button on the toolbar. This
opens the Add Port dialog. In the dialog select the [ITM Port number] to be opened to display it as a tab in
the SWV ITM Data Consoleview.

Figure 218. SWV ITM port configuration

[LE Add Port

ITM Port number {0}:

oK | Cancel
Note: Study the ITM SendChar () function to learn how to write a function that transmits characters to another ITM
port channel.
3.2.3.6 SWYV Statistical Profiling

TheSWYV Statistical Profiling view displays statistics based on Program Counter (PC) sampling. It shows the
amount of execution time spent within various functions. This is useful when optimizing code. The data can be
copied and pasted into other applications. The view is updated when debugging is suspended.
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1. Configure SWV to send Program Counter samples, as shown in Figure 219. Enable [PC Sampling] and
[Timestamps].
With the given [Core Clock] cycle intervals, SWV reports the Program Counter values to STM32CubelDE. Set
the [PC Sampling] to a high [Cycle/sample] value to avoid interface overflow.

Figure 219. SWV PC sampling enable

mSeriaI Wire Viewer settings for NUCLEO-F401RE Debug (ST-LINK) X
Clock Settings Trace Events PC Sampling
Core Clock: 84 MHz []CPI: Cycles per instruction [[] EXC: Exception overhead Enable Resolution: 16384 ~ Cycles/sample
Clock Prescaler: 42 [] SLEEP: Sleep cycles [C]LSU: Load store unit cycles -
. ) ) tamps
; [_]FOLD: Folded instructions [ ] EXETRC: Trace Exceptions Imes
SWO Clock: 2000.0 kHz [ Enable Prescaler: 1 =
Data Trace
Comparator 0 Comparator 1 Comparator 2 Comparator 3
D Enable |:| Enable |:| Enable |:| Enable
Var/Addr: posl Var/Addr: pos2 Var/Addr: 0x0 Var/Addr: 0x0
Access: Write Access: Write Access: Read/Write Access: Read/Write
Size: Word Size: Word Size: Word Size: Word
Generate: Data Value + PC Generate: Data Value + PC Generate: Data Value Generate: Data Value
ITM Stimulus Ports
Enable port: 31 L ICIC I 24 23011 ICICIC e 1sCIICICICICIC s 7EICICICICIC I o

Privileged only ports: ] Port 31..24 [ ] Port 23..16 [ ] Port 15..8 []Port 7.0

Cancel

2. Open the SWV Statistical Profiling view by selecting [Window]>[Show View]>[SWV Statistical Profiling].
The view is empty since no data is collected yet.

3. Press the red [Start/Stop Trace] button to send the configuration to the board.

4. Resume program debugging. STM32CubelDE starts collecting statistics about function usage via SWV when
the code is executing in the target system.

5. Suspend (Pause) the debugging. The view displays the collected data. The longer the debugging session, the
more statistics are collected.
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Figure 220. SWV Statistical Profiling

1DE O X
F9 SWV Statistical Profiling KX~ O
Function % in use Samples Start addr... Size

main() 59.06% 48575 0x80005bd 0x100

readSpeed() 24.82% 20413 0x80004d5 Ox46

readTemp() 16.04% 13191 0x800051b Ox2e

HAL_IncTick() 0.07% 56 0x8000b1d 0x34

SysTick_Handler() 0.01% 8 0x80009e5 0Oxc

writeSpeed() 0.00% 1 0x8000549 0Ox46

Overflow packets: 0 PC Samples: 82244

Note: A double-click on a function line in the SWV Statistical Profiling view opens the file containing the function in the

editor.
The column information in the SWV Statistical Profiling is described in Table 15.

Table 15. SWV Statistical Profiling columns details

e | e

The name of the function which is calculated by comparing address information in SWV packets with the

Function program e1f£ file symbol information.
% in use The calculated percentage of time the function is used.
Samples The number of samples received from the function.

Start address ' The start address for the function.

Size The size of the function.

3.24 Change the SWV trace buffer size

The incoming SWV packets are saved in the Serial Wire Viewer trace buffer, which has a default maximum size of
2 000 000 packets. To trace more packets, this figure must be increased.
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Select the [Windows]>[Preferences] menu. In the Preferences dialog, select [STM32Cube]>[Serial Wire
Viewer]. Update [Trace buffer size] if needed.

Figure 221. SWV Preferences

[l Preferences O X

type filter text ~ Serial Wire Viewer e
> General
C/C++
Help
Install/Update
Remote Development
Remote Systems
Run/Debug
v STM32Cube
Build
Device Configuration Tool
File Association
Firmware Updater
Serial Wire Viewer

Serial Wire Viewer
Trace buffer size: ‘ 2000000

vV VvV VvV V v Vv

Target Status
> Team
Terminal
Restore Defaults Apply
@ Dy | Apply and Close ] Cancel

The buffer is stored in the heap. The allocated heap is displayed by first selecting the [Windows]>[Preferences]
menu. In the Preferences dialog, select [General]. Enable [Show heap status] to display the current heap and
allocated memory in the bottom right corner of STM32CubelDE. There is an upper limit to the amount of memory
STM32CubelDE can allocate. This limit can be increased to store more information during a debug session.

To update the memory limit, proceed as follows:

1. Navigate to the STM32CubelDE installation directory. Open the folder in which the IDE is stored.

2. Edit the stm32cubeide.ini file and change the —Xmx1024m parameter to the desired size in megabytes.
3. Save the file and restart STM32CubelDE.

3.2.5 Common SWV problems
The following issues can occur when attempting to debut with SWV tracing:
. SWV is not enabled in the debug configuration currently used.

. The SWV Trace is not started, the red Start/Stop Trace button on the toolbar in some SWV view needs to
be pressed to enable SWV and send SWV configuration to the target board. Then start the program to
receive SWV data. For some SWV views the program then needs to be stopped again to visualize received
SWV information.

. The SWO receives an excess of data. Reduce the amount of data enabled for tracing.
. The JTAG probe, the GDB server, the target board, or possibly some other part, does not support SWV.
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. The target [Core Clock] is incorrectly set. It is very important to select the right [Core Clock].
If the frequency of the target [Core Clock] is unknown, it can sometimes be found by setting a breakpoint
in a program loop and open the Expressions view, when the breakpoint is hit.
Click on [Add new expression], type SystemCoreClock and press [Enter]. This is a global variable that,
according to the CMSIS standard, must be set by the software to the correct speed of the [Core Clock].
In CMSIS standard libraries, a function called SystemCoreClockUpdate () can be included in main () to
set the SystemCoreClock variable. Use the Variable view to track it.

Note: If the software dynamically changes the CPU clock speed during runtime, this might cause SWV to stop as the
clocking suddenly becomes wrong during execution.
To make sure that all data is received, apply the following steps:

1. Open the SWV configuration. Disable all tracing except [PC Sampling] and [Timestamps]. Set the
[Resolution] to the highest possible value.

2. Save, and open the SWV Trace Log view.
Start tracing.
4. Make sure that incoming packets can all be seen in the SWV Trace Log view.

w

3.3 Special Function Registers (SFRs)

3.3.1 Introduction to SFRs

Special Function Registers (SFRs) can be viewed, accessed and edited via the SFRs view. The view displays the
information for the current project. Its content changes if another project is selected. To open the view from the
menu, select the [Window]>[Show View]>[SFRs] menu command or use the [Quick Access] field, search for
“SFR”, and select it from the views.

Figure 222. Open the SFRs view using the [Quick Access] field

SFR| -
Views = SFRs (Debug)
Commands @ Show In (SFRs)
@ Show View (SFRs) - Shows a particular view
Help 4 Search 'SFR' in Help
3.3.2 Using the SFRs view

The SFRs view contains information about peripherals, registers and bit fields for the STM32 device used in the
project. When debugging the project, the registers and bit fields are populated with the values read from the
target. The view contains two main nodes, the Cortex®-M node and the STM32 node. The Cortex®-M node

includes common Cortex®-M core information and the STM32 node includes the STM32 device specific
peripherals.
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Figure 223. SFRs view
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The top of the SFRs view contains a search field to filter visible nodes, such as peripherals, registers, bit fields.
Upon text entry in the search field, only the nodes containing this text are displayed.

The information at the bottom of the SFRs view displays detailed information about the selected line. For registers
and bit fields, this includes [Access permission] and [Read action] information.

The [Access permission] contains the following details:

[RO](read-only)
[WO](write-only)
[RW](read-write)
[W1](writeOnce)
[RW1](read-writeOnce)

The Read action contains information only if there is a read action when reading the register or bit field:

[clear]

[set]

[modify]
[modifyExternal]
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The toolbar buttons are located at the top-right corner of the SFRs view.

Figure 224. SFRs view toolbar buttons

RD‘ Xig Xio X2 | ¢

L]

¥
:35

The [RD] button in the toolbar is used to force a read of the selected register. It causes a read of the register even
if the register, or some of the bit fields in the register, contains a ReadAction attribute set in the svb file.

When the register is read by pressing the [RD] button, all the other registers visible in the view are read again also
to reflect all register updates.

The program must be stopped to read registers.
The base format buttons ([X16], [X10], [X2]) are used to change the registers display base.
The [Configure SVD settings] button opens the CMSIS-SVD Settings Properties Panel for the current project.

The [Pin] button ("don’t follow" selection) can be used to keep focus on the current displayed svb file even if the
Project Explorer view is switched to another project.

Favorite lists

During a debug session, the user is interested usually only in certain information about peripherals, registers, or
bit fields related to a specific problem. Favorite lists help the user to organize registers into different tabs to better
focus on a particular problem area.

To add a set of peripherals, registers, or bit fields to a favorite list, follow these steps:
1. Select a project.
2. Right-click on a node in the SFRs view and select [Add as favorite...].

Figure 225. Debug - Addition of a node SFRs view as favorite

File Edit Source Refactor Navigate Search Project Run Window Help

OvEQ®v&~v@in/vomx SR AP Y EvYE Y HEYOYR Y @Y @ " vHEYEDOvD v e Q @B
@ Project Explorer x B%Y ¢ 70 Bmaincx = B =SkRs x 5 Outline © Build Targets RO |[ml% % |k @t =0
; ; 4/ —
B Led Jumper in STM32CubelDE) 48=  /* STM32G4xx HAL library initialization: A Allregisters|
> # Binaries a9 Configure the Flash prefetch, Flash preread and Buffer cach |[type filter text |
> @ Includes s0 - Systick timer is configured by default as source of time ba Reqi Add val N
> @& Debug 51 can eventually implement his proper time base source (a gister ress | Value
s & Doc 52 timer for example or other time source), keeping in min > HERNG
. > 53 duration should be kept ims since PPP_TIMEOUT_VALUEs ar > AES
& Drivers s4 handled in milliseconds basis. « & GPIOA
> & Example 55 - Low Level Initialization . W MODER 0x48000.
2 Led_Jumper.cfg 56 */
& Led_JumperJaunch 57 HAL_Init(); TYPER | 0x48000..
e 58 PEEDR  0x48000...
& STM32G431KBTX_FLASHId 59 /* Configure the'System clock to have a frequency of 178 MHz */ PDR 0x48000...
Zi SystemClock_Config(); . mIDR 0x48000...
62 /* Initialize the LED present on the Nucleo 32 Board */ e
63 BSP_LED_Init(LED2); > eS| as favorite...
64 > Toggle live update
65 /* Configure PA.12 pin as input with Pull-up */ 5 i AFRL 0x48000...
: PA12_Config(); > RH 0x48000...
68 /* Infinite loop */ > R 0x48000... .
69  while(1)
;i {/ If the state of PA.12 is low, then the j bet, PA.12 00000 OOCO0aG s
° * e state o .12 is low, then the jumper between PA.12 p P
72 pin 5) and GND (CN4 pin 4) is in place, else it is removed. * ;':edgd'“e'" 00[22000014 2
73 if (HAL_GPIO_ReadPin(GPIOA, GPIO_PIN_12) == GPIO_PIN_RESET) fess: x
72 F Value: null
75 BSP_LED_Toggle(LED2); Size: 32
76 /* Wait for 5eems */ Reset value: 0x0
77 HAL Delav(500): V| Reset mask: OXFFFFFFFF
< > Access RW v

21 Problems I Tasks & Console X [ Properties B%|» 8 =0

No consoles to display at this time.

@8~ ¥ =08 GgidAnalyzer = Static Stack Analyzer # Debug X
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3. Use the dialog that opens to add the selected node to an existing favorite list or create a new list.

Figure 226. Debug - SFRs view favorite list creation pop-up

m Add as favorite X

Create new or select an existing list

List name: | Favorite1 ~

@ oK | | Cancel

4. The new tab Favorite1 contains only the selected node added to the view.

Figure 227. Debug - Favorite SFRs view

® SFRs % *-Variabl.. ® Break.. %fExpres.. #¥Regist.. % LiveE.. U

RD‘ Ye Fo %2 | 3¢ = [ g
All registers |Favorite1

‘ type filter text

Register Address  Value
v @ STM32G431xx
v i GPIOA
> ODR 0x48000... Oxabffffff

3.3.2.2 Live update

When debugging a project in the standard way, the program must be stopped to read the registers. With
STM32CubelDE, it is also possible to use the live update debug with the SFRs view collecting register values
periodically, even when the target is running.
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To use the live update debug, first enable the live channel before starting the debugging session.

Figure 228. Debug - Live channel checkbox

m Edit Configuration O X
Edit launch configuration properties 'ﬁ\.
Name:| CRC_Example ‘
Main % Debuggerl B Startup |4 Source| E Common
Maximum SWO dock (kHz): | auto detect Port  |cortex m0 v ~
Port number: 61235
Port number. | 60000
External loaders
Loader Enabled Initialize Add...
Remove
Misc
Verify flash download
I Enable live expressionsl
[ ] Log to file: C\Users\dachraoa\STM32CubelDF\workspace_1.11.0NCRC_Fxam | Browse...
("] Shared ST-LINK
[ ] Max halt timeout(s): 2
v
| Revert | | Apply |
@ | oK | ‘ Cancel |
Then, right-click on the desired register node in the SFRs view and select [Toggle live update].
Figure 229. Debug - Live update
® SFRs X ®-Variabl... ® Break.. % Expres... i Regist... % Live E... 0
RD | % %0 % | 5 of B, €

All registers | Favorite1 *

type filter text

Register Address  Value
v © STM32G431xx
v 5 GPIOA
>t QDR e s sseny

Add as favorite...

Remove

Toggle live update
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3.3.2.3 Exporting registers

During an active debugging session, all registers and their corresponding values can be exported to a text file.
This allows the user to have a snapshot of all registers, or of the desired registers selected in the favorite list,
when the program is stopped at a defined point.

With this feature, the user can easily compare the values of registers between different execution points of the
application. This is done using the diff utilities available for comparing previously exported files.

To export registers, perform the following steps in the halted debug session:

1. Select the tab relevant for export.
Exporting the entire device register map from the All registers tab might be time consuming. It is more
convenient to use the favorites lists as the basis for export.

2. Select [Export view data to file] from the SFRs view toolbar.

Figure 230. Debug — Export view data to file

B SFRs X -Variab.. ° Break.. %fExpres.. ‘Regist.. % LiveE.. O

RD | % %o % | 3¢ of B, §

. o1
All registers | Favorite1 ! Export view data to file I

‘ type filter text |

Register Address  Value
v © STM32G431xx
v i GPIOA
> i ODR 0x48000... Oxabffffff

A View export dialog opens, where it is possible to define the destination of the export file.
Note that the exported file is placed by default in the sFr_export directory of the associated project as a . txt
file. The file basename is incremented each time.

3. - Select [Open generated file with associated editor]>[OK].

Figure 231. Debug — Export destination file

m View Export X

Export view data to file

File: | bl o 'I,n.'-nc:-llc:..pﬂ-:x:_1.1 1AL TR Doty IRVERCubae )l 30\SFR_export\1674463055.txt HBrowse___|

(] Open generated file with associated application

@ | oK | | Cancel

To compare the register values between two different execution points:
1. Select the two files in the Project Explorer view.
2. Select [Compare With]>[Each Other] from the context menu.
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3.33 Updating CMSIS-SVD settings
The SFRs view for a project can display two CMSIS-SVD (System View Description) files for this project:
. The default file selected by STM32CubelDE is the SVD file for the selected device in the project

. The other file can be a custom SVD file made to visualize specific user hardware configuration
To update the settings, use the [Configure SVD settings] toolbar button in the SFRs view to open the CMSIS-
SVD Settings properties.
Figure 232. SFRs CMSIS-SVD Settings
EProperties for NUCLEO-F401RE O X

\ CMSIS-SVD Settings

>
Resource CMSIS SVD (System View Description) Data Files

> C/C++ Build
> C/C++ General Device file  platform:/plugin/com.st.stm32cube.ide.mcu.productdb.debug/resources/cmsis/STMicroelectronics_CMSIS_SVD/STM32F401.svd Browse...
CMSIS-SVD Settings X
. Custom file Browse...
Project References
Run/Debug Settings
Restore Defaults Apply
@ Apply and Close Cancel

All SVD files must comply with the syntax outlined in the CMSIS-SVD specification available on Arm® website. If
these requirements are not met, the SFRs view is likely not to show any register information.

The [Device file] field is used for the System View Description (SVD) file. This file must describe the whole
device. Other views may fetch information from the SVD file pointed out by this field, therefore it is recommended
to use this field only for SVD files containing full STM32 device description. Updated SVD files can be obtained
from STMicroelectronics (refer to the HW Model, CAD Libraries and SVD columns in the device description
section on the STMicroelectronics website at www.st.com.

The [Custom file] field can be used to define special function registers related to custom hardware, in order to
simplify the viewing of different register states. Another possible use case is to create an SFR favourites’ file,
containing a subset of the content in the [Device file]. This subset may be for instance composed of frequently
checked registers. If a [Custom file] is pointed out, a new top-node in the SFRs view is created, which contains
the [Custom file] related register information.

Both fields may be changed by the user and both fields may be used at the same time.

Note: . It is possible to write new values in the value columns of registers and bit fields when these have write
access permission.
. It is possible to use the SFRs view while the target is running when using the ST-LINK GDB server.

However the [Live expression] option in the debug configuration must be enabled in this case.
. It is not possible to use SFRs view while the target is running when using OpenOCD or SEGGER J-Link.

. The SFRs view can also be useful in the C/C++ Editing perspective, however then only the names and
addresses of the registers are displayed.

3.4 RTOS-aware debugging

Real-time operating systems (RTOS) add different kinds of objects to the design such as threads, semaphores,
and timers. STM32CubelDE includes dedicated set of views to handle Microsoft® Azure® RTOS ThreadX and
FreeRTOS™ kernel objects.

These views visualize the status of the RTOS objects when stepping through the code or when the program hits a
breakpoint during a debug session.

Note: FreeRTOS is a trademark of Amazon in the United States and/or other countries.
All other trademarks are the property of their respective owners.

3.4.1 Azure® RTOS ThreadX
The following views are available for ThreadX:
. ThreadX Thread List
. ThreadX Semaphores
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. ThreadX Mutexes

. ThreadX Message Queues

. ThreadX Event Flags

. ThreadX Timers

. ThreadX Memory Block Pools
. ThreadX Memory Byte Pools

3.4.1.1 Finding the views

In the Debugger perspective, the ThreadX-related views are opened from the menu. Select the menu command
[Window]>[Show View]>[ThreadX]>[...] or use [Quick Access] and search for “ThreadX” and select it from the

views.
Figure 233. ThreadX views selectable from the menu
Window Help
Mew Window 0 "‘Ii végg? 4;"*v§ ..é ] v & v B0 o ow O v| Ej-| 0
cator > Q i®| BED
Appearance  time_gete 51 = O =V i ®%B fE R = 0
Show View > &2 ThreadX > &8 ThreadX Thread List
Perspective > & FreeRTOS > &2 ThreadX Semaphores
Navigation , B swv * &8 ThreadX Mutexes
B Breakpoints Alt+Shift+0, B &%  ThreadX Message Queues
| Preferences miy  Build Analyzer &2  ThreadX Event Flags
E Console Alt+Shift+C, C .ﬁ ThreadX Timers
: %3 Debug &2  ThreadX Memory Block Pools
_timer_system_clock Gl Debugger Console &%  ThreadX Memory Byte Pools

3.4.1.2 ThreadX Thread List view

The ThreadX Thread List view displays detailed information regarding all available threads in the target system.
The thread list is updated automatically each time the target execution is suspended.

There is one column for each type of thread parameter, and one row for each thread. If the value of any
parameter for a thread has changed since the last time the debugger was suspended, the corresponding row is
highlighted in yellow.

Figure 234. ThreadX Thread List view (default)

O o =
al¥ Thread Theesd List 11 ==p
Mamse Prcaity  State Rz Counl Stack Star Stack End Stack Side Stack Pte Stack Vrage

Main Thiead 3 SUEPENDED (MySemaphore 1) 1 D2 d001634 201432 512 28001 e Disabled
Systemn Timer Thread a SUBPENDED 1] D200 18 D200 1T 14 2 8000dce Disabled
Thread Oine 1 SUSPENDED (Wyhite_1) 1 2400183c 24001431 512 Ow2E001Edd Dusabled

=+ Theead Two 10 RUNNING 1 240071284 Ol 4007243 512 Ou2800bFe Dusabled
e
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Due to performance reasons, the Stack Usage column is disabled by default. To enable the stack analysis, use
the [Toggle Stack Checking] toolbar button (circled in pink in Figure 235) in the ThreadX Thread List view
toolbar.

Figure 235. ThreadX Thread List view (Stack Usage enabled)

= X
0® ThreadX Thread List §2 8
e

Name Priority  State Run Count Stack Start Stack End Stack Size Stack Ptr Stack Usage

Main Thread 5 SUSPENDED (Event Flag) 2 (24001524 0x240017a3 512 (24001614 512
System Timer Thread 0 SUSPENDED 505 (24000984 (x24000d83 1024 (x24000c4c 1024
Thread One 1o READY 381 24001 7ac 0x240019ab. 512 (24001824 512
=+ Thread Two 8 RUNNING 126 (24001904 x24001bb3 512 0x24001b0c 512

Idle

The column information in the ThreadX Thread List view is described in Table 16.

Table 16. ThreadX Thread List details

e

N/A A green arrow symbol indicates the currently running thread.
Name The name assigned to the thread.

Priority The thread priority.

State The current state of the thread.

Run Count The threads run counter.

Stack Start The start address of the stack area.

Stack End The end address of the stack area.

Stack Size The size of the stack area (bytes).

Stack Ptr The address of the stack pointer.

The maximum thread stack (bytes).

Stack Usage By default, ThreadX fills every byte of thread stacks with a OxEF data pattern during thread
creation. See the note below for more information.

Note: If the Stack Usage column contains the same values as the Stack Size column for all threads, the reason could
be that the thread stack has not been filled with the 0xEF data pattern during task creation. This happens if the
ThreadX kernel is built with stack data pattern filling disabled. Normally, a <tx _user.h> file is used, which
contains a TX DISABLE STACK FILLING define. Comment this define as shown in the example below and
rebuild the project to solve the problem. It is good to know that the <tx user.h> file also contains a
TX ENABLE STACK CHECKING define, which can be enabled to get run-time stack checking if stack corruption
is detected. Additional information can be found in the ThreadX user guide.
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Example of tx_user.n file from ThreadX header file with commented TX ENABLE STACK CHECKING define:

/* Determine is stack filling is enabled. By default, ThreadX stack filling is enabled,
which places an OxEF pattern in each byte of each thread's stack. This is used by
debuggers with ThreadX-aw:areness and by the ThreadX run-time stack checking feature. */

/* #define TX DISABLE STACK FILLING */

/* Determine whether or not stack checking is enabled. By default, ThreadX stack checking is
disabled. When the following is defined, ThreadX thread stack checking is enabled. If sta

ck
checking is enabled (TX ENABLE STACK CHECKING is defined), the TX DISABLE STACK FILLING

define is negated, thereby forcing the stack fill which is necessary for the stack checkin
logic. */

/*#define TX ENABLE STACK CHECKING*/

3.4.1.3 ThreadX Semaphores view
The ThreadX Semaphores view displays detailed information regarding all available resource semaphores in the
target system. The view is updated automatically each time the target execution is suspended.

There is one column for each type of semaphore parameter, and one row for each semaphore. If the value of any
parameter for a particular semaphore has changed since the last time the debugger was suspended, the
corresponding row is highlighted in yellow.

Figure 236. ThreadX Semaphores view

10| o X

1f® ThreadX Semaphores 3 = 08
Mame Count Suspended

MySemaphore_1 0 Main Thread

MySemaphore_2 5

MySemaphore 3 a

Table 17. ThreadX Semaphores details

I

Name The name assigned to the semaphore.

Count The current semaphore count.

Suspended The threads currently suspended because of the semaphore state.
3.4.1.4 ThreadX Mutexes view

The ThreadX Mutexes view displays detailed information regarding all available mutexes in the target system.
The view is updated automatically each time the target execution is suspended.
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There is one column for each type of mutex parameter, and one row for each mutex. If the value of any parameter
for a particular mutex has changed since the last time the debugger was suspended, the corresponding row is
highlighted in yellow.

Figure 237. ThreadX Mutexes view

10€ | ] X
of® ThreadX Mutexes 3 = g
Mame Owner Owner Count Suspended

MyMutex_1 Main Thread 1 Thread One Thread Two

MyMutex_2 0

MyMutex_3 0

Table 18. ThreadX Mutexes details

I

Name The name assigned to the mutex.
Owner The thread that currently owns the mutex.
Owner Count The mutex owner count (number of get operations performed by the owner thread).
Suspended The threads currently suspended because of the mutex state.
3.4.1.5 ThreadX Message Queues view

The ThreadX Message Queues view displays detailed information regarding all available message queues in the
target system. The view is updated automatically each time the target execution is suspended.

There is one column for each type of message queue parameter, and one row for each message queue. If the
value of any parameter for a particular message queue has changed since the last time the debugger was
suspended, the corresponding row is highlighted in yellow.

Figure 238. ThreadX Message Queues view

10¢] O %
0 ThreadX Message Queues 532 = B8
Name Address Capacity Used Free Message size Suspended

Message Queue One (24000208 10 0 10 1

Message Queue Two (2400003 10 0 10 1

Table 19. ThreadX Message Queues details

I

Name The name assigned to the message queue.

Address The address of the message queue.

Capacity The maximum number of entries allowed in the queue.

Used The current number of used entries in the queue.

Free The current number of free entries in the queue.

Message size The size (in 32-bit words) of each message entry.

Suspended The threads currently suspended because of the message queue state.
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3.4.1.6 ThreadX Event Flags view
The ThreadX Event Flags view displays detailed information regarding all available event flag groups in the target
system. The view is updated automatically each time the target execution is suspended.
There is one column for each type of parameter, and one row for each event flag group. If the value of any
parameter for a particular event flag group has changed since the last time the debugger was suspended, the
corresponding row is highlighted in yellow.

Figure 239. ThreadX Event Flags view

10 o X

1f® ThreadX Event Flags 532 = A
Marme Flags Suspended

Event Flagl 0 Main Thread

Event Flag2 0

Table 20. ThreadX Event Flags details

I

Name The name assigned to the event flag group.

Flags The current value of the event flag group.

Suspended The threads currently suspended because of the event flag group.
3.4.1.7 ThreadX Timers view

The ThreadX Timers view displays detailed information regarding all available software timers in the target
system. The timers view is updated automatically each time the target execution is suspended.

There is one column for each type of timer parameter, and one row for each timer. If the value of any parameter
for a particular timer has changed since the last time the debugger was suspended, the corresponding row is
highlighted in yellow.

Figure 240. ThreadX Timers view

10¢] a *
of® ThreadX Timers 53 = O
Mame Remaining Re-init Functicn

{ MyTimer_1 B 100 CxB30005d1 <MyTimerFunctionl>
MyTimer_2 72 200 0xB0005f3 <MyTimerFunction2»
MyTimer_3 276 500 (xB000615 < MyTimerFunction3=

Table 21. ThreadX Timers details

I

Name The name assigned to the timer.

Remaining The remaining number of ticks before the timer expires.

Re-init The timer re-initialization value (ticks) after expiration. It contains value O for one-shot timers.
Function The address and name of the function that is called when the timer expires.
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3.4.1.8 ThreadX Memory Block Pools view

The ThreadX Memory Block Pools view displays detailed information regarding all available memory block pools
in the target system. The view is updated automatically each time the target execution is suspended.

There is one column for each type of parameter, and one row for each memory block pool. If the value of any
parameter for a particular memory block pool has changed since the last time the debugger was suspended, the
corresponding row is highlighted in yellow.

Figure 241. ThreadX Memory Block Pools view

10€ | O X
158 ThreadX Memaory Block Pools 1 = g
Mame Address Used Free Total Block size  Pool size Suspended

MyBlockPool_1 (240005ec <P.. 0 3 3 28 100

MyBlockPool_2 0x240004ac <P.. 0 4 4 40 200

MyBlockPool_3 x2400034c <P.. 0 5 5 52 300

Table 22. ThreadX Memory Block Pools details

I

Name The name assigned to the memory block pool.

Address The starting address of the memory block pool.

Used The current number of allocated blocks.

Free The current number of free blocks.

Total The total number of memory block pools available.

Block size The size (bytes) of each block.

Pool size The total pool size (bytes).

Suspended The threads currently suspended because of the memory block pool state.
3.4.1.9 ThreadX Memory Byte Pools view

The ThreadX Memory Byte Pools view displays detailed information regarding all available memory byte pools in
the target system. The view is updated automatically each time the target execution is suspended.

There is one column for each type of parameter, and one row for each memory byte pool. If the value of any
parameter for a particular memory byte pool has changed since the last time the debugger was suspended, the
corresponding row is highlighted in yellow.

Figure 242. ThreadX Memory Byte Pools view

10€] O

&8 ThreadX Memory Byte Pools 53 = =
MNarmne Address Used Free Size Fragments Suspended

Byte Pool On24000f24 " 2140021" 1664 6528 8192 i

Table 23. ThreadX Memory Byte Pools details

e i

Name The name assigned to the memory byte pool.
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I

Address The starting address of the memory byte pool.

Used The current number of allocated bytes.

Free The current number of free bytes.

Size The number of fragments.

Fragments The size (bytes) of each block.

Suspended The threads currently suspended because of the memory byte pool state.

3.4.1.10 Azure® RTOS TraceX tool
Important:  The Microsoft® Azure® RTOS TraceX tool (TraceX) only exists for Windows®.
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To open TraceX automatically upon data export, select the [Windows]>[Preferences] menu to associate the file
type . trx with TraceX through the Preferences window as shown in Figure 243.

Figure 243. File associations

[E Preferences m] x
type filter text File Associations = A A |
e See ‘Content Types' for content-type based file associations.
¥ Appearance
Compare/Patch Open unassodated files with: System Editor; if none: Test Editor ~
Content Types File typees:
w Edi:}r:u '.'-‘_d!s Add..
ek m " dtsi
File Associations @*him Bemove
» Text Editors @* hirni
Globalization QO ioc
'::ﬂs w*ldd
Link Handlers i
¥ Metwork Connections .'5
Perspectives B
Project Matures
Quick Search
Search
» Security
» Startup and Shutdown
Ul Freeze Monitoring
» User Storage Service
Wb Browser
* Workspace
¥ CfCh+
% Help
¥ InstallUpdate
> Remote Development
» Run/Debug
» S§TM32Cube
SWTChart Extensions
Terminal
» Wersion Control (Tearn)
Assodated editors:
“TraceX (default) | Add...
Remowve
Default
Dimes Apply and Close Cancel
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The Azure® RTOS ThreadX kernel can generate various system events into the MCU RAM buffer. These events
can later be analyzed “off target” by the TraceX application. This requires an export of the RAM buffer to a
suitable file format. Trace data can be exported using the [Export trace] button available from the menu of any

Azure® RTOS ThreadX view as shown in Figure 244 and Figure 245.

Figure 244. RAM buffer export (1 of 2)

& Console [ Problems © Executables & Debugger Console 0 Memory i ThreadX Thread List & Siic o
Name Pri.. State Run Count Stack Start Stack End  Stack Size Stack Ptr  Stack Usa...
sine wave 8 SLEEP (1) 124 0x24002... 0x24002.. 1024 0x24002.. Disabled
System Timer T... 0 SUSPENDED 123 0x24013... 0x24013.. 1024 0x24013... Disabled
thread 0 1 SLEEP (10) 13 0x24000... 0x24000.. 1024 0x24000... Disabled
thread 1 16  READY 1874 0x24000... 0x24000.. 1024 0x24000.. Disabled

= thread 2 16 RUNNING 1876 0x24000... 0x24000.. 1024 0x24000.. Disabled
thread 3 8 SUSPENDED (semaph... 62 0x24000... 0x24001.. 1024 0x24000f.. Disabled
thread 4 8 SLEEP (2) 62 0x24001... 0x24001... 1024 0x24001... Disabled
thread 5 4 SUSPENDED (event fl.. 13 0x24001... 0x24001.. 1024 0x24001... Disabled
thread 6 8 SUSPENDED (mutex 0) 62 0x24001... 0x24001.. 1024 0x24001... Disabled
thread 7 8 SLEEP (2) 62 0x24001... 0x24002.. 1024 0x24001f... Disabled
Idle

Figure 245. RAM buffer export (2 of 2)

2 Console £ Problems @ Executables & Debugger Console 0 Memory i ThreadX Thread list & _'E 8= "’
Name Pri... State Run Count Stack Start Stack @ ThreadX Semaphores Show view... &
[ sine wave '8 SLEEP(1) 124 0x24002... Ox24l : Tisacts Mutsoes Export trace
System TimerT.. 0  SUSPENDED 123 BoI013,, |0l e Mlessane CNighes d
@ ThreadX Event Flags
thread 0 1 SLEEP (10) 13 0x24000... Ox241 @ ThreadX Timers d
thread 1 16  READY 1874 0x24000... Ox24t @ ThreadX Memory Block Pools d
= thread 2 16 RUNNING 1876 0<24000.. Ox24( g ThreadX Memory Byte Pools d
thread 3 ] SUSPENDED (semaph... 62 0x24000... Ox24007 1024 Ox24000T. Disabled
thread 4 8 SLEEP (2) 62 0x24001... 0x24001.. 1024 0x24001... Disabled
thread 5 4 SUSPENDED (event fl... 13 0x24001... 0x24001.. 1024 0x24001.. Disabled
thread 6 8 SUSPENDED (mutex 0) 62 0x24001... 0x24001.. 1024 0x24001... Disabled
thread 7 8 SLEEP (2) 62 0x24001... 0x24002.. 1024 0x24001f... Disabled

There are four prerequisites to export traces:
. The Azure® RTOS ThreadX kernel must be built with trace enabled
- The embedded STM32CubeMX editor provides GUI support to enable the trace events
. The function tx_trace enable () must be called before any data can be exported
. The trace export operation must not be performed inside the kernel API to avoid data file corruption
. The RAM buffer can only be read when the target is halted
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On run

When exporting, the export destination is prepopulated from the active debug context available at: spaTH TO PRO
JECT/TraceX/$LAUNCH CONFIGNAME.trx. If previous trace data already exists, the user is prompted whether to
overwrite them as shown in Figure 246.

Figure 246. Existing trace overwrite
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On export

When exporting the data to TraceX, STM32CubelDE reads the RAM buffer from the target. The corresponding
data is then used to create a *. trx file, which can later be opened with the TraceX tool. By default, a Tracex
directory is created in the project, containing the . trx file.

Figure 247. TraceX analysis
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Remember: - The export function only works once TraceX is initialized (tx_trace enable ()). The tool exports the
last N trace events.
. There is a risk of exported trace data corruption if the export is performed inside the kernel API. To avoid

such a corruption, make sure that the export is performed when the target is at a suitable location. For
instance, set a breakpoint outside the kernel API or configure the trace full callback.

3.4.2 FreeRTOS™
The following views are available for FreeRTOS™:
. FreeRTOS Task List
. FreeRTOS Timers
. FreeRTOS Semaphores
. FreeRTOS Queues

3.4.21 Requirements

To be able to populate the FreeRTOS ™-related views with detailed information about the RTOS status, some files
in the FreeRTOS™ kernel must be configured. The following sections describes some required configurations.
Consult the FreeRTOS reference manual for detailed information.

34211 Enable trace information

The define configUSE TRACE FACILITY in freeRTOSConfig.h must be enabled (set to 1). It results in
additional structure members and functions to be included in the build and enables for instance stack checking in
the FreeRTOS Task List view and lists the semaphore types in the FreeRTOS Semaphores view.

Example:

freeRTOSConfig.h
#define configUSE_TRACE_FACILITY 1

3.4.21.2 Add to registry
The application software must call the vQueueAddToRegistry () function to make the FreeRTOS Queues and

FreeRTOS Semaphores views able to display objects. The function adds an object to the FreeRTOS™ Queue
registry and takes two parameters, the first is the handle of the queue, and the second is a description of the

queue, which is presented in FreeRTOS™-related views.

Example:

vQueueAddToRegistry (mailId, "osMailQueue");
vQueueAddToRegistry (osQueueHandle, "osQueue");
vQueueAddToRegistry (osSemaphoreHandle, "osSemaphore");
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3.4.21.3

UM2609 - Rev 16

RTOS profiling information

To get valid RTOS run time statistics, the application must set up a run time statistics time base. The time-base
clock is recommended to run at least 10 times faster than the frequency of the clock used to handle the RTOS tick

interrupt. To enable the FreeRTOS™ collection of run time statistics, file freeRTOSConfig.h must include:

1. Define configGENERATE RUN TIME STATS 1

2. Define portCONFIGURE TIMER FOR RUN TIME STATS () to call the function that configures a timer to be
used for profiling

3. Define portGET RUN TIME COUNTER VALUE () to call the function that reads the current value from the
profiling timer

Example:

freeRTOSConfig.h

#define configGENERATE RUN TIME STATS 1

#define portCONFIGURE TIMER FOR RUN TIME STATS() configureRunTime ()
#define portGET _RUN_ TIME COUNTER VALUE () getRunTimeCounter ()

Or, if a run time variable is available in the system:

freeRTOSConfig.h

#define configGENERATE RUN TIME STATS 1
#define portCONFIGURE TIMER FOR RUN TIME STATS() (RunTime=0UL)
#define portGET_RUN_TIME COUNTER VALUE () RunTime

If the Run Time column in the FreeRTOS Task List view displays N/A after making these three settings, the
problem can a arise if project is not built with optimization level -00. The reason is quite likely found in the
declaration in tasks.c of ulTutoralRunTime.

Example:

#if ( configGENERATE RUN TIME STATS == 1 )
PRIVILEGED DATA static uint32 t ulTaskSwitchedInTime = OUL;
/*< Holds the value of a timer/counter the last time a task was switched in. */
PRIVILEGED DATA static uint32 t ulTotalRunTime = OUL;
/*< Holds the total amount of execution time as defined by the run time counter clock. */
#endif

Solutions:

. Either declare the variable as volatile:

PRIVILEGED DATA volatile static uint32 t ulTotalRunTime = OUL;
/*< Holds the total amount of execution time as defined by the run time counter clock.
=/

. Or simply change the optimization level only for tasks.c by
1. Right-clicking it in Project Explorer view and open Properties
2. Select [Properties]>[C/C++ Build]>[Settings]>[Tool Settings]>[Optimization]
3. Set [Optimization Level] to None (-00)
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3.4.2.2 Finding the views

In the Debugger perspective, the FreeRTOS ™-related views are opened from the menu. Select the menu
command [Window]>[Show View]>[FreeRTOS]>[...] or use [Quick Access], search for “FreeRTOS” and select
from the views.

Figure 248. FreeRTOS "-related views selectable from the menu

Window | Help
NewWindow |5 i@ i@ iR E - Eror @
Editos 2 [€) cmsis_os.c | FreeRTOSConf... [g mainc 2 Py =5 m b |
Appearance b =
Show View > &2 FreeRTOS > & FreeRTOS Queues
Perspective > B swy > @2 FreeRTOS Task List
Navigation 3 95 Breakpoints Alt+Shift+@Q, B & FreeRTOS Semaphores
g Build Analyzer éﬂ' FreeRTOS Timers
Preferences Console Alt+Shift+Q, C ;
3.4.2.3 FreeRTOS Task List view

The FreeRTOS Task List view displays detailed information regarding all available tasks in the target system. The
task list is updated automatically each time the target execution is suspended.

There is one column for each type of task parameter, and one row for each task. If the value of any parameter for
a task has changed since the last time the debugger was suspended, the corresponding row is highlighted in
yellow, as shown in the example in Figure 249.

Figure 249. FreeRTOS Task List (default)
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Due to performance reasons, stack analysis (the Min Free Stack column) is disabled by default. To enable stack
analysis (refer to Figure 251), use the Toggle Stack Checking toolbar button in the FreeRTOS Task List view
toolbar as shown in Figure 250.

Figure 250. FreeRTOS™ Toggle Stack Checking
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Figure 251. FreeRTOS Task List (Min Free Stack enabled)
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The FreeRTOS Task List view in Figure 251 contains a Min Free Stack column. The column information is
changed to Stack Usage if the project is built with the following define set:

#define configRECORD STACK HIGH ADDRESS 1

In this case, the full stack usage is presented according to the format Used/Total(%Used) as shown in Figure 252.

Figure 252. FreeRTOS Task List with ConfigRECORD_STACK_HIGH_ADDRESS enabled

= O X
7% FreeRTOS Task List == 0
Name Priority (B... Start of S.. Top of St... State Event Object Stack Usage Run Time...
= IDLE 0/0 0x20000... 0x20000.. RUNNING 96B / 20528 (4.7%) N/A
THREAD1 24/24 0x20001.. 0x20001.. DELAYED 144B /5128 (28.1%) N/A
THREAD2 24/24 0%x20001... 0x20001.. DELAYED 1448 / 512B (28.1%) N/A
Tmr Sve 2/2 0%20000... 0x20000.. BLOCKED TmrQ 1688 / 1028B (16.3%) N/A

The column information in the FreeRTOS Task List view is described in Table 24.

Table 24. FreeRTOS Task List details

e

N/A A green arrow symbol indicates the task currently running.
Name The name assigned to the task.
The task base priority and actual priority. The base priority is the priority assigned to the task.
Priority (Base/Actual) The actual priority is a temporary priority assigned to the task due to the priority inheritance
mechanism.
Start of Stack The address of the stack region assigned to the task.
Top of Stack The address of the saved task stack pointer.
State The current state of the task.
Event Object The name of the resource that has caused the task to be blocked.
The stack “high watermark”. Displays the minimum number of bytes left on the stack for a
Min Free Stack(") task. A value of 0 (most likely) indicates that a stack overflow has occurred.
Note: This feature must be enabled in the “View” toolbar.

The run time statistics provide information on the percentage of time the task has been used.

1 0,
Run Time (%) This can be used for profiling the system during development.

1. When the application is built with configRECORD STACK HIGH ADDRESS = 1, the column name is changed to “Stack
Usage”. It displays the stack usage in detailed format as “Used/Total(%Used)”.

3.4.2.4 FreeRTOS Timers view

The FreeRTOS Timers view displays detailed information regarding all available software timers in the target
system. The view is updated automatically each time the target execution is suspended. There is one column for
each type of timer parameter, and one row for each timer. If the value of any parameter for a timer has changed
since the last time the debugger was suspended, the corresponding row is highlighted in yellow.

Figure 253. FreeRTOS Timers

19| (m| »

1® FreeRTOS Timers

MName Active  Period Type Id Callback
myTimerTEST True 200 Auto-Reload Ox0 OxBO00429 <osTimarCallback >
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The column information in the FreeRTOS Timers view is described in Table 25.

Table 25. FreeRTOS Timers details

I

Name The name assigned to the timer.
Active The active status information.
Period The time (in ticks) between timer start and the execution of the callback function.
Type 'I_'he type o_f timer. Auto-reload timers are automatically reactivated after expiration. One-shot
timers expire only once.
Id The timer identifier.
Callback The address and name of the callback function executed when the timer expires.
Note: 1. If no name appears in the Name field, check that the timer is created with a name. The first parameter when

calling xTimerCreate () must contain the timer name string.

2. When using software timers, a Tmr Svc task and a TmrQ queue are created automatically. These objects
are displayed in the FreeRTOS Task List view and FreeRTOS Queues view.

3.4.25 FreeRTOS Semaphores view
The FreeRTOS Semaphores view displays detailed information regarding all available synchronization objects in
the target system, including:

. Mutexes

. Counting semaphores
. Binary semaphores

. Recursive semaphores

The view is updated automatically each time the target execution is suspended. There is one column for each
type of semaphore parameter, and one row for each semaphore. If the value of any parameter for a semaphore
has changed since the last time the debugger was suspended, the corresponding row is highlighted in yellow.

Figure 254. FreeRTOS Semaphores

104 O 5
i FreeFTOS Semaphores 12 = 8
Name Address Type Size Free # Blocked tasks
osSemaphore (20000058 BIMNARY_SEMAPHORE 1 0 0
Note: If the Type information displays N/A, make sure that the define configUSE TRACE FACILITY is enabled in

file FreeRTOSconfig. h.
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The column information in the FreeRTOS Semaphores view is described in Table 26.

Table 26. FreeRTOS Semaphores details

I

Name The name assigned to the semaphore.

Address The address of the object.

Type The type of the object.

Size The maximum number of owning tasks.

Free The number of free slots currently available.

#Blocked tasks The number of tasks currently blocked waiting for the object.
3.4.2.6 FreeRTOS Queues view

The FreeRTOS Queues view displays detailed information regarding all available queues in the target system.
The view is updated automatically each time the target execution is suspended. There is one column for each
type of queue parameter, and one row for each queue. If the value of any parameter for a queue has changed
since the last time the debugger was suspended, the corresponding row is highlighted in yellow.

Figure 255. FreeRTOS Queues

@ o x
18 FreeRTOS Queves 33 = B0
Mame Address Max Length tem Size Curmrent Length & Wasting Te # Waiting Rx
oslueue O200000ES 1 2 0 0 1

The column information in the FreeRTOS Queues view is described in Table 27.

Table 27. FreeRTOS Queues details

I

Name The name assigned to the queue in the queue registry.

Address The address of the queue.

Max Length The maximum number of items that the queue can hold.

ltem Size The size in bytes of each queue item.

Current Length The number of items currently in the queue.

#Waiting Tx The number of tasks currently blocked waiting to be sent to the queue.

#Waiting Rx The number of tasks currently blocked waiting to be received from the queue.
343 RTOS-kernel-aware debug

The RTOS-kernel-aware debug in STM32CubelDE supports the Microsoft® Azure® RTOS ThreadX and
FreeRTOS™ operating systems using an RTOS proxy. The RTOS proxy is included in STM32CubelDE and can
be used with ST-LINK GDB server, OpenOCD, and SEGGER J-Link GDB server.

When RTOS-kernel-aware debugging is enabled and a debug session is started, all threads are listed in the
Debug view. By selecting a thread in the Debug view, the thread current context is visualized in views. For
instance, the Variables, Registers, Editor views reflect the active stack frame.
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Figure 256 shows a debug session. The ThreadX Thread List view displays that the Message Queue Receiver
Thread is RUNNING. This can also be seen in the Debug view. In the Debug view the

MsgSenderThreadTwo Entr
sleep for 500 ms state.

Fi

y function is selected, and the editor area displays that the thread is waiting in a

gure 256. RTOS-kernel-aware debug

I workspace_um8 - Tx_Thread_MsgQueue/Application/User/app_threadx.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help
Ovl@leievitvOoOvQvin|RpiaNzaRPSLidios
% Debug & Project Explorer 8%|» i =0
v [0 7x_Thread_MsgQueue [STM32 Cortex-M C/C++ Application]
~ 1 T Thread_MsgQueue.elf
v & Thread #2 [Message Queue Sender Thread One] 603979944 (Suspended : Container)
= _get ipst_value() at b porth:368 0x8003e86
thread_system_return_inline() at tx_porth:447 0x8003¢86
t_thread_system_suspend( at tx_thread_system_suspend.c:549 0x8003¢86
thread_sleep() at tx_thread_sleep.c:189 0x8003a70
MsgSenderThreadOne_Entry() at app_threadx.c:189 0x80007cc
tx_thread_shell_entry() at tx_thread_shell_entry.c:114 0x8003938

Oxffffffe
~ o Thread #3 [Message Queue Receiver Thread] 603980120 (RUNNING) (Suspended : Signal : SIGINT

txe_queue_receive() at tre_queue_receive.c102 0x80043de
MsgReceiverThread_Entry() at app_threadx.c:229 0x8000826
tx_thread_shell_entry() at tx_thread_shell_entry.c:114 0x8003938
xfffffife
~ o Thread #4 [Message Queue Sender Thread Two) 603980296 (Suspended : Container)
= _get ipsr_value() at t_porth:368 0x8003e86
= _t thread_system_return_inline() at tx_porth:447 0x8003e86
thread_system_suspend( at t_thread_system_suspend.c:549 0x8003e86
tx_thread_sleep( at t_thread_sleep.c:189 0x8003a70
MsgSenderThreadTwo_Entry() at app_threadx.c211 0x8000802
tx_thread_shell_entry() at tx_thread_shell_entry.c:114 0x8003938
= Oxfffffffe
v & Thread #5 [System Timer Thread] 603980976 (Suspended : Container)
_get_ipsr_value() at tx_porth:368 0x8003¢86
thread_system_return_inline() at t_porth:447 0x8003e86
thread_system_suspend( at tx_thread_system_suspend.c:549 0x8003e86
tx_timer_thread_entry() at tx_timer_thread_entry.c462 0x8004adc
thread_shell_entry() at tx_thread_shell_entry.c:114 0x8003938
Oxfffffffe
+4 arm-none-eabi-gdb (8.3.1.20191211)
»8 ST-LINK (ST-LINK GDB server)
4 RTOS Proxy

- O X
CIevo v e Qs @
(@ app_threadx.c & [ tx thread sy.. D txthreads.. [Etxqueuere. [Eitxthreads.. [ txe queuer.. = B erVar.® %Br. %Ex. BMo.. Re. @ Liv.. ®SF. -0
195  * @param thread_input: Not used ~ wElri g
196  * @retval None Name Type Value
197 */ ) .
198-void MsgSenderThreadTwo_Entry(ULONG thread_input) o thread input ULONG 0
199 { - Msg ULONG 1
200 ULONG Msg = TOGGLE_LED;
201 (void) thread_input;
202 /* Infinite loop */
203 while(1)
204 {
205 /* Send message to MsgQueueTwo. */
206 if (tx_queue_send(&MsgQueueTwo, &Msg, TX_WAIT_FOREVER) != TX_SUCCESS)
207
208 Error_Handler();
209 3}
210 /* Sleep for 500s */
211 tx_thread_sleep(500);
212}
213 }
214
2158 /**
216  * @brief Function implementing the MsgReceiverThread thread.
217 thread_input: Not used
218 1 None
219
220-void MsgReceiverThread_Entry(ULONG thread_input)
221
222 ULONG RMsg
223 UINT status = © ;
224 (void) thread_input;
225 /* Infinite loop */
226 while (1) < >
227
228 /* Determine whether a message MsgQueueOne or MsgQueueTwo is available */
229 status = tx_queue_receive(&MsgQueueOne, &RMsg, TX_NO_WAIT);
230 if (statu TX_SUCCESS)
231
232 /* Check Message value */
233 if (RMsg != TOGGLE_LED)
234
235 Error_Handler();
236 ¥
237 else
238
239 BSP_LED_Toggle(LED_GREEN); .
Sha N
B Console [ Problems @ Executables & Debugger Console 0 Memory i ThreadX Thread List 2 ==
Name Pri.. State Run Count ~ Stack Start Stack End Stack Size Stack Ptr Stack Usage
= Message Queue Receiver Thread 10 RUNNING 875 0x2400139¢ 0x2400159b 512 0x240014fc Disabled
Message Queue Sender Thread One 5 SLEEP (200) 74 0x24000f8¢ 0x2400118b 512 0x2400105¢ Disabled
Message Queue Sender Thread Two 5 SLEEP (404) 30 0x24001194 0x24001393 512 0x24001264 Disabled
System Timer Thread 0 SUSPENDED 874 0x24000570 0x2400096f 1024 0x2400083¢ Disabled
Idle
< >
L)

To enable RTOS-kernel-aware debugging the Debugger tab in the Debug Configurations dialog contains settings
to enable RTOS proxy, driver (RTOS ThreadX or FreeRTOS™), port (Cortex® core) and configuration of port

number to use with the proxy.

The RTOS tab also contains a Driver settings selection to select the Driver (“ThreadX” or “FreeRTOS”) and the
port used. The “Auto-detect” driver setting is still experimental.
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Figure 257. RTOS-kernel-awareness debug configuration

E Debug Configurations

Create, ge, and run fig

CEeEXBEY-~

Name: | NUCLEG-F401RE

| type filter text

[E] C/C++ Application
[E] C/T++ Attach to Application
[E] C/C++ Postmortem Debugger
[E] C/C++ Remote Application
[£] GDB Hardware Debugging
& Launch Group

v [ 5TM32 C/C++ Application

[ NMUCLEO-F401RE
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Filter matched 8 of & items

Main [ﬁ Debugger] > Startup| Es Sourca‘ = COI"I"II"I"IDH|

GDE Connection Settings
(@) Autostart local GDB server Host name or IP address  localhost

(C) Connect to remote GDE server  Port number 61234

Debug probe ‘ST—LINK (ST-LINK GDB server)

GDE Server Command Line Opticns

Show Cemmand Line

Interface

®5WD O JTAG
CIST-LINK 5/N ~ | | Sean

Frequency (kHz): | Auto v|

Access port: | 0 - Cortex-M4 v |

Reset behaviour

Device settings

Debug in low power modes: |[nab|e

Suspend watchdog counters while halted: | No cenfiguration

Serial Wire Viewer (SWV) RTOS Kernel Awareness
Enable

[ Lirnit SWO clock Driver: |'I'hlead)(

Maximum SWO clock (kHz): | auto detect Port: |corte1(,m€l

Port number: 61235

Misc
[vA Verify flash download
Enable live expressions

[ External Loader:

] Shared ST-LINK
[ Max halt timeout(s): | 2

[JLogto file: C\Usersbmsguea’ STM32CubelDE\workspace_umd\NUCLEO-FA01RE\Debug)st-link_gdbserver_|

Browse...

~ | | Scan

Initialize

Revert

Apply |

@

Debug

Close ‘

Figure 258. ThreadX-kernel-awareness debug configuration

RTOS Kernel Awareness
Enable RTOS Proxy
Driver settings

Driver: |Threa dx ~ |

Port: | cortex_m0 ~ |

Part number: | 60000
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The port selection lists the supported cores. The items listed depend on the selected RTOS driver as displayed in
Figure 259 and Figure 260.

Figure 259. ThreadX port configuration

RTOS Kernel Awareness
Enable RTOS Proxy
Driver settings

Driver: |ThreadX ~

Port:

Port nufcortex m3

Figure 260. FreeRTOS™ port configuration
RTOS Kernel Awareness
Enable RTOS Proxy

Driver settings

Driver: |FreeRTOS ™~

Port: |ARM_CMO

Port nufARM_CM3
ARM CM3 MPU

vace 1.7.0\Apm cM33 NTZ

Known limitations

. Live expressions must be disabled when used with the ST-LINK GDB server
. The Registers view content for swapped out threads is intermixed with active CPU context for some
registers (all registers are not saved by the context switcher)
. The Registers view floating point registers are not updated correctly
3.5 Fault Analyzer
3.5.1 Introduction to the Fault Analyzer

The STM32CubelDE Fault Analyzer feature interprets information extracted from the Cortex®-M nested vector
interrupt controller (NVIC) in order to identify the reasons that caused a fault. This information is visualized in the
Fault Analyzer view. It helps to identify and resolve hard-to-find system faults that occur when the CPU is driven
into a fault condition by the application software.

Among such conditions are:

. Accessing invalid memory locations

. Accessing memory locations on misaligned boundaries
. Executing undefined instruction

. Division by zero
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Upon fault occurrence, the code line where the fault occurred is displayed in the debugger. The view displays the
reasons for the error condition. Faults are coarsely categorized into hard, bus, usage and memory faults.

. Hard and bus faults occur when an invalid access attempt is made across the bus, either of a peripheral
register or a memory location

. Usage faults are the result of illegal instructions or other program errors

. Memory faults include attempts of access to an illegal location or violations of rules maintained by the

memory protection unit (MPU)

To further assist fault analysis, an exception stack frame visualization option provides a snapshot of the MCU
register values at the time of the crash. Isolating the fault to an individual instruction allows to reconstruct the
MCU condition at the time the faulty instruction was executed.

In the Debugger perspective, the Fault Analyzer view is opened from the menu. Select the menu command
[Window]>[Show View]>[Fault Analyzer] or use the [Quick Access] field, search for “Fault Analyzer” and select
it from the views.

Figure 261. Open the Fault Analyzer view

Eworkspace#um1 - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

Mo siS s %@ ea.ei  NewWindow v 4B vilvinor o vre@
Edit o =g
4 Debug ¥ & Project Explorer rer 5 Emainc 2 B startup_stm3.. o,
Appearance > . lmsis TR
v [ENUCLEO-F401RE Debug (ST-LINK) | . S =
, ) Show View > B Swv >
v i NUCLEO-F401RE.elf [cores: 0] . = : .
: | Perspective > % Breakpoints Alt+Shift+Q, B
v #®Thread #1 [main] 1 [core: 0] ( - :
= HardFault Handl Navigation , a Build Analyzer
_ ardrau handlerlatsiy B Console Alt+Shift+Q, C
= <signal handler called>() Preferences 4 Debug
fwrit[eSpeed()_at main.c:147 0x800055c¢ ® Debugger Console
= main() at main.c:232 0x8000684 = Disassembly

= Reset_Handler() at startup_stm32f401retx.s:113 Ox: Error Log Alt+Shift+Q, L
»l C:/ST/STM32CubelDE_1.1.0/STM32CubelDE/plugins/con
»w: ST-LINK (ST-LINK GDB server)

O Executables

& Expressions

® Fault Analyzer
& Live Expressions
0 Memory

3.5.2 Using the Fault Analyzer view

The Fault Analyzer view has five main sections, which can be expanded and collapsed. The sections contain
different kinds of information for better understanding the reason that caused a particular fault to occur. The
sections are:

. Hard Fault Details

. Bus Fault Details

. Usage Fault Details

. Memory Management Fault Details

. Register Content During Fault Exception

Figure 262 shows an example of the Fault Analyzer view when an error is detected. In this example, the error is
caused by a project making a divide by zero with the debugger stopped in the HardFault Handler ().

Opening the Fault Analyzer view when this happens displays the reason of the error. In the example, it displays
[Usage Fault Detected] and [Attempt to perform a division by zero (DIVBYZERO)].
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Figure 262. Fault Analyzer view

i0e| o X

@ Fault Analyzer

! Hard Fault Detected
Hard Fault Details

@ Bus, memory management or usage fault (FORCED)

& r= | wertor fete W

& Dabug event (DERLIGEY

Bus Fault Details

255 register (BRAR): | DxeD00e:

] Ao + + T + - sl s w0

@ Attempt to perform a division by zero [DIVBYZERQ)

Memaory Management Fault Details

= X
& Float 11 tlazy state preserwstion erme il

ster (IMMEAR) | DxeD00e:
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. The Editor view is opened from the Project Explorer view on the fault location return address by using the
information in the PC and LR registers in the stack and the symbol information in the debugged e1 file.
. Clicking on the [Instruction stepping mode] toolbar opens the Disassembly view on the fault location

return address by using the information in the PC and LR registers in the stack and the symbol information
in the debugged e1t file.

Figure 263 and Figure 264 show the Editor and Disassembly views opened using the toolbar buttons to find the
fault location in the example.

Figure 263. Fault analyzer open editor on fault

(@ main.c ©* 8 startup_stm3..  ld system_stm3... w STM32F401RET...
142

43=int writeSpeed(int pos)

46 // update speed
47
48 return speed;

49

50 }

Figure 264. Fault analyzer open disassembly on fault

= Variables ® Breakpoints ® Modules =' Disassembly ' !} Registers ®#SFRs 4 Live Expressions

Fnter lacation her || & fy ol s
08000855c: | sdiv r2, rl, r2

08000560 ldr rl, [pc, #28] ; (0x8000580 <writeSpeed+56>)
08000562 : 1ldr Fl; (K35 L)
08000564 : str r2, [rl, #0]
148 return speed;
Note: The fault analyzer can be used on all STM32 projects. It requires no special code and no special build
configuration. All data are collected for the Cortex®-M registers. The symbol information is read from the
debugged e1r file.
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4 Code verification

411

Cyclomatic complexity

Introduction to the cyclomatic complexity view

The STM32CubelDE cyclomatic complexity is a calculation of the built program complexity. It analyzes in detail

the .cyclo files, generated by gcc, and the .e1f file. It presents the resulting information in the view.

The view contains a list of all the functions included in the selected program. It provides the options to [Hide dead
code] functions and [Filter]the visible functions. Use the [Hide dead code] selection to enable or disable the
listing of dead code functions. If it is used, the [Filter] field restricts the display to the functions matching the filter
key.
The view is populated with the complexity of each function included in the program, each line consisting of the

Function, Location, and Complexity columns.

Note:

UM2609 - Rev 16

Function
Location

Complexity

Figure 265. Cyclomatic complexity view

@ Cyclomatic Complexity X

STM32F4xx-Nucleo.elf - /STM32F4xx-Nucleo/Debug - Feb 16, 2023, 11:27:24 AM

Hide dead code

[ search by function name

Function

® HAL_RCC_OscConfig

@ HAL_RCC_ClockConfig

@ HAL_RCCEx_PeriphCLKConfig
® HAL_GPIO_Init

© HAL_RTC SetTime

© HAL_RTC_SetDate

© main

© RTC_EnterlnitMode

© HAL_RTC_Init

© HAL_RCC_GetSysClockFreq
© HAL InitTick

© HAL Delay

© HAL_NVIC_SetPriority

© HAL_RTC_WaitForSynchro
© RTC_ExitinitMode

© HAL_RTC_Mspinit

© HAL_SYSTICK Config

© HAL_GPIO_WritePin

© RTC_ByteToBcd2

© HAL_RTC_GetTime

© HAL_RTC_GetDate

© BSP_LED_Init

© BSP_LED_Toggle

© Systeminit

© HAL Msplnit

© HAL Init

© HAL IncTick

© HAL GetTick

© HAL_NVIC_SetPriorityGrouping
© HAL_GPIO_TogglePin

© HAL_RTC_Mspinit

© RTC_Bcd2ToByte

© HAL_RTCEX BKUPWrite
© HAL_RTCEx_BKUPRead

Location

stm32f4xx_hal rec.c219
stm32f4x_hal_rec.c591
Stm32f40_hal_rcc_ex.c2513
stm32f4x«_hal_gpio.c:164
Stm32f4x_hal_tc.c686
Stm32f40_hal_rtc.c845
maincs4

stm32f4x_hal rtc.c:1799
Stm32f4hal_rtc.c249
stm32f4x_hal rec.c885
stm32f4xx_hal 253
stm32f4xx_hal ¢:389
stm32f4x_hal_cortexc:163
stm32f4x_hal rtc.c1662
stm32f4xx hal_rtc.c:1834
stm32f4x_hal_msp.c:S3
stm32f4x«_hal_cortex.c:227
stm32f4x(_hal_gpio.c410
stm32f4x_hal rtc.c:1860
Stm32f4x¢_hal_rtc.c:800
Stm32f40 hal_rtc.c934
Stm32f40¢ nucleo 171
Stm32f4x¢ nucleo.c235
system_stm32f4uxc132
stm32f4xx_hal 219
stm32f4x_hal. 157
stm32f4x_hal c312
stm32f4xx_hal.c:323
stm32f4x_hal_cortex.c:141
stm32f4xx_hal_gpio.c433
Stm32f4x¢ hal_rtc.c629
stm32f4x_hal rtc.c:1878
Stm32f4xx_hal_rtc_ex.c:1245
stm32f40_hal_rtc_ex.c:1268

Complexity

Table 28. Cyclomatic Complexity details

I T

Function name.

Indicates where the function is declared. It is possible to double-click on a line and open the file with
the defined function in the editor.

The number displays the complexity score of the function.

The sorting order can be changed by clicking on a column name.

Double-click on a line that displays the file location and the line number in the table to open the function in the

“Editor” view.

The small icon left of the function name in the column Function indicates the following:
. Green dot: the function has a score below the default complexity ceiling.
. Red dot: the function has a score that exceeds the default complexity ceiling.
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To change the default complexity ceiling, go under [Window]>[Preferences], select the Build Views settings
option of STM32Cube in the left pane, and fill the field [Complexity Ceiling].

Figure 266. Cyclomatic complexity - Default complexity ceiling preference

m Preferences O X

i
4
iy
4

| type filter text Build Views settings

> General

> C/C++

> Help

> Install/Update

> Remote Development

> Run/Debug
v STM32Cube Cyclomatic Complexity View
ICompIexity Ceiling: | 10 I

Build Views Options
Build Views Refresh Mode

O Auto

®on request

Build Views settings
Default GDB Server
Device Configuration Tool

End User Agreements
File Association
Firmware Updater
MPU Serial
Serial Wire Viewer
Target Status
Toolchain Manager
Terminal
> Version Control (Team)

| Restore Defaults ‘ | Apply ‘

@ a4 | Apply and Close | | Cancel |

DT72012V2

41.2 Using the cyclomatic complexity view

By default, the view Cyclomatic Complexity is found open in the C/C++ perspective. If the view is closed, it can be
opened from the menu by selecting [Window]>[Show View]>[Cyclomatic complexity].
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Figure 267. Cyclomatic complexity - Open the view

Window Help
New Window B Tig~flvtoD vy~ B
| Editor ? ﬁ (P Cyclomatic Complexity * ]
Appearance > | || sSTM32F4xx-Nucleo.elf - /STM32F4xx-}
Show View *  |oe  Build Analyzer
Perspective ¥ Build Targets
L B8 C/C++ Projects
Navigation ’ B Console Alt+Shift+Q, C
Preferences Cyclomatic Complexity
‘s Include Browser
o= Cutline Alt+Shift+Q, O
(2! Problems Alt+Shift+Q, X
{5 Project Explorer
[ Properties
< Search Alt+Shift+Q, S
&% SFRs
= Static Stack Analyzer
¥ Tasks
Other... Alt+5hift+Q, Q

Another way to open the Cyclomatic Complexity view is to type “cyclomatic complexity” in the [Quick Access]
search bar and select the view among the list of proposed views.

Figure 268. Cyclomatic complexity - Open the view (alternate)

Q @@

1 complexi v H

Views @ Cyclomatic Complexity (C/C++)
_ Commands @ preferences (STM32Cube > Cyclomatic Complexity) - Open the preferences dialog
1 @ Show In (Cyclomatic Complexity)

® Show View (Cyclomatic Complexity) - Shows a particular view
Preferences ® Cyclomatic Complexity - STM32Cube
Help %" Search ‘complex’ in Help

The Cyclomatic Complexity view is populated when a built project is selected in the Project Explorer. The project
must be built with the option [-fcyclomatic-complexity] enabled, otherwise the view cannot present any
information.

The next section Enable cyclomatic complexity information explains how to set up the compiler to generate
cyclomatic complexity information.

UM2609 - Rev 16 page 233/258



UM2609

Code verification

41.3 Enable cyclomatic complexity information
If the top of the view displays the message “No Cyclomatic Complexity information found, please enable in the
compiler settings”, the build configuration must be updated for the compiler to generate the cyclomatic complexity
information:
1. Open the project properties, for instance with a right-click on the project in the Project Explorer view
2. Select [Properties] and, in the dialog, select [C/C++ Build]>[Settings]
3. Select the Tool Settings tab
4. Select [MCU GCC Compiler]>[Miscellanous]
5. Select [Enable Cyclomatic Complexity (-fcyclomatic-complexity)] as shown in Figure 269
6. Save the setting and rebuild the program
Figure 269. Cyclomatic complexity - Generate information per function
[I] Properties for STM32F4xcNucleo ] s i
[ type filter text Settings R
> Resource
~ C/C++ Build N
Build Variables Configuration: Debug [ Active ] VHManage(‘ i i |
Environment
I;;tg“grl‘gf ® Tool Settings # Build Steps Build Artifact Binary Parsers @ Error Parsers
Tool Chain Editor # MCU Toolchain Other flags 8085 &
> C/C++ General 2 MCU Settings
Project Natures (& MCU Post build outputs
Project References ~  MCU GCC Assembler
Run/Debug Settings 8 General
(2 Debugging
(2 Preprocessor
(2 Include paths
2 Miscellaneous
~ &8 MCU GCC Compiler
(& General
(2 Debugging
(2 Preprocessor
(2 Include paths
(2 Optimization
(2 Warnings
(# Miscellaneous
~ & MCU GCC Linker
(2 General
(B Libraries
2 Miscellaneous
[ verbose (-v)
[ position Independent Code (-fPIC)
Enable stack usage analysis (-fstack-usage)
Cyclomatic Complexity (-feyclomatic-complexity) 1
‘ Restore Defaults ‘ | Apply ‘ ;
® |Apply and Closel | Cancel ‘ 1
41.4 Using the filter field

UM2609 - Rev 16

The view proposes a field to search functions by their names. It selects all the function names matching the
characters entered in the field.
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Figure 270. Cyclomatic complexity - Function search field

@ Cyclomatic Complexity x |

STM32F4xx-Nucleo.elf - /STM32F4xx-Nucleo/Debug - Feb 16, 2023, 11:27:24 AM

=0
Hide dead code
[Rrec
Function Location Complexity
® HAL_RCC_OscConfig stm32f4x_hal_rcc.c219 60

® HAL_RCC_ClockConfig
® HAL_RCCEx_PeriphCLKConfig
© HAL_RCC_GetSysClockFreq

stm32f4x_hal_rec.c:591 19

stm32f4xx_hal_rcc_ex.ci2513 16

stm32f4x_hal_rcc.c:885 4
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5 Tools update
5.1 Installing updates and additional Eclipse® plugins
51.1 Check for updates

STM32CubelDE checks for available updates regularly and opens the Available Updates dialog when a new
update is detected. It is also possible to check for updates manually. Use menu [Help]>[Check for Updates] to
check if new software is available.

When updates are found, select the update to install and press [Next].

Figure 271. STM32CubelDE available updates

[ Available Updates O X
Available Updates K((>
A\

Check the updates that you wish to install. @
Name Version Id

@:STM32CubeIDE 1.02 com.st.stm32cube.ide.mcu.rep.product

Select All ‘ ‘ Deselect All
Details
@ [ oo
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Update details is displayed. Review and confirm the update. Press Next.

Figure 272. STM32CubelDE update details

[F Available Updates O X
Update Details /<L>
Review and confirm the updates. k@

Name Version Id &
v @: STM32CubelDE 1.0.2 com.st.stm32cube.ide.mcu.rcp.prod...

@: STM32CubelDE ARM Toolchain Definition 1.0.2.201907121423 com.st.stm32cube.ide.feature.mcu.t...

@: STM32CubelDE Build 1.0.2.201907091052 com.st.stm32cube.ide.feature.mcu....

@: STM32CubelDE Build Analyzer 1.0.2.201907120816 com.st.stm32cube.ide.feature.mcu....

> @:STMBZCubeIDE Build UI 1.0.2.201907092029 com.st.stm32cube.ide.feature.mcu....

@: STM32CubelDE C/C++ Debugging Tools for MCU 1.0.2.201907120816 com.st.stm32cube.ide.feature.mcu....

@: STM32CubelDE C/C++ Embedded Development Tools for MCU  1.0.2.201907121423 com.st.stm32cube.ide.feature.mcu.i...

@: STM32CubelDE Common Mx Services 1.0.2.201907091052 com.st.stm32cube.ide.feature.com...

@: STM32CubelDE Common Services 1.0.2.201907091052 com.st.stm32cube.ide.feature.com...

@: STM32CubelDE Common Ul 1.0.2.201907120816 com.st.stm32cube.ide.feature.com...

@: STM32CubelDE Common Utilities 1.0.2.201907091052 com.st.stm32cube.common.feature.... v

i

Size: Unknown

Details

@ ‘ < Back ” Next > | Finish

Review Licenses details are displayed. Review the licenses, select [| accept the terms of the license
agreements] and press [Finish] to install the update.

Figure 273. STM32CubelDE update review licenses

[ Available Updates O X
Review Licenses /<L>
A
Licenses must be reviewed before the software can be installed. This includes licenses for software required to complete the install. @
Licenses: License text:
v Eclipse Foundation Software User Agreement ~ || STMicroelectronics Software License Agreement A
Marketplace Client 1.7.7.v20190521-1752
v STMicroelectronics Software License Agreement SLAQ048 Rev4/March 2018

STM32CubelDE 1.0.2

STM32CubelDE ARM Toolchain Definition 1.0.2.201907121423
STM32CubelDE Build 1.0.2.201907091052

STM32CubelDE Build Analyzer 1.0.2.201907120816
STM32CubelDE Build Ul 1.0.2.201907092029

BY INSTALLING COPYING, DOWNLOADING, ACCESSING OR
OTHERWISE USING THIS SOFTWARE PACKAGE OR ANY PART
THEREOF (AND THE RELATED DOCUMENTATION) FROM
STMICROELECTRONICS INTERNATIONAL N.V, SWISS BRANCH
AND/OR ITS AFFILIATED COMPANIES (STMICROELECTRONICS), THE

STM32CubelDE C/C++ Debugging Tools for MCU 1.0.2.201907120816 RECIPIENT, ON BEHALF OF HIMSELF OR HERSELF, OR ON BEHALF
STM32CubelDE C/C++ Embedded Development Tools for MCU 1.0.2.2019071 OF ANY ENTITY BY WHICH SUCH RECIPIENT IS EMPLOYED AND/OR
STM32CubelDE Common Mx Services 1.0.2.201907091052 ENGAGED AGREES TO BE BOUND BY THIS SOFTWARE PACKAGE
STM32CubelDE Common Services 1.0.2.201907091052 LICENSE AGREEMENT.

STM32CubelDE Common Ul 1.0.2.201907120816
STM32CubelDE Common Utilities 1.0.2.201907091052
STM32CubelDE Core Toolchain Helper 1.0.2.201907091052

< > Ol do not accept the terms of the license agreements

@1 accept the terms of the license agreements

@ Next > Finish | ‘ Cancel
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The progress bar displayed at the bottom of the STM32CubelDE window shows the installation completion rate.
Restart STM32CubelDE when the update is finished.

5.1.2 Install from the Eclipse® market place

It is possible to install additional third-party Eclipse® plugins in STM32CubelDE using the Eclipse Marketplace. To
install from Eclipse Marketplace, select menu [Help]>[Eclipse Marketplace...].

Figure 274. Eclipse Marketplace menu

Eworkspace_um‘l - NUCLEO-F401RE/Core/Src/main.c - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

7% v /. B Information Center T4
- . @ Help Contents
‘& Projec P Seal:ch re?cmtl
Show Contextual Help figur
- —= = Clock
Show Active Keybindings... Ctrl+Shift+L | -opec
v ENU ¥\ Tips and Tricks...
y 2 Cheat Sheets... R COC
Y @ Eclipse User Storage ‘Open the Eclipse Marketplace wizard|
3 “% Check for Updates R COC
) @ Install New Software... o
@ Eclipse Marketplace... tiali
" I Data Refresh 0_Ini
Check for Updates
Manage embedded software packages RT2_L
ST-LINK Upgrade B Cor
R CoC

[ About STM32CubelDE
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The Eclipse Marketplace dialog opens. Search for the plugin or use the tabs (Recent, Popular, Favorites) to find
the software wanted and install it.

Figure 275. Eclipse marketplace

[ Eclipse Marketplace O X
Eclipse Marketplace @
Select solutions to install. Press Install Now to proceed with installation.
Press the "more info" link to learn more about a solution.
Search Recent Popular Favorites Installed . Giving loT an Edge _
. A
Darkest Dark Theme with DevStyle Cl 2019.9.16
Darkest Dark is now DevStyle - a free plugin providing an enhanced set of experiences for
Eclipse. Included:  Darkest Dark theme - #1 in the Marketplace: True... more info
by Genuitec, LLC, Commercial - Free
dark theme Darkest Dark Genuitec
#3048 # Installs: 987K (41,486 last month) Install
Spring Tools 4 - for Spring Boot (aka Spring Tool Suite 4)
4.4.1.RELEASE
‘ Spring Tools 4 is the next generation of Spring Boot tooling for your favorite coding v
Marketplaces
- 4
= 9
@ < Back Install Now > Finish Cancel

Wait until the installation is finished and restart STM32CubelDE.

5.1.3 Install using [Install new software...]
Another way to install new software is to use menu [Help]>[Install New Software...].

Note: When installing a new toolchain, it is recommended to use the Toolchain Manager described in
Section 2.3.1: Toolchain Manager.
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Figure 276. Install new software menu

Eworkspace_um‘l - NUCLEO-F401RE/Core/Src/main.c - STM32Cube

File Edit Source Refactor Navigate Search Project Run Window Help

= v . B Information Center
R Projec @ Help Contents L
%' Search F
> Emy Show Contextual Help F
v FEENU 1
> 2 Show Active Keybindings... Ctrl+Shift+L
> @l #s Tips and Tricks...
v @@ Cheat Sheets... E
, @ Eclipse User Storage > |
+ ‘@ Check for Updates :
4 Install New Software... |
& Eclipse Marketplace... ]
Data Refresh ]
Check for Updates |
Manage embedded software packages L
ST-LINK Upgrade
[Z About STM32CubelDE

The Install dialog opens. Enter the plugin update site URL. If the URL is not known, use [--All Available Sites--].

Figure 277. Install new software

[ Install ] X

Available Software l |

Select a site or enter the location of a site.

Work with:” v Add... Manage...
- type or select a site
type filter t__a|| Available Sites-- % Select All
Name http://download.eclipse.org/mpc/releases/1.7.7 Deselect All
@ Th http://download.eclipse.org/usssdk/updates/release/latest
http://sw-center.st.com/stm32cubeide/updatesite1
https://download.eclipse.org/releases/2019-09
http://www.genuitec.com/updates/devstyle/ci/

Details
Show only the latest versions of available software Hide items that are already installed
Group items by category What is already installed?

[[] Show only software applicable to target environment

Contact all update sites during install to find required software

®@ < Back Next > Finish Cancel
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If no direct Internet connection is available, the plugin can be downloaded into an archive on a computer with an
Internet connection, and then manually transferred to the computer with an STM32CubelDE installation. Add the
archived file by clicking on the [Add...] button and then select [Archive and select the downloaded file].

Figure 278. Install new software from computer

[[ Add Repository X
Name: ‘ ‘ ‘ Local... |
Location: ‘ http:// ‘ Archive...

@ Add Cancel

Select the appropriate plugins and install the software. Restart STM32CubelDE when installation is finished.
Remember:  Not all Eclipse® plugins are compatible with STM32CubelDE.

5.1.4 Uninstalling installed additional Eclipse® plugins
To uninstall a plugin that is no longer needed, select menu [Help]>[About STM32CubelDE].

Figure 279. About STM32CubelDE

[I About STM32CubelDE ] e
Gy  STM32CubelDE

Version: 1.4.0.20rc1

STM32 i' Build: 7141_20200610_1836 (UTC)

CubelDE (C) 2019 STMicroelectronics ALL RIGHTS RESERVED

S el E I Sl=

(7) Installation Details
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Press the [Installation Details] button to open the STM32CubelDE Installation Details dialog.

Figure 280. Installation details

[I STM32CubelDE Installation Details O X

Installed Software Installation History Features Plug-ins Configuration

type filter text

Name Version Id Provider

> -DevStyle (includes Darkest Dark Theme) 1.11.0.201909171704 com.genuitec.eclipse.theming.feature feature.gr... Genuitec, LLC

> §-STM32CubelDE 1.1.0 com.st.stm32cube.ide.mcu.rcp.product

< >

DevsStyle provides themes & more to enhance Eclipse’s style, including
the #1 Darkest Dark theme.

@ Update... Uninstall... Properties

Select the plugin to uninstall in the Installed Software tab and press [Uninstall...]. Restart STM32CubelDE when
the uninstallation is finished.

Update to new CDT™

When a new version of STM32CubelDE is installed based on a new version of Eclipse®, CDT™ or both, it is
recommended to create a new workspace instead of using a former workspace. The following warning is
displayed when trying to use an old workspace with a new STM32CubelDE.

Figure 281. Older workspace version warning

EOIder Workspace Version X
@ Workspace 'C:/Users/ /STM32CubelDE/workspace_um' was written with an older version of
the product and will be updated. Updating the workspace can make it incompatible with older

versions of the product.

Continue with this workspace?

|:| Do not warn again about workspace versions

Continue | |Change Workspace...‘ | Exit
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6 References

Table 29. STMicroelectronics reference documents

Reference Document short name Description Document source

[ST-01] DB3871 STM32CubelDE data brief
[ST-02] RNO114 STM32CubelDE release note
[ST-03] UM2553 STM32CubelDE quick start guide
[ST-04] UM2563 STM32CubelDE installation guide

. . . www.st.com
Migration guide from TrueSTUDIO to

[ST-05] UM2578 STM32CubelDE
Migration guide from the system workbench to
[ST-06] UM2579 STM32CubelDE
[ST-07] UM2576 STM32CubelDE ST-LINK GDB server
. . . Lo Refer to STM32CubelDE in
[ST-08] Getting started with projects based on the STM32MP1 Series in the “Tools” section of

()]
STM32CubelDE wiki.st.com/stm32mpu

Getting started with dual-core STM32H7

[ST-09] ANS36T MCUs in STM32CubelDE
Getting started with STM32H7Rx/7Sx MCUs in
[ST-10] ANG127 STM32CubelDE
Getting started with STM32L5 MCUs in
[ST-11] ANS394 STM32CubelDE
Getting started with STM32N6 MCUs in
[ST-12] ANG265 STM32CubelDE
Getting started with dual-core STM32WL
[ST-13] ANS564 MCUs in STM32CubelDE
Use STM32F3/STM32G4 CCM SRAM with www.st.com
IAR Embedded Workbench®, Keil® MDK-
[ST-14] AN4296 ARM, STMicroelectronics STM32CubelDE,
and other GNU-based toolchains
[ST-15] AN5952 How to use CMake in STM32CubelDE
License agreement applicable to
[ST-16] SLA0D48 STM32CubelDE
[ST-17] UM1718 STM32CubeMX for STM32 configuration and
initialization C code generation
[ST-18] UM2238 STM32 trusted package creation tool in the

STM32CubeProgrammer tool set

1. Legacy application note AN5360 remains available on www.st.com.
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https://www.st.com/resource/en/user_manual/dm00598966.pdf
https://www.st.com/resource/en/user_manual/dm00603964.pdf
https://www.st.com/resource/en/user_manual/dm00613834.pdf
https://www.st.com/resource/en/user_manual/dm00613836.pdf
https://www.st.com/resource/en/user_manual/dm00613038.pdf
https://wiki.st.com/stm32mpu
https://www.st.com/resource/en/application_note/dm00629855.pdf
https://www.st.com
https://www.st.com/resource/en/application_note/dm01081534.pdf
https://www.st.com/resource/en/application_note/dm00652038.pdf
https://www.st.com/resource/en/application_note/dm01157905.pdf
https://www.st.com/resource/en/application_note/dm00736854.pdf
https://www.st.com/resource/en/application_note/dm00083249.pdf
https://www.st.com/resource/en/application_note/dm00965631.pdf
https://www.st.com/sla0048
https://www.st.com/resource/en/user_manual/dm00104712.pdf
https://www.st.com/resource/en/user_manual/dm00403513.pdf
https://www.st.com/resource/en/application_note/dm00629854.pdf
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Table 30. External reference documents

Reference Description Document source

[EXT-01] GNU Assembler

[EXT-02] GNU Compiler Collection

[EXT-03] GNU C Library

[EXT-04] GNU C Preprocessor

[EXT-05] GNU Linker

[EXT-06] GNU Binary Utilities GNU tool suite!"
[EXT-07] Red Hat Newlib C Library

[EXT-08] Red Hat Newlib C Math Library

[EXT-09] Newlib nano readme

[EXT-10] Debugging with GDB

[EXT-11] GDB Quick Reference Card

[EXT-12] GNU Tools for STM32 Patch list Information Center

1. For GNU documentation principles, refer to www.gnu.org.
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Table 31. Document revision history

24-Jul-2020 1 Initial release.
Document updated for STM32CubelDE v1.5.0:
. Only one toolchain is installed by default
. The SFRs view displays the Arm® Cortex® core registers node
. Debug with OpenOCD supports SWV and live expressions
02-Nov-2020 2 . Added Preferences - Build variables

. Added Toolchain Manager

. Added RTOS-aware debugging with FreeRTOS™ information
. Added General debug and run launch flow

. Added Post-build with makefile targets

Document updated for STM32CubelDE v1.6.0:

. Added the Azure RTOS ThreadX section into the chapter RTOS-aware
debugging. Reorganized the FreeRTOS section

. Updated the Toolchain Manager section for the support of local
toolchains
18-Feb-2021 3 . Updated the Project C/C++ build settings section, MCU toolchain
selection moved
. Updated Information Center
. Updated the entire document for the “SWV packet” terminology
. Updated References

. Removed Section 4.3.3 SWV Exception Timeline Graph

Document updated for STM32CubelDE v1.7.0:

. Added Section 2.7 Thread-safe wizard for empty projects and CDT
projects

. Added Section 3.8 Import STM32 Cortex-M executable

. Added Section 6.3 RTOS-kernel-aware debug

. Updated Information Center — Home page
05-Jul-2021 4 . Updated Headless build description
. Updated Section 2.5.6 Linker script with new memory map layout figure
and additional description
. Updated Position-independent code description

. Updated debug configuration descriptions for ST-LINK GDB server,
OpenOCD, and SEGGER in Debug using different GDB servers

. Updated FreeRTOS Task List view

Document updated for STM32CubelDE v1.8.0:

. Added Section 1.3.3 Videos

17-Nov-2021 5 . Added Section 6.1.10 Azure RTOS TraceX tool
. Updated Section 2.2.2 Creating a new STM32 static library project
. Removed Section 1.3.3 Technical documentation and Section 1.3.4

Closing the Information Center

Document updated for STM32CubelDE v1.10.0:

. Updated Table 2. Key shortcut examples
. Added a note in Section 2.5.7.3 Place variables at specific addresses
13-Jun-2022 6 about the possible linker garbage collection of nonreferenced variables
. Updated figures about debug configurations and tabs: Figure 137,
Figure 143, Figure 145, Figure 146, Figure 147, Figure 148, Figure 156,
Figure 164, and Figure 223

Document updated for STM32CubelDE v1.11.0:

. Updated Section 2.2.2 Creating a new STM32 static library project with
21-Nov-2022 7 the Figure 52 featuring the new static lib project
. Updated the debug session name in Section 3.2 Debug configurations,
Section 3.3 Manage debug configurations, and Section 3.7 Run
configurations
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Document updated for STM32CubelDE v1.12.0:

. Added Favorite lists, Live update, and Exporting registers in Section 5.2
Using the SFRs view

15-Feb-2023 8 : .
. Added the Cyclomatic complexity chapter
. Updated Figure 4. Help menu, Figure 5. Help - Information Center
menu, and Section 1.3.3 Videos
Document updated for STM32CubelDE v1.13.0:
. Added Section 1.2.3 STM32CubelDE user authentication
. Updated Figure 6. Help menu, Figure 7. Help - Information Center
menu, and Figure 8. Information Center — Home page
. Updated the figures from Figure 204 to Figure 209 in the Section 5.2
Using the SFRs view
. Updated the figures from Figure 264 to Figure 269 in the Cyclomatic
complexity chapter
05-Jul-2023 9 . Updated Section 2.2.2 Creating a new STM32 static library project:
Added Section 2.2.3 Creating a new CDT™ project and Section 2.2.4
Creating a new CMake project
. Updated Figure 143. Debug configuration debugger tab, Figure 150.
ST-LINK GDB server debugger tab, and Figure 153. Debug
configurations
. Added Debug authentication in Section 3.2.3 Debugger tab
. Updated Section 3.6.1 Live Expressions view
. Updated Figure 241. Fault Analyzer view
Document updated for STM32CubelDE v1.14.0:
. Reorganized as detailed in Appendix A Document reorganization from
13-Nov-2023 10 revision 9 to revision 10
. Added the offline work description in Section 1.2.3 STM32CubelDE
user authentication
Document updated for STM32CubelDE v1.15.0:
07-Mar-2024 11 . Added Section 2.5: Build view setting

. Updated Figure 46, Figure 188, and Figure 267

Document updated for STM32CubelDE v1.16.0:

25-Jun-2024 12 . Updated Section 1.2.3: STM32CubelDE user authentication
. Updated Figure 2, Figure 10, and Figure 13

Document updated for STM32CubelDE v1.17.0:

. Updated the user authentication scheme and description in Section
1.2.3: STM32CubelDE user authentication and Section 3.1.2.3:
Debugger tab

. Updated Figure 2. STM32CubelDE window

. Updated Section 1.2.4: Help system

Document updated for STM32CubelDE v1.18.0:

. Updated Figure 10, Figure 11, and Figure 13 in Section 1.3: Information
Center

. Updated Figure 16 in Section 1.4.1.1: C/C++ perspective

. Updated Section 2.1.3.1: Importing an STM32CubelDE project,

14-Feb-2025 14 including Figure 66, Figure 68, and Figure 69 detailing project import

from the root directory or an archive file

. Updated Figure 74 in Section 2.2.1: Linking the project

. Updated Section 3.5.2: Using the Fault Analyzer view, including the
removal of the Fault Analyzer toolbar and its description

14-Nov-2024 13

. Removed Appendix A Document reorganization from revision 9 to
revision 10
Document updated for STM32CubelDE v1.19.0:
17-Jun-2025 15 . Added Section 3.1.6.7: Incremental flash memory programming
. Updated Table 29. STMicroelectronics reference documents
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Document updated for STM32CubelDE v2.0.0 with no STM32CubeMX
integration, LLVM toolchain support, and semihosting:

. Updated Introduction

. Updated Section 1.1: Product information including Figure 1

. Removed Section 1.2.3: STM32CubelDE user authentication

. Updated Section 1.2.3: Help system including Figure 4

. Updated Figure 5. Help - Information Center menu,
Figure 6. Information Center — Home page, Figure 7. Help — Tutorial
video, and Figure 8. Information Center — Video browser page

. Removed Section 1.4.1.3: Device Configuration Tool perspective

. Updated Section 1.4.2: Editors

. Updated Section 2.1.2.1: Creating a new STM32 executable project
including Figure 43 and Figure 44

. Updated Figure 45. STM32 static library project

. Updated Section 2.1.2.3: Creating a new CDT™ project including the
addition of Figure 48

. Updated Section 2.1.3.1: Importing an STM32CubelDE project
including Figure 55, Figure 56, and the addition of Figure 57

. Updated Section 2.1.3.2: Importing System Workbench and
TrueSTUDIO projects including Figure 60

. Updated Figure 76. Select a wizard

. Added Section 3.1.6.8: Semihosting

05-Nov-2025 16
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IMPORTANT NOTICE — READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and improvements to ST
products and/or to this document at any time without notice.

In the event of any conflict between the provisions of this document and the provisions of any contractual arrangement in force between the purchasers and
ST, the provisions of such contractual arrangement shall prevail.

The purchasers should obtain the latest relevant information on ST products before placing orders. ST products are sold pursuant to ST’s terms and
conditions of sale in place at the time of order acknowledgment.

The purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or the design of
the purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.
Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

If the purchasers identify an ST product that meets their functional and performance requirements but that is not designated for the purchasers' market
segment, the purchasers shall contact ST for more information.

ST and the ST logo are trademarks of ST. For additional information about ST trademarks, refer to www.st.com/trademarks. All other product or service names
are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2025 STMicroelectronics — All rights reserved
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