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Getting started with the eDSim electrical simulator

Introduction

eDSim is a fast and powerful electrical simulation tool for SMPS and analog ICs, integrated in the eDesignSuite tool. It features
enhanced accuracy and higher convergence speed for SMPS, enabling a simulation time 10-50x faster than the classical
analog SPICE simulators.

The tool is a specific version of the SIMPLIS/SIMetrix simulation environment paired with ST model components, for a full
electrical simulation with no limitation of nodes and circuit size as long as you use the models provided by ST.

Design your analog circuit using the eDesignSuite engine, display a preview of it in few seconds with a full annotated schematic
and BOM, and then run the electrical simulation through eDSim to get fast and accurate simulations and reliable design
validation, thus reducing the effort and risks related to hardware prototyping.

Related links

How to get started using eDSim

Case study: design and simulate L6983 buck converter operation with eDSim
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For further information contact your local STMicroelectronics sales office.


https://www.st.com/en/product/stsw-edsim?ecmp=tt9470_gl_link_feb2019&rt=um&id=UM3017
https://www.st.com/content/st_com/en/support/resources/edesign.html
https://www.st.com/content/st_com/en/support/resources/edesign.html
https://www.st.com/en/product/stsw-edsim?ecmp=tt9470_gl_link_feb2019&rt=um&id=UM3017
https://st-videos.s3.amazonaws.com/Video/Q2-2022/edesignsuite-mooc-episode-4-720p.mp4
https://st-videos.s3.amazonaws.com/Video/Q2-2022/edesignsuite-mooc-episode-5-720p.mp4
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How to start the eDSim simulator

How to start the eDSim simulator
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To start the eDSim analog simulator, follow the steps below.

Step 1.  Double-click on the desktop shortcut after the installation or select eDSim from the start menu of your
PC.

Figure 1. eDSim simulator icon

eDSim

A splash screen then shows the eDSim analog simulator logo and the licensing terms.

Figure 2. eDSim simulator splash screen
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Fast and powerful simulation tool

eDSim is a fast and powerful electrical simulation tool for SMPS and Analog ICs.

It features enhanced accuracy and convergence time for SMPS, enabling simulation

time 10-50x faster than dassical SPICE simulators.

SMPS Application Circuits Export for eDSim capability is integrated into eDesignSuite tools.

The tool features:

* Built-in interface with eDesignSuite

* Time domain simulation

* Control loop stability

* Pre-defined Application case simulation

* Schematic editor for customization

* Waveform viewer with measurements capabilities

eDSim documentation integrated in the Help menu.
ST suggests to periodically perform the Check fer Updates (Help menu)

Engineer Community available at:
https: fjcommunity. st.com s

STMicroelectronics distributes the eDSim simulation tool under license from SIMPLIS
Technologies, By using this tool, users accept: (i) the eDSim Simulation Tool Software License
Agreement and (ji) the SIMetrix f STMPLIS ELULA

[ o 1]

Step 2. Click [OK].
The welcome page appears on your screen.
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2 Welcome page overview

The welcome page features the following sections:

. [Create New] to create a new schematic for the SIMPLIS or SIMetrix environment;
. [Recent Schematics] to open all the recent available schematics;
. [STMicroelectronics Examples] to obtain a list of example application schematics available in:

- Examples-91\SIMPLIS\STMicroelectronics
- Examples-91\SIMetrixX\STMicroelectronics
. [Support] to get:
- a [Getting Started] (this user manual) that represents a quick introduction to the eDSim tool
- the [End-user License Agreement] (EULA)
- a technical [Release Note] with the last feature enhancements and bug fixes
- the [eDSim Product Page], which contains the whole eDSim project folder
- the [Contents Update Settings] allows you to check and download the latest available updates

Figure 3. eDSim simulator welcome page
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2.1 [Create New]

To create a new schematic or symbol for SIMetrix or SIMPLIS from scratch, follow the procedure below.

Step 1. Choose one of the following options.
- Click on [File]>[New]>[SIMetrix/SIMPLIS Schematic]

Figure 4. eDSim main window - create new
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- Use the [Create New] quick link from the welcome page.

Figure 5. eDSim welcome page - create new
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- Click on the [Blank Page] button.

Figure 6. eDSim blank page button - create new
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Step 2. Modify Simplis/SIMetrix options parameters by clicking on the [Options/Preferences] and [Simplis

Option] buttons next to the [Blank Page] button.

Figure 7. [Blank Page], [Options/Preferences], [Simplis Options] buttons
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Figure 9. [Simplis Options]
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Step 3.  To create a new schematic, use the ST models from the [Place]>[From STMicroelectronics Library]
menu.

The model list is organized according to the product category. The tool shows only the models
compatible with the currently selected simulator (SIMetrix or SIMPLIS).

Figure 10. [Place]>[From STMicroelectronics Library]
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Step 4.  Press the keyboard [Ctrl] button and [G].
The [Select device] window allows you to place a device.

Figure 11. Select and place a device
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On the top menu bar, you can find a list of available devices, such as capacitors, resistors, inductors,
which you can use to design your project.
You can also find a set of probes that allow you to display all the simulation waveforms.

Figure 12. Place buttons
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2.2 [Recent Schematics]
This section shows you all the recent opened schematics.

Figure 13. [Recent Schematics] section
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3 Predefined ST application test benches

eDSim provides you a list of ST application schematics that you can partially modify according to your needs:
access them from the [File View] tab in the STMicroelectronics folder under the SIMetrix or SIMPLIS folders, as
shown in the figure below taking into account, for example, SIMPLIS.

Figure 14. eDSim directory and folders
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All these schematics are available in your local [Documents] folder, in [ST eDSim]>[Examples].

Important:  If you modify any of these schematics, we highly recommend you to save a copy of the file [File]>[Save
Schematics As] to avoid overwriting the default version.

If you want to save a newly created schematic, select [File]>[Save Schematic As].

Figure 15. Saving a local copy of the schematic
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4 Setting the update schedule

The ST schematic library is subject to continuous updates. Thus, you need to set up the eDSim analog simulator
to check for any available updates, to get the latest patches, models, and example application schematics.

Step 1. Select [Help] on the eDSim command shell window and tick the [Check Updates Now] box.

Figure 16. [ Update Settings ] window

J Update Settings X
Check Updates Now
Automatic Update Schedule
Ok Cancel

Step 2. To set the desired update schedule, click [Help][Check Updates Now] and change the [Automatic
Update Schedule] to [Daily], [Weekly], or [Monthly].
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To start the simulation phase and run the default analysis, follow the procedure below.

Step 1. Open and customize an ST schematic.
Figure 17. eDSim - starting the simulation
Step 2. Press the F9 key or select [Simulator]>[Run Schematic] to run the schematic simulation.
Figure 18. eDSim - running the simulation
View = Simulator Place Probe Probe AC/Noise Hierarchy Monte
K E Choose Analysis... F8 Q‘
[ | Run Schematic F9 |
L Abort
= Show SIMPLIS Status Window Ctrl+Space
r;::::" Initial Conditions >
IMPLI Setup Multi-step...
Ad Run Multi-step
An
Step 3.  Press the F8 key to open the [Choose Analysis] window and modify the analysis type to perform.

Figure 19. eDSim - [Choose Analysis] window
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Step 4.  Set up the desired parameters.

Figure 20. eDSim - [Choose Analysis] settings
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5.1 Simulation results

Once you have launched a new simulation, a simulation status window automatically appears. It shows the
evolution process of your simulation.

Figure 21. eDSim - simulation status
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The eDSim analog simulator performs the time domain analysis, which allows the designers to evaluate voltage
limits, threshold, and overshoot values.

Figure 22. eDSim - time domain simulation results
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eDSim also allows simulating the frequency domain for a proper small signal analysis.
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Figure 23. eDSim - Bode simulation results
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6 eDSim interaction with eDesignSuite

eDesignSuite is an easy-to-use comprehensive online software suite. It helps the customers define their needs
and transform their application requirements into satisfactory solutions based on the wide range of ST products.

There is a strict connection between the eDSim analog simulator tool and eDesignSuite. Once you have selected
the solution that perfectly fits your design specification, you can get all the simulation details using the eDSim
simulator.

Step 1. Select your design by adding the I/O voltages and current values.
The tool suggests the solutions that match your requirement.

Figure 24. eDesignSuite interface
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Once selected on one of the proposed applications, you have the opportunity.
Step 2. Run eDSim to analyze, modify, and get more details on the project.

Step 3.  Click on [Export for eDSim].

Figure 25. eDesignSuite - IC interface
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A popup window appears to help you to install the eDSim tool on your PC and to download the *.zip file
of the project started on eDesignSuite.

Figure 26. eDesignSuite - popup window
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Step 4.  Unzip the file and follow the instructions of the readme.ixt.

Figure 27. eDesignSuite - zip folder content

Name h Date modified Type Size

eDSim.bat 20-Apr-2111:20 Windows Batch File 1KB
B L6983NQTR.compvalues.log 20-Apr-2113:33 Text Document 2KB
L6983NQTR.compvalues.txt 20-Apr-2111:20 Text Document 1KB
L6983NQTR.sxsch 20-Apr-2111:20 SIMetrix Schematic 101 KB
[] L6983MATR sesch.lck 20-Apr-21 13:33 LCK File 1KB
readme.txt 20-Apr-2111:20 Text Document 1KB

Step 5. Clicking on the eDSim.bat file.
The eDSim tool automatically loads the solution that you have chosen and modified on eDesignSuite.
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7 eDSim limitations

eDSim is a customized edition of the SIMPLIS/SIMetrix simulation environment paired with the ST model specific
components. It allows a full electrical simulation with no limitation to the node count and circuit size as long as you
use the ST provided models. If you create a new schematic or customize any of the ST available projects, the
number of modifications is limited, as detailed in the following sections.

7.1 SIMPLIS circuit size limits

1. A maximum of 15 state variables. Each capacitor or inductor requires one state variable. Each time-varying
or small-signal AC source requires one state variable, except for sinusoidal or cosinusoidal sources, which
require two state variables per source

A maximum of 10 capacitors or inductors combined

A maximum of 6 switches (simple or transistor)

A maximum of 6 logic gates

A maximum of 26 states. Each PWL element, switch, time-varying source, and logic gate requires one state

A maximum of 100 new topologies, which are enough for simple switching circuits that use simple models
only. More complex circuits or circuits that have more complicated models may exceed this limit

o0 wN

7.2 SIMetrix circuit size limits
For the SIMetrix simulator, the simulated circuit size limits are:
. 140 analog nodes (internal and external)
. 360 digital nodes
. 720 digital ports
. 300 digital components
. 360 digital outputs
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IMPORTANT NOTICE — READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and improvements to ST
products and/or to this document at any time without notice. Purchasers should obtain the latest relevant information on ST products before placing orders. ST
products are sold pursuant to ST’s terms and conditions of sale in place at the time of order acknowledgment.

Purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or the design of
purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.
Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

ST and the ST logo are trademarks of ST. For additional information about ST trademarks, refer to www.st.com/trademarks. All other product or service names
are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2024 STMicroelectronics — All rights reserved
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